Gestionnaire des tables liées, changement de pc

Le
drazou
Bonjour tout le monde,

J'ai une grosse base de données comportant plus de 40 tables liées à une base frontale ou dorsale je ne sais jamais laquelle et laquelle. Ca marche très bien sauf que aujourd'hui jai voulu copier ma base sur un autre ordinateur et la c est le drame! Tous les liens des tables liées sont morts, normal me direz vous vu que c est plus le meme chemin d'acces et meme plus le meme ordinateur. Mais lorsque j'utilise le gestionnaire des tables liées, il ne voit aucune table Et donc je ne peux pas les re-linker :(

J'ai essayé de feinter un créant le meme chemin depuis le pc d'origine. Je pensais que du coup access ne s'en rendrait meme pas compte mais j'obtiens le meme résultat!

Le pire c est que depuis le nouveau pc je peux lire les données de mes tables, utiliser les requetes dessus ect mais pas actualiser les attaches!!!

Mes tables sont liées mais pas liées

Un tel cas de figure vous est il deja arrivé? Quelqu'un a une solution magique?

Merci d'avance, bonne journée
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Blaise Cacramp
Le #17437631
Bonjour ou bonsoir, selon.

La frontale, c'est celle qui est sur le pc et qui devrait contenir les
tables liées
La dorsale, c'est celle qui est sur un serveur dans le réseau

Si le nouveau PC n'a pas accès au réseau, il ne peut "voir" la dorsale.

okay ?

Cdt, Blaise
---- ---- ----


"drazou"
Bonjour tout le monde,

J'ai une grosse base de données comportant plus de 40 tables liées à une
base
frontale ou dorsale je ne sais jamais laquelle et laquelle. Ca marche très
bien
sauf que aujourd'hui jai voulu copier ma base sur un autre ordinateur et
la c
est le drame! Tous les liens des tables liées sont morts, normal me direz
vous
vu que c est plus le meme chemin d'acces et meme plus le meme ordinateur.
Mais
lorsque j'utilise le gestionnaire des tables liées, il ne voit aucune
table...
Et donc je ne peux pas les re-linker :(

J'ai essayé de feinter un créant le meme chemin depuis le pc d'origine. Je
pensais que du coup access ne s'en rendrait meme pas compte mais j'obtiens
le
meme résultat!

Le pire c est que depuis le nouveau pc je peux lire les données de mes
tables,
utiliser les requetes dessus ect mais pas actualiser les attaches!!!

Mes tables sont liées mais pas liées...

Un tel cas de figure vous est il deja arrivé? Quelqu'un a une solution
magique?

Merci d'avance, bonne journée


drazou
Le #17444201
Blaise Cacramp a écrit le 06/10/2008 à 17h28 :
Bonjour ou bonsoir, selon.

La frontale, c'est celle qui est sur le pc et qui devrait contenir les
tables liées
La dorsale, c'est celle qui est sur un serveur dans le réseau

Si le nouveau PC n'a pas accès au réseau, il ne peut
"voir" la dorsale.

okay ?

Cdt, Blaise
---- ---- ----


"drazou" a écrit dans le message
de news:

Bonjour tout le monde,

J'ai une grosse base de données comportant plus de 40 tables
liées à une
base
frontale ou dorsale je ne sais jamais laquelle et laquelle. Ca marche
très
bien
sauf que aujourd'hui jai voulu copier ma base sur un autre ordinateur et
la c
est le drame! Tous les liens des tables liées sont morts, normal me
direz
vous
vu que c est plus le meme chemin d'acces et meme plus le meme ordinateur.
Mais
lorsque j'utilise le gestionnaire des tables liées, il ne voit aucune
table...
Et donc je ne peux pas les re-linker :(

J'ai essayé de feinter un créant le meme chemin depuis le pc
d'origine. Je
pensais que du coup access ne s'en rendrait meme pas compte mais j'obtiens
le
meme résultat!

Le pire c est que depuis le nouveau pc je peux lire les données de mes
tables,
utiliser les requetes dessus ect mais pas actualiser les attaches!!!

Mes tables sont liées mais pas liées...

Un tel cas de figure vous est il deja arrivé? Quelqu'un a une solution
magique?

Merci d'avance, bonne journée





Bonjour Blaise,

Oui j'imagine bien qu'il faut que la frontale est acces à la dorsale pour que ca fonctionne. En fait dans mon cas un seul utilisateur l'utilise. Pour faire plus "pro" ils avaient scindé la base, mais cela ne sert a rien. La finalité étant que l'utilisateur ait sur son pc la frontale et la dorsale.
Pour travailler sur la base je l'ai copié sur mon pc (frontale+dorsale) et maintenant qu'elle est prete j'aimerais la rendre à son propriétaire. Et c'est la que les soucis de tables liées apparaissent.

J'espère que mes propos ne sont pas trop confus. Une solution serait peut être de refusionner la dorsale et frontale en une seule base, mais la encore j'ai besoin de vos lumières sur la marche à suivre.

Merci en tout cas de ta réponse, a bientot
3stone
Le #17446551
Salut,

"drazou"
| J'ai une grosse base de données comportant plus de 40 tables liées à une base
| frontale ou dorsale je ne sais jamais laquelle et laquelle. Ca marche très bien
| sauf que aujourd'hui jai voulu copier ma base sur un autre ordinateur et la c
| est le drame! Tous les liens des tables liées sont morts, normal me direz vous
| vu que c est plus le meme chemin d'acces et meme plus le meme ordinateur. Mais
| lorsque j'utilise le gestionnaire des tables liées, il ne voit aucune table...


Tu veux dire que lorsque tu appelles le menu

- "Outils, Utilitaires de base de données, Gestionnaire de table liées"

tu ne vois aucune table liées ? (images précédées d'une flêche)

si c'est le cas, es-tu sûr de ne pas avoir importé les tables chez toi,
au lieu de les attacher ?

Dans la frontale (celle qui contient les formulaires, requêtes...)
tu as bien l'image des tables précédées d'une flêche ?


--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)
drazou
Le #17446791
3stone a écrit le 07/10/2008 à 13h58 :
Salut,

"drazou"
| J'ai une grosse base de données comportant plus de 40 tables
liées à une base
| frontale ou dorsale je ne sais jamais laquelle et laquelle. Ca marche
très bien
| sauf que aujourd'hui jai voulu copier ma base sur un autre ordinateur et la c
| est le drame! Tous les liens des tables liées sont morts, normal me
direz vous
| vu que c est plus le meme chemin d'acces et meme plus le meme ordinateur.
Mais
| lorsque j'utilise le gestionnaire des tables liées, il ne voit aucune
table...


Tu veux dire que lorsque tu appelles le menu

- "Outils, Utilitaires de base de données, Gestionnaire de table
liées"

tu ne vois aucune table liées ? (images précédées
d'une flêche)

si c'est le cas, es-tu sûr de ne pas avoir importé les tables chez
toi,
au lieu de les attacher ?

Dans la frontale (celle qui contient les formulaires, requêtes...)
tu as bien l'image des tables précédées d'une flêche
?


--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)


Rebonjour,

En fait c'est étrange, si je regarde la fenêtre base de données ( la ou on peut voir les tables/requettes/forms/...) je vois mes tables attachées ( avec la fleche pour montrer que c'est bien des tables liées).
En revanche si je veux les ouvrir ils me dit que le chemin d'acces n'est pas valide, malgré ma feinte sur le chemin d'access. Par contre les requetes et états fonctionnent encore, donc access accède d'une manière ou d'une autre à ces tables. Le problème c'est que lorsque j'ouvre le gestionnaire des tables liées, il n'en affiche aucune! Et du coup je ne peux pas rétablir le chemin d'acces :(
3stone
Le #17452551
Salut,

"drazou"
| > | J'ai une grosse base de données comportant plus de 40 tables
| > liées à une base
| > | frontale ou dorsale je ne sais jamais laquelle et laquelle. Ca marche
| > très bien
| > | sauf que aujourd'hui jai voulu copier ma base sur un autre ordinateur et la
| c
| > | est le drame! Tous les liens des tables liées sont morts, normal me
| > direz vous
| > | vu que c est plus le meme chemin d'acces et meme plus le meme ordinateur.
| > Mais
| > | lorsque j'utilise le gestionnaire des tables liées, il ne voit aucune
| > table...
| >
| >
| > Tu veux dire que lorsque tu appelles le menu
| >
| > - "Outils, Utilitaires de base de données, Gestionnaire de table
| > liées"
| >
| > tu ne vois aucune table liées ? (images précédées
| > d'une flêche)
| >
| > si c'est le cas, es-tu sûr de ne pas avoir importé les tables chez
| > toi,
| > au lieu de les attacher ?
| >
| > Dans la frontale (celle qui contient les formulaires, requêtes...)
| > tu as bien l'image des tables précédées d'une flêche
|
"drazou"
| En fait c'est étrange, si je regarde la fenêtre base de données ( la ou on peut
| voir les tables/requettes/forms/...) je vois mes tables attachées ( avec la
| fleche pour montrer que c'est bien des tables liées).
| En revanche si je veux les ouvrir ils me dit que le chemin d'acces n'est pas
| valide, malgré ma feinte sur le chemin d'access. Par contre les requetes et
| états fonctionnent encore, donc access accède d'une manière ou d'une autre à ces
| tables. Le problème c'est que lorsque j'ouvre le gestionnaire des tables liées,
| il n'en affiche aucune! Et du coup je ne peux pas rétablir le chemin d'acces :(


Je pressent un problème Access...

Dans un premier temps, je te propose de supprimer simplement les tables
liées et de refaire la liaison via le menu Fichier, Données Externes, Lier les tables

Là, tus va rejoinde la base dorsale (celle qui contient les tables) et tu refais
la liaison.
Ensuite, je te propose d'installer ceci, ce qui simplifiera grandement le déplacement
futur de l'une des deux bases :
http://www.3stone.be/access/articles.php?lng=fr&pg(

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)
drazou
Le #17455221
3stone a écrit le 07/10/2008 à 22h55 :
Salut,

"drazou"
| > | J'ai une grosse base de données comportant plus de 40 tables
| > liées à une base
| > | frontale ou dorsale je ne sais jamais laquelle et laquelle. Ca marche
| > très bien
| > | sauf que aujourd'hui jai voulu copier ma base sur un autre ordinateur
et la
| c
| > | est le drame! Tous les liens des tables liées sont morts,
normal me
| > direz vous
| > | vu que c est plus le meme chemin d'acces et meme plus le meme
ordinateur.
| > Mais
| > | lorsque j'utilise le gestionnaire des tables liées, il ne voit
aucune
| > table...
| >
| >
| > Tu veux dire que lorsque tu appelles le menu
| >
| > - "Outils, Utilitaires de base de données, Gestionnaire de
table
| > liées"
| >
| > tu ne vois aucune table liées ? (images
précédées
| > d'une flêche)
| >
| > si c'est le cas, es-tu sûr de ne pas avoir importé les
tables chez
| > toi,
| > au lieu de les attacher ?
| >
| > Dans la frontale (celle qui contient les formulaires, requêtes...)
| > tu as bien l'image des tables précédées d'une
flêche
|
"drazou"
| En fait c'est étrange, si je regarde la fenêtre base de
données ( la ou on peut
| voir les tables/requettes/forms/...) je vois mes tables attachées (
avec la
| fleche pour montrer que c'est bien des tables liées).
| En revanche si je veux les ouvrir ils me dit que le chemin d'acces n'est pas
| valide, malgré ma feinte sur le chemin d'access. Par contre les
requetes et
| états fonctionnent encore, donc access accède d'une
manière ou d'une autre à ces
| tables. Le problème c'est que lorsque j'ouvre le gestionnaire des
tables liées,
| il n'en affiche aucune! Et du coup je ne peux pas rétablir le chemin
d'acces :(


Je pressent un problème Access...

Dans un premier temps, je te propose de supprimer simplement les tables
liées et de refaire la liaison via le menu Fichier, Données
Externes, Lier les tables

Là, tus va rejoinde la base dorsale (celle qui contient les tables) et
tu refais
la liaison.
Ensuite, je te propose d'installer ceci, ce qui simplifiera grandement le
déplacement
futur de l'une des deux bases :
http://www.3stone.be/access/articles.php?lng=fr&pg(

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)


Salut salut,

Ouais je pense aussi que c'est un soucis access mais jai refais le transfert entre les ordis et ca m'a donné le même résultat... Bref tant pis, jai finalement supprimer mes tables liées ( une par une parce que access veut pas en prendre plusieurs d'un coup!!!) et je les ai importé une bonne fois pour toute. Cette solution radicale me chagrinait parce que cela supprimait également les relations entre les tables, mais en fait je viens r&aliser que comme ces relations sont explicites dans chaque requêtes, ba access s'en fout :D

Donc voila ca marche, merci beaucoup à vous. J'aurais bien essayé ton utilitaire de déplacement de bases mais le lien est mort, mais ca m'intéresse, si tu pouvais me le redonné. Merci, ++ draz
3stone
Le #17458461
Salut,

"drazou"
| > Dans un premier temps, je te propose de supprimer simplement les tables
| > liées et de refaire la liaison via le menu Fichier, Données
| > Externes, Lier les tables
| >
| > Là, tus va rejoinde la base dorsale (celle qui contient les tables) et
| > tu refais
| > la liaison.
| > Ensuite, je te propose d'installer ceci, ce qui simplifiera grandement le
| > déplacement
| > futur de l'une des deux bases :
| > http://www.3stone.be/access/articles.php?lng=fr&pg(
| >
|
| Ouais je pense aussi que c'est un soucis access mais jai refais le transfert
| entre les ordis et ca m'a donné le même résultat... Bref tant pis, jai
| finalement supprimer mes tables liées ( une par une parce que access veut pas en
| prendre plusieurs d'un coup!!!) et je les ai importé une bonne fois pour toute.
| Cette solution radicale me chagrinait parce que cela supprimait également les
| relations entre les tables, mais en fait je viens r&aliser que comme ces
| relations sont explicites dans chaque requêtes, ba access s'en fout :D
|
| Donc voila ca marche, merci beaucoup à vous. J'aurais bien essayé ton
| utilitaire de déplacement de bases mais le lien est mort, mais ca m'intéresse,
| si tu pouvais me le redonné. Merci, ++ draz


Je te conseille vivement de recréer les relations entre tes tables *ET*
d'y appliquer l'integrité référencielle (avec mise à jour en cascade)
car Access ne s'en fout absolument pas ;-(

PS: Le lien n'est pas mort !!
Par contre tu devrais utiliser un "lecteur de news" et lire les messages
directement sur ce newsgroup !

Clique ici : news://msnews.microsoft.com/microsoft.public.fr.access

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)
drazou
Le #17460551
3stone a écrit le 08/10/2008 à 14h38 :
Salut,

"drazou"
| > Dans un premier temps, je te propose de supprimer simplement les tables
| > liées et de refaire la liaison via le menu Fichier,
Données
| > Externes, Lier les tables
| >
| > Là, tus va rejoinde la base dorsale (celle qui contient les
tables) et
| > tu refais
| > la liaison.
| > Ensuite, je te propose d'installer ceci, ce qui simplifiera grandement
le
| > déplacement
| > futur de l'une des deux bases :
| > http://www.3stone.be/access/articles.php?lng=fr&pg(
| >
|
| Ouais je pense aussi que c'est un soucis access mais jai refais le transfert
| entre les ordis et ca m'a donné le même résultat... Bref
tant pis, jai
| finalement supprimer mes tables liées ( une par une parce que access
veut pas en
| prendre plusieurs d'un coup!!!) et je les ai importé une bonne fois
pour toute.
| Cette solution radicale me chagrinait parce que cela supprimait
également les
| relations entre les tables, mais en fait je viens r&aliser que comme ces
| relations sont explicites dans chaque requêtes, ba access s'en fout :D
|
| Donc voila ca marche, merci beaucoup à vous. J'aurais bien
essayé ton
| utilitaire de déplacement de bases mais le lien est mort, mais ca
m'intéresse,
| si tu pouvais me le redonné. Merci, ++ draz


Je te conseille vivement de recréer les relations entre tes tables *ET*
d'y appliquer l'integrité référencielle (avec mise
à jour en cascade)
car Access ne s'en fout absolument pas ;-(

PS: Le lien n'est pas mort !!
Par contre tu devrais utiliser un "lecteur de news" et lire les
messages
directement sur ce newsgroup !

Clique ici : news://msnews.microsoft.com/microsoft.public.fr.access

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)


Rebonjour,

J'ai recréé les relations entre les tables pour être sur, j'ai testé au hasard plusieurs formulaires et états, tout à l'air de marcher. De toute manière si certains modules ne marche pas, l'utilisateur à qui cette base est destiné m'en fera rapidement part.

Pour les newsgroup, mouais j'ai jamais vraiment regardé comment ca marche, jy viendrai surement un jour mais pour l'instant ce n'est vraiment pas ma priorité.
En tout cas merci beaucoup pour ton aide.

a bientot
chpa
Le #17465171
Bonsoir,

Pardon de vous reprendre Blaise, mais si la frontale est bien la base qui
doit être sur le PC,
ce n'est pas elle qui doit contenir les tables.
La frontale (sur le PC) doit contenir les formulaires et le code associé,
les fonctions,les requêtes.
La dorsale (sur le réseau) ne contenant que les données (donc les tables)

"Blaise Cacramp" news:%
Bonjour ou bonsoir, selon.

La frontale, c'est celle qui est sur le pc et qui devrait contenir les
tables liées
La dorsale, c'est celle qui est sur un serveur dans le réseau

Si le nouveau PC n'a pas accès au réseau, il ne peut "voir" la dorsale.

okay ?

Cdt, Blaise
---- ---- ----


"drazou"
Bonjour tout le monde,

J'ai une grosse base de données comportant plus de 40 tables liées à une
base
frontale ou dorsale je ne sais jamais laquelle et laquelle. Ca marche
très bien
sauf que aujourd'hui jai voulu copier ma base sur un autre ordinateur et
la c
est le drame! Tous les liens des tables liées sont morts, normal me direz
vous
vu que c est plus le meme chemin d'acces et meme plus le meme ordinateur.
Mais
lorsque j'utilise le gestionnaire des tables liées, il ne voit aucune
table...
Et donc je ne peux pas les re-linker :(

J'ai essayé de feinter un créant le meme chemin depuis le pc d'origine.
Je
pensais que du coup access ne s'en rendrait meme pas compte mais
j'obtiens le
meme résultat!

Le pire c est que depuis le nouveau pc je peux lire les données de mes
tables,
utiliser les requetes dessus ect mais pas actualiser les attaches!!!

Mes tables sont liées mais pas liées...

Un tel cas de figure vous est il deja arrivé? Quelqu'un a une solution
magique?

Merci d'avance, bonne journée






3stone
Le #17465981
Salut,

"chpa"
| Pardon de vous reprendre Blaise, mais si la frontale est bien la base qui
| doit être sur le PC,
| ce n'est pas elle qui doit contenir les tables.


Ce n'est pas ce qui a dit (ou voulut dire), je pense ;-)


| "Blaise Cacramp"
| > La frontale, c'est celle qui est sur le pc et qui devrait contenir les
| > tables liées


"les tables liées" - il pensait sûrement à celles avec la flêche devant...

Mais je reconnais que ce n'était pas heureux comme expression ;-)

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)
Publicité
Poster une réponse
Anonyme