Gnus et smptp-auth

Le
Christophe Cuq
Bonjour les gens.

Vala, depuis que j'ai fait évoluer mon serveur de mail, j'ai de gros
problèmes pour faire authentifier mon Gnus pour l'envoi de mails.

En effet, le serveur envoie bien les infos de STARTTLS, mais pas les
modes d'auhtentification qui ne sont envoyés qu'après le STARTTLS.

Or, j'ai l'impression que Gnus n'envoie le STARTTLS que si il voit le
AUTH, et donc on tourne en rond.

Ma config (.emacs) :

,-
| (setq smtpmail-debug-info t)
|
| ; Options de mail par défaut
| ; définition du mode smtp pour envoyer le courier
|
| (load-library "smtpmail")
| (load-library "message")
|
| (setq mail-host-address "le-bulb.cuq.org")
| (setq mail-user-agent (quote gnus-user-agent))
| (setq read-mail-command (quote gnus))
|
| (setq user-mail-address "christophe@cuq.org")
|
| ;; Placed before other tls and smtp stuff according to
| ;; http://www.emacswiki.org/cgi-bin/wiki/SmtpAuth
|
| (setq starttls-use-gnutls t)
| (setq starttls-gnutls-program "gnutls-cli")
| (setq starttls-extra-arguments nil)
|
| ;; Send mail using SMTP on the mail submission port 587.
|
| (setq message-send-mail-function 'smtpmail-send-it
| smtpmail-starttls-credentials '(("mail.cuq.org" 587 nil nil))
| smtpmail-default-smtp-server "mail.cuq.org"
| smtpmail-smtp-server "mail.cuq.org"
| smtpmail-smtp-service 587)
`-

Les infos de connexion sont dans le .authinfo

Le message buffer :

,-
| 220 mail.cuq.org ESMTP Postfix
| 250-mail.cuq.org
| 250-PIPELINING
| 250-SIZE 20480000
| 250-ETRN
| 250-STARTTLS
| 250-ENHANCEDSTATUSCODES
| 250-8BITMIME
| 250 DSN
| 530 5.7.0 Must issue a STARTTLS command first
| 221 2.0.0 Bye
| smtpmail-send-it: Sending failed; SMTP protocol error
`-

Quelqu'un aurait-il une solution pour forcer Gnus à envoyer le STARTTLS ?

--
CHC
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Vincent Belaïche
Le #21774831
Salut,

Alors là si qq un répond je suis aussi très intéressé car j'ai
sensiblement la même config que toi, et je ne suis jamais arrivé à
envoyer un mail avec le module SMTP.

Sinon pour info tu peux mettre (setq smtpmail-debug-verb t) histoire
d'avoir un peu plus de messages...

A+,
Vincent.

Christophe Cuq a écrit :
Bonjour les gens.

Vala, depuis que j'ai fait évoluer mon serveur de mail, j'ai de gros
problèmes pour faire authentifier mon Gnus pour l'envoi de mails.

En effet, le serveur envoie bien les infos de STARTTLS, mais pas les
modes d'auhtentification qui ne sont envoyés qu'après le STARTTLS.

Or, j'ai l'impression que Gnus n'envoie le STARTTLS que si il voit le
AUTH, et donc on tourne en rond.

Ma config (.emacs) :

,----
| (setq smtpmail-debug-info t)
|
| ; Options de mail par défaut
| ; définition du mode smtp pour envoyer le courier
|
| (load-library "smtpmail")
| (load-library "message")
|
| (setq mail-host-address "le-bulb.cuq.org")
| (setq mail-user-agent (quote gnus-user-agent))
| (setq read-mail-command (quote gnus))
|
| (setq user-mail-address "")
|
| ;; Placed before other tls and smtp stuff according to
| ;; http://www.emacswiki.org/cgi-bin/wiki/SmtpAuth
|
| (setq starttls-use-gnutls t)
| (setq starttls-gnutls-program "gnutls-cli")
| (setq starttls-extra-arguments nil)
|
| ;; Send mail using SMTP on the mail submission port 587.
|
| (setq message-send-mail-function 'smtpmail-send-it
| smtpmail-starttls-credentials '(("mail.cuq.org" 587 nil nil))
| smtpmail-default-smtp-server "mail.cuq.org"
| smtpmail-smtp-server "mail.cuq.org"
| smtpmail-smtp-service 587)
`----

Les infos de connexion sont dans le .authinfo

Le message buffer :

,----
| 220 mail.cuq.org ESMTP Postfix
| 250-mail.cuq.org
| 250-PIPELINING
| 250-SIZE 20480000
| 250-ETRN
| 250-STARTTLS
| 250-ENHANCEDSTATUSCODES
| 250-8BITMIME
| 250 DSN
| 530 5.7.0 Must issue a STARTTLS command first
| 221 2.0.0 Bye
| smtpmail-send-it: Sending failed; SMTP protocol error
`----

Quelqu'un aurait-il une solution pour forcer Gnus à envoyer le STARTTLS ?

Christophe Cuq
Le #21774821
Vincent Belaïche
Salut,

Alors là si qq un répond je suis aussi très intéressé car j'ai
sensiblement la même config que toi, et je ne suis jamais arrivé à
envoyer un mail avec le module SMTP.



Ah pourtant, ça ça fonctionne parfaitement. Avant la modif du serveur,
j'envoyais en smtp-auth sur le port 25 et je n'ai jamais eu de problème.

,----[ .emacs.old ]
| (setq smtpmail-debug-info t)
|
| ; Options de mail par défaut
| ; définition du mode smtp pour envoyer le courier
|
| (load-library "smtpmail")
| (load-library "message")
|
| (setq mail-host-address "le-bulb.cuq.org")
| (setq mail-user-agent (quote gnus-user-agent))
| (setq read-mail-command (quote gnus))
|
| (setq user-mail-address "")
| (setq smtpmail-default-smtp-server "mon.serveur.amoi")
| (setq smtpmail-smtp-server "mon.serveur.amoi")
| (setq smtpmail-smtp-service 25)
| (setq send-mail-function 'smtpmail-send-it)
| (setq message-send-mail-function 'smtpmail-send-it)
`----

Avec les infos d'authentification dans le .authinfo

Sinon pour info tu peux mettre (setq smtpmail-debug-verb t) histoire
d'avoir un peu plus de messages...



Il y était déjà, première ligne de l'extrait de mon .emacs.

--
CHC
Xavier Maillard
Le #21773221
Vincent Belaïche
PS: Moi je n'ai pas mis les info d'authentification dans un .authinfo,
mais directement dans mon fichier d'init (variable
smtpmail-auth-credentials) je me demande si c'est bien prudent d'avoir
tout ça en clair.



Ton .authinfo contient aussi les informations en clair :) Donc
l'un dans l'autre, les choses sont sensiblement les memes.
Sébastien Kirche
Le #21773211
Le 13 décembre 2008 à 09:17, Xavier Maillard a dit :

Vincent Belaïche
> PS: Moi je n'ai pas mis les info d'authentification dans un PS:
> .authinfo, mais directement dans mon fichier d'init (variable
> smtpmail-auth-credentials) je me demande si c'est bien prudent
> d'avoir tout ça en clair.

Ton .authinfo contient aussi les informations en clair :) Donc
l'un dans l'autre, les choses sont sensiblement les memes.



Normalement l'utilisation du .authinfo devrait se faire en coordination
avec des droits d'accès ad-hoc :

,----[ ls -l .authinfo ]
| -rwx------ 1 seki seki 413 2007-06-09 11:54 .authinfo
`----

Mon .authinfo n'est lisible ni modifiable que par moi sur cette
installation linux (dont je suis le seul utilisateur, luxe de
précautions :), alors qu'on pourrait décider de rendre les fichiers de
config publics. D'ailleurs je publie mes fichiers de conf sur ma page
web, mais pas le .authinfo.

Sur une install windows >= 2000 on peut décider de rendre les fichiers
de "Mes Documents" privés (non lisibles par d'autres utilisateurs), il
suffit de placer le .authinfo là-dedans.
--
Sébastien Kirche
Xavier Maillard
Le #21773191
Sébastien Kirche writes:

Le 13 décembre 2008 à 09:17, Xavier Maillard a dit :

Vincent Belaïche
> PS: Moi je n'ai pas mis les info d'authentification dans un PS:
> .authinfo, mais directement dans mon fichier d'init (variable
> smtpmail-auth-credentials) je me demande si c'est bien prudent
> d'avoir tout ça en clair.

Ton .authinfo contient aussi les informations en clair :) Donc
l'un dans l'autre, les choses sont sensiblement les memes.



Normalement l'utilisation du .authinfo devrait se faire en coordination
avec des droits d'accès ad-hoc :

,----[ ls -l .authinfo ]
| -rwx------ 1 seki seki 413 2007-06-09 11:54 .authinfo
`----



Pas faux :)
Publicité
Poster une réponse
Anonyme