Grande Valeur

Le
Clochard
Bonjour,

Je recherche les 3 plus grandes valeurs dans une plage
où entre autre il a des nombres tels 211, 213, 208, 200, 217 etc
avec ces formules..

=SI(ESTNUM(GRANDE.VALEUR((DI$22:DK$44);1));GRANDE.VALEUR((DI$22:DK$44);1);"")

=SI(ESTNUM(GRANDE.VALEUR((DI$22:DK$44);2));GRANDE.VALEUR((DI$22:DK$44);2);"")

=SI(ESTNUM(GRANDE.VALEUR((DI$22:DK$44);3));GRANDE.VALEUR((DI$22:DK$44);3);"")

La première = 217
La deuxième= 213
La troisième= 213 au lieu de 211

Ma question. pourquoi ma troisième formule ne me donne-t-elle pas 211 au
lieu de répéter pour une deuxième foir 213 ????

J'ai beau la repasser et repasser rien a faire
--
Clochard
Aimerais bien savoir.
Merci!
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #5279901
Bonjour.
C'est comme tous les classements, quand il y a deux seconds ex-aequo, le
suivant est quatrième.
Seulement GRANDE.VALEUR ne sait pas dire "second ex-aequo", il dit
"troisième".
Cordialement.
Daniel
"Clochard"
Bonjour,

Je recherche les 3 plus grandes valeurs dans une plage
où entre autre il a des nombres tels 211, 213, 208, 200, 217... etc...
avec ces formules..

=SI(ESTNUM(GRANDE.VALEUR((DI$22:DK$44);1));GRANDE.VALEUR((DI$22:DK$44);1);"")

=SI(ESTNUM(GRANDE.VALEUR((DI$22:DK$44);2));GRANDE.VALEUR((DI$22:DK$44);2);"")

=SI(ESTNUM(GRANDE.VALEUR((DI$22:DK$44);3));GRANDE.VALEUR((DI$22:DK$44);3);"")

La première = 217
La deuxième= 213
La troisième= 213 au lieu de 211

Ma question.... pourquoi ma troisième formule ne me donne-t-elle pas 211
au
lieu de répéter pour une deuxième foir 213 ????

J'ai beau la repasser et repasser ... rien a faire...
--
Clochard
Aimerais bien savoir....
Merci!


JB
Le #5279871
Bonjour,

3 + gran sans doublons:

-Sélectionner C2:C5
=GRANDE.VALEUR(SI((EQUIV(ch;ch;
0)=LIGNE(INDIRECT("1:"&LIGNES(ch))));ch);{1;2;3})
Valider avec Maj+Ctrl+Entrée

Si cellules vides dans le champ:
=GRANDE.VALEUR(SI(NON(ESTNA(EQUIV(ch;ch;0)));SI((EQUIV(ch;ch;
0)=LIGNE(INDIRECT("1:"&LIGNES(ch))));ch));{1;2;3})
Valider avec Maj+Ctrl+Entrée

JB

On 8 fév, 17:29, Clochard
Bonjour,

Je recherche les 3 plus grandes valeurs dans une plage
où entre autre il a des nombres tels 211, 213, 208, 200, 217... etc...
avec ces formules..

=SI(ESTNUM(GRANDE.VALEUR((DI$22:DK$44);1));GRANDE.VALEUR((DI$22:DK$44);1 );"­")

=SI(ESTNUM(GRANDE.VALEUR((DI$22:DK$44);2));GRANDE.VALEUR((DI$22:DK$44);2 );"­")

=SI(ESTNUM(GRANDE.VALEUR((DI$22:DK$44);3));GRANDE.VALEUR((DI$22:DK$44);3 );"­")

La première = 217
La deuxième= 213
La troisième= 213 au lieu de 211

Ma question.... pourquoi ma troisième formule ne me donne-t-elle pas 211 au
lieu de répéter pour une deuxième foir 213 ????

J'ai beau la repasser et repasser ... rien a faire...
--
Clochard
Aimerais bien savoir....
Merci!


Clochard
Le #5279711
Merci JB

Je travaille sur mon problème avec ta suggestion....

Merci beaucoup...
Et merci aussi Daniel pour ton support
--
Clochard




Bonjour,

3 + gran sans doublons:

-Sélectionner C2:C5
=GRANDE.VALEUR(SI((EQUIV(ch;ch;
0)=LIGNE(INDIRECT("1:"&LIGNES(ch))));ch);{1;2;3})
Valider avec Maj+Ctrl+Entrée

Si cellules vides dans le champ:
=GRANDE.VALEUR(SI(NON(ESTNA(EQUIV(ch;ch;0)));SI((EQUIV(ch;ch;
0)=LIGNE(INDIRECT("1:"&LIGNES(ch))));ch));{1;2;3})
Valider avec Maj+Ctrl+Entrée

JB

On 8 fév, 17:29, Clochard
Bonjour,

Je recherche les 3 plus grandes valeurs dans une plage
où entre autre il a des nombres tels 211, 213, 208, 200, 217... etc...
avec ces formules..

=SI(ESTNUM(GRANDE.VALEUR((DI$22:DK$44);1));GRANDE.VALEUR((DI$22:DK$44);1);"­")

=SI(ESTNUM(GRANDE.VALEUR((DI$22:DK$44);2));GRANDE.VALEUR((DI$22:DK$44);2);"­")

=SI(ESTNUM(GRANDE.VALEUR((DI$22:DK$44);3));GRANDE.VALEUR((DI$22:DK$44);3);"­")

La première = 217
La deuxième= 213
La troisième= 213 au lieu de 211

Ma question.... pourquoi ma troisième formule ne me donne-t-elle pas 211 au
lieu de répéter pour une deuxième foir 213 ????

J'ai beau la repasser et repasser ... rien a faire...
--
Clochard
Aimerais bien savoir....
Merci!






Publicité
Poster une réponse
Anonyme