#N/A ; graphe et format de s

Le
ylc
Bonjour   tous,

J'ai un graphe en X/Y avec des X et 2 s©ries de Y l'une saisie Y1 l'autre
calcul©e Y2.
Les Y calcul©s doivent ªtre reli©s par du trait.
Je ne souhaite pas que les valeurs de Y "nulles" apparaissent   l'©cran.

J'ai donc saisie dans la formule un condition qui renvoit #N/A ou =NA()
chaque fois que n©cessaire pour qu'excel glisse sur ces donn©es.
Cela marche en "point par point" mais d¨s que j'impose de relier les
segments de droite le trait appara®t aussi sur le tron§on de la donn©e Y
"inexistante".(trait de Y-1   Y+1)
et cel  qq soit les options de Outil/Option/Graphique
Est-il possible d'avoir une restitution de graphique avec plusieurs
segments de droites pour une seule s©rie?

Je peux bien s»r s©lectionner "  la main le segment" et l'©liminer mais
c'est fastidieux
Je patauge, je patauge!

Remerciements Anticip©s
Bonne soir©e

Yves
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Francois L
Le #16602672
ylc a ©crit :

Bonjour,

Vas voir l  si tu trouves ton bonheur...

http://www.excelabo.net/compteclic.php?nom=fl-valeursvidesgraph

--
Fran§ois L
Bonjour   tous,

J'ai un graphe en X/Y avec des X et 2 s©ries de Y l'une saisie Y1 l'autre
calcul©e Y2.
Les Y calcul©s doivent ªtre reli©s par du trait.
Je ne souhaite pas que les valeurs de Y "nulles" apparaissent   l'©cran.

J'ai donc saisie dans la formule un condition qui renvoit #N/A ou =NA()
chaque fois que n©cessaire pour qu'excel glisse sur ces donn©es.
Cela marche en "point par point" mais d¨s que j'impose de relier les
segments de droite le trait appara®t aussi sur le tron§on de la donn©e Y
"inexistante".(trait de Y-1   Y+1)
et cel  qq soit les options de Outil/Option/Graphique
Est-il possible d'avoir une restitution de graphique avec plusieurs
segments de droites pour une seule s©rie?

Je peux bien s»r s©lectionner "  la main le segment" et l'©liminer mais
c'est fastidieux...
Je patauge, je patauge!

Remerciements Anticip©s
Bonne soir©e

Yves




ylc
Le #16602692
pas tout   fait!

Imaginons les X: 1,2,3,4
les Y1: 2, 4, "manquant", 8
les Y2: = {si(X<>0;10*X; #N/A)} ou {si(X<>0;10*X;
NA()}....

cela va marcher pour les Y1 saisis "  la main"
mais pas pour les Y2 dans lequel il y a une formule; mªme si le "vide" est
#N/A

c'est l  mon pb. J'ai des Y manquants "calcul©s" et quelque soit la formule
dans une cellule vide cela conduit   une interpolation!

Irritant!!!

Merci de l'aide.
Francois L
Le #16602752
ylc a ©crit :
pas tout   fait!

Imaginons les X: 1,2,3,4
les Y1: 2, 4, "manquant", 8
les Y2: = {si(X<>0;10*X; #N/A)} ou {si(X<>0;10*X;
NA()}....

cela va marcher pour les Y1 saisis "  la main"
mais pas pour les Y2 dans lequel il y a une formule; mªme si le "vide" est
#N/A

c'est l  mon pb. J'ai des Y manquants "calcul©s" et quelque soit la formule
dans une cellule vide cela conduit   une interpolation!

Irritant!!!

Merci de l'aide.





Re,

Eh oui, une valeur Na est toujours interpol©e comme je l'explique dans
mon classeur et une valeur de type "" n'est pas vide ! Conclusion, soit
tu remplaces par VBA les NA ou "" par des vraies valeurs vides (cf
explication dans le classeur), soit tu fait plusieurs s©ries pour avoir
des vides l  o¹ tu as des valeurs manquantes !

Sur ce coup l , Excel n'est vraiment pas net, mais c'est comme §a dans
toutes les versions.

--
Fran§ois L
ylc
Le #16602851
Merci!
Je vais travailler sur l'option VBA!
et l
Publicité
Poster une réponse
Anonyme