Graphique sur une plage variable

Le
Frank Delannoy
Bonjour !

J'aimerais créer un graphique d'évolution de capital. Mais je ne veux pas
réserver d'avance la plage à utiliser dans le graphique (il peut y avoir
plusieurs centaines de données).
J'aimerais que l'abscisse évolue en même temps que la quantité de données
pour ne pas avoir de zones vides dans le graphique, qu'il soit toujours
"complet".

J'ai créé un nom de page graphauto
=ÞCALER(Feuil1!$B$3;0;0;NB.SI(Feuil1!$B$3:$B$1000;">0");1)
Si je fais =SOMME(graphauto), cela fonctionne très bien, cela s'adapte.
Si, dans les propriétés du graph, Données sources, Plage de données, je
colle =graphauto , cela fonctionne mais il transforme en références
actuelles et ne s'adapte plus après.

Comment faire pour qu'il garde graphauto et s'adapte automatiquement ?
Ou une autre méthode ?

Merci d'avance !!
A+
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #4749361
Bonsoir,

http://boisgontierjacques.free.fr/pages_site/graphiques.htm#GraphiqueDynami que
http://boisgontierjacques.free.fr/fichiers/graphe/jb-GraphiqueDynamique.xls

JB
http://boisgontierjacques.free.fr

On 11 sep, 21:09, "Frank Delannoy" wrote:
Bonjour !

J'aimerais créer un graphique d'évolution de capital. Mais je ne veux pas
réserver d'avance la plage à utiliser dans le graphique (il peut y av oir
plusieurs centaines de données).
J'aimerais que l'abscisse évolue en même temps que la quantité de d onnées
pour ne pas avoir de zones vides dans le graphique, qu'il soit toujours
"complet".

J'ai créé un nom de page graphauto
=ÞCALER(Feuil1!$B$3;0;0;NB.SI(Feuil1!$B$3:$B$1000;">0");1)
Si je fais =SOMME(graphauto), cela fonctionne très bien, cela s'adapt e.
Si, dans les propriétés du graph, Données sources, Plage de donné es, je
colle =graphauto , cela fonctionne mais il transforme en références
actuelles et ne s'adapte plus après.

Comment faire pour qu'il garde graphauto et s'adapte automatiquement ?
Ou une autre méthode ?

Merci d'avance !!
A+


Frank Delannoy
Le #4749271
Re...

Bonsoir,


http://boisgontierjacques.free.fr/pages_site/graphiques.htm#GraphiqueDynamique


http://boisgontierjacques.free.fr/fichiers/graphe/jb-GraphiqueDynamique.xls


C'est exactement cela !!
J'avais oublié le coup du =SERIE(...) dans la barre de formule !
Après 1-2 adaptations, tout fonctionne parfaitement !

Merci !!

JB
http://boisgontierjacques.free.fr


T'es un champion
Bravo
et super site !!

A+

On 11 sep, 21:09, "Frank Delannoy" wrote:
Bonjour !

J'aimerais créer un graphique d'évolution de capital. Mais je ne veux pas
réserver d'avance la plage à utiliser dans le graphique (il peut y avoir
plusieurs centaines de données).
J'aimerais que l'abscisse évolue en même temps que la quantité de données
pour ne pas avoir de zones vides dans le graphique, qu'il soit toujours
"complet".

J'ai créé un nom de page graphauto
=ÞCALER(Feuil1!$B$3;0;0;NB.SI(Feuil1!$B$3:$B$1000;">0");1)
Si je fais =SOMME(graphauto), cela fonctionne très bien, cela s'adapte.
Si, dans les propriétés du graph, Données sources, Plage de données, je
colle =graphauto , cela fonctionne mais il transforme en références
actuelles et ne s'adapte plus après.

Comment faire pour qu'il garde graphauto et s'adapte automatiquement ?
Ou une autre méthode ?

Merci d'avance !!
A+


Publicité
Poster une réponse
Anonyme