Gros bugue de X

Le
nicolas.patrois
Bonjour,

J'ai envoyé un rapport de bugue (Bug#627175), j'ai vraiment un gros
problème :
* XMMS 1 plante X au lancement.
* KDE et WMaker plantent au lancement, j'ai à peine le temps de voir le
fond d'écran.
* Banshee et Amarok peuvent être lancés mais plantent X lors d'une
action précise, comme utiliser un ascenseur ou cliquer avec le bouton
droit.
Planter X signifie revenir à GDM.
Il se trouve que le bugue n'existe pas dans Ubuntu en Live CD ou dans
une session d'un autre utilisateur.
Le problème est donc dans ma configuration privée, de X je pense.

Quelqu'un a une piste ?

nicolas patrois : pts noir asocial
--
RÉALISME

M : Qu'est-ce qu'il nous faudrait pour qu'on nous considère comme des
humains ? Un cerveau plus gros ?
P : Non Une carte bleue suffirait
=

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/1305990635.6112.1@new-host.home
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Bernard Schoenacker
Le #23381141
Le Sat, 21 May 2011 17:10:35 +0200,
a écrit :

Bonjour,

J'ai envoyé un rapport de bugue (Bug#627175), j'ai vraiment un gros
problème :
* XMMS 1 plante X au lancement.
* KDE et WMaker plantent au lancement, j'ai à peine le temps de voir
le fond d'écran.
* Banshee et Amarok peuvent être lancés mais plantent X lors d' une
action précise, comme utiliser un ascenseur ou cliquer avec le bouto n
droit.
Planter X signifie revenir à GDM.
Il se trouve que le bugue n'existe pas dans Ubuntu en Live CD ou dans
une session d'un autre utilisateur.
Le problème est donc dans ma configuration privée, de X je pens e.

Quelqu'un a une piste ?

nicolas patrois : pts noir asocial



bonjour,

puisque tu as un début de solution, je te conseille simplement de
supprimer ton home et de le recréer en version vierge ....

mode opératoire :

<CTRL>+<ALT>+<F2>
login root
kill all process user 1000

mv nicolas nicolas.OLD
mkdir -p nicolas
chown -R 1000:1000 nicolas

le reste est classique ....


slt
bernard

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Courrier Debian
Le #23381181
Le samedi 21 mai 2011 17:10:35, a écrit :
Bonjour,

J'ai envoyé un rapport de bugue (Bug#627175), j'ai vraiment un gros
problème :
* XMMS 1 plante X au lancement.
* KDE et WMaker plantent au lancement, j'ai à peine le temps de voir le
fond d'écran.
* Banshee et Amarok peuvent être lancés mais plantent X lors d'une
action précise, comme utiliser un ascenseur ou cliquer avec le bouton
droit.
Planter X signifie revenir à GDM.
Il se trouve que le bugue n'existe pas dans Ubuntu en Live CD ou dans
une session d'un autre utilisateur.
Le problème est donc dans ma configuration privée, de X je pense.

Quelqu'un a une piste ?

nicolas patrois : pts noir asocial


Donne Un peu plus de détail sur ta config :
Version de Linux 32 ou 38?
Si 38 il y a un gros Bug avec les drivers ATI et cela ne fonctionne pas.
Si 32 la dernière version du driver ATI 11-4-2 fglrx est très mauvaise , sur
deux ordinateurs Sid AMD 64 et Testing 32 Bits avec une carte vidéo qui
devrait être très performante les résultats sont déplorables.
glxgear donne sur les deux cartes donne des résultats entre 1000 et 2000
normalement la carte HD 2600 donne entre 7000 et 9000.
A+
Philippe MERLIN

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
nicolas.patrois
Le #23381231
Le 21/05/2011 18:01:45, Courrier Debian a écrit :

Donne Un peu plus de détail sur ta config :
Version de Linux 32 ou 38?

uname -a


Linux new-host.home 2.6.38-2-686-bigmem #1 SMP Sun May 8 15:43:39 UTC
2011 i686 GNU/Linux

Mais j'ai le même bugue avec un vieux noyau 2.6.30, avec VESA comme
avec le pilote propriétaire de nVidia.

De plus, je n'ai pas le bugue avec une session d'un autre utilisateur
et ça me saoule de tripoter mon répertoire personnel et de tout
refaire.

nicolas patrois : pts noir asocial
--
RÉALISME

M : Qu'est-ce qu'il nous faudrait pour qu'on nous considère comme des
humains ? Un cerveau plus gros ?
P : Non... Une carte bleue suffirait...

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Jean-Francois Rousval
Le #23381701
Pas de piste mais ...
... j'ai un problème identique depuis le 13 avril suite à une mise à jour
suite à une mise à jour (je ne sais pas quel paquet).

Je suis en testing, Gnome fonctionne mais certaines applications KDE : ko nsole, kmymoney
plante Gnome qui revient à l'écran de démarrage avec dans Xorg.log :

Backtrace:
[ 43983.201] 0: /usr/bin/X (xorg_backtrace+0x37) [0x80ed307]
[ 43983.201] 1: /usr/bin/X (0x8048000+0x6356a) [0x80ab56a]
[ 43983.201] 2: (vdso) (__kernel_rt_sigreturn+0x0) [0xb772f40c]
[ 43983.201] 3: /usr/bin/X (doListFontsWithInfo+0xf3) [0x8075f23]
[ 43983.201] 4: /usr/bin/X (ProcessWorkQueue+0x2d) [0x807990d]
[ 43983.201] 5: /usr/bin/X (WaitForSomething+0x5a) [0x80a4bba]
[ 43983.201] 6: /usr/bin/X (0x8048000+0x2d2e2) [0x80752e2]
[ 43983.201] 7: /usr/bin/X (0x8048000+0x205ac) [0x80685ac]
[ 43983.201] 8: /lib/i686/cmov/libc.so.6 (__libc_start_main+0xe6) [0xb742 2e46]
[ 43983.202] 9: /usr/bin/X (0x8048000+0x208c1) [0x80688c1]
[ 43983.202] Segmentation fault at address (nil)
[ 43983.202]
Fatal server error:
[ 43983.202] Caught signal 11 (Segmentation fault). Server aborting

Jean-François Rousval




Le 21/05/2011 17:10, a écrit :
Bonjour,

J'ai envoyé un rapport de bugue (Bug#627175), j'ai vraiment un gros
problème :
* XMMS 1 plante X au lancement.
* KDE et WMaker plantent au lancement, j'ai à peine le temps de voir le
fond d'écran.
* Banshee et Amarok peuvent être lancés mais plantent X lors d'une
action précise, comme utiliser un ascenseur ou cliquer avec le bouton
droit.
Planter X signifie revenir à GDM.
Il se trouve que le bugue n'existe pas dans Ubuntu en Live CD ou dans
une session d'un autre utilisateur.
Le problème est donc dans ma configuration privée, de X je pense.

Quelqu'un a une piste ?

nicolas patrois : pts noir asocial



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Gaëtan PERRIER
Le #23381951
ça semble aussi être le même problème que celui que je signalais le 4 mai dans
le fil : [testing] problème avec QT ?

Gaëtan

Le Sat, 21 May 2011 22:36:00 +0200
Jean-Francois Rousval

Pas de piste mais ...
... j'ai un problème identique depuis le 13 avril suite à une mise à jour
suite à une mise à jour (je ne sais pas quel paquet).

Je suis en testing, Gnome fonctionne mais certaines applications KDE :
konsole, kmymoney plante Gnome qui revient à l'écran de démarrage avec dans
Xorg.log :

Backtrace:
[ 43983.201] 0: /usr/bin/X (xorg_backtrace+0x37) [0x80ed307]
[ 43983.201] 1: /usr/bin/X (0x8048000+0x6356a) [0x80ab56a]
[ 43983.201] 2: (vdso) (__kernel_rt_sigreturn+0x0) [0xb772f40c]
[ 43983.201] 3: /usr/bin/X (doListFontsWithInfo+0xf3) [0x8075f23]
[ 43983.201] 4: /usr/bin/X (ProcessWorkQueue+0x2d) [0x807990d]
[ 43983.201] 5: /usr/bin/X (WaitForSomething+0x5a) [0x80a4bba]
[ 43983.201] 6: /usr/bin/X (0x8048000+0x2d2e2) [0x80752e2]
[ 43983.201] 7: /usr/bin/X (0x8048000+0x205ac) [0x80685ac]
[ 43983.201] 8: /lib/i686/cmov/libc.so.6 (__libc_start_main+0xe6)
[0xb7422e46] [ 43983.202] 9: /usr/bin/X (0x8048000+0x208c1) [0x80688c1]
[ 43983.202] Segmentation fault at address (nil)
[ 43983.202]
Fatal server error:
[ 43983.202] Caught signal 11 (Segmentation fault). Server aborting

Jean-François Rousval




Le 21/05/2011 17:10, a écrit :
> Bonjour,
>
> J'ai envoyé un rapport de bugue (Bug#627175), j'ai vraiment un gros
> problème :
> * XMMS 1 plante X au lancement.
> * KDE et WMaker plantent au lancement, j'ai à peine le temps de voir le
> fond d'écran.
> * Banshee et Amarok peuvent être lancés mais plantent X lors d'une
> action précise, comme utiliser un ascenseur ou cliquer avec le bouton
> droit.
> Planter X signifie revenir à GDM.
> Il se trouve que le bugue n'existe pas dans Ubuntu en Live CD ou dans
> une session d'un autre utilisateur.
> Le problème est donc dans ma configuration privée, de X je pense.
>
> Quelqu'un a une piste ?
>
> nicolas patrois : pts noir asocial

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/





--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
nicolas.patrois
Le #23382141
Le 22/05/2011 02:27:24, Gaëtan PERRIER a écrit :

ça semble aussi être le même problème que celui que je signalais le 4
mai dans le fil : [testing] problème avec QT ?



Vous avez rapporté le bugue ?
Pour le moment il est réassigné à tort à Sawfish.

nicolas patrois : pts noir asocial
--
RÉALISME

M : Qu'est-ce qu'il nous faudrait pour qu'on nous considère comme des
humains ? Un cerveau plus gros ?
P : Non... Une carte bleue suffirait...

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Jean-Francois Rousval
Le #23382401
Quelqu'un sait il comment retrouver l'historique des dates
des mises à jour de paquets sur une machine ?

Jean-François Rousval

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Grégory Bulot
Le #23382491
Bonjour, Bonsoir,

Le Sun, 22 May 2011 11:22:36 +0200, Jean-Francois Rousval, vous avez
écrit :

Quelqu'un sait il comment retrouver l'historique des dates
des mises à jour de paquets sur une machine ?

Jean-François Rousval





/var/log/apt/history.log ?


--
Cordialement
Grégory BULOT


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Jean-Francois Rousval
Le #23382831
Le 22/05/2011 11:48, Grégory Bulot a écrit :

/var/log/apt/history.log ?




Merci pour la piste c'est :

/var/log/apt/term.log /var/log/apt/term.log.x.gz

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Jean-Francois Rousval
Le #23382921
Ce n'est pas une explication ... :(

... mais la suggestion faite dans le rapport de bug #615975
de supprimer la ligne :

FontPath "unix/:7100"

dans xorg.conf semble apporter une solution sur ma machine.

Jean-François Rousval




Le 21/05/2011 17:10, a écrit :
Bonjour,

J'ai envoyé un rapport de bugue (Bug#627175), j'ai vraiment un gros
problème :
* XMMS 1 plante X au lancement.
* KDE et WMaker plantent au lancement, j'ai à peine le temps de voir le
fond d'écran.
* Banshee et Amarok peuvent être lancés mais plantent X lors d'une
action précise, comme utiliser un ascenseur ou cliquer avec le bouton
droit.
Planter X signifie revenir à GDM.
Il se trouve que le bugue n'existe pas dans Ubuntu en Live CD ou dans
une session d'un autre utilisateur.
Le problème est donc dans ma configuration privée, de X je pense.

Quelqu'un a une piste ?

nicolas patrois : pts noir asocial



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme