Gros problème de configuration IIS 5.1 pour ASP

Le
batman57
Bonjour,

J'essaie actuellement de configurer un IIS en local pour retoucher un site Internet développé en ASP avec base de données Access.

Le site fonctionne très bien en local sur la machine d'un collègue, mais sur la mienne la connexion à la base de données pose problème (connexion via ODBC).

Au moment de la connexion, l'erreur suivante se produit:

Microsoft OLE DB Provider for ODBC Drivers (0x80004005)
[Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified.

Le site fonctionnant sur une autre machine, les scripts ASP ne peuvent pas être mis en cause.
L'ODBC est configuré de la même façon sur les deux machines.
J'en déduis que c'est la configuration du IIS qui est en cause.

Après un long parcours de forums, j'en suis arrivé à effectuer toutes sortes de manipulations mais sans succès (attribuer les droits en écriture pour le IUSR par exemple).

Donc si quelqu'un pouvait me venir en aide, vous m'oterez une grosse épine du pied.

Si j'ai oublié de fournir des informations, faites le moi savoir.

Merci d'avance.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
batman57
Le #16706351
batman57 a écrit le 28/08/2008 à 11h06 :
Bonjour,

J'essaie actuellement de configurer un IIS en local pour retoucher un site
Internet développé en ASP avec base de données Access.

Le site fonctionne très bien en local sur la machine d'un
collègue, mais sur la mienne la connexion à la base de
données pose problème (connexion via ODBC).

Au moment de la connexion, l'erreur suivante se produit:

Microsoft OLE DB Provider for ODBC Drivers (0x80004005)
[Microsoft][ODBC Driver Manager] Data source name not found and no default
driver specified.

Le site fonctionnant sur une autre machine, les scripts ASP ne peuvent pas
être mis en cause.
L'ODBC est configuré de la même façon sur les deux
machines.
J'en déduis que c'est la configuration du IIS qui est en cause.

Après un long parcours de forums, j'en suis arrivé à
effectuer toutes sortes de manipulations mais sans succès (attribuer les
droits en écriture pour le IUSR par exemple).

Donc si quelqu'un pouvait me venir en aide, vous m'oterez une grosse
épine du pied.

Si j'ai oublié de fournir des informations, faites le moi savoir.

Merci d'avance.


Alors vraiment personne n'a d'idée ?!!
Publicité
Poster une réponse
Anonyme