Grub Geom Error

Le
leger
Bonjour,

Un petit souci.
Ca fait plusieurs fois que j'installe Elive sur un Athlon 800 Mhz, et
Elive Installer s'arrête avant de pouvoir mettre Grub à la bonne place
(MBR ?)
Donc j'ai cette erreur "Grub Geom Error".

J'ai tout regardé, ça ne peut venir que du fait que l'installation c'est
mal faite.

Comment mettre grub? (j'ai lu pas mal de chose)
Je n'ai que Elive sur ce PC.
J'ai mis grub-install dans un terminal, mais ça se trouve faut rajouter
des trucs derrière. (je ne suis pas informaticien)

Bon, si vous avez 5 minutes. ;-)

(Ubuntu rame sur ce PC, pour ça que je mets Elive, mais je n'ai pas
cette erreur)

--
@+
leger
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
leger
Le #20169651
Juste pour dire que même avec un live CD pour réinstaller Grub, ça ne va
pas.
Code erreur 2 ??!!

J'ai tout essayé : (à partir du CD Live de Elive)
_ grub-install /mnt/hda2/
_ grub-install /mnt/hda2/boot/
_ etc...

Ca me dit qu'il manque un paramètre.
Voilà, si vous aviez une astuce.

--
@+
leger
Vivien MOREAU
Le #20170471
On 2009-09-17, leger wrote:

Juste pour dire que même avec un live CD pour réinstaller Grub, ça ne va
pas.
Code erreur 2 ??!!

J'ai tout essayé : (à partir du CD Live de Elive)
_ grub-install /mnt/hda2/
_ grub-install /mnt/hda2/boot/
_ etc...

Ca me dit qu'il manque un paramètre.
Voilà, si vous aviez une astuce.




Utilise grub-install avec le nom de fichier du périphérique, pas du
point de montage.
Genre, grub-install /dev/hda2 pour l'installer sur le MBR de cette
partition (pas forcément ce que tu veux faire ), ou
grub-install /dev/hda pour l'installer sur le MBR du disque.

man grub-install en cas de doute ;-)


--
Vivien MOREAU / vpm
leger
Le #20174311
Vivien MOREAU a écrit :
Utilise grub-install avec le nom de fichier du périphérique, pas du
point de montage.



Oui, je teste ça, merci.
leger
Le #20174621
Bon, je réinstalle Elive manuellement.
Je ne suis pas arrivé à remettre Grub.

Pourquoi j'ai cette difficulté avec Elive et pas avec Ubuntu par exemple.
Grub, c'est grub.
Et je n'ai pas changé de disque entre temps.


--
@+
Leger
leger
Le #20175091
C'est bon, ça marche! :-))
Impressionnant Elive au démarrage!
Même sur un "vieux" Athlon 800 Mhz.
Ca devrait être stable, c'est Debian (que je n'ai pas, j'ai un CD live
de Debian avec LXDE mais pas instalable)
On va voir si c'est vrai qu'Elive demande peu de ressources.


Par contre j'ai dû tout réinstaller à la main et partitionner en Ext3.
Sinon l'installation se faisait avec reseirfs, et ça devait être bugué
car je n'arrivais pas jusque la phase où fallait choisir où mettre grub.

Bon, je teste tout ça, c'est plaisant.
Merci au libre quand même.

--
@+
Leger
Publicité
Poster une réponse
Anonyme