grub et lilo

Le
Jean-Jacques Gerbaud
Bonjour à tous,

Comme je le laissais entendre il y a quelques semaines (mois ?) j'ai
finalement viré grub !. Je pense que je vais avoir des réactions pour me
dire que je "n'aurais pas du" (allons bon, voila -t'il-pas que mon
accent circonflèxe ne fonctionne plus ?)

bon, je l'ai viré et j'ai installé lilo et, après un liloconfig en
console, j'ai du (encore !) tatonner un peu mais finalement mon
/etc/lilo.conf est bon et me lance sur la bonne distribution (linuxmint 13)

Maintenant je demande votre aide pour compléter mon /etc/lilo.conf pour
y mettre - en cas de coup dur - le démarrage "récupération" (recovery)

Merci de votre aide
--
Jean-Jacques Gerbaud
entre Dauphiné et PACA
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Emmanuel Florac
Le #24729732
Le Tue, 28 Aug 2012 15:39:03 +0200, Jean-Jacques Gerbaud a écrit:


Maintenant je demande votre aide pour compléter mon /etc/lilo.conf pour
y mettre - en cas de coup dur - le démarrage "récupération" (recovery)




Ce serait plus facile si tu montrais le contenu du fichier :)

--
SCSI is not magic. There are fundamental technical reasons why you have
to sacrifice a young goat to your SCSI chain every now and then.
John F. Woods
Jean-Jacques Gerbaud
Le #24730262
Le 28/08/2012 22:43, Emmanuel Florac a écrit :
Le Tue, 28 Aug 2012 15:39:03 +0200, Jean-Jacques Gerbaud a écrit:


Maintenant je demande votre aide pour compléter mon /etc/lilo.conf pour
y mettre - en cas de coup dur - le démarrage "récupération" (recovery)




Ce serait plus facile si tu montrais le contenu du fichier :)




le voici

# /etc/lilo.conf - systemwide LILO configuration (LILO 23)
# details see in manpages: lilo(8) and lilo.conf(5)

# +-------------------------------------------------------------+
# | !! Reminder !! |
# | |
# | Don't forget to run 'lilo' after you make changes to this |
# | conffile or you have installed a new kernel. |
# +-------------------------------------------------------------+

lba32
boot = /dev/sda
map = /boot/map
install = menu
menu-scheme = Wb:Yr:Wb:Wb
prompt
timeout = 100
vga = normal
default = "linuxmint"

image=/boot/vmlinuz-3.2.0-29-generic
label="linuxmint"
root="UUID4045d6-e4ec-414c-8e8d-b75d044cbe50"
initrd=/boot/initrd.img-3.2.0-29-generic

--------------------------------------------------------------------------

J'ai évidemment enlevé toutes les lignes commentées (#) et il y en a pas
mal ! :-)

Merci de l'aide à venir

--
Jean-Jacques Gerbaud
entre Dauphiné et PACA
Pascal Hambourg
Le #24730362
Salut,

Jean-Jacques Gerbaud a écrit :

Maintenant je demande votre aide pour compléter mon /etc/lilo.conf pour
y mettre - en cas de coup dur - le démarrage "récupération" (recovery)



Qu'entends-tu exactement par "récupération" ?
Toxico Nimbus
Le #24730732
Le 28/08/2012 23:36, Jean-Jacques Gerbaud a écrit :
Le 28/08/2012 22:43, Emmanuel Florac a écrit :
Le Tue, 28 Aug 2012 15:39:03 +0200, Jean-Jacques Gerbaud a écrit:


Maintenant je demande votre aide pour compléter mon /etc/lilo.conf pour
y mettre - en cas de coup dur - le démarrage "récupération" (recovery)




Ce serait plus facile si tu montrais le contenu du fichier :)




le voici

# /etc/lilo.conf - systemwide LILO configuration (LILO 23)
# details see in manpages: lilo(8) and lilo.conf(5)

# +-------------------------------------------------------------+
# | !! Reminder !! |
# | |
# | Don't forget to run 'lilo' after you make changes to this |
# | conffile or you have installed a new kernel. |
# +-------------------------------------------------------------+

lba32
boot = /dev/sda
map = /boot/map
install = menu
menu-scheme = Wb:Yr:Wb:Wb
prompt
timeout = 100
vga = normal
default = "linuxmint"

image=/boot/vmlinuz-3.2.0-29-generic
label="linuxmint"
root="UUID4045d6-e4ec-414c-8e8d-b75d044cbe50"
initrd=/boot/initrd.img-3.2.0-29-generic

--------------------------------------------------------------------------

J'ai évidemment enlevé toutes les lignes commentées (#) et il y en a pas
mal ! :-)

Merci de l'aide à venir




A priori (je ne suis pas spécialiste de lilo), tu dois créer une
deuxième entrée comme suit:

image=/boot/vmlinuz-3.2.0-29-generic
label="linuxmint"
root="UUID4045d6-e4ec-414c-8e8d-b75d044cbe50"
initrd=/boot/initrd.img-3.2.0-29-generic
append="single"

(tu peux aussi remplacer single par emergency pour un boot encore moins
avancé).
Pascal Hambourg
Le #24730972
Toxico Nimbus a écrit :

A priori (je ne suis pas spécialiste de lilo), tu dois créer une
deuxième entrée comme suit:

image=/boot/vmlinuz-3.2.0-29-generic
label="linuxmint"
root="UUID4045d6-e4ec-414c-8e8d-b75d044cbe50"
initrd=/boot/initrd.img-3.2.0-29-generic
append="single"



Il vaudrait mieux changer le label.
Toxico Nimbus
Le #24732102
Le 29/08/2012 09:31, Pascal Hambourg a écrit :
Toxico Nimbus a écrit :

A priori (je ne suis pas spécialiste de lilo), tu dois créer une
deuxième entrée comme suit:

image=/boot/vmlinuz-3.2.0-29-generic
label="linuxmint"
root="UUID4045d6-e4ec-414c-8e8d-b75d044cbe50"
initrd=/boot/initrd.img-3.2.0-29-generic
append="single"



Il vaudrait mieux changer le label.



C'est pas faux
Jean-Jacques Gerbaud
Le #24732312
Le 29/08/2012 08:12, Toxico Nimbus a écrit :
Le 28/08/2012 23:36, Jean-Jacques Gerbaud a écrit :
Le 28/08/2012 22:43, Emmanuel Florac a écrit :
Le Tue, 28 Aug 2012 15:39:03 +0200, Jean-Jacques Gerbaud a écrit:




Merci de l'aide à venir




A priori (je ne suis pas spécialiste de lilo), tu dois créer une
deuxième entrée comme suit:

image=/boot/vmlinuz-3.2.0-29-generic
label="linuxmint"
root="UUID4045d6-e4ec-414c-8e8d-b75d044cbe50"
initrd=/boot/initrd.img-3.2.0-29-generic
append="single"



Pour répondre à Pascal Hambourg quant au label, il n'a pas accepté 2
entrées avec le même label. J'ai donc mis "recovery"

Cependant, avec
append="single"

tout se lance normalement et j'arrive sur une console. Là, je me rends
compte que toutes les partitions sont montées ce qui n'est pas le but
d'un "recovery" ! :-(

(tu peux aussi remplacer single par emergency pour un boot encore moins
avancé).



J'ai essayé mais le système ne se lance pas :
enter root password for maintenance or Ctrl-D to continue.

Aucune des deux options ne fonctionnent.

J'ai finalement mis "ro"dans "append" à la suite de "single"

Mais en fait, mon but était de pouvoir relancer la machine et de me
trouver face à un système équivalent à un live-CD. En fait, si le
système est déjà monté, c'est peut être une facilité, non ?

Est-ce que je dois enlever le "ro" ?

Merci de vos réponses


--
Jean-Jacques Gerbaud
entre Dauphiné et PACA
Fabien LE LEZ
Le #24732882
On Wed, 29 Aug 2012 14:57:10 +0200, Jean-Jacques Gerbaud

Mais en fait, mon but était de pouvoir relancer la machine et de me
trouver face à un système équivalent à un live-CD.



Franchement, je trouve plus facile d'utiliser carrément un live-CD (ou
plutôt un live-USB).
Emmanuel Florac
Le #24734282
Le Wed, 29 Aug 2012 14:57:10 +0200, Jean-Jacques Gerbaud a écrit:


J'ai essayé mais le système ne se lance pas : enter root password for
maintenance or Ctrl-D to continue.

Aucune des deux options ne fonctionnent.



C'est à dire? Tu as essayé d'entrer le mot de passe root comme sur un
clavier qwerty, au cas où?

--
Toutes les organisations ont leur règles, et les Femmes Algériennes
doivent avoir aussi leurs règles.
Kaid Ahmed.
Jean-Jacques Gerbaud
Le #24734662
Le 29/08/2012 20:56, Emmanuel Florac a écrit :
Le Wed, 29 Aug 2012 14:57:10 +0200, Jean-Jacques Gerbaud a écrit:


J'ai essayé mais le système ne se lance pas : enter root password for
maintenance or Ctrl-D to continue.

Aucune des deux options ne fonctionnent.





Le système continue d'alligner
enter root password for maintenance or Ctrl-D to continue.
enter root password for maintenance or Ctrl-D to continue.
enter root password for maintenance or Ctrl-D to continue.

et ainsi de suite. Même pas moyen de passer par un autre tty. Ma seule
solution, maintenir le bouton de mise en marche appuyé jusqu'à ce que le
système s'arrête.


C'est à dire? Tu as essayé d'entrer le mot de passe root comme sur un
clavier qwerty, au cas où?



mon mot de passe ne comporte aucune lettre qui pourrait être mal
interprétée par un clavier US. C'est à dire qi'il peut s'écrire aussi
bien dans le clavier us que fr.

Une autre piste ? Mais en fait, je crois que je vais arrêter là. Je peux
aller dans le système en "recovery mode" avec l'option

append "single"

--
Jean-Jacques Gerbaud
entre Dauphiné et PACA
Publicité
Poster une réponse
Anonyme