Help poir un magasinier

Le
euch20
Bonjour à tous,

Par avance merci de porter un interêt à ma requête.

J'ai sous Excel 2003 créé une Feuil1 comportant mon stock du magasin
La Feuil2 comporte quant à elle ce qui est parti du stock dans la
journée mais le plus important est la Feuil3 qui comme je le voudrais
aurai lereste du stock. Afin d'éviter maintes et maintes formules
répétées par ligne, j'aurais voulu savoir si qu'un pourrait
éventuellement m'aiguiller sur un code VBA. A moins d'avoir une astuce
avec les formules.

Cordialement.
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #20647731
bonjour euch20,

à mettre sur la Feuil3
=SOMMEPROD((Feuil1!A1:A10¡)*(Feuil1!B1:B10))-SOMMEPROD((Feuil2!A1:A10¡)*(Feuil2!B1:B10))

isabelle

euch20 a écrit :
Bonjour à tous,

Par avance merci de porter un interêt à ma requête.

J'ai sous Excel 2003 créé une Feuil1 comportant mon stock du magasin
La Feuil2 comporte quant à elle ce qui est parti du stock dans la
journée mais le plus important est la Feuil3 qui comme je le voudrais
aurai lereste du stock. Afin d'éviter maintes et maintes formules
répétées par ligne, j'aurais voulu savoir si qu'un pourrait
éventuellement m'aiguiller sur un code VBA. A moins d'avoir une astuce
avec les formules.

Cordialement.


euch20
Le #20646601
isabelle a écrit :
bonjour euch20,

à mettre sur la Feuil3
=SOMMEPROD((Feuil1!A1:A10¡)*(Feuil1!B1:B10))-SOMMEPROD((Feuil2!A1:A10¡)*(Feuil2!B1:B10))


isabelle



Merci Isabelle, je ne pensais pas qu'une seule ligne ferai l'affaire.
Cordialement
euch20
Le #20647881
euch20 a écrit :
isabelle a écrit :
bonjour euch20,

à mettre sur la Feuil3
=SOMMEPROD((Feuil1!A1:A10¡)*(Feuil1!B1:B10))-SOMMEPROD((Feuil2!A1:A10¡)*(Feuil2!B1:B10))


isabelle



Merci Isabelle, je ne pensais pas qu'une seule ligne ferai l'affaire.
Cordialement



Euh non, marche pas : (voici ce dont à quoi le tablau ressemble sur 2
colonnes A et B)
Feuil1 : Débroussailleuse 15 (Feuille de Stock initial)
Feuil2 : Débroussailleuse 9 (Feuille après distribution du matériel)

et ainsi de suite pour les autres matériels et en Feuil3 :

Feuil3 : Débroussailleuse 6

Par avance merci.
isabelle
Le #20646631
bonjour euch20,

voici un exemple : http://cjoint.com/?lBwiHXNPpj

isabelle

euch20 a écrit :
euch20 a écrit :
isabelle a écrit :
bonjour euch20,

à mettre sur la Feuil3
=SOMMEPROD((Feuil1!A1:A10¡)*(Feuil1!B1:B10))-SOMMEPROD((Feuil2!A1:A10¡)*(Feuil2!B1:B10))


isabelle



Merci Isabelle, je ne pensais pas qu'une seule ligne ferai l'affaire.
Cordialement



Euh non, marche pas : (voici ce dont à quoi le tablau ressemble sur 2
colonnes A et B)
Feuil1 : Débroussailleuse 15 (Feuille de Stock initial)
Feuil2 : Débroussailleuse 9 (Feuille après distribution du
matériel)

et ainsi de suite pour les autres matériels et en Feuil3 :

Feuil3 : Débroussailleuse 6

Par avance merci.


isabelle
Le #20646751
bonjour euch20,

voici un exemple :

http://cjoint.com/?lBwpiFpFxZ

isabelle


euch20 a écrit :
euch20 a écrit :
isabelle a écrit :
bonjour euch20,

à mettre sur la Feuil3
=SOMMEPROD((Feuil1!A1:A10¡)*(Feuil1!B1:B10))-SOMMEPROD((Feuil2!A1:A10¡)*(Feuil2!B1:B10))


isabelle



Merci Isabelle, je ne pensais pas qu'une seule ligne ferai l'affaire.
Cordialement



Euh non, marche pas : (voici ce dont à quoi le tablau ressemble sur 2
colonnes A et B)
Feuil1 : Débroussailleuse 15 (Feuille de Stock initial)
Feuil2 : Débroussailleuse 9 (Feuille après distribution du
matériel)

et ainsi de suite pour les autres matériels et en Feuil3 :

Feuil3 : Débroussailleuse 6

Par avance merci.


euch20
Le #20648411
isabelle a écrit :
bonjour euch20,

voici un exemple :

http://cjoint.com/?lBwpiFpFxZ

isabelle



Merci mille fois, Isabelle mais une dernière chose sans vouloir abuser
de votre gentillesse :
Peut-on éviter de rentrer cette formule à chaque fois. merci encore.
isabelle
Le #20650401
bonjour euch20,

sur l'exemple j'ai ajouté des $ ( valeur absolue) pour pouvoir recopier
la formule vers le bas,
pas sur de comprendre ta question ?

isabelle




euch20 a écrit :
isabelle a écrit :
bonjour euch20,

voici un exemple :

http://cjoint.com/?lBwpiFpFxZ

isabelle



Merci mille fois, Isabelle mais une dernière chose sans vouloir abuser
de votre gentillesse :
Peut-on éviter de rentrer cette formule à chaque fois. merci encore.


Philippe.R
Le #20651941
Bonjour,
Si je comprends, ça pourrait être quelque chose comme ceci
http://cjoint.com/?lChrGD4FDH
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/web/mpfe
News://news.microsoft.com/microsoft.public.fr.excel
"euch20" news:Oh$
isabelle a écrit :
bonjour euch20,

voici un exemple :

http://cjoint.com/?lBwpiFpFxZ

isabelle



Merci mille fois, Isabelle mais une dernière chose sans vouloir abuser de
votre gentillesse :
Peut-on éviter de rentrer cette formule à chaque fois. merci encore.


euch20
Le #20647941
Philippe.R a écrit :
Bonjour,
Si je comprends, ça pourrait être quelque chose comme ceci
http://cjoint.com/?lChrGD4FDH



Merci, mais c'est très bien comme vous me l'avez formulé tous deux. Pour
Isabelle, j'ai juste tiré vers le bas la premiere cellule contenant sa
formule. merci encore
Cordialement
Publicité
Poster une réponse
Anonyme