les heures encore et toujours

Le
daryl
bonjour à tous désolée je viens encore avec un souci de soustraction
d'heures- j'ai un tableau où le resuktat des soustractions peut être negatif-
je ne veux pas utilsier le calendrier 1904 - j'ai donc mis la formule
suivante :
=TEXT(ABS(A1-A2);"-h:mm:ss") mais j'ai l'erreur "nom"
merci de m'aider
daryl
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
ChristianM
Le #18860681
un E à TEXTE

--
ChristianM


"daryl"
bonjour à tous désolée je viens encore avec un souci de soustraction
d'heures- j'ai un tableau où le resuktat des soustractions peut être
negatif-
je ne veux pas utilsier le calendrier 1904 - j'ai donc mis la formule
suivante :
=TEXT(ABS(A1-A2);"-h:mm:ss") mais j'ai l'erreur "nom"
merci de m'aider
daryl



Jacky
Le #18860841
Bonjour,

Pour ce qui est de l'erreur "NOM" , c'est parce qu'il manque un "E" à "TEXT"

Et pour éviter que si le résultat de la soustraction n'est pas négatif,
l"affichage du moins (-)
Je propose par exemple
=SI(A2>A1;TEXTE(ABS(A1-A2);"-h:mm:ss");A1-A2)
cellule au format: [h]:mm:ss
--
Salutations
JJ


"daryl"
bonjour à tous désolée je viens encore avec un souci de soustraction
d'heures- j'ai un tableau où le resuktat des soustractions peut être
negatif-
je ne veux pas utilsier le calendrier 1904 - j'ai donc mis la formule
suivante :
=TEXT(ABS(A1-A2);"-h:mm:ss") mais j'ai l'erreur "nom"
merci de m'aider
daryl



Jacky
Le #18860941
Plutôt

=SI(A2>A1;TEXTE(ABS(A1-A2);"-[h]:mm:ss");A1-A2)
cellule au format: [h]:mm:ss

Au cas ou le résultat est plus grand que 24h ou -24h
--
Salutations
JJ


"Jacky"
Bonjour,

Pour ce qui est de l'erreur "NOM" , c'est parce qu'il manque un "E" à
"TEXT"

Et pour éviter que si le résultat de la soustraction n'est pas négatif,
l"affichage du moins (-)
Je propose par exemple
=SI(A2>A1;TEXTE(ABS(A1-A2);"-h:mm:ss");A1-A2)
cellule au format: [h]:mm:ss
--
Salutations
JJ


"daryl"
bonjour à tous désolée je viens encore avec un souci de soustraction
d'heures- j'ai un tableau où le resuktat des soustractions peut être
negatif-
je ne veux pas utilsier le calendrier 1904 - j'ai donc mis la formule
suivante :
=TEXT(ABS(A1-A2);"-h:mm:ss") mais j'ai l'erreur "nom"
merci de m'aider
daryl







daryl
Le #18860911
merci
j'avais rajouté le "E" mais cela n'a rien changé-
par contre je viens d'essayer votre formule et sachant que dans la realite
j'ai en A1 124:50 et en B2 180:00 les deux au format [hh]:mm j'obtiens -7h10
alors que la vrais dif est > à 55h
ces heures restent un mystere pour moi
daryl

"Jacky" a écrit :

Plutôt

=SI(A2>A1;TEXTE(ABS(A1-A2);"-[h]:mm:ss");A1-A2)
cellule au format: [h]:mm:ss

Au cas ou le résultat est plus grand que 24h ou -24h
--
Salutations
JJ


"Jacky"
> Bonjour,
>
> Pour ce qui est de l'erreur "NOM" , c'est parce qu'il manque un "E" à
> "TEXT"
>
> Et pour éviter que si le résultat de la soustraction n'est pas négatif,
> l"affichage du moins (-)
> Je propose par exemple
> =SI(A2>A1;TEXTE(ABS(A1-A2);"-h:mm:ss");A1-A2)
> cellule au format: [h]:mm:ss
> --
> Salutations
> JJ
>
>
> "daryl" >
>> bonjour à tous désolée je viens encore avec un souci de soustraction
>> d'heures- j'ai un tableau où le resuktat des soustractions peut être
>> negatif-
>> je ne veux pas utilsier le calendrier 1904 - j'ai donc mis la formule
>> suivante :
>> =TEXT(ABS(A1-A2);"-h:mm:ss") mais j'ai l'erreur "nom"
>> merci de m'aider
>> daryl
>>
>
>





daryl
Le #18861041
Ok je suis etourdie j'avais oublié les crochets c'est bon j'ai mon compte
-55h10 mais B1 n'est pas toujours sup à A1 et ensuite la formule ne marche pas
merci de votre patience

daryl

"daryl" a écrit :

bonjour à tous désolée je viens encore avec un souci de soustraction
d'heures- j'ai un tableau où le resuktat des soustractions peut être negatif-
je ne veux pas utilsier le calendrier 1904 - j'ai donc mis la formule
suivante :
=TEXT(ABS(A1-A2);"-h:mm:ss") mais j'ai l'erreur "nom"
merci de m'aider
daryl



Sam
Le #18862071
Bonjour,
=SI(A2>A1;TEXTE((A2-A1);"-[h]:mm");TEXTE((A1-A2);"[h]:mm"))
Cordialement
Michel dit "Sam"

"daryl"
Ok je suis etourdie j'avais oublié les crochets c'est bon j'ai mon compte
-55h10 mais B1 n'est pas toujours sup à A1 et ensuite la formule ne marche
pas
merci de votre patience

daryl

"daryl" a écrit :

bonjour à tous désolée je viens encore avec un souci de soustraction
d'heures- j'ai un tableau où le resuktat des soustractions peut être
negatif-
je ne veux pas utilsier le calendrier 1904 - j'ai donc mis la formule
suivante :
=TEXT(ABS(A1-A2);"-h:mm:ss") mais j'ai l'erreur "nom"
merci de m'aider
daryl





daryl
Le #18864301
bonsoir,

merci beaucoup
ça marche
!!
daryl


"Sam" a écrit :



Bonjour,
=SI(A2>A1;TEXTE((A2-A1);"-[h]:mm");TEXTE((A1-A2);"[h]:mm"))
Cordialement
Michel dit "Sam"

"daryl"
> Ok je suis etourdie j'avais oublié les crochets c'est bon j'ai mon compte
> -55h10 mais B1 n'est pas toujours sup à A1 et ensuite la formule ne marche
> pas
> merci de votre patience
>
> daryl
>
> "daryl" a écrit :
>
>> bonjour à tous désolée je viens encore avec un souci de soustraction
>> d'heures- j'ai un tableau où le resuktat des soustractions peut être
>> negatif-
>> je ne veux pas utilsier le calendrier 1904 - j'ai donc mis la formule
>> suivante :
>> =TEXT(ABS(A1-A2);"-h:mm:ss") mais j'ai l'erreur "nom"
>> merci de m'aider
>> daryl
>>





Publicité
Poster une réponse
Anonyme