[HF] Passer de HF classique à un Serveur HF

Le
ae-info
Bonjour,

Existe-t-il une méthode pour passer des fichiers HF vers un serveur HF ?

(en conservant les données)

Ma question est surtout pour un site Webdev, mais j'imagine que la
méthode est identique pour Windev.

Merci


Didier

http://www.obtuli.fr
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Romain PETIT
Le #19686371
ae-info a exposé le 02/07/2009 :
Bonjour,



Bonjour,


Existe-t-il une méthode pour passer des fichiers HF vers un serveur HF ?
(en conservant les données)




1. Installer le serveur HF et vérfier son fonctionnement avec une base
test
2. Modifier son programme pour pouvoir accéder à la base en HF/CS
(HouvreConnexion, HDecritConnexion..). Un code de connexion rapide est
fourni en copié coller par le centre de controle HF.
2. Couper les accès à la base Classic et sauvegarder...
3. Utiliser le Centre de controle HF pour migrer la base Classic en
HF/CS.
4. Tester...

Ca fonctionne bien. Pour les liaisons et les contraintes, il faut
fournir le wdd de l'analyse.

A+

--
Romain PETIT
contact : http://cerbermail.com/?O16kfXOFcq
+-+ posté sur Usenet avec MesNews et non depuis un forum web +-+
news:fr.comp.developpement.agl.windev
http://www.mesnews.net/
http://fr.wikipedia.org/wiki/Newsgroup
ae-info
Le #19695491
Romain PETIT a écrit :
ae-info a exposé le 02/07/2009 :
Bonjour,



Bonjour,


Existe-t-il une méthode pour passer des fichiers HF vers un serveur HF ?
(en conservant les données)




1. Installer le serveur HF et vérfier son fonctionnement avec une base test
2. Modifier son programme pour pouvoir accéder à la base en HF/CS
(HouvreConnexion, HDecritConnexion..). Un code de connexion rapide est
fourni en copié coller par le centre de controle HF.
2. Couper les accès à la base Classic et sauvegarder...
3. Utiliser le Centre de controle HF pour migrer la base Classic en HF/CS.
4. Tester...

Ca fonctionne bien. Pour les liaisons et les contraintes, il faut
fournir le wdd de l'analyse.

A+



Merci pour tes conseils, que veux tu dire par couper les accès à la base
classique ?
J'ai crée deux connexion, une sur mon serveur HF en local pour
développer et une autre sur le serveur.

Pour le moment sur le serveur malgrès le houvreConnexion, il cherche
toujours la connexion de mon serveur local ... je cherche

Merci

DP

http://www.obtuli.fr
ae-info
Le #19696981
ae-info a écrit :
Romain PETIT a écrit :
ae-info a exposé le 02/07/2009 :
Bonjour,



Bonjour,


Existe-t-il une méthode pour passer des fichiers HF vers un serveur HF ?
(en conservant les données)




1. Installer le serveur HF et vérfier son fonctionnement avec une base
test
2. Modifier son programme pour pouvoir accéder à la base en HF/CS
(HouvreConnexion, HDecritConnexion..). Un code de connexion rapide est
fourni en copié coller par le centre de controle HF.
2. Couper les accès à la base Classic et sauvegarder...
3. Utiliser le Centre de controle HF pour migrer la base Classic en
HF/CS.
4. Tester...

Ca fonctionne bien. Pour les liaisons et les contraintes, il faut
fournir le wdd de l'analyse.

A+



Merci pour tes conseils, que veux tu dire par couper les accès à la base
classique ?
J'ai crée deux connexion, une sur mon serveur HF en local pour
développer et une autre sur le serveur.

Pour le moment sur le serveur malgrès le houvreConnexion, il cherche
toujours la connexion de mon serveur local ... je cherche

Merci

DP

http://www.obtuli.fr




C'est ok, j'avais oublié hchangeConnexion :)

Encore merci pour ton aide

DP

http://www.obtuli.fr
Romain PETIT
Le #19703751
ae-info a formulé la demande :

Merci pour tes conseils, que veux tu dire par couper les accès à la base
classique ?



Désactiver le partage du répertoire...

A+

--
Romain PETIT
contact : http://cerbermail.com/?O16kfXOFcq
+-+ posté sur Usenet avec MesNews et non depuis un forum web +-+
news:fr.comp.developpement.agl.windev
http://www.mesnews.net/
http://fr.wikipedia.org/wiki/Newsgroup
pyfux
Le #19727391
Bonjour,

Sa marche très bien l'import par le Centre de contrôle HF C/S.
Mais si tu as modifié l'analyse en cours de route (entre la version
classique et HF C/S) comme par exemple avoir rajouté un champ dans un
table, j'ai codé une procédure de copie brute des données:

////////////////////////////////////////////////////////////////
sTableName est une chaîne //Nom de la table
sRubrique est une chaîne
sRup est une chaîne
sFILE est une chaîne = sTableName + ".FIC"


SI HDéclareExterne(SC_SelecteurRépertoire.SAI_REP + "" + sFILE,
sTableName + "SRC" ) ALORS


sRubrique=HListeRubrique(sTableName + "SRC")

HLitPremier( sTableName + "SRC")
TANTQUE PAS HEnDehors( sTableName + "SRC")


POUR TOUTE CHAINE sRup DE sRubrique SEPAREE PAR RC

{sTableName + "." + sRup,indRubrique} = {sTableName + "SRC" + "." +
sRup,indRubrique}
FIN


HAjoute(sTableName)

HLitSuivant( sTableName + "SRC")
FIN

HFerme( sTableName + "SRC")

FIN
HAnnuleDéclaration( sTableName + "SRC")
////////////////////////////////////////////////////////////////

Cette procédure dans ton projet te permet d'importer dans HF C/S pour la
table (sTableName) les données du fichier de données classique présent
dans le dossier SC_SelecteurRépertoire.SAI_REP

PyFux


Romain PETIT a écrit :
ae-info a exposé le 02/07/2009 :
Bonjour,



Bonjour,


Existe-t-il une méthode pour passer des fichiers HF vers un serveur HF ?
(en conservant les données)




1. Installer le serveur HF et vérfier son fonctionnement avec une base test
2. Modifier son programme pour pouvoir accéder à la base en HF/CS
(HouvreConnexion, HDecritConnexion..). Un code de connexion rapide est
fourni en copié coller par le centre de controle HF.
2. Couper les accès à la base Classic et sauvegarder...
3. Utiliser le Centre de controle HF pour migrer la base Classic en HF/CS.
4. Tester...

Ca fonctionne bien. Pour les liaisons et les contraintes, il faut
fournir le wdd de l'analyse.

A+



pyfux
Le #19727381
Attention, il faut modifier l'analyse et transformer le champs Id Auto
en numérique de la table en question avant l'import sinon les valeurs
des clefs ne seront pas récupérées du fichier classique mais calculé.

++

a écrit :
Bonjour,

Sa marche très bien l'import par le Centre de contrôle HF C/S.
Mais si tu as modifié l'analyse en cours de route (entre la version
classique et HF C/S) comme par exemple avoir rajouté un champ dans un
table, j'ai codé une procédure de copie brute des données:

////////////////////////////////////////////////////////////////
sTableName est une chaîne //Nom de la table
sRubrique est une chaîne
sRup est une chaîne
sFILE est une chaîne = sTableName + ".FIC"


SI HDéclareExterne(SC_SelecteurRépertoire.SAI_REP + "" + sFILE,
sTableName + "SRC" ) ALORS


sRubrique=HListeRubrique(sTableName + "SRC")

HLitPremier( sTableName + "SRC")
TANTQUE PAS HEnDehors( sTableName + "SRC")


POUR TOUTE CHAINE sRup DE sRubrique SEPAREE PAR RC

{sTableName + "." + sRup,indRubrique} = {sTableName + "SRC"
+ "." + sRup,indRubrique}
FIN


HAjoute(sTableName)

HLitSuivant( sTableName + "SRC")
FIN

HFerme( sTableName + "SRC")

FIN
HAnnuleDéclaration( sTableName + "SRC")
////////////////////////////////////////////////////////////////

Cette procédure dans ton projet te permet d'importer dans HF C/S pour la
table (sTableName) les données du fichier de données classique présent
dans le dossier SC_SelecteurRépertoire.SAI_REP

PyFux


Romain PETIT a écrit :
ae-info a exposé le 02/07/2009 :
Bonjour,



Bonjour,


Existe-t-il une méthode pour passer des fichiers HF vers un serveur HF ?
(en conservant les données)




1. Installer le serveur HF et vérfier son fonctionnement avec une base
test
2. Modifier son programme pour pouvoir accéder à la base en HF/CS
(HouvreConnexion, HDecritConnexion..). Un code de connexion rapide est
fourni en copié coller par le centre de controle HF.
2. Couper les accès à la base Classic et sauvegarder...
3. Utiliser le Centre de controle HF pour migrer la base Classic en
HF/CS.
4. Tester...

Ca fonctionne bien. Pour les liaisons et les contraintes, il faut
fournir le wdd de l'analyse.

A+





Publicité
Poster une réponse
Anonyme