HLitPremier fonctionne avec l'alias mais pas avec HLitRecherchePremier

Le
IntelInside
Je remercie pour vos réponses.

Je travaille avec l'acces natif oracle.

HLitPremier fonctionne mais pas avec HLitRecherchePremier?

ce code fonctionne:

sARTICLE est une Source DE Données

SI PAS HAlias(ARTICLE,sARTICLE) ALORS
Info(HErreur())
SINON
Info("alias")
FIN
SI PAS HChangeRep(sARTICLE,"BASESOM") ALORS
Info("HChangeRep:"+HErreur())
FIN
SI PAS HChangeNom(sARTICLE,"ARTICLE") ALORS
Info("HChangeNom:"+HErreur())
FIN
SI HLitPremier(sARTICLE,CODE_ARTICLE) ALORS
Info(sARTICLE.CODE_ARTICLE)
SINON
Info(HErreurInfo())
FIN

HAnnuleAlias(sARTICLE)



mais ce code ne fonctionne pas, alors que j'ai juste remplacé
HlitPremier par HLitRecherchePremier:


sARTICLE est une Source DE Données

SI PAS HAlias(ARTICLE,sARTICLE) ALORS
Info(HErreur())
SINON
Info("alias")
FIN
SI PAS HChangeRep(sARTICLE,"BASESOM") ALORS
Info("HChangeRep:"+HErreur())
FIN
SI PAS HChangeNom(sARTICLE,"ARTICLE") ALORS
Info("HChangeNom:"+HErreur())
FIN
SI HLitRecherchePremier(sARTICLE,CODE_ARTICLE,"AF018002Z") ALORS
Info(sARTICLE.CODE_ARTICLE)
SINON
Info(HErreurInfo())
FIN

HAnnuleAlias(sARTICLE)


l'erreur est la suivante:
Vous avez appelé la fonction HLitRecherchePremier.
La dernière rubrique utilisée n'a pas pu être déterminée sur le
fichier <sARTICLE>.

c'est étonnant, puisqu'avant il a bien reconnu CODE_ARTICLE avec
HLitPremier(sARTICLE,CODE_ARTICLE)

THOMAS Patrice
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel
Le #22860501
Bonjour,

mettre HLitRecherchePremier(sARTICLE,"CODE_ARTICLE","AF018002Z").




Le 29/11/2010 11:39, IntelInside a écrit :
Je remercie pour vos réponses.

Je travaille avec l'acces natif oracle.

HLitPremier fonctionne mais pas avec HLitRecherchePremier?

ce code fonctionne:

sARTICLE est une Source DE Données

SI PAS HAlias(ARTICLE,sARTICLE) ALORS
Info(HErreur())
SINON
Info("alias")
FIN
SI PAS HChangeRep(sARTICLE,"BASESOM") ALORS
Info("HChangeRep:"+HErreur())
FIN
SI PAS HChangeNom(sARTICLE,"ARTICLE") ALORS
Info("HChangeNom:"+HErreur())
FIN
SI HLitPremier(sARTICLE,CODE_ARTICLE) ALORS
Info(sARTICLE.CODE_ARTICLE)
SINON
Info(HErreurInfo())
FIN

HAnnuleAlias(sARTICLE)



mais ce code ne fonctionne pas, alors que j'ai juste remplacé
HlitPremier par HLitRecherchePremier:


sARTICLE est une Source DE Données

SI PAS HAlias(ARTICLE,sARTICLE) ALORS
Info(HErreur())
SINON
Info("alias")
FIN
SI PAS HChangeRep(sARTICLE,"BASESOM") ALORS
Info("HChangeRep:"+HErreur())
FIN
SI PAS HChangeNom(sARTICLE,"ARTICLE") ALORS
Info("HChangeNom:"+HErreur())
FIN
SI HLitRecherchePremier(sARTICLE,CODE_ARTICLE,"AF018002Z") ALORS
Info(sARTICLE.CODE_ARTICLE)
SINON
Info(HErreurInfo())
FIN

HAnnuleAlias(sARTICLE)


l'erreur est la suivante:
Vous avez appelé la fonction HLitRecherchePremier.
La dernière rubrique utilisée n'a pas pu être déterminée sur le
fichier<sARTICLE>.

c'est étonnant, puisqu'avant il a bien reconnu CODE_ARTICLE avec
HLitPremier(sARTICLE,CODE_ARTICLE)

THOMAS Patrice




--
suivre ce lien pour répondre:
http://cerbermail.com/?2KrV3YZXnn
Daniel
;-)
Publicité
Poster une réponse
Anonyme