Horaires

Le
Manu
Bonsoir,

J'importe des horaires ainsi :
73020 (qui veut dire 07:03:20)
155030 (qui veut dire 15:50:30)
Je souhaite les mettre dans un format horaire classique hh:mm:ss alors j'ai
trouvé ceci qui marche tres bien :
=SI(NBCAR(A1)=5;CNUM(GAUCHE(A1;1)&":"&STXT(A1;2;2)&":"&DROITE(A1;2));CNUM(GAUCHE(A1;2)&":"&STXT(A1;3;2)&":"&DROITE(A1;2)))
Puis j'ai mis le format approprier et c'est tout bon, mais par curiosité
avez vous une idée pour la jouer plus courte ?

Merci

Manu
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #17338241
Bonjour.
Tu ne gagnes pas grand chose :
=GAUCHE(A1;NBCAR(A1)-4)&":"&STXT(A1;NBCAR(A1)-3;2)&":"&(DROITE(A1;2))
--
Cordialement.
Daniel
"Manu"
Bonsoir,

J'importe des horaires ainsi :
73020 (qui veut dire 07:03:20)
155030 (qui veut dire 15:50:30)
Je souhaite les mettre dans un format horaire classique hh:mm:ss alors
j'ai trouvé ceci qui marche tres bien :
=SI(NBCAR(A1)=5;CNUM(GAUCHE(A1;1)&":"&STXT(A1;2;2)&":"&DROITE(A1;2));CNUM(GAUCHE(A1;2)&":"&STXT(A1;3;2)&":"&DROITE(A1;2)))
Puis j'ai mis le format approprier et c'est tout bon, mais par curiosité
avez vous une idée pour la jouer plus courte ?

Merci

Manu



Modeste
Le #17339431
Bonsour® Manu avec ferveur ;o))) vous nous disiez :

J'importe des horaires ainsi :
73020 (qui veut dire 07:03:20)
155030 (qui veut dire 15:50:30)
Je souhaite les mettre dans un format horaire classique hh:mm:ss
alors j'ai trouvé ceci qui marche tres bien :
=SI(NBCAR(A1)=5;CNUM(GAUCHE(A1;1)&":"&STXT(A1;2;2)&":"&DROITE(A1;2)); CNUM(GAUCHE(A1;2)&":"&STXT(A1;3;2)&":"&DROITE(A1;2)))
Puis j'ai mis le format approprier et c'est tout bon, mais par
curiosité avez vous une idée pour la jouer plus courte ?



;o)))
=1*TEXTE(1*A1;"#0"":""00"":""00")
format horaire [h]:mm:ss




--
--
@+
;o)))
Manu
Le #17339621
Merci, daniel a vue le probleme a l'envers, je n'y avis pas pensé, bravo, et
modeste m'a fait un truc que j'ignorais, peus tu expliquer ta formule
modeste. Merci.

Manu

"Modeste"
Bonsour® Manu avec ferveur ;o))) vous nous disiez :

J'importe des horaires ainsi :
73020 (qui veut dire 07:03:20)
155030 (qui veut dire 15:50:30)
Je souhaite les mettre dans un format horaire classique hh:mm:ss
alors j'ai trouvé ceci qui marche tres bien :
=SI(NBCAR(A1)=5;CNUM(GAUCHE(A1;1)&":"&STXT(A1;2;2)&":"&DROITE(A1;2));CNUM(GAUCHE(A1;2)&":"&STXT(A1;3;2)&":"&DROITE(A1;2)))
Puis j'ai mis le format approprier et c'est tout bon, mais par
curiosité avez vous une idée pour la jouer plus courte ?



;o)))
=1*TEXTE(1*A1;"#0"":""00"":""00")
format horaire [h]:mm:ss




--
--
@+
;o)))
Jacky
Le #17339991
Bonsoir Modeste

=1*TEXTE(1*A1;"#0"":""00"":""00")
Joliiiiiiiie !!!!!!
:-)
--
Salutations
JJ


"Modeste"
Bonsour® Manu avec ferveur ;o))) vous nous disiez :

J'importe des horaires ainsi :
73020 (qui veut dire 07:03:20)
155030 (qui veut dire 15:50:30)
Je souhaite les mettre dans un format horaire classique hh:mm:ss
alors j'ai trouvé ceci qui marche tres bien :
=SI(NBCAR(A1)=5;CNUM(GAUCHE(A1;1)&":"&STXT(A1;2;2)&":"&DROITE(A1;2));CNUM(GAUCHE(A1;2)&":"&STXT(A1;3;2)&":"&DROITE(A1;2)))
Puis j'ai mis le format approprier et c'est tout bon, mais par
curiosité avez vous une idée pour la jouer plus courte ?



;o)))
=1*TEXTE(1*A1;"#0"":""00"":""00")
format horaire [h]:mm:ss




--
--
@+
;o)))
Modeste
Le #17340941
Bonsour® Manu avec ferveur ;o))) vous nous disiez :

Merci, daniel a vue le probleme a l'envers, je n'y avis pas pensé,
bravo, et modeste m'a fait un truc que j'ignorais, peus tu expliquer
ta formule modeste. Merci.



J'importe des horaires ainsi :
73020 (qui veut dire 07:03:20)
155030 (qui veut dire 15:50:30)





=1*TEXTE(1*A1;"#0"":""00"":""00")
format horaire [h]:mm:ss

1*A1
pour forcer Excel à interpréter A1 en numerique au cas ou la saisie serait en format texte ou '1373020

"#0"":""00"":""00"
il s'agit d'un format personnalisé comme on le fait par exemple pour les N° de telephone

TEXTE(1*A1;"#0"":""00"":""00")
on obtient un TEXTE du type 137:30:20
le # pour format numerique facultatif ,
les " 0 " obligatoires au cas ou la saisie serait inferieure à 1 h
ex : 624 ===> 0:06:24

1*TEXTE(......) ou 1 * "137:30:20"
pour forcer excel à interpréter le contenu en numerique
soit 1,56273148148148000 en format standard

le format [h]:mm:ss
pour afficher plus de 24h
soit 137:30:20 en format horaire

--
--
@+
;o)))
Manu
Le #17342431
Super ! il falait vraiment y penser, ca parait desormais si simple. Bravo et
merci !

Manu

"Modeste"
Bonsour® Manu avec ferveur ;o))) vous nous disiez :

Merci, daniel a vue le probleme a l'envers, je n'y avis pas pensé,
bravo, et modeste m'a fait un truc que j'ignorais, peus tu expliquer
ta formule modeste. Merci.



J'importe des horaires ainsi :
73020 (qui veut dire 07:03:20)
155030 (qui veut dire 15:50:30)





=1*TEXTE(1*A1;"#0"":""00"":""00")
format horaire [h]:mm:ss

1*A1
pour forcer Excel à interpréter A1 en numerique au cas ou la saisie serait
en format texte ou '1373020

"#0"":""00"":""00"
il s'agit d'un format personnalisé comme on le fait par exemple pour les N°
de telephone

TEXTE(1*A1;"#0"":""00"":""00")
on obtient un TEXTE du type 137:30:20
le # pour format numerique facultatif ,
les " 0 " obligatoires au cas ou la saisie serait inferieure à 1 h
ex : 624 ===> 0:06:24

1*TEXTE(......) ou 1 * "137:30:20"
pour forcer excel à interpréter le contenu en numerique
soit 1,56273148148148000 en format standard

le format [h]:mm:ss
pour afficher plus de 24h
soit 137:30:20 en format horaire

--
--
@+
;o)))
Publicité
Poster une réponse
Anonyme