[HS] Compiler firefox 3.5 RC2 sur Lenny AMD64

Le
YOUNOUSS Abba Soungui
--nextPart1627467.K4JWElsimN
Content-Type: text/plain;
charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Bonjour,

J'essaye de compiler firefox sur Lenny AMD64, mais j'ai le message suivant=

quand je lance le script ./configure :

checking for pkg-config /usr/bin/pkg-config
checking for gtk+-2.0 >= 2.10.0 gtk+-unix-print-2.0 glib-2.0 gobject-2.0=

gdk-x11-2.0 Package gtk+-2.0 was not found in the pkg-config search path=
.
Perhaps you should add the directory containing `gtk+-2.0.pc' to the
PKG_CONFIG_PATH environment variable No package 'gtk+-2.0' found Package
gtk+-unix-print-2.0 was not found in the pkg-config search path. Perhaps yo=
u
should add the directory containing `gtk+-unix-print-2.0.pc' to the
PKG_CONFIG_PATH environment variable No package 'gtk+-unix-print-2.0' found=

Package glib-2.0 was not found in the pkg-config search path. Perhaps you
should add the directory containing `glib-2.0.pc' to the PKG_CONFIG_PATH
environment variable No package 'glib-2.0' found Package gobject-2.0 was no=
t
found in the pkg-config search path. Perhaps you should add the directory
containing `gobject-2.0.pc' to the PKG_CONFIG_PATH environment variable No=

package 'gobject-2.0' found Package gdk-x11-2.0 was not found in the
pkg-config search path. Perhaps you should add the directory containing
`gdk-x11-2.0.pc' to the PKG_CONFIG_PATH environment variable No
package 'gdk-x11-2.0' found
configure: error: Library requirements (gtk+-2.0 >= 2.10.0 gtk+-unix-prin=
t-2.0
glib-2.0 gobject-2.0 gdk-x11-2.0) not met; consider adjusting the
PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard=

prefix so pkg-config can find them.

On dirait que pkg-config ne trouve des librairie (qui sont pour tant bien
installées). Quelqu'un peut il me dire comment régler ce problème?

Merci.

--nextPart1627467.K4JWElsimN
Content-Type: application/pgp-signature; name=signature.asc
Content-Description: This is a digitally signed message part.

--BEGIN PGP SIGNATURE--
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEABECAAYFAkpDbMUACgkQyVjEFylGLtSRSgCgqakd0nND1E6H1c8styu2jIZT
DUIAoJ++bJp53FcI5PLuGw1sbshTOesY
±JM
--END PGP SIGNATURE--

--nextPart1627467.K4JWElsimN--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
steve
Le #19635021
> Bonjour,



Salut,

J'essaye de compiler firefox sur Lenny AMD64, mais j'ai le message suivant
quand je lance le script ./configure :

checking for pkg-config... /usr/bin/pkg-config
checking for gtk+-2.0 >= 2.10.0 gtk+-unix-print-2.0 glib-2.0 gobject-2.0
gdk-x11-2.0... Package gtk+-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtk+-2.0.pc' to the
PKG_CONFIG_PATH environment variable No package 'gtk+-2.0' found Package
gtk+-unix-print-2.0 was not found in the pkg-config search path. Perhaps you
should add the directory containing `gtk+-unix-print-2.0.pc' to the
PKG_CONFIG_PATH environment variable No package 'gtk+-unix-print-2.0' found
Package glib-2.0 was not found in the pkg-config search path. Perhaps you
should add the directory containing `glib-2.0.pc' to the PKG_CONFIG_PATH
environment variable No package 'glib-2.0' found Package gobject-2.0 was not
found in the pkg-config search path. Perhaps you should add the directory
containing `gobject-2.0.pc' to the PKG_CONFIG_PATH environment variable No
package 'gobject-2.0' found Package gdk-x11-2.0 was not found in the
pkg-config search path. Perhaps you should add the directory containing
`gdk-x11-2.0.pc' to the PKG_CONFIG_PATH environment variable No
package 'gdk-x11-2.0' found
configure: error: Library requirements (gtk+-2.0 >= 2.10.0 gtk+-unix-print-2.0
glib-2.0 gobject-2.0 gdk-x11-2.0) not met; consider adjusting the
PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard
prefix so pkg-config can find them.

On dirait que pkg-config ne trouve des librairie (qui sont pour tant bien
installées). Quelqu'un peut il me dire comment régler ce problème?



Il manque probablement des paquets *-dev, genre libgtk2.0-dev. Les
installer et y aller petit à petit jusqu'à la disparition de ces
messages.

Merci.



Pas de quoi,
Steve

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
YOUNOUSS Abba Soungui
Le #19637521
--nextPart2106182.aYNVk4K6EF
Content-Type: text/plain;
charset="utf-8"
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Il manque probablement des paquets *-dev, genre libgtk2.0-dev. Les
installer et y aller petit à petit jusqu'à la disparition de ces
messages.



Effectivement, j'ai installé les paquets *-dev et ca marche.

Merci.

--nextPart2106182.aYNVk4K6EF
Content-Type: application/pgp-signature; name=signature.asc
Content-Description: This is a digitally signed message part.

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEABECAAYFAkpDxfwACgkQyVjEFylGLtT/ZwCgqY91z+W+sgrwiShHjz7dHP3X
SFAAoMPpN3hz/1G9NQnCAiZdbOX9hWDP
=QSnY
-----END PGP SIGNATURE-----

--nextPart2106182.aYNVk4K6EF--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Publicité
Poster une réponse
Anonyme