[HS] lenteur sur internet, modification de MTU ?

Le
giggz
Bonsoir la liste,

Désolé pour le HS.
Ce problème a de nombreuses fois été soulevé, mais je n'y comprends pas
grand chose alors je poste :
J'ai une connexion free (qui marche très bien). Je peux télécharger sur
kernel.org à 300kb/s bref pas de problème de ce côté là. Mon laptop est
branché sur un routeur Netgear, qui est lui même relié à la freebox.

Depuis qq temps sur certains sites je mets extrêmement longtemps à me
connecter. ou alors le téléchargement commence puis s'arrête. Pour le
faire reprendre, j'ouvre une autre page internet et je télécharge autre
choseet là le téléchargement initiale reprend. bref bizarre bizarre
ça m'arrive aussi avec le dépot d'edevelop d'E17. pas de problème avec
celui de ftp.fr.debian.
Comme je n'y connais pas grand chose la dedans, j'ai cherché un peu et
le réglage de la MTU revient fréquemment :
sur mon laptop j'ai une MTU de 1492 selon ifconfig.
par contre mon routeur a qd à lui une MTU de 1500.
Faut il que je les règle toutes 2 à la même valeur ? ou alors c'est po
grave ?

Merci de vos lumières
Guillaume


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jean-Yves F. Barbier
Le #9616651
giggz a écrit :
Bonsoir la liste,

Désolé pour le HS.
Ce problème a de nombreuses fois été soulevé, mais je n'y compr ends pas
grand chose alors je poste :
J'ai une connexion free (qui marche très bien). Je peux télécharg er sur
kernel.org à 300kb/s bref pas de problème de ce côté là. Mon laptop est
branché sur un routeur Netgear, qui est lui même relié à la fre ebox.

Depuis qq temps sur certains sites je mets extrêmement longtemps à me
connecter. ou alors le téléchargement commence puis s'arrête. Pou r le
faire reprendre, j'ouvre une autre page internet et je télécharge a utre
chose...et là le téléchargement initiale reprend. bref bizarre bi zarre...
ça m'arrive aussi avec le dépot d'edevelop d'E17. pas de problème avec
celui de ftp.fr.debian.
Comme je n'y connais pas grand chose la dedans, j'ai cherché un peu e t
le réglage de la MTU revient fréquemment :
sur mon laptop j'ai une MTU de 1492 selon ifconfig.
par contre mon routeur a qd à lui une MTU de 1500.
Faut il que je les règle toutes 2 à la même valeur ? ou alors c'e st po
grave ?



à 1500 les 2

Merci de vos lumières
Guillaume





--
"He could be a poster child for retroactive birth control."
giggz
Le #9616631
Jean-Yves F. Barbier a écrit :
giggz a écrit :
Bonsoir la liste,

Désolé pour le HS.
Ce problème a de nombreuses fois été soulevé, mais je n'y comprends pas
grand chose alors je poste :
J'ai une connexion free (qui marche très bien). Je peux télécharger sur
kernel.org à 300kb/s bref pas de problème de ce côté là. Mon laptop est
branché sur un routeur Netgear, qui est lui même relié à la freebox.

Depuis qq temps sur certains sites je mets extrêmement longtemps à me
connecter. ou alors le téléchargement commence puis s'arrête. Pour le
faire reprendre, j'ouvre une autre page internet et je télécharge autre
chose...et là le téléchargement initiale reprend. bref bizarre bizarre...
ça m'arrive aussi avec le dépot d'edevelop d'E17. pas de problème avec
celui de ftp.fr.debian.
Comme je n'y connais pas grand chose la dedans, j'ai cherché un peu et
le réglage de la MTU revient fréquemment :
sur mon laptop j'ai une MTU de 1492 selon ifconfig.
par contre mon routeur a qd à lui une MTU de 1500.
Faut il que je les règle toutes 2 à la même valeur ? ou alors c'est po
grave ?



à 1500 les 2




Pourquoi à 1500 ?
Pourquoi pas à 1492 ?
Pourquoi sous linux c'est 1492 de base ?

ça fait bcp de pourquoi...
désolé :)

Merci de ta réponse

Merci de vos lumières
Guillaume









--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Jean-Yves F. Barbier
Le #9616621
giggz a écrit :
Jean-Yves F. Barbier a écrit :
giggz a écrit :
Bonsoir la liste,

Désolé pour le HS.
Ce problème a de nombreuses fois été soulevé, mais je n'y com prends pas
grand chose alors je poste :
J'ai une connexion free (qui marche très bien). Je peux télécha rger sur
kernel.org à 300kb/s bref pas de problème de ce côté là. Mo n laptop est
branché sur un routeur Netgear, qui est lui même relié à la f reebox.

Depuis qq temps sur certains sites je mets extrêmement longtemps à me
connecter. ou alors le téléchargement commence puis s'arrête. P our le
faire reprendre, j'ouvre une autre page internet et je télécharge autre
chose...et là le téléchargement initiale reprend. bref bizarre bizarre...
ça m'arrive aussi avec le dépot d'edevelop d'E17. pas de problè me avec
celui de ftp.fr.debian.
Comme je n'y connais pas grand chose la dedans, j'ai cherché un peu et
le réglage de la MTU revient fréquemment :
sur mon laptop j'ai une MTU de 1492 selon ifconfig.
par contre mon routeur a qd à lui une MTU de 1500.
Faut il que je les règle toutes 2 à la même valeur ? ou alors c 'est po
grave ?


à 1500 les 2




Pourquoi à 1500 ?



parce que

Pourquoi pas à 1492 ?



v. point n°1

Pourquoi sous linux c'est 1492 de base ?



ça n'a jamais été 1492 mais 1500; 1492 c'est pour le côté inter net
(1500 - 8 byte == en-tête PPPoE, 4 byte pour l'adresse IP source et 4 pour
l'adresse de destination)

v. /usr/share/doc/HOWTOS/en-txt/DSL-HOWTO.txt

--
It's odd, and a little unsettling, to reflect upon the fact that
English is the only major language in which "I" is capitalized; in many
other languages "You" is capitalized and the "i" is lower case.
-- Sydney J. Harris
giggz
Le #9616591
[...]




Pourquoi à 1500 ?



parce que

Pourquoi pas à 1492 ?



v. point n°1

Pourquoi sous linux c'est 1492 de base ?



ça n'a jamais été 1492 mais 1500; 1492 c'est pour le côté internet
(1500 - 8 byte == en-tête PPPoE, 4 byte pour l'adresse IP source et 4 pour
l'adresse de destination)




Alors ce que renvoie la commande ifconfig est juste l'en tête car moi j'ai :
eth0 Lien encap:Ethernet HWaddr 00:0A:E4:54:E5:10
inet adr:192.168.0.3 Bcast:192.168.0.255 Masque:255.255.255.0
adr inet6: fe80::20a:e4ff:fe54:e510/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1492 Metric:1
RX packets:19052 errors:0 dropped:0 overruns:0 frame:0
TX packets:13265 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:23228472 (22.1 MiB) TX bytes:1449848 (1.3 MiB)
Interruption:10

et je n'ai pas touché au paramètre MTU

v. /usr/share/doc/HOWTOS/en-txt/DSL-HOWTO.txt



bon je vais lire

Merci


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Jean-Yves F. Barbier
Le #9616581
giggz a écrit :
[...]




Alors ce que renvoie la commande ifconfig est juste l'en tête car moi j'ai :
eth0 Lien encap:Ethernet HWaddr 00:0A:E4:54:E5:10
inet adr:192.168.0.3 Bcast:192.168.0.255 Masque:255.255.255.


0
adr inet6: fe80::20a:e4ff:fe54:e510/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1492 Metric:1
RX packets:19052 errors:0 dropped:0 overruns:0 frame:0
TX packets:13265 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:23228472 (22.1 MiB) TX bytes:1449848 (1.3 MiB)
Interruption:10

et je n'ai pas touché au paramètre MTU



sur QUELLE I/F ethernet? (normalement celle qui est connectée au modem;
pour le LAN, ce serait incorrect)

--
The sweeter the apple, the blacker the core --
Scratch a lover and find a foe!
-- Dorothy Parker, "Ballad of a Great Weariness"
giggz
Le #9616571
Jean-Yves F. Barbier a écrit :
giggz a écrit :
[...]




Alors ce que renvoie la commande ifconfig est juste l'en tête car moi
j'ai :
eth0 Lien encap:Ethernet HWaddr 00:0A:E4:54:E5:10
inet adr:192.168.0.3 Bcast:192.168.0.255 Masque:255.255.255.0
adr inet6: fe80::20a:e4ff:fe54:e510/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1492 Metric:1
RX packets:19052 errors:0 dropped:0 overruns:0 frame:0
TX packets:13265 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:23228472 (22.1 MiB) TX bytes:1449848 (1.3 MiB)
Interruption:10

et je n'ai pas touché au paramètre MTU



sur QUELLE I/F ethernet? (normalement celle qui est connectée au modem;
pour le LAN, ce serait incorrect)




voilà ce que retourne ifconfig :
eth0 Lien encap:Ethernet HWaddr 00:0A:E4:54:E5:10
inet adr:192.168.0.3 Bcast:192.168.0.255 Masque:255.255.255.0
adr inet6: fe80::20a:e4ff:fe54:e510/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1492 Metric:1
RX packets:26479 errors:0 dropped:0 overruns:0 frame:0
TX packets:22511 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:27180917 (25.9 MiB) TX bytes:2528112 (2.4 MiB)
Interruption:10

eth1 Lien encap:Ethernet HWaddr 00:0E:35:63:17:E7
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interruption:11 Adresse de base:0x4000 Mémoire:d0202000-d0202fff

lo Lien encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:Hôte
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:13288 errors:0 dropped:0 overruns:0 frame:0
TX packets:13288 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
RX bytes:7250201 (6.9 MiB) TX bytes:7250201 (6.9 MiB)

eth0 est ma connexion ethernet par cable RJ45
eth1 est ma connection wifi (éteinte)

eth0 est relié à mon routeur netgear FR114P qui a une MTU réglé à 1500
ensuite ce routeur est branché à la freebox.

Pour avoir le réseau j'utilise ifplugd qui s'occupe d'établir des
connections internet. il se base sur le /etc/network/interfaces que voici :
# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)

# The loopback interface
auto lo
iface lo inet loopback

#auto eth0
iface eth0 inet dhcp
name Carte Ethernet

#ligne a ajouter pour configurer resolvconf
#dns-search
#dns-nameservers 212.27.54.252 212.27.53.252 213.228.0.96

#iface dsl-provider inet static
#provider dsl-provider
# please do not modify the following line
# pre-up /sbin/ifconfig eth0 up # line maintained by pppoeconf
# name Type d'interface inconnu
iface dsl-provider inet ppp
provider dsl-provider

#auto eth1
iface eth1 inet dhcp
# post-up /usr/bin/wirelessled-on
# pre-down /usr/bin/wirelessled-off

J'ai fais un grep -iR 1492 /etc/* pour voir s'il n'y avait pas un vieux
fichier de conf et j'ai juste ceci :
"/usr/sbin/pppoe
-I
eth0
-T 80
-m 1452"
dans
/etc/ppp/peers/dsl-provider

Mais je ne vois pas en quoi ce fichier intervient lors de l'activation
de eth0...

Merci de m'aider
Guillaume






--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Pascal Hambourg
Le #9616551
Salut,

Jean-Yves F. Barbier a écrit :

Pourquoi à 1500 ?



parce que



Complément : c'est le MTU standard d'ethernet, et, par extension, celui
par défaut d'autres couches de liaison comme PPP.

Pourquoi pas à 1492 ?





Ce MTU ne se justifie que sur les liaisons PPPoE.

Pourquoi sous linux c'est 1492 de base ?



ça n'a jamais été 1492 mais 1500;



En effet.

1492 c'est pour le côté internet



Non, c'est pour PPPoE. Le côté internet peut utiliser autre chose, et
PPPoE peut servir à autre chose qu'internet.

(1500 - 8 byte == en-tête PPPoE, 4 byte pour l'adresse IP source et 4 pour
l'adresse de destination)



Pas vraiment. 6 octets pour l'en-tête PPPoE et 2 octets pour
l'identificateur de protocole de PPP. Cf. RFC 1661 et 2516. Les adresses
IP source et destination sont contenues dans l'en-tête IP quelle que
soit l'encapsulation.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
giggz
Le #9616541
Pascal Hambourg a écrit :
Salut,

Jean-Yves F. Barbier a écrit :

Pourquoi à 1500 ?



parce que



Complément : c'est le MTU standard d'ethernet, et, par extension, celui
par défaut d'autres couches de liaison comme PPP.

Pourquoi pas à 1492 ?





Ce MTU ne se justifie que sur les liaisons PPPoE.

Pourquoi sous linux c'est 1492 de base ?



ça n'a jamais été 1492 mais 1500;



En effet.

1492 c'est pour le côté internet



Non, c'est pour PPPoE. Le côté internet peut utiliser autre chose, et
PPPoE peut servir à autre chose qu'internet.

(1500 - 8 byte == en-tête PPPoE, 4 byte pour l'adresse IP source et 4
pour
l'adresse de destination)



Pas vraiment. 6 octets pour l'en-tête PPPoE et 2 octets pour
l'identificateur de protocole de PPP. Cf. RFC 1661 et 2516. Les adresses
IP source et destination sont contenues dans l'en-tête IP quelle que
soit l'encapsulation.




Ok, merci pour ces précisions.

J'ai fait un
ifconfig eth0 mtu 1500

sur ma connection déjà établie. qd je fais ifconfig j'ai bien :
eth0 Lien encap:Ethernet HWaddr 00:0A:E4:54:E5:10
inet adr:192.168.0.3 Bcast:192.168.0.255 Masque:255.255.255.0
adr inet6: fe80::20a:e4ff:fe54:e510/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:696 errors:0 dropped:0 overruns:0 frame:0
TX packets:730 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:479486 (468.2 KiB) TX bytes:73741 (72.0 KiB)
Interruption:10

Mais dès que je redémarre le reseau je récupère une MTU de 1492.
Je sais que je peux forcer la MTU via le fichier interface, mais mon pb
est que j'utilise parfois (à l'étranger) des liaisons pppoe via
"pon dsl-provider" et cela passe sur eth0.

En tout cas je ne sais vraiment pas pourquoi il me force à 1492 au lieu
de 1500. Est un coup de udev ? on ne sait jamais...il fait bcp de chose
celui là.

Merci en tout cas
Guillaume




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Pascal Hambourg
Le #9616531
giggz a écrit :
Jean-Yves F. Barbier a écrit :

giggz a écrit :
Alors ce que renvoie la commande ifconfig est juste l'en tête car moi
j'ai :
eth0 Lien encap:Ethernet HWaddr 00:0A:E4:54:E5:10
inet adr:192.168.0.3 Bcast:192.168.0.255 Masque:255.255.255.0
adr inet6: fe80::20a:e4ff:fe54:e510/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1492 Metric:1






[...]
et je n'ai pas touché au paramètre MTU



sur QUELLE I/F ethernet? (normalement celle qui est connectée au modem;
pour le LAN, ce serait incorrect)





Ce serait encore moins correct pour l'interface connectée à un modem
bridge à travers lequel passe PPPoE, qui *doit* avoir un MTU à 1500.
C'est l'interface PPP créée par pppd avec pppoe qui doit avoir un MTU à
1492 maxi.

[...]
eth0 est ma connexion ethernet par cable RJ45
eth0 est relié à mon routeur netgear FR114P qui a une MTU réglé à 1500



MTU côté LAN ou WAN ?

ensuite ce routeur est branché à la freebox.

Pour avoir le réseau j'utilise ifplugd qui s'occupe d'établir des
connections internet. il se base sur le /etc/network/interfaces que voici :
# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)

# The loopback interface
auto lo
iface lo inet loopback

#auto eth0
iface eth0 inet dhcp
name Carte Ethernet



On aurait pu soupçonner la présence une option "mtu" ici mais ce n'est
pas le cas. Il reste l'éventualité d'une option "interface-mtu" qui
serait passée par le serveur DHCP. Tu peux sniffer ou remplacer la
méthode dhcp par une configuration statique pour comparer.

[...]
J'ai fais un grep -iR 1492 /etc/* pour voir s'il n'y avait pas un vieux
fichier de conf et j'ai juste ceci :
"/usr/sbin/pppoe -I eth0 -T 80 -m 1452"
dans /etc/ppp/peers/dsl-provider

Mais je ne vois pas en quoi ce fichier intervient lors de l'activation
de eth0...



En rien, c'est un fichier d'options de pppd pour établir une connexion
PPPoE.

Sinon, si tu veux vérifier si le MTU est pour quelque chose dans tes
problèmes de lenteurs, tu le règles à un valeur suffisamment basse comme
1000 et tu vois ce que ça donne.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
giggz
Le #9616511
[...]

[...]
eth0 est ma connexion ethernet par cable RJ45
eth0 est relié à mon routeur netgear FR114P qui a une MTU réglé à 1500



MTU côté LAN ou WAN ?




MTU côté LAN. Pour le WAN ce n'est pas marqué comme pouvant être changé.

ensuite ce routeur est branché à la freebox.

Pour avoir le réseau j'utilise ifplugd qui s'occupe d'établir des
connections internet. il se base sur le /etc/network/interfaces que
voici :
# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)

# The loopback interface
auto lo
iface lo inet loopback

#auto eth0
iface eth0 inet dhcp
name Carte Ethernet



On aurait pu soupçonner la présence une option "mtu" ici mais ce n'est
pas le cas. Il reste l'éventualité d'une option "interface-mtu" qui
serait passée par le serveur DHCP. Tu peux sniffer ou remplacer la
méthode dhcp par une configuration statique pour comparer.




Bon eh bien, bien vu! ça vient du dhcp...mais alors pourquoi...ça c'est
une bonne question.

En effet qd j'impose en static ma configuration (sans dhcp), mon MTU
reste bien à 1500. par contre dès que je repasse en dhcp, il retombe à
1492. De plus si je reviens en statique ensuite il reste à 1492, je suis
obligé de le changer via 'ifconfig eth0 mtu 1500'

Ce sera le serveur dhcp du routeur qui fait des bêtises ?

[...]

Merci
GUillaume


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme