[hs or not] Pcmanfm ne monte plus mes périphériques

Le
Grégory Bulot
Bonjour,

Depuis 1 ou 2 mois, le montage de périphériques de stockage usb ne
fonctionne plus.

Pcmanfm "fige" : kill -9 nécessaire
via un ps -aef, j'ai remarqué que ceci était lancé lorsque j=
e clic sur
un périphériques de stockage usb (clef, dd externe)

/usr/bin/gksudo
pcmanfm --mount
'/org/freedesktop/Hal/devices/volume_uuid_48C0_ACF2'

je nommerais ici cette commande "[cmd]"

cette même commande génère l'exécution de celle ci :
/usr/bin/sudo -H -S -p GNOME_SUDO_PASS -u root -- [cmd]

effectivement, sudo n'étant pas graphique cela ne risque pas de
fonctionner.

Deux choses étrange :
- sudo me demandera mon mot de passe, qu n'est pas dans sudoers. Avant
de constater mon problème de montage, je n'avais pas à saisir d=
e mot
de passe pour ces périphériques

- admettons que la communauté dev debian a décidé lors d'une=
MAJ de ma
lenny [ou lenny-backports] qu'il faut être dans sudoers pour monter
sa clef usb. Pourquoi c'est sudo (cli) qui remplace gtksudo
(graphique) pourtant initialement executé ?

Je pense que mon problème a commencé suite à un
"aptitude remove gnome-volume-manager"
il y'a quelques mois, mais je n'ais pas été confronté au pro=
blème
jusqu'à un récent redémarrage.



--
Cordialement
Grégory BULOT

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/20110116170850.462d5698@morpheus.bulot-fr.com
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Grégory Bulot
Le #23027111
Bonjour, Bonsoir,

Le Sun, 16 Jan 2011 17:08:50 +0100, Grégory Bulot, vous avez écri t :

/etc/init.d/hal restart
puis débranchement/rebranchement du périphérique !!

--
Cordialement
Grégory BULOT

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Bernard Schoenacker
Le #23027231
Le Sun, 16 Jan 2011 17:08:50 +0100,
Grégory Bulot
Bonjour,

Depuis 1 ou 2 mois, le montage de périphériques de stockage usb ne
fonctionne plus.

Pcmanfm "fige" : kill -9 nécessaire
via un ps -aef, j'ai remarqué que ceci était lancé lorsque je clic sur
un périphériques de stockage usb (clef, dd externe)

/usr/bin/gksudo
pcmanfm --mount
'/org/freedesktop/Hal/devices/volume_uuid_48C0_ACF2'

je nommerais ici cette commande "[cmd]"

cette même commande génère l'exécution de celle ci :
/usr/bin/sudo -H -S -p GNOME_SUDO_PASS -u root -- [cmd]

effectivement, sudo n'étant pas graphique cela ne risque pas de
fonctionner.

Deux choses étrange :
- sudo me demandera mon mot de passe, qu n'est pas dans sudoers. Avant
de constater mon problème de montage, je n'avais pas à saisir de mot
de passe pour ces périphériques

- admettons que la communauté dev debian a décidé lors d'u ne MAJ de ma
lenny [ou lenny-backports] qu'il faut être dans sudoers pour monter
sa clef usb. Pourquoi c'est sudo (cli) qui remplace gtksudo
(graphique) pourtant initialement executé ?

Je pense que mon problème a commencé suite à un
"aptitude remove gnome-volume-manager"
il y'a quelques mois, mais je n'ais pas été confronté au p roblème
jusqu'à un récent redémarrage.



--
Cordialement
Grégory BULOT



Bonjour,

Quelles sont les motivations réelles du Bulot ?

voici le lien : bugs.debian.org/pcmanfm

et voici ce que j'attend du bulot :

dpkg -l `apt-cache depends pcmanfm |awk '{print $2}' |xargs `

rendre compte à la liste des paquets installés ...

ensuite, nettoyer le paquet désinstallé :

for pkg in gnome-volume-manager
do
apt-get install $pkg
apt-get remove --purge $pkg
dpkg --configure -a
done

mais qu'est ce que tu fait dans la Bat-cave ....

solution de repli :

for pkg in `apt-cache search thunar |grep thunar |awk '{print $1}'|xargs `
do
apt-get install $pkg
done

et une fois l'opération terminée, prière de n'y plus touche r ...

slt
bernard



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Grégory Bulot
Le #23027761
Bonjour, Bonsoir,

Le Sun, 16 Jan 2011 17:46:49 +0100, Bernard Schoenacker, vous avez
écrit :

Je me permet de vous couper la parole, j'ai déjà taggé 'rà ©solu', mais
pour vous remercier de votre effort de recherche, et dans l'espoir que
cela puisse servir si quelqu'un d'autre se trouve dans cette situation :

Bonjour,

Quelles sont les motivations réelles du Bulot ?



A l'avenir, merci d'éviter les jeux de mots sur mon Nom


voici le lien : bugs.debian.org/pcmanfm



Celui qui se rapproche est celui là :
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug`0853
mais la question se pose en fait pour le desktop pour cette personne

dans lenny-backports, pcmanfm n'existe pas
(http://packages.debian.org/search?keywords=pcmanfm&searchon=names&sect ion=all&suite=lenny-backports),
c'est donc la version stable qui est de rigueur.


dpkg -l `apt-cache depends pcmanfm |awk '{print $2}' |xargs `



Pour les yeux, j'ajoute un cut
dpkg -l `apt-cache depends pcmanfm |awk '{print $2}' |xargs `
| cut -c1-62

ii gnome-icon-theme 2.22.0-1
ii libc6 2.11.2-7
ii libcairo2 1.8.8-2~bpo50+1
ii libglib2.0-0 2.24.2-1
ii libgtk2.0-0 2.18.6-1~bpo50+1
ii libpango1.0-0 1.20.5-6
ii libx11-6 2:1.1.5-2
ii lxde-icon-theme 0.0.1+svn20091206-1~bpo50+1
Aucun paquet ne correspond à libfm-gtk0.
Aucun paquet ne correspond à libfm0.
Aucun paquet ne correspond à gvfs-backends.
Aucun paquet ne correspond à gvfs-fuse.
Aucun paquet ne correspond à en.


rendre compte à la liste des paquets installés ...

ensuite, nettoyer le paquet désinstallé :

for pkg in gnome-volume-manager
do
apt-get install $pkg
apt-get remove --purge $pkg
dpkg --configure -a
done



Forcément il ne se passe pas grand chose :-D


mais qu'est ce que tu fait dans la Bat-cave ....



Haha, merci google, Ixquick, ou autre


solution de repli :

for pkg in `apt-cache search thunar |grep thunar |awk '{print
$1}'|xargs ` do
apt-get install $pkg
done



Non, pcmanfm me vas très sur mes machines, j'ai pris lxde, après un
passage xfce.


et une fois l'opération terminée, prière de n'y plus touc her ...



Pas si facile que ça, rhythmbox (pour l'exemple que j'ai en
tête) réclame, à l'installation, les dépendances
gnome-[network|volume]-manager.


--
Cordialement
Grégory BULOT

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Grégory Bulot
Le #23030361
Bonjour, Bonsoir,

Le Sun, 16 Jan 2011 17:46:49 +0100, Bernard Schoenacker, vous avez
écrit :


for pkg in gnome-volume-manager
do
apt-get install $pkg
apt-get remove --purge $pkg
dpkg --configure -a
done



Super, aptitude n'a pas aimer cette étape ... et j'ai répondu oui comme
un c.n pour supprimer toutes les applis à dépendances cassée s : c'est
juste des dépendances symboliques, car elles fonctionnent très bi en
sans gnome*manager

Je venais de réussir à remettre ffmpeg fonctionnel sans erreur de
segmentation lors de l'utilisation....



--
Cordialement
Grégory BULOT

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Bernard Schoenacker
Le #23030351
Le Mon, 17 Jan 2011 20:41:08 +0100,
Grégory Bulot
Bonjour, Bonsoir,

Le Sun, 16 Jan 2011 17:46:49 +0100, Bernard Schoenacker, vous avez
écrit :


> for pkg in gnome-volume-manager
> do
> apt-get install $pkg
> apt-get remove --purge $pkg
> dpkg --configure -a
> done

Super, aptitude n'a pas aimer cette étape ... et j'ai répondu oui
comme un c.n pour supprimer toutes les applis à dépendances cassées :
c'est juste des dépendances symboliques, car elles fonctionnent très
bien sans gnome*manager

Je venais de réussir à remettre ffmpeg fonctionnel sans erreur de
segmentation lors de l'utilisation....



--
Cordialement
Grégory BULOT



bonjour,

si aptitude et apt se marchent dessus c'estr que l'install n'est
proprement réalisée ....

reste simplent à retrouver la liste des paquets désinstallés

slt
bernard

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Grégory Bulot
Le #23064031
Bonjour, Bonsoir,

sur une nouvelle installation (autre machine), toujours en lenny je me
retrouve avec ce problème de montage de périphérique de stoc kage usb qui
ne fonctionne pas.

un ps -aef me retourne cela :
/usr/bin/gksudo pcmanfm --mount
'/org/freedesktop/Hal/devices/volume_uuid_639E_C2E9'

Côté interface graphique, j'ai une fenêtre qui me demande de saisir mon
mot de passe 'utilisateur', sauf que je ne suis pas pas dans sudoers
(comme mes autres stations, mais pour celles-ci cela ne pose pas de
problèmes)

ensuite j'ai fait :
# aptitude remove --purge $(dpkg-query -l | grep gnome- | grep "^i" |
awk '{print $2}' | xargs)
# aptitude install gdm iceweasel

# dpkg-query -l | grep gnome- | grep "^i"
ii gnome-keyring 2.22.3-2
ii libgnome-keyring0 2.22.3-2
ii libpam-gnome-keyring 2.22.3-2

$ rm -fR ~/.*

# /etc/init.d/gdm restart
[login]

sous pcmanfm, tentative d'accès au contenu de la clef, retour à la
question au début de ce post avec cette ligne supplémentaire
/usr/bin/sudo -H -S -p GNOME_SUDO_PASS -u root -- pcmanfm
--mount /org/freedesktop/Hal/device








--
Cordialement
Grégory BULOT

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Grégory Bulot
Le #23064011
Bonjour, Bonsoir,

Le Sun, 16 Jan 2011 17:32:01 +0100, Grégory Bulot, vous avez écri t :

Bonjour, Bonsoir,

Le Sun, 16 Jan 2011 17:08:50 +0100, Grégory Bulot, vous avez éc rit :

/etc/init.d/hal restart
puis débranchement/rebranchement du périphérique !!




Je viens de reinstaller une lenny sur une autre machine, et j'ai de
nouveau le problème, mais /etc/init.d/hal restart (ci-dessus) ne change
rien.

Install via netinst usb, puis aptitude install lxde, login via gdm et
c'est tout !

C'est embêtant pour une stable de longue date


--
Cordialement
Grégory BULOT

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Grégory Bulot
Le #23064561
Bonjour, Bonsoir,


désolé pour le double post, il y a du y avoir une panne d'un smtp
quelquepart, ou du gestionnaire de liste.

--
Cordialement
Grégory BULOT

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme