[HS] pb avec nut

Le
Philippe MONROUX
Bonjour,

J'utilisais nut avec un apc smart-ups 700 qui communique avec un port
série.
Le pb est que je viens de changer de carte mère et qu'elle n'a pas de
port série. J'ai donc acheté un adaptateur série<-> usb

Celui-ci est bien reconnu :

drivers/usb/serial/usb-serial.c: USB Serial support registered for pl2303
[ 4.039051] pl2303 2-2:1.0: pl2303 converter detected
[ 4.072285] usb 2-2: pl2303 converter now attached to ttyUSB0

mais si je mets dans /etc/nut/ups.conf
[apc]
driver = apcsmart
port = /dev/ttyUSB1

cela ne marche pas

vais-je être obligé d'acheter un autre onduleur ?

marci pour toute suggestion

--
philippe

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
David Prévot
Le #9657491
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Philippe MONROUX a écrit :
Bonjour,

J'utilisais nut avec un apc smart-ups 700 qui communique avec un port
série.
Le pb est que je viens de changer de carte mère et qu'elle n'a pas de
port série. J'ai donc acheté un adaptateur série<-> usb

Celui-ci est bien reconnu :

drivers/usb/serial/usb-serial.c: USB Serial support registered for pl2303
[ 4.039051] pl2303 2-2:1.0: pl2303 converter detected
[ 4.072285] usb 2-2: pl2303 converter now attached to ttyUSB0

mais si je mets dans /etc/nut/ups.conf
[apc]
driver = apcsmart
port = /dev/ttyUSB1

cela ne marche pas



Ça, c'est normal : man apcsmart -> « This driver expects to see a
940‐0024C cable [...] », donc le pilote ne travaille *que* sur un
onduleur branché sur le port série.

vais-je être obligé d'acheter un autre onduleur ?



Tu peux aussi te trouver un port série en carte pci ou émulé depuis un
port usb, voire découvrir des broches qui vont bien sur ta carte mère.

marci pour toute suggestion



Essayer de faire fonctionner un pilote usb pour nut, il y en en a
quelques uns, des génériques comme megatec peut-être ? Pour ma part, je
reste en port série, car mes essais en usb ont été infructueux (mais le
manuel m'avais prévenu).

Amicalement

David

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAkhcaCUACgkQ18/WetbTC/qvKgCcDI6gUG5nDDuaK7Q+Nyw7SoTh
HJ0AnjWbXDIGuXlhLm5v+HyEMMZW+FvI
=EwI6
-----END PGP SIGNATURE-----

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Philippe Marzouk
Le #9655601
On Sat, Jun 21, 2008 at 06:12:46AM +0400, Philippe MONROUX wrote:
Bonjour,

J'utilisais nut avec un apc smart-ups 700 qui communique avec un port
série.
Le pb est que je viens de changer de carte mère et qu'elle n'a pas de
port série. J'ai donc acheté un adaptateur série<-> usb

Celui-ci est bien reconnu :

drivers/usb/serial/usb-serial.c: USB Serial support registered for pl2303
[ 4.039051] pl2303 2-2:1.0: pl2303 converter detected
[ 4.072285] usb 2-2: pl2303 converter now attached to ttyUSB0

mais si je mets dans /etc/nut/ups.conf
[apc]
driver = apcsmart
port = /dev/ttyUSB1

cela ne marche pas

vais-je être obligé d'acheter un autre onduleur ?




Le message du noyau dit ttyUSB0 mais tu indiques ttyUSB1 dans la
configuration, il y a une raison particulière ?

Philippe

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Philippe MONROUX
Le #9655521
De (from) (von)
Le message du noyau dit ttyUSB0 mais tu indiques ttyUSB1 dans la
configuration, il y a une raison particulière ?



Non en fait j'ai deux adaptateurs et j'ai essayé les deux. Finalement
j'ai ajouté une carte pci avec 2 port série et ça marche. Merci
--
philippe

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme