Identifier un réseau (et le rendre privé) sous Vista

Le
Frederic STOCK
Salut,

Windows Vista Pro SP1.
Domaine AD2000.

le réseau local est bien identifié (avec le nom du domaine AD) et il est
de type "privé".
J'ai installé sur ce poste pour des raisons de compatibilité
d'authentification avec un serveur SCO Unix, VmWare pour émuler un
Windows XP.
VmWare installe des cartes réseaux virtuelles.
Or chaque fois que le PC Vista redémarre, le réseau "virtuel" se trouve
en réseau non identifié et de type public.
Je peux changer le type de public à privé, mais seulement tant que le PC
est sous tension; si celui-ci est arrêté ou redémarrer, le réseau
virtuel repasse en type public.
Existe-t-il un moyen pour:
1) indiquer définitivement que ce réseau est de type "privé" ?
2) d'identifier ce réseau (la zone non du réseau n'est pas modifiable) ?

Merci.
F. STOCK
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Azur
Le #17879261
Bonjour,

Tu devrais plutôt t'adresser à : microsoft.public.fr.windows.vista.reseau

Je fais le transfert, tiens !

Etrange ton problème . il me semble que les paramêtres du type
de reseau ne change pas "comme ca" dans vista.

Tu arrêtes proprement la machine virtuelle avant d'arreter la vrai machine ?


-azur-




"Frederic STOCK" gfrqtg$htg$
Salut,

Windows Vista Pro SP1.
Domaine AD2000.

le réseau local est bien identifié (avec le nom du domaine AD) et il est
de type "privé".
J'ai installé sur ce poste pour des raisons de compatibilité
d'authentification avec un serveur SCO Unix, VmWare pour émuler un Windows
XP.
VmWare installe des cartes réseaux virtuelles.
Or chaque fois que le PC Vista redémarre, le réseau "virtuel" se trouve en
réseau non identifié et de type public.
Je peux changer le type de public à privé, mais seulement tant que le PC
est sous tension; si celui-ci est arrêté ou redémarrer, le réseau virtuel
repasse en type public.
Existe-t-il un moyen pour:
1) indiquer définitivement que ce réseau est de type "privé" ?
2) d'identifier ce réseau (la zone non du réseau n'est pas modifiable) ?

Merci.
F. STOCK


Frederic STOCK
Le #17900231
Salut merci pour le bon forum,

j'ai peut-être trouvé un début d'explication (mais de pas de résolution):
en fait VmWare crées 3 cartes réseau virtuelles:
1 en mode bridge (donc couplée avec la carte physique du PC)
1 en mode host (cad réseau virtuel différent du reseau local)
1 en mode NAT.

sur les 2 modes host et Nat, un serveur dhcp (virtuel) est lancé et les
masque de réseau sont différents du masque de mon réseau local.
Je pense que c'est pour cette raison que Vista ne veut pas les
identifier, ce qui ne m'explique pas pourquoi je ne peux pas les forcer
comme étant de type "privé".

Merci.
Salutations.

F. STOCK

Azur a écrit :
Bonjour,

Tu devrais plutôt t'adresser à : microsoft.public.fr.windows.vista.reseau

Je fais le transfert, tiens !

Etrange ton problème . il me semble que les paramêtres du type
de reseau ne change pas "comme ca" dans vista.

Tu arrêtes proprement la machine virtuelle avant d'arreter la vrai machine ?


-azur-




"Frederic STOCK" gfrqtg$htg$
Salut,

Windows Vista Pro SP1.
Domaine AD2000.

le réseau local est bien identifié (avec le nom du domaine AD) et il est
de type "privé".
J'ai installé sur ce poste pour des raisons de compatibilité
d'authentification avec un serveur SCO Unix, VmWare pour émuler un Windows
XP.
VmWare installe des cartes réseaux virtuelles.
Or chaque fois que le PC Vista redémarre, le réseau "virtuel" se trouve en
réseau non identifié et de type public.
Je peux changer le type de public à privé, mais seulement tant que le PC
est sous tension; si celui-ci est arrêté ou redémarrer, le réseau virtuel
repasse en type public.
Existe-t-il un moyen pour:
1) indiquer définitivement que ce réseau est de type "privé" ?
2) d'identifier ce réseau (la zone non du réseau n'est pas modifiable) ?

Merci.
F. STOCK






Jean-Claude BELLAMY
Le #17900931
"Frederic STOCK" news:
Salut merci pour le bon forum,

j'ai peut-être trouvé un début d'explication (mais de pas de résolution):
en fait VmWare crées 3 cartes réseau virtuelles:
1 en mode bridge (donc couplée avec la carte physique du PC)


= VMNet0
1 en mode host (cad réseau virtuel différent du reseau local)


=VMNet1
1 en mode NAT.


=VMNet8


sur les 2 modes host et Nat, un serveur dhcp (virtuel) est lancé et les
masque de réseau sont différents du masque de mon réseau local.
Je pense que c'est pour cette raison que Vista ne veut pas les identifier,
ce qui ne m'explique pas pourquoi je ne peux pas les forcer comme étant de
type "privé".
[...]


Exact ...

Et pour ton info, je te signale que je DÉSACTIVE systématiquement ces 2
cartes virtuelles "VMNet1" et "VMNet8", vu que je fonctionne toujours en
mode "bridged".
Suivant la métrique qui leur est attribuée, j'ai constaté qu'elles passaient
parfois en 1er, quand je faisais un parcours réseau, et je me goinfrais des
tas d'erreurs 53 sur un "NET VIEW" p.ex., et au minimum des temps de réponse
phénoménaux.
Vu qu'elles avaient des adresses IP dans des plages qui n'avaient aucun
rapport avec mon LAN en 192.168.0.x (198.168.224.1 ou 192.168.29.1), leur
requêtes tombaient systématiquement dans le vide!


--
May the Force be with You!
La Connaissance s'accroît quand on la partage
----------------------------------------------------------
Jean-Claude BELLAMY [MVP] - http://www.bellamyjc.org
Mario MORINO
Le #17903451
Jean-Claude BELLAMY a écrit :


... vu que je fonctionne toujours en mode "bridged".




Accessoirement, tu peux expliquer ce qu'est ce mode ?

Merci d'avance !

Slurp !

;o)

--
Mario MORINO
Forums francophones http://www.winpasapas.org/
L'informatique pas-à-pas
Frederic STOCK
Le #17904081
Jean-Claude BELLAMY a écrit :
"Frederic STOCK" news:
Salut merci pour le bon forum,

j'ai peut-être trouvé un début d'explication (mais de pas de résolution):
en fait VmWare crées 3 cartes réseau virtuelles:
1 en mode bridge (donc couplée avec la carte physique du PC)


= VMNet0
1 en mode host (cad réseau virtuel différent du reseau local)


=VMNet1
1 en mode NAT.


=VMNet8


sur les 2 modes host et Nat, un serveur dhcp (virtuel) est lancé et
les masque de réseau sont différents du masque de mon réseau local.
Je pense que c'est pour cette raison que Vista ne veut pas les
identifier, ce qui ne m'explique pas pourquoi je ne peux pas les
forcer comme étant de type "privé".
[...]


Exact ...

Et pour ton info, je te signale que je DÉSACTIVE systématiquement ces 2
cartes virtuelles "VMNet1" et "VMNet8", vu que je fonctionne toujours en
mode "bridged".
Suivant la métrique qui leur est attribuée, j'ai constaté qu'elles
passaient parfois en 1er, quand je faisais un parcours réseau, et je me
goinfrais des tas d'erreurs 53 sur un "NET VIEW" p.ex., et au minimum
des temps de réponse phénoménaux.
Vu qu'elles avaient des adresses IP dans des plages qui n'avaient aucun
rapport avec mon LAN en 192.168.0.x (198.168.224.1 ou 192.168.29.1),
leur requêtes tombaient systématiquement dans le vide!


--
May the Force be with You!
La Connaissance s'accroît quand on la partage
----------------------------------------------------------
Jean-Claude BELLAMY [MVP] - http://www.bellamyjc.org




Salut Jean-Claude,

merci d'avoir confirmé mes dires; et j'ai egalement fait comme tu le
cites à savoir désactiver les deux cartes virtuelles car je ne m'en sers
pas.
De ce fait, le réseau "non identifié" n'apparaît plus, et effectivement
je n'avais pas remarqué mais comme tu l'indiques, le parcours réseau et
nettement plus rapide !

Cordialement,
F. STOCK
Jean-Claude BELLAMY
Le #17904831
"Mario MORINO" news:u4%
Jean-Claude BELLAMY a écrit :


... vu que je fonctionne toujours en mode "bridged".



Accessoirement, tu peux expliquer ce qu'est ce mode ?



Même en détail , je peux !!! ;-)

Au niveau réseau, par défaut, VMWare (qui est un émulateur de matériel, ne
l'oublions pas) crée 3 cartes Ethernet virtuelles :
- VMnet 0 : carte virtuelle utilisée en cas de fonctionnement "bridged"
(elle se "superpose" à la carte réseau physique du PC
hôte)
- VMnet 1 : carte virtuelle utilisée en cas de réseau local isolé
- VMnet 8 : carte virtuelle utilisée en cas de fonctionnement "NAT"
(on peut en créer d'autres si on veut)

Ensuite, on dispose de 4 modes de fonctionnement réseau, au choix, :

- non connecté ("Not connected")
pas de réseau, la machine virtuelle est donc totalement isolée.
Ce mode peut s'avérer utile dans des circonstances très
particulières, telles que le test de l'action de certains virus.
-> aucune carte virtuelle n'est utilisée

- réseau local isolé ("Host only")
les machines virtuelles communiquent entre elles via un
réseau virtuel, mais ne peuvent pas communiquer avec la
machine hôte ou les autres machines réelles du réseau réel
-> la carte WMnet1 est utilisée dans la machine invitée

- intégration au réseau réel ('"bridged")
les machines virtuelles se comportent comme n'importe
quelle autre machine réelle du LAN, reçoivent p.ex. une
adresse IP d'un serveur DHCP, et sont vues depuis les
autres machines du LAN comme si elles étaient réelles.
C'est le mode standard.
-> la carte WMnet0 est utilisée dans la machine invitée


- NAT (Network Addresses Translation)
De la même façon qu'un routeur connecté à Internet
va effectuer une conversion des adresses locales
(en 192.168.x.x p.ex.) pour toute requête vers Internet
émise par une machine locale, ici la machine hôte effectue
une conversion analogue des adresses locales des
machines invitées.
Donc une machine invitée pourra accéder au LAN réel ,
voire à Internet, mais ne sera pas vue du LAN réel.
-> la carte WMnet8 est utilisée dans la machine invitée


--
May the Force be with You!
La Connaissance s'accroît quand on la partage
----------------------------------------------------------
Jean-Claude BELLAMY [MVP] - http://www.bellamyjc.org
Paspub
Le #17906171
Le Thu, 20 Nov 2008 15:00:02 +0100, Frederic STOCK

Jean-Claude BELLAMY a écrit :
j'ai peut-être trouvé un début d'explication (mais de pas de résolution):
en fait VmWare crées 3 cartes réseau virtuelles:
1 en mode bridge (donc couplée avec la carte physique du PC)


= VMNet0
1 en mode host (cad réseau virtuel différent du reseau local)


=VMNet1
1 en mode NAT.


=VMNet8
Et pour ton info, je te signale que je DÉSACTIVE systématiquement ces 2
cartes virtuelles "VMNet1" et "VMNet8", vu que je fonctionne toujours en
mode "bridged".



merci d'avoir confirmé mes dires; et j'ai egalement fait comme tu le
cites à savoir désactiver les deux cartes virtuelles car je ne m'en sers
pas.
De ce fait, le réseau "non identifié" n'apparaît plus, et effectivement
je n'avais pas remarqué mais comme tu l'indiques, le parcours réseau et
nettement plus rapide !

Cordialement,
F. STOCK



Comment désactiver les cartes virtuelles VMNet1 et VMNet8 ? J'ai
changé de FAI, je suis actuellement chez Numericable et sous Vista.
J'ai très régulièrement (au bout de quelques secondes ou quelques
heures) des déconnexions avec un message de connectivité limitée et
"réseau non identifié".
Mario MORINO
Le #17910461
Jean-Claude BELLAMY a écrit :


... vu que je fonctionne toujours en mode "bridged".



Accessoirement, tu peux expliquer ce qu'est ce mode ?



Même en détail , je peux !!! ;-)

...



Merci ! Dans ma malle aux trésors !

;o)


--
Mario MORINO
Forums francophones http://www.winpasapas.org/
L'informatique pas-à-pas
Jean-Claude BELLAMY
Le #17913211
"Paspub" news:
[...]
Comment désactiver les cartes virtuelles VMNet1 et VMNet8 ?



C'est ultra-simple !
Il suffit d'ouvrir le panneau "Connexions réseau"

Pour cela, il y a plusieurs méthodes, la plus rapide, AMHA, étant d'exécuter
la commande :
start shell:ConnectionsFolder

ou, si on aime les chiffres (;-)) :
explorer ::{7007ACC7-3202-11D1-AAD2-00805FC1270E}

Et là, on sélectionne la connexion VMNet1, clic droit, menu "Désactiver".
Idem pour VMNet8, et le tour est joué ! ;-)


--
May the Force be with You!
La Connaissance s'accroît quand on la partage
----------------------------------------------------------
Jean-Claude BELLAMY [MVP] - http://www.bellamyjc.org
Publicité
Poster une réponse
Anonyme