If...une partie du texte

Le
Denys
Bonjour à tous,

En cellule C1 je voudrais écrire une formule qui voudrait dire ce qui
suit:

Si en D1 il y a le mot MERIT, alors C1 = Y, sinon ""

Ce qu'il y a c'est qu'en D1 ce peut être Train-Merit ou encore
Restaurant chez Pierre-MERIT etc..

Voyez le dilemme. J'ai 4900 lignes

Merci pour votre aide

Denys
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacky
Le #19763091
Bonsoir,

En D1
=SI(ESTERREUR(CHERCHE("*merit*";D1));"";"y")

--
Salutations
JJ


"Denys"
Bonjour à tous,

En cellule C1 je voudrais écrire une formule qui voudrait dire ce qui
suit:

Si en D1 il y a le mot MERIT, alors C1 = Y, sinon ""

Ce qu'il y a c'est qu'en D1 ce peut être Train-Merit ou encore
Restaurant chez Pierre-MERIT etc..

Voyez le dilemme.... J'ai 4900 lignes...

Merci pour votre aide

Denys
Philippe.R
Le #19763191
Bonsoir,
Ou bien :
=si(droite(d1;6)="MERIT";"Y";"")
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/mpfe/connexion.php
News://news.microsoft.com/microsoft.public.fr.excel
"Denys" news:
Bonjour à tous,

En cellule C1 je voudrais écrire une formule qui voudrait dire ce qui
suit:

Si en D1 il y a le mot MERIT, alors C1 = Y, sinon ""

Ce qu'il y a c'est qu'en D1 ce peut être Train-Merit ou encore
Restaurant chez Pierre-MERIT etc..

Voyez le dilemme.... J'ai 4900 lignes...

Merci pour votre aide

Denys
Daniel.C
Le #19763181
Bonjour.
=SI(ESTNUM(TROUVE("MERIT";D1));"Y";"")
Daniel

Bonjour à tous,

En cellule C1 je voudrais écrire une formule qui voudrait dire ce qui
suit:

Si en D1 il y a le mot MERIT, alors C1 = Y, sinon ""

Ce qu'il y a c'est qu'en D1 ce peut être Train-Merit ou encore
Restaurant chez Pierre-MERIT etc..

Voyez le dilemme.... J'ai 4900 lignes...

Merci pour votre aide

Denys


Daniel.C
Le #19763331
Toutefois, est-ce que "merit" est ou non sensible à la casse et est-ce
qu'il doit s'agir d'un mot isolé dans une chaîne de caractères ?
Daniel

Bonjour à tous,

En cellule C1 je voudrais écrire une formule qui voudrait dire ce qui
suit:

Si en D1 il y a le mot MERIT, alors C1 = Y, sinon ""

Ce qu'il y a c'est qu'en D1 ce peut être Train-Merit ou encore
Restaurant chez Pierre-MERIT etc..

Voyez le dilemme.... J'ai 4900 lignes...

Merci pour votre aide

Denys


Denys
Le #19763321
On 15 juil, 14:42, "Jacky"
Bonsoir,

En D1
=SI(ESTERREUR(CHERCHE("*merit*";D1));"";"y")

--
Salutations
JJ

"Denys"
Bonjour à tous,

En cellule C1 je voudrais écrire une formule qui voudrait dire ce qui
suit:

Si en D1 il y a le mot MERIT, alors C1 = Y, sinon ""

Ce qu'il y a c'est qu'en D1 ce peut être Train-Merit ou encore
Restaurant chez Pierre-MERIT etc..

Voyez le dilemme.... J'ai 4900 lignes...

Merci pour votre aide

Denys



Bonsoir Jacky,

Merci beaucoup....

C'est parfait

Denys
DesseJ
Le #19765431
Bonjour,

pour compléter ;o)))

=SI(NB.SI(D1;"*merit*")=1;"Y";"")

Bonne journée
StephD
Jacky
Le #19769481
Re...

Pour compléter le "déjà compléter" ;o)))
On enlève le "=1"
<(:-)
--
Salutations
JJ


"DesseJ"
Bonjour,

pour compléter ;o)))

=SI(NB.SI(D1;"*merit*")=1;"Y";"")

Bonne journée
StephD
LSteph
Le #19769641
Salut,
;o)) Parfois on reconnait ceux qui ont du "*merit*"
....avant la casse!

--
lSteph
( C'est à cause de la crise! )

On 16 juil, 17:34, "Jacky"
Re...

Pour compléter le "déjà compléter" ;o)))
On enlève le "=1"
<(:-)
--
Salutations
JJ


Publicité
Poster une réponse
Anonyme