IIS 7.0 et Visual Studio 2005

Le
Oriane
Bonjour,

lorsque je veux faire fonctionner une appli ASP.Net (par ex un Web services)
développée sur XP , IIS me jette car il trouve le fichier web.config
incorrect.

Si je crée mon Web Service avec Visual Studio 2005 SP1 avec le patch pour
Vista, sur Vista, et que je demande à créer mon projet Web service sur IIS
7.0 (et pas sur le serveur Web émulé par VStudio), un message me signale que
je n'ai pas la bonne version d'IIS (cad la 6) et qu'il faut que je
télécharge "IIS 6.0 metabase and configuration compatibility". Je ne trouve
pas ce composant en téléchargement

Est-ce normal ? Si oui comment migrer ?

Oriane
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
jbongran
Le #11326681
Oriane wrote:
Bonjour,

lorsque je veux faire fonctionner une appli ASP.Net (par ex un Web
services) développée sur XP , IIS me jette car il trouve le fichier
web.config incorrect.

Si je crée mon Web Service avec Visual Studio 2005 SP1 avec le patch
pour Vista, sur Vista, et que je demande à créer mon projet Web
service sur IIS 7.0 (et pas sur le serveur Web émulé par VStudio), un
message me
signale que je n'ai pas la bonne version d'IIS (cad la 6) et qu'il
faut que je télécharge "IIS 6.0 metabase and configuration
compatibility". Je ne trouve pas ce composant en téléchargement...

Est-ce normal ? Si oui comment migrer ?

Oriane



http://www.iis.net/articles/view.aspx/IIS7/Use-IIS7-Administration-Tools/Using-XML-Configuration/How-to-use-Metabase-Compatibility-with-IIS7
et le lien pour le metabase explorer:
http://support.microsoft.com/kb/840671#8
Oriane
Le #11326671
Bonjour,

vos liens servent apparemment à faire fonctionner IIS 7.0 sur W2K3. Moi je
veux faire marcher des applis Asp.Net XP (donc prévues pour IIS 5.0) sur IIS
7.0...

Cdt
jbongran
Le #11326661
Oriane wrote:
Bonjour,

vos liens servent apparemment à faire fonctionner IIS 7.0 sur W2K3.
Moi je veux faire marcher des applis Asp.Net XP (donc prévues pour
IIS 5.0) sur IIS 7.0...

Cdt



Non, le premier lien indiqué est bien pour IIS 7.0 ...
Oriane
Le #11326621
"jbongran" news:ezSw6%
Oriane wrote:
Bonjour,

vos liens servent apparemment à faire fonctionner IIS 7.0 sur W2K3.
Moi je veux faire marcher des applis Asp.Net XP (donc prévues pour
IIS 5.0) sur IIS 7.0...

Cdt



Non, le premier lien indiqué est bien pour IIS 7.0 ...


Peut être mais pour rendre IIS 7.0 "IIS5" compatible il suffit d'activer la
fonctionnalité ad hoc dans Vista via le panneau de configuration. En gros il
s'agit d'une ase à cocher mais bordel pourquoi n'est-ce pasindiqué dans le
"help" de IIS !!!!!

Oriane
jbongran
Le #11346521
Oriane wrote:
"jbongran" news:ezSw6%
Oriane wrote:
Bonjour,

vos liens servent apparemment à faire fonctionner IIS 7.0 sur W2K3.
Moi je veux faire marcher des applis Asp.Net XP (donc prévues pour
IIS 5.0) sur IIS 7.0...

Cdt



Non, le premier lien indiqué est bien pour IIS 7.0 ...


Peut être mais pour rendre IIS 7.0 "IIS5" compatible il suffit
d'activer la fonctionnalité ad hoc dans Vista via le panneau de
configuration. En gros il s'agit d'une ase à cocher mais bordel
pourquoi n'est-ce pasindiqué dans le "help" de IIS !!!!!

Oriane



Peut être avez-vous sauté l'étape IIS 6.0 ou par défaut toutes les
fonctionnalités sont désactivées afin de réduire la surface d'attaque des
serveurs.
Ce groupe n'étant pas en écriture seule, la réponse concernant IIS 6.0 s'y
trouve déja...
Oriane
Le #11346501
"jbongran" news:e$
Oriane wrote:
Non, le premier lien indiqué est bien pour IIS 7.0 ...


Peut être mais pour rendre IIS 7.0 "IIS5" compatible il suffit
d'activer la fonctionnalité ad hoc dans Vista via le panneau de
configuration. En gros il s'agit d'une ase à cocher mais bordel
pourquoi n'est-ce pasindiqué dans le "help" de IIS !!!!!

Oriane



Peut être avez-vous sauté l'étape IIS 6.0 ou par défaut toutes les
fonctionnalités sont désactivées afin de réduire la surface d'attaque des
serveurs.


Non pas vraiment, mais rappelons cependant qu'IIS 6.0 était installé sur un
serveur. La désactivation par défaut est une bonne chose. Et le faire savoir
dans l'aide ou dans le panneau de démarrage d'IIS serait aussi une bonne
chose car je ne suis visiblement pas le seul à chercher comment activer
Asp.Net..

Ce groupe n'étant pas en écriture seule, la réponse concernant IIS 6.0 s'y
trouve déja...


Mais alors que ne me l'avez vous donnée..

Cordialement
jbongran
Le #11346481
Oriane wrote:
"jbongran" news:e$
Oriane wrote:
Non, le premier lien indiqué est bien pour IIS 7.0 ...


Peut être mais pour rendre IIS 7.0 "IIS5" compatible il suffit
d'activer la fonctionnalité ad hoc dans Vista via le panneau de
configuration. En gros il s'agit d'une ase à cocher mais bordel
pourquoi n'est-ce pasindiqué dans le "help" de IIS !!!!!

Oriane



Peut être avez-vous sauté l'étape IIS 6.0 ou par défaut toutes les
fonctionnalités sont désactivées afin de réduire la surface
d'attaque des serveurs.


Non pas vraiment, mais rappelons cependant qu'IIS 6.0 était installé
sur un serveur. La désactivation par défaut est une bonne chose. Et
le faire savoir dans l'aide ou dans le panneau de démarrage d'IIS
serait aussi une bonne chose car je ne suis visiblement pas le seul à
chercher comment activer Asp.Net..


Je suis d'accord sur le fait que les fonctionnalités du gestionnaire
d'extension ne sont pas mises en avant.

Ce groupe n'étant pas en écriture seule, la réponse concernant IIS
6.0 s'y trouve déja...


Mais alors que ne me l'avez vous donnée..



La réponse à été donnée très souvent dans ce newsgroup, c'est pourquoi il
est conseillé d'abord de lire/rechercher dans ce dernier avant de poster.
Ceci s'applique a tout newsgroup.
Pour être tout à fait franc, j'ai visiblement eu du mal à cerner votre souci
d'après les éléments fourni, désolé du temps que cela aurai pu vous faire
perdre dans la résolution de celui-ci.
Oriane
Le #11346461
"jbongran"
Pour être tout à fait franc, j'ai visiblement eu du mal à cerner votre
souci d'après les éléments fournis,


C'est normal parce que j'avais moi-même du mal à le comprendre. A la base,
je pensais que les web.config générés par VStudio 2005 SP1 n'étaient pas
compatibles avec IIS 7.0. Or la réponse est bien sûr : si, c'est compatible.

L'erreur que j'ai faite était de publier un site Web en tant que Répertoire
virtuel sur un site existant. Et là du coup ca ne marchait pas. Il fallait
évidemment le publier sur un Site Web...

désolé du temps que cela aurai pu vous faire perdre dans la résolution de
celui-ci.


Faut vraiment pas...

Cordialement
Publicité
Poster une réponse
Anonyme