image fantôme... (écho ?)

Le
Thierry M.
Bonjour,

Bon, je craque, suis même pret à encoder avec ffmpeg en ligne de
commande, c'est dire :o)

J'ai un 720p que je tenais de toute façon à recompresser en 2500 (je
fais le ménage en ce moment) et qui présente avec VLC et le lecteur
windows des images fantômes roses, décalées sur la droite

oui mais : dans la prévisualisation (ffdshow) de M4ng, ya pas ! tout va
bien ! alors je me dis ! bon, cette comme cette satanée bande verte
verticale sous VLC (qui n'apparait pas d'ailleurs avec le wd tv live ?)
de certaines compressions, comme la aussi ça n'apparait pas dans la
prévisu, et qu'en compression, ça disparait pas de bleme !

ouais, mais la ! même la compression a toujours ces images écho roses !

?????????

Je me dis que si la prévisu ya pas, ça doit être possible !

cqcb ?

bon, j'essaye un coup de mediacoder, et apres je vous demande en ligne
de commande si ça le fait pas

--
Thierry
Aero-QCM (Vol libre, vol à voile, ulm, avion)
http://ardf.free.fr/QCM/forum/
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 6
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Thierry M.
Le #24548441
Dans son message précédent, Thierry M. a écrit :

bon, j'essaye un coup de mediacoder



source/encoder mencoder
pareil

(dans le fichier temp on peut lancer le fichier en cours des qu'il pese
trois cacahouettes...)

j'essaye source mencoder/encoder ffmpeg
heu... c'est pire : ya des gros carrés en plus ???? comme s'il y avait
un bitrate de nain... ???
bon de toute façon, ça doit venir du décodeur...

bon, avisynth/mencoder message d'erreur
mplayer/mencoder pareil (en fait c'est pas rose, c'est jaune caca)

je perd patience :-(

et je n'insisterai pas si dans m4ng la prévisu était bonne !!!???
ARGH

--
Thierry
Aero-QCM (Vol libre, vol à voile, ulm, avion)
http://ardf.free.fr/QCM/forum/
Stephane Legras-Decussy
Le #24548591
Le 10/06/2012 17:02, Thierry M. a écrit :


et je n'insisterai pas si dans m4ng la prévisu était bonne !!!???
ARGH




bon, à tout hasard :

ffmpeg -i source.xxx -vcodec libx264 -b 2500k -acodec copy test.mkv
Thierry M.
Le #24548721
Stephane Legras-Decussy a écrit :
Le 10/06/2012 17:02, Thierry M. a écrit :


et je n'insisterai pas si dans m4ng la prévisu était bonne !!!???
ARGH




bon, à tout hasard :

ffmpeg -i source.xxx -vcodec libx264 -b 2500k -acodec copy test.mkv



ça tourne avec une autre combinaison m4ng mais ce coup ci je ne peux
pas tester le fichier de sortie avant qu'il ne soit fini (.264 pas
lisible avec VLC) et des que c'est libre si c'est pas encore bon (je
sens que je vais tourner en rond longtemps moi...) j'essaye ta ligne...

--
Thierry
Aero-QCM (Vol libre, vol à voile, ulm, avion)
http://ardf.free.fr/QCM/forum/
Alf92
Le #24549141
"Thierry M."
ffmpeg -i source.xxx -vcodec libx264 -b 2500k -acodec copy test.mkv



ça tourne avec une autre combinaison m4ng mais ce coup ci je ne peux pas
tester le fichier de sortie avant qu'il ne soit fini (.264 pas lisible avec
VLC) et des que c'est libre si c'est pas encore bon (je sens que je vais
tourner en rond longtemps moi...) j'essaye ta ligne...




pratique pour faire des tests :

ffmpeg -ss 80 -t 60 -i source.xxx -vcodec libx264 -b 2500k -acodec copy
test.mkv

(commence à la seconde 80 et encode sur une durée de 60s.)
Alf92
Le #24549131
"Alf92"
ffmpeg -i source.xxx -vcodec libx264 -b 2500k -acodec copy test.mkv



ça tourne avec une autre combinaison m4ng mais ce coup ci je ne peux pas
tester le fichier de sortie avant qu'il ne soit fini (.264 pas lisible avec
VLC) et des que c'est libre si c'est pas encore bon (je sens que je vais
tourner en rond longtemps moi...) j'essaye ta ligne...




pratique pour faire des tests :

ffmpeg -ss 80 -t 60 -i source.xxx -vcodec libx264 -b 2500k -acodec copy
test.mkv

(commence à la seconde 80 et encode sur une durée de 60s.)



ou : -ss 00:00:05.000 -t 00:00:05.000
(HH:MM:SS.SSS)
Thierry M.
Le #24549601
J'ai essayé dans le dossier m4ng ou se trouve ffmpeg
puis en mettant ffmpeg trouvé dans http://ffdshow.faireal.net/
dans system 32

même punition: ffmpeg a rencontré une erreur et doit fermer etc.

=
j'ai eu un résultat *sans les fantômes* avec M4ng en utilisant l'option
x264vfw (au lieu de x264cli) avec en conteneur un avi MAIS
ce con de m4ng dans ce cas ignore le reglage de bitrate et se démerde
pour sortir 700 Mo, donc bitrate a 800, par la...
(quoique dans la fenetre "ligne de commande" d'info, il est bien
spécifié 2500 dans les paramètres...)

GRRRRRRRRRRR

--
Thierry
Aero-QCM (Vol libre, vol à voile, ulm, avion)
http://ardf.free.fr/QCM/forum/
Thierry M.
Le #24549701
Après mûre réflexion, Thierry M. a écrit :
J'ai essayé dans le dossier m4ng ou se trouve ffmpeg
puis en mettant ffmpeg trouvé dans http://ffdshow.faireal.net/
dans system 32

même punition: ffmpeg a rencontré une erreur et doit fermer etc.



pris une version de cette année sur le site d'origine, en un seul
fichier, et la ça passe, mais impossible de voir le résultat, je suis
sous teamviewer (les vidéos sont en noir en controle distant...) je
verrai ce soir...

--
Thierry
http://ardf.free.fr
Thierry M.
Le #24549781
Le 11/06/2012, Thierry M. a supposé :

pris une version de cette année sur le site d'origine, en un seul fichier, et
la ça passe, mais impossible de voir le résultat



ah, j'avais oublié la capture écran : c'est bon, mais qu'est ce que
c'est lent ! et j'ai du utiliser ta premiere formulation pour le test,
parcequ'avec la deuxieme, si je fais :
-ss 00:00:10.000 -t 00:00:20.000
20 secondes après la 10eme seconde...
je n'obtient que 3s d'écran noir ???
avec -ss 80 -t 60 j'ai bien la minute

j'essaye en ce momment de réutiliser m4ng en ayant remplacé le
ffmpeg.exe par le nouveau (*)... et si ça marche pas, ben ça prendra le
temps que ça faut, mais je referai ta ligne de commande sans les bornes
temporelles (la ligne de stephane en fait)

(*)je sais pas ce que ça peut donner, parceque deja m4ng utilise
avisynth je crois et que la version ffmpeg a pas l'air toute jeune
qu'elle utilise le dll, puisque si je comprend bien, dans la nouvelle,
ya tout dans l'exe (enfin bon, vu qu'il ya plusieurs versions ??)
et j'ai des ffmpeg_x264 dans le dossier m4ng ???

--
Thierry
Lecteur de news de course:
http://www.mesnews.net
JPaulV
Le #24549861
Dans le message :,
Thierry M.
pris une version de cette année sur le site d'origine, en un seul
fichier, et la ça passe, mais impossible de voir le résultat, je suis
sous teamviewer (les vidéos sont en noir en controle distant...) je
verrai ce soir...



J'ai fait une recherche sur ffmpeg dans mon PC
ça semble être un peu la foire dans les versions.
http://cjoint.com/?BFljHAnc2MG

Laquelle est la bonne ?

--
JPaulV
Thierry M.
Le #24549991
JPaulV a émis l'idée suivante :
Dans le message :,
Thierry M.
pris une version de cette année sur le site d'origine, en un seul
fichier, et la ça passe, mais impossible de voir le résultat, je suis
sous teamviewer (les vidéos sont en noir en controle distant...) je
verrai ce soir...



J'ai fait une recherche sur ffmpeg dans mon PC
ça semble être un peu la foire dans les versions.
http://cjoint.com/?BFljHAnc2MG

Laquelle est la bonne ?



suivre les liens ffmpeg.org, dans mon pc c'est pareil, y'en a partout,
j'ai pris (windows) 32bits static et extrait l'exe du dossier bin et
juste posé a côté du fichier a recompresser, et appliqué la (première)
ligne de commande 'test' de alf...

je l'ai mis aussi dans le dossier system de m4ng pour remplacer le
ffmpeg.exe qu'il y avait, la, ça tourne, on verra bien, mais c'est quoi
ce ffmpeg_x264.exe qu'il y a a côté ?

--
Thierry
Aero-QCM (Parapente, Delta, Planeur, ULM, Aviation...)
http://ardf.free.fr/QCM/forum/
Publicité
Poster une réponse
Anonyme