import profils utilisateur

Le
Joël
Bonjour,

Sur mon lieu de stage, nous disposons d'une configuration un peu
particulière :

Un AD qui comporte les logins utilisateurs pour la gestion des
sessions Windows, mais qui ne comporte quasiment rien d'autre.
Un annuaire LDAP pour tout le reste, qui contient toutes les infos des
utilisateurs.

Nous souhaitons déployer Sharepoint sur l'ensemble de l'entreprise
mais l'import des profils depuis AD serait problématique puisque ce
dernier ne dispose que de très peu d'infos. Aussi nous voudrions
importer les profils depuis l'annuaire LDAP et (au mieux) utiliser
ensuite l'AD pour l'authentification (j'ai des doutes sur la
faisabilité d'une telle chose, est-ce que quelqu'un peut confirmer ou
infirmer?).

Mais avant ça, sur ma VM de test, lorsque j'essaye de créer la
connexion pour l'import des profils depuis un annuaire LDAP, et plus
particulièrement lors de la validation des paramètres, Sharepoint
tente de faire un import de test mais celui-ci échoue constamment
après une minute ou deux, avec comme message que la requête n'as
retourné aucun résultat. Ça fait une semaine que je piétine sur ç=
a
sans trouver d'infos. J'ai l'impression de louper quelque chose mais
je ne sais pas quoi!

Merci d'avance de votre aide.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Lognoul, Marc \(Private\)
Le #16939791
Bonjour,

Nous souhaitons déployer Sharepoint sur l'ensemble de l'entreprise
mais l'import des profils depuis AD serait problématique puisque ce
dernier ne dispose que de très peu d'infos. Aussi nous voudrions
importer les profils depuis l'annuaire LDAP et (au mieux) utiliser
ensuite l'AD pour l'authentification (j'ai des doutes sur la
faisabilité d'une telle chose, est-ce que quelqu'un peut confirmer ou
infirmer?).


Faisable oui, mais gardez à l'esprit que l'authentification et l'import de
profils sont deux choses différent, éventuellement liée.
Par ordre de priorité, il vous faut d'abord pouvoir authentifier et
autoriser
Ensuite, vous pourrez lier des profils (dont les informations proviennent
d'un annuaire) aux identités dérivant de l'authentification.

Mais avant ça, sur ma VM de test, lorsque j'essaye de créer la
connexion pour l'import des profils depuis un annuaire LDAP, et plus
particulièrement lors de la validation des paramètres, Sharepoint
tente de faire un import de test mais celui-ci échoue constamment
après une minute ou deux, avec comme message que la requête n'as
retourné aucun résultat. Ça fait une semaine que je piétine sur ça
sans trouver d'infos. J'ai l'impression de louper quelque chose mais
je ne sais pas quoi!


Regarder dans l'event log application de votre (vos) serveur SharePoint si
un ou plusieurs warning/erreurs sont liés à ce problème
Avant toute configuration, il est préférable d'être en possession des info
suivantes:
nom du serveur LDAP
Mécanisme(s) d'authentification supporté(s)
Information de type query: base du query, niveau, attributs...
Avant de paramétrer SharePoint, vous pouvez tester votre configuration en
utilisant un simple client LDAP, par ex ldp.exe

--
Marc
[Heureux celui qui a pu pénétrer les causes secrètes des choses]
Joël
Le #16939781
Merci de votre réponse rapide :)
Je devrais préciser autre chose : la VM que j'utilise est une VM de
démo fournie par Microsoft, et qui contient un contrôleur de domaine,
SQL2005 et MOSS 2007. L'AD est rempli par un domaine de démo d'une
entreprise fictive (Litware Inc. pour les connaisseurs) afin de
démontrer les fonctions de MOSS. Je pense que la VM n'est pas prévue
pour ce que je veux en faire mais on m'as dit que non :)
Je devrais peut-être faire une installation toute fraiche, ça me
faciliterait peut-être les choses.

Ensuite, vous pourrez lier des profils (dont les informations proviennent
d'un annuaire) aux identités dérivant de l'authentification.



pourriez-vous expliquer ceci?


Regarder dans l'event log application de votre (vos) serveur SharePoint s i
un ou plusieurs warning/erreurs sont liés à ce problème



J'obtiens une erreur récurrente :
Event Type: Error
Event Source: .NET Runtime
Event Category: None
Event ID: 0
Date: 06/08/2008
Time: 11:32:29
User: N/A
Computer: LITWAREDEMO
Description:
The description for Event ID ( 0 ) in Source ( .NET Runtime ) cannot
be found. The local computer may not have the necessary registry
information or message DLL files to display messages from a remote
computer. You may be able to use the /AUXSOURCE= flag to retrieve this
description; see Help and Support for details. The following
information is part of the event: Unable to open shim database version
registry key - v2.0.50727.00000.

Avant toute configuration, il est préférable d'être en possession d es info
suivantes



Je dispose de toutes les infos, j'utilise LDAP Browser pour explorer
mon LDAP. Aucun problème de ce côté là (à priori).

On 6 août, 12:31, "Lognoul, Marc (Private)" wrote:
Bonjour,

> Nous souhaitons déployer Sharepoint sur l'ensemble de l'entreprise
> mais l'import des profils depuis AD serait problématique puisque ce
> dernier ne dispose que de très peu d'infos. Aussi nous voudrions
> importer les profils depuis l'annuaire LDAP et (au mieux) utiliser
> ensuite l'AD pour l'authentification (j'ai des doutes sur la
> faisabilité d'une telle chose, est-ce que quelqu'un peut confirmer ou
> infirmer?).

Faisable oui, mais gardez à l'esprit que l'authentification et l'import de
profils sont deux choses différent, éventuellement liée.
Par ordre de priorité, il vous faut d'abord pouvoir authentifier et
autoriser
Ensuite, vous pourrez lier des profils (dont les informations proviennent
d'un annuaire) aux identités dérivant de l'authentification.

> Mais avant ça, sur ma VM de test, lorsque j'essaye de créer la
> connexion pour l'import des profils depuis un annuaire LDAP, et plus
> particulièrement lors de la validation des paramètres, Sharepoint
> tente de faire un import de test mais celui-ci échoue constamment
> après une minute ou deux, avec comme message que la requête n'as
> retourné aucun résultat. Ça fait une semaine que je piétine sur ça
> sans trouver d'infos. J'ai l'impression de louper quelque chose mais
> je ne sais pas quoi!

Regarder dans l'event log application de votre (vos) serveur SharePoint s i
un ou plusieurs warning/erreurs sont liés à ce problème
Avant toute configuration, il est préférable d'être en possession d es info
suivantes:
nom du serveur LDAP
Mécanisme(s) d'authentification supporté(s)
Information de type query: base du query, niveau, attributs...
Avant de paramétrer SharePoint, vous pouvez tester votre configuration en
utilisant un simple client LDAP, par ex ldp.exe

--
Marc
[Heureux celui qui a pu pénétrer les causes secrètes des choses]


Lognoul, Marc \(Private\)
Le #16939771
Bonjour,

"Joël" news:
Merci de votre réponse rapide :)
Je devrais préciser autre chose : la VM que j'utilise est une VM de
démo fournie par Microsoft, et qui contient un contrôleur de domaine,
SQL2005 et MOSS 2007. L'AD est rempli par un domaine de démo d'une
entreprise fictive (Litware Inc. pour les connaisseurs) afin de
démontrer les fonctions de MOSS. Je pense que la VM n'est pas prévue
pour ce que je veux en faire mais on m'as dit que non :)
Je devrais peut-être faire une installation toute fraiche, ça me
faciliterait peut-être les choses.


Je n'ai jamais utilisé ces VM préinstallée pour ce type de test.
Je n'ai aucune idée sur le fait qu'elles soient "bridées" ou non.

J'obtiens une erreur récurrente :
Event Type: Error
Event Source: .NET Runtime
Event Category: None
Event ID: 0
Date: 06/08/2008
Time: 11:32:29
User: N/A
Computer: LITWAREDEMO
Description:
The description for Event ID ( 0 ) in Source ( .NET Runtime ) cannot
be found. The local computer may not have the necessary registry
information or message DLL files to display messages from a remote
computer. You may be able to use the /AUXSOURCE= flag to retrieve this
description; see Help and Support for details. The following
information is part of the event: Unable to open shim database version
registry key - v2.0.50727.00000.


Pour corriger le problème, le correctif suivant est disponible:
http://support.microsoft.com/kb/918642/fr
Je doute toutefois qu'il soit la cause de votre problème.

--
Marc
[Heureux celui qui a pu pénétrer les causes secrètes des choses]
Joël
Le #16939761
En effet, ce n'est pas la source de mon problème.
Agacé par cette situation, j'ai décidé de prendre le taureau par les
cornes et j'ai écouté la conversation entre la vm et l'annuaire avec
Wireshark.

En résumé, après l'établissement de la connexion, voici ce que dise nt
les deux machines (j'ai remplacé le nom de la boîte par xxxxx partout
où il apparaissait):
VM :
0YcO

xobjectclass0+subschemaSubentrydsServiceNamenamingContextsdefaultNamingCont extschemaNamingContext
configurationNamingContextrootDomainNamingContextsupportedControlsupportedL DAPVersionsupportedLDAPPoliciessupported
SASLMechanismsdnsHostNameldapServiceNameserverNamesupportedCapabilities

Annuaire :
0tdl0f0
subschemaSubentry1cn=schema0:namingContexts1(&dc=intrannuaire,dc=fran cetelecom,dc=fr0supportedControl12.16.840.1.113730.3.4.22.16.840.1.113730 .3.4.32.16.840.1.113730.3.4.42.
16.840.1.113730.3.4.51.2.840.113556.1.4.4732.16.840.1.113730.3.4.92.16.840. 1.113730.3.4.162.16.840.1.113730.3.4.152.16.840.1.
113730.3.4.172.16.840.1.113730.3.4.191.3.6.1.4.1.42.2.27.9.5.22.16.840.1.11 3730.3.4.141.3.6.1.4.1.1466.29539.122.16.840.1.113730.3.4.
122.16.840.1.113730.3.4.182.16.840.1.113730.3.4.130supportedLDAPVersion1230 1supportedSASLMechanisms1EXTERNAL
DIGEST-MD5

VM :
^#EQ@;

u21APx0#`
DIGEST-MD5
je suppose qu'ils se mettent d'accord sur la méthode d'authentification



Annuaire :
0a
nonce="spmwoiiGu3/M0bwzQ6CbZtnLMnO/
Hv0JpyCmwgZswYk=",realm="dspdi511.toulouse.xxxxx.fr",qop="auth",maxbu fe535,charset=utf-8,algorithm=md5-
sess


VM :
03`)
DIGEST-MD5username="litwaredemo$",realm="litwareinc",nonce="spmwoiiGu 3/
M0bwzQ6CbZtnLMnO/Hv0JpyCmwgZswYk=",digest-uri="ldap/test-
import.toulouse.xxxxx.fr",cnonce="f08fa4b268c980bbdef16961860a4afc",nc= 00000001,response!ebcd9ce4d947c893829ef5088a02fd,qop=auth,charset=u tf-8
comme on peut le voir ici le domaine n'est pas le même que celui envoy é par l'annuaire. litwareinc est le domaine AD utilisé dans la VM.



Annuaire :
0MaG
(-1): generic failure: realm changed: authentication aborted
:'(



Ensuite, quelques données sont envoyées sans rien d'exploitable.
Sharepoint retente alors une authentification (un peu différente j'ai
l'impression) qui échoue également pour les mêmes raisons.
Je ne m'explique pas ce comportement, même si la VM n'appartient pas
au domaine de l'annuaire, je devrais être capable de dialoguer avec
lui.

On 7 août, 07:32, "Lognoul, Marc (Private)" wrote:
Bonjour,

"Joël"
news: > Merci de votre réponse rapide :)
> Je devrais préciser autre chose : la VM que j'utilise est une VM de
> démo fournie par Microsoft, et qui contient un contrôleur de domain e,
> SQL2005 et MOSS 2007. L'AD est rempli par un domaine de démo d'une
> entreprise fictive (Litware Inc. pour les connaisseurs) afin de
> démontrer les fonctions de MOSS. Je pense que la VM n'est pas prévu e
> pour ce que je veux en faire mais on m'as dit que non :)
> Je devrais peut-être faire une installation toute fraiche, ça me
> faciliterait peut-être les choses.

Je n'ai jamais utilisé ces VM préinstallée pour ce type de test.
Je n'ai aucune idée sur le fait qu'elles soient "bridées" ou non.



> J'obtiens une erreur récurrente :
> Event Type: Error
> Event Source: .NET Runtime
> Event Category: None
> Event ID: 0
> Date: 06/08/2008
> Time: 11:32:29
> User: N/A
> Computer: LITWAREDEMO
> Description:
> The description for Event ID ( 0 ) in Source ( .NET Runtime ) cannot
> be found. The local computer may not have the necessary registry
> information or message DLL files to display messages from a remote
> computer. You may be able to use the /AUXSOURCE= flag to retrieve thi s
> description; see Help and Support for details. The following
> information is part of the event: Unable to open shim database version
> registry key - v2.0.50727.00000.

Pour corriger le problème, le correctif suivant est disponible:http://s upport.microsoft.com/kb/918642/fr
Je doute toutefois qu'il soit la cause de votre problème.

--
Marc
[Heureux celui qui a pu pénétrer les causes secrètes des choses]


Publicité
Poster une réponse
Anonyme