impossible de s'identifier sur la console

Le
Bonjour.

J'ai upgradé les util-linux sur une Slackware 13, je suis passé de la
2.14.2 à la 2.18.

Depuis, lorsque je veux veux me connecter sur la console, j'obtiens 4
fois de suite « login incorrect » puis je reviens au prompt « login:
», sans avoir eu la possibilité de taper mon mot de passe cela se
produit comme utilisateur et comme root.

Quelqu'un a-t-il une solution ou une piste ????

Merci !

--
F. Delente
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Doug713705
Le #22718831
Le 25/10/2010 19:00 dans fr.comp.os.linux.configuration
nous expliquait:

J'ai upgradé les util-linux sur une Slackware 13, je suis passé de la
2.14.2 à la 2.18.

Depuis, lorsque je veux veux me connecter sur la console, j'obtiens 4
fois de suite « login incorrect » puis je reviens au prompt « login:
», sans avoir eu la possibilité de taper mon mot de passe... cela se
produit comme utilisateur et comme root.

Quelqu'un a-t-il une solution ou une piste ????




Aucune idée du pourquoi du comment mais une solution pourrait être :
- Lancer un DVD d'installation (appuyer sur Entrée après le boot du DVD)
- au prompt :
1 - Créer un point de montage (ex. mkdir /mon_system)

2 - Monter toutes les partition de ton système
ex. mount -t reiserfs /dev/sda1 /mon_system
mount -t reiserfs /dev/sda2 /mon_system/usr

3 - monter /proc (pas toujours utile mais ça peut servir)
ex. mount -t proc /mon_system/proc

4 - monter le DVD sous ton point de montage
ex. mount -t iso9660 /dev/sr0 /mon_system/mnt/cdrom

5 - chrooter pour ton système
ex. chroot /mon_system

6 - Virer le paquet foireux (en espérant que tu aies fait les choses
proprement)
ex. removepkg util-linux

7 - réinstaller le paquet qui va bien
installpkg /mnt/cdrom/chemin/vers/paquet/util-linux-xx.tgz

Un truc dans ce goût là.

Une question tout de même : Pourquoi avoir upgradé ?

Pour ton info la slackware current utilise util-linux-ng-2.17.2 et non
pas util-linux-2.18.

Bon courage.
--
@+
Doug - Linux user #307925 - Slackware64 roulaize ;-)
Usenet-fr ? Mais qu'est-ce que c'est ?
Pour en savoir plus : http://www.dougwise.org/wiki
Doug713705
Le #22719121
Le 25/10/2010 19:31 dans fr.comp.os.linux.configuration Doug713705 nous
expliquait:

1 - Créer un point de montage (ex. mkdir /mon_system)

2 - Monter toutes les partition de ton système
ex. mount -t reiserfs /dev/sda1 /mon_system
mount -t reiserfs /dev/sda2 /mon_system/usr

3 - monter /proc (pas toujours utile mais ça peut servir)
ex. mount -t proc /mon_system/proc

4 - monter le DVD sous ton point de montage
ex. mount -t iso9660 /dev/sr0 /mon_system/mnt/cdrom

5 - chrooter pour ton système
ex. chroot /mon_system

6 - Virer le paquet foireux (en espérant que tu aies fait les choses
proprement)
ex. removepkg util-linux

7 - réinstaller le paquet qui va bien
installpkg /mnt/cdrom/chemin/vers/paquet/util-linux-xx.tgz



J'ai oublié :

8 - quitter le chroot
9 - Démonter les partitions qui sont sous /mon_system
10 - rebooter

Juste au cas où ;-)
--
@+
Doug - Linux user #307925 - Slackware64 roulaize ;-)
Usenet-fr ? Mais qu'est-ce que c'est ?
Pour en savoir plus : http://www.dougwise.org/wiki
Le #22720391
Ok, merci. C'était un mélange entre le login de util-linux et celui de
sysvinit... idem pour shutdown d'ailleurs.

Merci du coup de main !

--
F. Delente
Publicité
Poster une réponse
Anonyme