impossible d'installer qgis sur sid

Le
Samy Mezani
Bonjour,

Je tourne en rond depuis 2 heures.
J'essaie d'installer qgis sur sid amd64 mais il y a un problème de
dépendances :
aptitude install qgis
[]
Les paquets suivants ont des dépendances non satisfaites :
qgis : Dépend: libgdal.so.1-1.11.2 which is a virtual package,
provided by:
- libgdal1h, mais il n'est pas installable.
libopenscenegraph100v5 : Dépend: libgdal.so.1-1.11.2 which is a
virtual package, provided by:
- libgdal1h, mais il n'est pas
installable.
libosgearth3 : Dépend: libgdal.so.1-1.11.2 which is a virtual package,
provided by:
- libgdal1h, mais il n'est pas installable.

Or ces dépendances à libgdal1h sont étranges car ces 3 paquets qgis,
libopenscenegraph100v5, libosgearth3 sont dépendants à libgdal1i d'après
https://packages.debian.org/

Je ne comprends plus rien.

Merci pour toute aide.

Samy
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
cedric rousselot
Le #26373573
Bonjour,
Si j'essaie d'installer qgis sur ma debian sid,
Il me propose ca comme dependances:
Les paquets supplémentaires suivants seront installés :
gdal-bin libarmadillo6 libarpack2 libdap17v5 libdapclient6v5
libdapserver7v5 libdrm-amdgpu1 libdrm-dev libepsilon1 libfcgi0ldbl
libfreexl1 libgdal1i libgeos-3.5.0 libgeos-c1v5 libgl1-mesa-dev
libglu1-mesa-dev libgraphicsmagick-q16-3 libhdf4-0-alt libhdf5-10
libhdf5-8 libjs-leaflet libkmlbase1 libkmlconvenience1 libkmldom1
libkmlengine1 libkmlregionator1 libkmlxsd1 liblwgeom-2.1.8 libminizip1
libnetcdf7 libodbc1 libogdi3.2 libopenscenegraph100v5 libopenthreads20
libosgearth3 libosgearthannotation3 libosgearthfeatures3 libosgearthqt3
libosgearthsymbology3 libosgearthutil3 libpq5 libproj9
libqgis-analysis2.8.3 libqgis-core2.8.3 libqgis-customwidgets
libqgis-gui2.8.3 libqgis-networkanalysis2.8.3 libqgis-server2.8.3
libqgispython2.8.3 libqscintilla2-12v5 libqscintilla2-l10n libqt4-dev
libqt4-dev-bin libqt4-opengl-dev libqt4-qt3support libqtwebkit-dev
libqwt6 libspatialindex4v5 libspatialite7 libsuperlu4 liburiparser1
libx11-xcb-dev libxcb-dri2-0-dev libxcb-dri3-dev libxcb-glx0-dev
libxcb-present-dev libxcb-randr0-dev libxcb-render0-dev
libxcb-shape0-dev libxcb-sync-dev libxcb-xfixes0-dev libxerces-c3.1
libxine2 libxine2-bin libxine2-doc libxine2-ffmpeg
libxine2-misc-plugins libxine2-plugins libxshmfence-dev libxxf86vm-dev
mesa-common-dev odbcinst odbcinst1debian2 osgearth-data proj-bin
proj-data python-cycler python-dateutil python-egenix-mxdatetime
python-egenix-mxtools python-gdal python-imaging python-jinja2
python-markupsafe python-matplotlib python-pil python-psycopg2
python-pygments python-pyparsing python-pyspatialite python-qgis
python-qgis-common python-qscintilla2 python-tz qgis-common
qgis-plugin-globe qgis-plugin-globe-common qgis-providers
qgis-providers-common qt4-designer qt4-linguist-tools qt4-qmake
x11proto-dri2-dev x11proto-gl-dev x11proto-xf86vidmode-dev

(donc installer le paquet libgdal1i).
De plus, si je fais "apt-cache search libgdal", apt me propose ces
paquets:
~/scripts$ apt-cache search libgdal
libgdal-dev - Geospatial Data Abstraction Library - Development files
libgdal-java - Java bindings to the Geospatial Data Abstraction Library
libgdal-perl - Perl bindings to the Geospatial Data Abstraction Library
libgdal1-dev - Geospatial Data Abstraction Library - Transitional
package libgdal1-1.11.2-grass - GRASS extension for the GDAL library
libgdal1i - Bibliothèque d'abstraction de données géospatial es
libgdal-doc - Documentation pour la bibliothèque d'abstraction de
données géospatiales (GDAL)

La solution a votre probleme serait peut-etre d'installer libgdal1i
avant de passer a l'installation de qgis.


Le Thu, 22 Oct 2015 15:31:24 +0200,
Samy Mezani
Bonjour,

Je tourne en rond depuis 2 heures.
J'essaie d'installer qgis sur sid amd64 mais il y a un problème de
dépendances :
aptitude install qgis
[...]
Les paquets suivants ont des dépendances non satisfaites :
qgis : Dépend: libgdal.so.1-1.11.2 which is a virtual package,
provided by:
- libgdal1h, mais il n'est pas installable.
libopenscenegraph100v5 : Dépend: libgdal.so.1-1.11.2 which is a
virtual package, provided by:
- libgdal1h, mais il n'est pas
installable.
libosgearth3 : Dépend: libgdal.so.1-1.11.2 which is a virtual
package, provided by:
- libgdal1h, mais il n'est pas installable.

Or ces dépendances à libgdal1h sont étranges car ces 3 paq uets qgis,
libopenscenegraph100v5, libosgearth3 sont dépendants à libgdal1i
d'après https://packages.debian.org/

Je ne comprends plus rien.

Merci pour toute aide.

Samy






--
Cordialement,
Cedric Rousselot
Service Helpdesk
N° regroupement: 01.73.50.34.90
AOMSL Samy
Le #26373594
Merci pour ta réponse,

Le 22/10/2015 15:53, cedric rousselot a écrit :
La solution a votre probleme serait peut-etre d'installer libgdal1i
avant de passer a l'installation de qgis.



J'y ai bien pensé mais même sentence, il veut libgdal1h. C'est quand
même incroyable ce truc.
Pour préciser, je n'ai que 'deb http://ftp.fr.debian.org/debian/ sid
main' dans mon sources.list

Samy
Bernard Schoenacker
Le #26373595
--MP_/Tf1yGwr.GcU44fhF_RrfqqB
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Content-Disposition: inline

Le Thu, 22 Oct 2015 17:11:23 +0200,
AOMSL Samy
Merci pour ta réponse,

Le 22/10/2015 15:53, cedric rousselot a écrit :
> La solution a votre probleme serait peut-etre d'installer libgdal1i
> avant de passer a l'installation de qgis.

J'y ai bien pensé mais même sentence, il veut libgdal1h. C'est quand
même incroyable ce truc.
Pour préciser, je n'ai que 'deb http://ftp.fr.debian.org/debian/ sid
main' dans mon sources.list

Samy




bonjour,

ci joint un sources.list

slt
bernard
--MP_/Tf1yGwr.GcU44fhF_RrfqqB
Content-Type: application/octet-stream; name=sources.list-stretch
Content-Transfer-Encoding: base64
Content-Disposition: attachment; filename=sources.list-stretch

ZGViIGh0dHA6Ly9mdHAuZnIuZGViaWFuLm9yZy9kZWJpYW4vIHNpZCBtYWluIG5vbi1mcmVlIGNv
bnRyaWIKCmRlYiBodHRwOi8vZnRwLmZyLmRlYmlhbi5vcmcvZGViaWFuLyBzdHJldGNoIG1haW4g
bm9uLWZyZWUgY29udHJpYgpkZWItc3JjIGh0dHA6Ly9mdHAuZnIuZGViaWFuLm9yZy9kZWJpYW4v
IHN0cmV0Y2ggbWFpbiBub24tZnJlZSBjb250cmliCgpkZWIgaHR0cDovL3NlY3VyaXR5LmRlYmlh
bi5vcmcvIHN0cmV0Y2gvdXBkYXRlcyBtYWluIGNvbnRyaWIgbm9uLWZyZWUKZGViLXNyYyBodHRw
Oi8vc2VjdXJpdHkuZGViaWFuLm9yZy8gc3RyZXRjaC91cGRhdGVzIG1haW4gY29udHJpYiBub24t
ZnJlZQoKIyBzdHJldGNoLXVwZGF0ZXMsIHByZXZpb3VzbHkga25vd24gYXMgJ3ZvbGF0aWxlJwoK
ZGViIGh0dHA6Ly9mdHAuZnIuZGViaWFuLm9yZy9kZWJpYW4vIHN0cmV0Y2gtdXBkYXRlcyBtYWlu
IGNvbnRyaWIgbm9uLWZyZWUKZGViLXNyYyBodHRwOi8vZnRwLmZyLmRlYmlhbi5vcmcvZGViaWFu
LyBzdHJldGNoLXVwZGF0ZXMgbWFpbiBjb250cmliIG5vbi1mcmVlCgojIHN0cmV0Y2gtYmFja3Bv
cnRzLCBwcmV2aW91c2x5IG9uIGJhY2twb3J0cy5kZWJpYW4ub3JnCgojIGRlYiBodHRwOi8vZnRw
LmZyLmRlYmlhbi5vcmcvZGViaWFuLyBzdHJldGNoLWJhY2twb3J0cyBtYWluIGNvbnRyaWIgbm9u
LWZyZWUKIyBkZWItc3JjIGh0dHA6Ly9mdHAuZnIuZGViaWFuLm9yZy9kZWJpYW4vIHN0cmV0Y2gt
YmFja3BvcnRzIG1haW4gY29udHJpYiBub24tZnJlZQo
--MP_/Tf1yGwr.GcU44fhF_RrfqqB
Content-Type: application/octet-stream; name=sources.list
Content-Transfer-Encoding: base64
Content-Disposition: attachment; filename=sources.list

IyAKCiMgZGViIGNkcm9tOltEZWJpYW4gR05VL0xpbnV4IDguMS4wIF9KZXNzaWVfIC0gT2ZmaWNp
YWwgaTM4NiB4ZmNlLUNEIEJpbmFyeS0xIDIwMTUwNjA2LTEzOjAwXS8gamVzc2llIG1haW4KCiMg
ZGViIGNkcm9tOltEZWJpYW4gR05VL0xpbnV4IDguMS4wIF9KZXNzaWVfIC0gT2ZmaWNpYWwgaTM4
NiB4ZmNlLUNEIEJpbmFyeS0xIDIwMTUwNjA2LTEzOjAwXS8gamVzc2llIG1haW4KCmRlYiBodHRw
Oi8vZnRwLmZyLmRlYmlhbi5vcmcvZGViaWFuLyBzaWQgbWFpbiBub24tZnJlZSBjb250cmliCgpk
ZWIgaHR0cDovL2Z0cC5mci5kZWJpYW4ub3JnL2RlYmlhbi8gamVzc2llIG1haW4gbm9uLWZyZWUg
Y29udHJpYgpkZWItc3JjIGh0dHA6Ly9mdHAuZnIuZGViaWFuLm9yZy9kZWJpYW4vIGplc3NpZSBt
YWluIG5vbi1mcmVlIGNvbnRyaWIKCmRlYiBodHRwOi8vc2VjdXJpdHkuZGViaWFuLm9yZy8gamVz
c2llL3VwZGF0ZXMgbWFpbiBjb250cmliIG5vbi1mcmVlCmRlYi1zcmMgaHR0cDovL3NlY3VyaXR5
LmRlYmlhbi5vcmcvIGplc3NpZS91cGRhdGVzIG1haW4gY29udHJpYiBub24tZnJlZQoKIyBqZXNz
aWUtdXBkYXRlcywgcHJldmlvdXNseSBrbm93biBhcyAndm9sYXRpbGUnCmRlYiBodHRwOi8vZnRw
LmZyLmRlYmlhbi5vcmcvZGViaWFuLyBqZXNzaWUtdXBkYXRlcyBtYWluIGNvbnRyaWIgbm9uLWZy
ZWUKZGViLXNyYyBodHRwOi8vZnRwLmZyLmRlYmlhbi5vcmcvZGViaWFuLyBqZXNzaWUtdXBkYXRl
cyBtYWluIGNvbnRyaWIgbm9uLWZyZWUKCiMgamVzc2llLWJhY2twb3J0cywgcHJldmlvdXNseSBv
biBiYWNrcG9ydHMuZGViaWFuLm9yZwpkZWIgaHR0cDovL2Z0cC5mci5kZWJpYW4ub3JnL2RlYmlh
bi8gamVzc2llLWJhY2twb3J0cyBtYWluIGNvbnRyaWIgbm9uLWZyZWUKZGViLXNyYyBodHRwOi8v
ZnRwLmZyLmRlYmlhbi5vcmcvZGViaWFuLyBqZXNzaWUtYmFja3BvcnRzIG1haW4gY29udHJpYiBu
b24tZnJlZQo
--MP_/Tf1yGwr.GcU44fhF_RrfqqB--
Samy Mezani
Le #26373599
Le 22/10/2015 17:33, Bernard Schoenacker a écrit :
ci joint un sources.list



Merci Bernard,

Mais j'en suis très content de mon sources.list, et je ne veux pas
d'autres dépôts pour l'instant ! ;-)
Avec le dépôt de qgis, le problème de dépendances était encore pire.

$ apt-cache policy qgis libopenscenegraph100v5 libosgearth3
qgis:
Installé : (aucun)
Candidat : 2.8.3+dfsg-3
Table de version :
2.8.3+dfsg-3 0
500 http://ftp.fr.debian.org/debian/ sid/main amd64 Packages
100 /var/lib/dpkg/status
libopenscenegraph100v5:
Installé : (aucun)
Candidat : 3.2.1-7
Table de version :
3.2.1-7 0
500 http://ftp.fr.debian.org/debian/ sid/main amd64 Packages
100 /var/lib/dpkg/status
libosgearth3:
Installé : (aucun)
Candidat : 2.5.0+dfsg-7
Table de version :
2.5.0+dfsg-7 0
500 http://ftp.fr.debian.org/debian/ sid/main amd64 Packages
100 /var/lib/dpkg/status

# aptitude install qgis
[...]
Les paquets suivants ont des dépendances non satisfaites :
qgis : Dépend: libgdal.so.1-1.11.2 which is a virtual package,
provided by:
- libgdal1h, mais il n'est pas installable.
libopenscenegraph100v5 : Dépend: libgdal.so.1-1.11.2 which is a
virtual package, provided by:
- libgdal1h, mais il n'est pas
installable.
libosgearth3 : Dépend: libgdal.so.1-1.11.2 which is a virtual package,
provided by:
- libgdal1h, mais il n'est pas installable.

Les actions suivantes permettront de résoudre ces dépendances :

Conserver les paquets suivants dans leur version actuelle :
1) libopenscenegraph100v5 [Non installé]
2) libosgearth3 [Non installé]
3) libosgearthannotation3 [Non installé]
4) libosgearthfeatures3 [Non installé]
5) libosgearthqt3 [Non installé]
6) libosgearthsymbology3 [Non installé]
7) libosgearthutil3 [Non installé]
8) qgis [Non installé]
9) qgis-plugin-globe [Non installé]

Accepter cette solution ? [Y/n/q/?] n

*** Aucune autre solution disponible ***
[...]

$ aptitude show libgdal.so.1-1.11.2
Pas de version courante ou candidate trouvée pour libgdal.so.1-1.11.2
Paquet : libgdal.so.1-1.11.2
État: n'est pas un paquet réel
Fourni par : libgdal1h (1.11.2+dfsg-1~exp3)

C'est là que ça coince, ce paquet virtuel devrait dépendre de libgdal1i.
Comment effacer cette information ou le forcer à mettre à jour les
informations ? Un '# aptitude update' ne le fait pas ?

Samy
Samy Mezani
Le #26373713
Bonjour,

Le 22/10/2015 17:53, Samy Mezani a écrit :
$ aptitude show libgdal.so.1-1.11.2
Pas de version courante ou candidate trouvée pour libgdal.so.1-1.11.2
Paquet : libgdal.so.1-1.11.2
État: n'est pas un paquet réel
Fourni par : libgdal1h (1.11.2+dfsg-1~exp3)

C'est là que ça coince, ce paquet virtuel devrait dépendre de libgdal1i.
Comment effacer cette information ou le forcer à mettre à jour les
informations ? Un '# aptitude update' ne le fait pas ?



Une petite idée pour me sortir de cette impasse ?

Samy
Publicité
Poster une réponse
Anonyme