Incohérence de apt-listbugs

Le
Laurent Lemoine
--00504502cfb0c411db0480f428a4
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Bonjour à tous,

Je suis tombé sur une incohérence de apt-listbugs que je ne m'explique
pas

A l'instalation d'un paquet "bogué" (grub-pc par exemple) :
Lorsque l'on choisi "y" (qui est censé continuer l'installation MAIS SANS
IGNORER LES BOGUES) il installe le paquet bogué
*
Code:*
Êtes-vous certain de vouloir installer/mettre à jour les paquets ci-des=
sus ?
[Y/n/?/] y
Préconfiguration des paquets
(Lecture de la base de données 194881 fichiers et répertoires déj=
à
installés.)
Préparation du remplacement de grub-pc 1.98~20100115-1 (en utilisant
/grub-pc_1.98~20100128-1.2_amd64.deb)
Dépaquetage de la mise à jour de grub-pc
Préparation du remplacement de grub-common 1.98~20100115-1 (en utilisant
/grub-common_1.98~20100128-1.2_amd64.deb)

C'est le même résultat que si l'on choisi "a"*
Code:*
Êtes-vous certain de vouloir installer/mettre à jour les paquets ci-des=
sus ?
[Y/n/?/] a
Préconfiguration des paquets
(Lecture de la base de données 194881 fichiers et répertoires déj=
à
installés.)
Préparation du remplacement de grub-pc 1.98~20100115-1 (en utilisant
/grub-pc_1.98~20100128-1.2_amd64.deb)
Dépaquetage de la mise à jour de grub-pc
Préparation du remplacement de grub-common 1.98~20100115-1 (en utilisant
/grub-common_1.98~20100128-1.2_amd64.deb)

Je ne vois pas de logique à ça ! Est-ce un bug ? Une erreur de traducti=
on ?

Merci pour vos réponses

--00504502cfb0c411db0480f428a4
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

<meta http-equiv="content-type" content="text/html; charset=utf-8"><s=
pan class="Apple-style-span" style="font-family: tahoma, sans-serif; fo=
nt-size: 16px; color: rgb(51, 51, 51); -webkit-border-horizontal-spacing: 5=
px; -webkit-border-vertical-spacing: 5px; ">Bonjour à tous,</span><div>
<span class="Apple-style-span" style="font-family: tahoma, sans-serif; =
font-size: 16px; color: rgb(51, 51, 51); -webkit-border-horizontal-spacing:=
5px; -webkit-border-vertical-spacing: 5px; "><br>Je suis tombé sur une i=
ncohérence de apt-listbugs que je ne m&#39;explique pas<br>
<br>A l&#39;instalation d&#39;un paquet &quot;bogué&quot; (grub-pc par ex=
emple) :<br>Lorsque l&#39;on choisi &quot;y&quot; (qui est <span style==
"color: rgb(255, 0, 0); ">censé</span> continuer l&#39;installation MAI=
S <span style="color: rgb(255, 0, 0); ">SANS IGNORER LES BOGUES</span>)=
il installe le paquet bogué<br>
<div class="codetitle"><strong><br>Code:</strong></div><div class="code=
content">Êtes-vous certain de vouloir installer/mettre à jour les paque=
ts ci-dessus ? [Y/n/?/]  y<br>Préconfiguration des paquets<br>(=
Lecture de la base de données 194881 fichiers et répertoires déj=
à installés.)<br>
Préparation du remplacement de grub-pc 1.98~20100115-1 (en utilisant /=
grub-pc_1.98~20100128-1.2_amd64.deb) <br>Dépaquetage de la mise à jo=
ur de grub-pc <br>Préparation du remplacement de grub-common 1.98~2010=
0115-1 (en utilisant /grub-common_1.98~20100128-1.2_amd64.deb) </div>
<br>C&#39;est le même résultat que si l&#39;on choisi &quot;a&quot;<str=
ong><br>Code:</strong><div class="codecontent">Êtes-vous certain de vou=
loir installer/mettre à jour les paquets ci-dessus ? [Y/n/?/]  a<b=
r>Préconfiguration des paquets<br>
(Lecture de la base de données 194881 fichiers et répertoires déj=
à installés.)<br>Préparation du remplacement de grub-pc 1.98~20100115=
-1 (en utilisant /grub-pc_1.98~20100128-1.2_amd64.deb) <br>Dépaquet=
age de la mise à jour de grub-pc <br>
Préparation du remplacement de grub-common 1.98~20100115-1 (en utilisant =
/grub-common_1.98~20100128-1.2_amd64.deb) </div><br>Je ne vois pas de=
logique à ça ! Est-ce un bug ? Une erreur de traduction ?<br><br>Merci=
pour vos réponses</span></div>

--00504502cfb0c411db0480f428a4--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/e05fc3f81003032300q485bbc94vd65814bc2ff8873d@mail.gmail.com
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Aurelien
Le #21311401
On Thu, Mar 04, 2010 at 10:00:51AM +0300, Laurent Lemoine wrote :
Bonjour à tous,

Je suis tombé sur une incohérence de apt-listbugs que je ne m'explique
pas...

A l'instalation d'un paquet "bogué" (grub-pc par exemple) :
Lorsque l'on choisi "y" (qui est censé continuer l'installation MAIS SANS
IGNORER LES BOGUES) il installe le paquet bogué...
*
Code:*
Êtes-vous certain de vouloir installer/mettre à jour les paquets ci-dessus ?
[Y/n/?/...] y
Préconfiguration des paquets...
(Lecture de la base de données... 194881 fichiers et répertoires déjà
installés.)
Préparation du remplacement de grub-pc 1.98~20100115-1 (en utilisant
.../grub-pc_1.98~20100128-1.2_amd64.deb) ...
Dépaquetage de la mise à jour de grub-pc ...
Préparation du remplacement de grub-common 1.98~20100115-1 (en utilisant
.../grub-common_1.98~20100128-1.2_amd64.deb) ...

C'est le même résultat que si l'on choisi "a"*
Code:*
Êtes-vous certain de vouloir installer/mettre à jour les paquets ci-dessus ?
[Y/n/?/...] a
Préconfiguration des paquets...
(Lecture de la base de données... 194881 fichiers et répertoires déjà
installés.)
Préparation du remplacement de grub-pc 1.98~20100115-1 (en utilisant
.../grub-pc_1.98~20100128-1.2_amd64.deb) ...
Dépaquetage de la mise à jour de grub-pc ...
Préparation du remplacement de grub-common 1.98~20100115-1 (en utilisant
.../grub-common_1.98~20100128-1.2_amd64.deb) ...

Je ne vois pas de logique à ça ! Est-ce un bug ? Une erreur de traduction ?

Merci pour vos réponses



J'ai en effet remarqué ça sur grub et apt sur le dernière upgrade de
squeeze. J'ai eu beau "pinner" les deux paquets, ils apparaissaient dans
l'install à chaque fois. Du coup, j'ai fait l'upgrade ... à la main !

--
Aurélien

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Laurent Lemoine
Le #21311561
--00148531b7e3455e8a0480f54bfe
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Le 4 mars 2010 10:58, Aurelien
On Thu, Mar 04, 2010 at 10:00:51AM +0300, Laurent Lemoine wrote :
> Bonjour à tous,
>
> Je suis tombé sur une incohérence de apt-listbugs que je ne m'expli que
> pas...
>
> A l'instalation d'un paquet "bogué" (grub-pc par exemple) :
> Lorsque l'on choisi "y" (qui est censé continuer l'installation MAIS SANS
> IGNORER LES BOGUES) il installe le paquet bogué...
> *
> Code:*
> Êtes-vous certain de vouloir installer/mettre à jour les paquets
ci-dessus ?
> [Y/n/?/...] y
> Préconfiguration des paquets...
> (Lecture de la base de données... 194881 fichiers et répertoires d éjà
> installés.)
> Préparation du remplacement de grub-pc 1.98~20100115-1 (en utilisant
> .../grub-pc_1.98~20100128-1.2_amd64.deb) ...
> Dépaquetage de la mise à jour de grub-pc ...
> Préparation du remplacement de grub-common 1.98~20100115-1 (en utilis ant
> .../grub-common_1.98~20100128-1.2_amd64.deb) ...
>
> C'est le même résultat que si l'on choisi "a"*
> Code:*
> Êtes-vous certain de vouloir installer/mettre à jour les paquets
ci-dessus ?
> [Y/n/?/...] a
> Préconfiguration des paquets...
> (Lecture de la base de données... 194881 fichiers et répertoires d éjà
> installés.)
> Préparation du remplacement de grub-pc 1.98~20100115-1 (en utilisant
> .../grub-pc_1.98~20100128-1.2_amd64.deb) ...
> Dépaquetage de la mise à jour de grub-pc ...
> Préparation du remplacement de grub-common 1.98~20100115-1 (en utilis ant
> .../grub-common_1.98~20100128-1.2_amd64.deb) ...
>
> Je ne vois pas de logique à ça ! Est-ce un bug ? Une erreur de trad uction
?
>
> Merci pour vos réponses

J'ai en effet remarqué ça sur grub et apt sur le dernière upgrade d e
squeeze. J'ai eu beau "pinner" les deux paquets, ils apparaissaient dans
l'install à chaque fois. Du coup, j'ai fait l'upgrade ... à la main !

--
Aurélien

--




Salut,
Merci pour ta réponse,
Ma question ne porte pas sur le "marquage" qui fonctionne bien (réponse " p"
à la question de apt-listbugs) mais plutôt sur le fait que choisir "y" ou
"a" donne le même résultat... Il installe le paquet bogué...

--
Laurent
--

--00148531b7e3455e8a0480f54bfe
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

On Thu, Mar 04, 2010 at 10:00:51AM +0300, Laurent Lemoine wrote :<br>
<div><div></div><div class="h5">&gt; Bonjour à tous,<br>
&gt;<br>
&gt; Je suis tombé sur une incohérence de apt-listbugs que je ne m&#39; explique<br>
&gt; pas...<br>
&gt;<br>
&gt; A l&#39;instalation d&#39;un paquet &quot;bogué&quot; (grub-pc par e xemple) :<br>
&gt; Lorsque l&#39;on choisi &quot;y&quot; (qui est censé continuer l&#39 ;installation MAIS SANS<br>
&gt; IGNORER LES BOGUES) il installe le paquet bogué...<br>
&gt; *<br>
&gt; Code:*<br>
&gt; Êtes-vous certain de vouloir installer/mettre à jour les paquets c i-dessus ?<br>
&gt; [Y/n/?/...]  y<br>
&gt; Préconfiguration des paquets...<br>
&gt; (Lecture de la base de données... 194881 fichiers et répertoires d éjà<br>
&gt; installés.)<br>
&gt; Préparation du remplacement de grub-pc 1.98~20100115-1 (en utilisant <br>
&gt; .../grub-pc_1.98~20100128-1.2_amd64.deb) ...<br>
&gt; Dépaquetage de la mise à jour de grub-pc ...<br>
&gt; Préparation du remplacement de grub-common 1.98~20100115-1 (en utili sant<br>
&gt; .../grub-common_1.98~20100128-1.2_amd64.deb) ...<br>
&gt;<br>
&gt; C&#39;est le même résultat que si l&#39;on choisi &quot;a&quot;*<b r>
&gt; Code:*<br>
&gt; Êtes-vous certain de vouloir installer/mettre à jour les paquets c i-dessus ?<br>
&gt; [Y/n/?/...]  a<br>
&gt; Préconfiguration des paquets...<br>
&gt; (Lecture de la base de données... 194881 fichiers et répertoires d éjà<br>
&gt; installés.)<br>
&gt; Préparation du remplacement de grub-pc 1.98~20100115-1 (en utilisant <br>
&gt; .../grub-pc_1.98~20100128-1.2_amd64.deb) ...<br>
&gt; Dépaquetage de la mise à jour de grub-pc ...<br>
&gt; Préparation du remplacement de grub-common 1.98~20100115-1 (en utili sant<br>
&gt; .../grub-common_1.98~20100128-1.2_amd64.deb) ...<br>
&gt;<br>
&gt; Je ne vois pas de logique à ça ! Est-ce un bug ? Une erreur de tra duction ?<br>
&gt;<br>
&gt; Merci pour vos réponses<br>
<br>
</div></div>J&#39;ai en effet remarqué ça sur grub et apt sur le derni ère upgrade de<br>
squeeze. J&#39;ai eu beau &quot;pinner&quot; les deux paquets, ils apparais saient dans<br>
l&#39;install à chaque fois. Du coup, j&#39;ai fait l&#39;upgrade ... à la main !<br>
<br>
--<br>
Aurélien<br>
<font color="#888888"><br>
-- <div><br></div><div>--</div><div>Laurent</div><div>--</div></div>

--00148531b7e3455e8a0480f54bfe--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
vanicat
Le #21311541
Laurent Lemoine
Bonjour à tous,

Je suis tombé sur une incohérence de apt-listbugs que je ne m'explique
pas...

A l'instalation d'un paquet "bogué" (grub-pc par exemple) :
Lorsque l'on choisi "y" (qui est censé continuer l'installation MAIS SANS
IGNORER LES BOGUES) il installe le paquet bogué...



Ben, non....

*
Code:*
Êtes-vous certain de vouloir installer/mettre à jour les paquets ci-dessus ?
[Y/n/?/...] y



Tu lui a dis que oui, tu voulais installer les paquets ci-dessus, donc
oui il les installe. Il n'y a ni bug ni problème de traduction....

Le fait que les bugs soit ignoré (avec a) indique juste qu'il ne les
considérera plus lors des futures mis à jour.

Ce que tu veux faire est visiblement 'p' (ce qui interdit
l'installation des paquets défectueux, mais nécessite de relancer apt

--
Rémi Vanicat

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Laurent Lemoine
Le #21311701
--0014853198f23a5f3d0480f5c0db
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Le 4 mars 2010 11:24, Rémi Vanicat
Laurent Lemoine
> Bonjour à tous,
>
> Je suis tombé sur une incohérence de apt-listbugs que je ne m'expli que
> pas...
>
> A l'instalation d'un paquet "bogué" (grub-pc par exemple) :
> Lorsque l'on choisi "y" (qui est censé continuer l'installation MAIS SANS
> IGNORER LES BOGUES) il installe le paquet bogué...

Ben, non....

> *
> Code:*
> Êtes-vous certain de vouloir installer/mettre à jour les paquets
ci-dessus ?
> [Y/n/?/...] y

Tu lui a dis que oui, tu voulais installer les paquets ci-dessus, donc
oui il les installe. Il n'y a ni bug ni problème de traduction....

Le fait que les bugs soit ignoré (avec a) indique juste qu'il ne les
considérera plus lors des futures mis à jour.

Ce que tu veux faire est visiblement 'p' (ce qui interdit
l'installation des paquets défectueux, mais nécessite de relancer apt

--
Rémi Vanicat

--




Salut,
Merci pour ta réponse.

En fait je ne vois pas trop l'intérêt d'avoir les options "y" et "a" .. .

Si je choisi "y" il installe sans ignorer le bug.

y - continuer l'installation avec APT, mais sans ignorer les bogues.

Si je choisi "a" il installe en ignorant le bug.

a - continuer l'installation avec APT en ignorant les bogues ci-dessus .


Donc "a" ou "y" revient au même non ? Le paquet bogué est installé. Q u'il
l'ignore plus tard apporte quoi, puisqu'il est installé ?
Vous allez trouver que je chipote (un peu c'est vrai) mais j'aime bien
comprendre...

--
Laurent
--

--0014853198f23a5f3d0480f5c0db
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

<br>
&gt; Bonjour à tous,<br>
&gt;<br>
&gt; Je suis tombé sur une incohérence de apt-listbugs que je ne m&#39; explique<br>
&gt; pas...<br>
&gt;<br>
&gt; A l&#39;instalation d&#39;un paquet &quot;bogué&quot; (grub-pc par e xemple) :<br>
&gt; Lorsque l&#39;on choisi &quot;y&quot; (qui est censé continuer l&#39 ;installation MAIS SANS<br>
&gt; IGNORER LES BOGUES) il installe le paquet bogué...<br>
<br>
<div class="im"><br>
&gt; *<br>
&gt; Code:*<br>
&gt; Êtes-vous certain de vouloir installer/mettre à jour les paquets c i-dessus ?<br>
&gt; [Y/n/?/...]  y<br>
<br>
</div>Tu lui a dis que oui, tu voulais installer les paquets ci-dessus, don c<br>
oui il les installe. Il n&#39;y a ni bug ni problème de traduction....<br >
<br>
Le fait que les bugs soit ignoré (avec a) indique juste qu&#39;il ne les< br>
considérera plus lors des futures mis à jour.<br>
<br>
Ce que tu veux faire est visiblement &#39;p&#39; (ce qui interdit<br>
l&#39;installation des paquets défectueux, mais nécessite de relancer a pt<br>
<br>
--<br>
Rémi Vanicat<br>
<div class="im"><br>
-- y - continuer l&#39;installation avec APT, mais sans ignorer les bogues . a - continuer l&#39;installation avec APT en ignorant les bogues ci-de ssus.
--0014853198f23a5f3d0480f5c0db--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
vanicat
Le #21311801
Laurent Lemoine

[...]

Salut,
Merci pour ta réponse.

En fait je ne vois pas trop l'intérêt d'avoir les options "y" et "a" ...

Si je choisi "y" il installe sans ignorer le bug.

y - continuer l'installation avec APT, mais sans ignorer les bogues.

Si je choisi "a" il installe en ignorant le bug.

a - continuer l'installation avec APT en ignorant les bogues ci-dessus.


Donc "a" ou "y" revient au même non ? Le paquet bogué est installé.



A vrai dire, je n'ai jamais utilisé a, donc je ne sais pas vraiment mais:

Qu'il l'ignore plus tard apporte quoi, puisqu'il est installé ?



Lors d'une future mis à jour, le bugs pourrait ne toujours pas être
résolue, au quel cas il est possible que apt-listbugs indique à nouveau
le bug. Ou alors le bug pourrait avoir été fermé, et apt-listbugs
indiqué que le bug est fermé (done). Dans les deux cas, si apt-listbugs
ignore le bugs, il ne va pas le réindiqué.

Bon, j'ai rien trouvé dans la documentation, et je ne suis donc pas sur
de la réponse exacte.

--
Rémi Vanicat

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
vanicat
Le #21311871
(Rémi Vanicat) writes:

Laurent Lemoine


[...]


Donc "a" ou "y" revient au même non ? Le paquet bogué est installé.



A vrai dire, je n'ai jamais utilisé a, donc je ne sais pas vraiment
mais:



j'ai trouvé:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bugH4408
l'idée est que lorsque vous installez un paquet bugué, si ça ce passe
vraiment trop mal, vous pourriez reinstaller une version plus vieille.

Mais alors, lors de la re-mis à jours, vous voulez revoir le bugs en
question.

Toutefois, il y a des bugs que l'on peut ignorer sans hésitation (comme
par exemple les bugs "should not go to testing"), au quel cas, on peu
utiliser i pour les ignorer manuellement.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Aurelien
Le #21316421
On Thu, Mar 04, 2010 at 09:24:31AM +0100, Rémi Vanicat wrote :
Laurent Lemoine
> Bonjour à tous,
>
> Je suis tombé sur une incohérence de apt-listbugs que je ne m'explique
> pas...
>
> A l'instalation d'un paquet "bogué" (grub-pc par exemple) :
> Lorsque l'on choisi "y" (qui est censé continuer l'installation MAIS SANS
> IGNORER LES BOGUES) il installe le paquet bogué...

Ben, non....

> *
> Code:*
> Êtes-vous certain de vouloir installer/mettre à jour les paquets ci-dessus ?
> [Y/n/?/...] y

Tu lui a dis que oui, tu voulais installer les paquets ci-dessus, donc
oui il les installe. Il n'y a ni bug ni problème de traduction....

Le fait que les bugs soit ignoré (avec a) indique juste qu'il ne les
considérera plus lors des futures mis à jour.

Ce que tu veux faire est visiblement 'p' (ce qui interdit
l'installation des paquets défectueux, mais nécessite de relancer apt



En l'occurence (bien que je n'ai pas cherché plus avant pourquoi), le
pin n'a pas fonctionné sur ces deux paquets dans mon dernier upgrade !


--
Aurélien

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme