incrémentation automatique

Le
Manu
Bonsoir,

Je souhaiterais sans VBA avoir dans ma col A une suite 1 ; 2 ;3 . jusqu'à
ce qu'il y a quelque chose de taper dans la col B. Mais je veux surtout que
cette col A se mette automatiquement à jour dès que j'insèrerais quelque
part une ligne.

Merci

Manu



Ce courrier électronique ne contient aucun virus ou logiciel malveillant parce que la protection avast! Antivirus est active.
http://www.avast.com
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
gaetan.goulet
Le #26306649
Le mercredi 3 septembre 2014 11:56:16 UTC-4, Manu a écrit :
Bonsoir,



Je souhaiterais sans VBA avoir dans ma col A une suite 1 ; 2 ;3 .... jusq u'à

ce qu'il y a quelque chose de taper dans la col B. Mais je veux surtout q ue

cette col A se mette automatiquement à jour dès que j'insérerais qu elque

part une ligne.





Hyp.: A10=1

Alors en A11, inscris =SI(B11="","",A10+1) et tu copies cette formule de A12 jusqu'à la cellule désirée. Au besoin remplace , par ; dans l a formule.
isabelle
Le #26306728
bonjour,

en cellule A1
=SI(B1<>"";Ligne();"")

isabelle


Le 2014-09-03 11:56, Manu a écrit :
Bonsoir,

Je souhaiterais sans VBA avoir dans ma col A une suite 1 ; 2 ;3 .... jusqu'à ce
qu'il y a quelque chose de taper dans la col B. Mais je veux surtout que cette
col A se mette automatiquement à jour dès que j'insèrerais quelque part une ligne.

Merci

Manu

---
Ce courrier électronique ne contient aucun virus ou logiciel malveillant parce
que la protection avast! Antivirus est active.
http://www.avast.com

Manu
Le #26306762
Merci, je garde la solution d'Isabelle qui à l'avantage de ne tirer la
formule que sur une cellule..

Manu

"isabelle" a écrit dans le message de groupe de discussion :
lu7t62$bp4$

bonjour,

en cellule A1
=SI(B1<>"";Ligne();"")

isabelle


Le 2014-09-03 11:56, Manu a écrit :
Bonsoir,

Je souhaiterais sans VBA avoir dans ma col A une suite 1 ; 2 ;3 ....
jusqu'à ce
qu'il y a quelque chose de taper dans la col B. Mais je veux surtout que
cette
col A se mette automatiquement à jour dès que j'insèrerais quelque part
une ligne.

Merci

Manu

---
Ce courrier électronique ne contient aucun virus ou logiciel malveillant
parce
que la protection avast! Antivirus est active.
http://www.avast.com





---
Ce courrier électronique ne contient aucun virus ou logiciel malveillant parce que la protection avast! Antivirus est active.
http://www.avast.com
andre
Le #26307286
Bonsoir
un autre exemple avec un peu de retard
=SI($B3<>"";NBVAL(INDIRECT("$B$3:B"&LIGNE($A3)));"")
un fichier en pj
http://cjoint.com/?DIhtxUTX4uy

--
André
Publicité
Poster une réponse
Anonyme