Incrémentation à chaque changement de nom dans une colonne?

Le
ericop
Bonjour,

Pour plus de clarté voici un fichier excel expliquant de façon simple mon
problème :

http://cjoint.com/?glkNJx8tXm

La colonne A est triée par ordre croissant. Je souhaite ajouter par calcul
automatique la colonne rang (incrémentation simple)
(a chaque fois que la ligne objet change de nom, il y a une nouvelle
incrémentation)

nb: En fait j'ai de plusieurs milliers de ligne à incrémenter.

Merci d'avance pour toute aide,
Eric
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Haïku
Le #4578721
Salut,

Essai comme ceci
en C2 de ton exemple tu mets: =SI(A1<>A2;1;C1+1)
et tu copies/colles jusqu'en bas

++


Bonjour,

Pour plus de clarté voici un fichier excel expliquant de façon simple
mon problème :

http://cjoint.com/?glkNJx8tXm

La colonne A est triée par ordre croissant. Je souhaite ajouter par
calcul automatique la colonne rang (incrémentation simple)
(a chaque fois que la ligne objet change de nom, il y a une nouvelle
incrémentation)

nb: En fait j'ai de plusieurs milliers de ligne à incrémenter.

Merci d'avance pour toute aide,
Eric




AV
Le #4578711
Avec plages nommées
En C2 :
=1+SOMMEPROD((Objet¢)*(Prix<B2))

Sélection C2 et double-clic sur la croix de recopie (bors inf/droit) si
t'as la flemme de "tirer" vers le bas

PS : On peut automatiser
AV
AV
Le #4578661
=1+SOMMEPROD((Objet¢)*(Prix<B2))


Hum...hum...
En relisant, je m'aperçois que le rang n'a pas de rapport avec le prix....

Pour un résultat insensible à l'ordre en colonne A (mais pas de vides)
En C2 et recopie >> Cxxx
=SOMMEPROD(($A$2:$A2¢)*1)

AV

FFO
Le #4578631
Salut à toi
Dans le VBA de la feuille tu mets ce code :

Private Sub Worksheet_Change(ByVal Target As Range)
If Target.Column = 1 Then
n = 1
For Each c In Worksheets("Feuil1").Range([A2], [A65535].End(xlUp))
c.Offset(0, 2) = n
n = n + 1
If c <> c.Offset(1, 0) Then
n = 1
End If
Next
End If
End Sub

Celà devrait convenir
Dis moi !!!!


Bonjour,

Pour plus de clarté voici un fichier excel expliquant de façon simple mon
problème :

http://cjoint.com/?glkNJx8tXm

La colonne A est triée par ordre croissant. Je souhaite ajouter par calcul
automatique la colonne rang (incrémentation simple)
(a chaque fois que la ligne objet change de nom, il y a une nouvelle
incrémentation)

nb: En fait j'ai de plusieurs milliers de ligne à incrémenter.

Merci d'avance pour toute aide,
Eric





ericop
Le #4578611
Whaou! Fantastique! ;) Merci beaucoup à tous les deux. ;))
Bonne journée,
Eric
Publicité
Poster une réponse
Anonyme