Index et Equiv --- Aidez-moi SVP

Le
Sunburn
Bonjour,
j'ai du mal avec index et equiv voici mon tableau :

A !! B
11 !! formule !! 701
12 !! formule !! 718
13 !! formule !! 702

!! O !! P
26 !! 701 !! texte
27 !! 702 !! texte
28 !! 703 !! texte

en fait, mon tableau de données de bases est en 026 à P35
ma colonne B comporte des nombres, à au moins 3 chiffres.

Donc, je veux qu'en colonne A, il me donne le texte de la colonne P, en
fonction des 3 premiers caratères de la colonne B sont égaux à la colonne O.
Actuellement, j'ai ça, mais ça plante:
=INDEX(O26:P35;EQUIV(GAUCHE(D13;3);O26:P35;0);2)

Merci de votre aide.
YANN
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sunburn
Le #18164001
bon, j'ai ça qui fonctionne, mais si j'ai que 3 chiffre en B :
=SI(D16="";"";INDEX($O$26:$P$35;EQUIV(D16;INDEX($O$26:$P$35;;1);0);2))

j'ai essayé ça, pour mon pb de 3 chiffres, mais ça plante
=SI(D17="";"";INDEX($O$26:$P$35;EQUIV(GAUCHE(D17;3);INDEX($O$26:$P$35;;1);0);2))

Merci de votre aide, mon guahce() n'est pas accepter !!!

YANN
Sunburn
Le #18164191
Re,
décidemment ...
j'ai trouvé ça en formule matricielle, quelqu'un peut me dire si c'est le
mieux ???

{=SI(D17="";"";INDEX($O$26:$P$35;EQUIV(GAUCHE($D17;3)*1;INDEX($O$26:$P$35;;1);0);2))}

Merci. YANN
Daniel.C
Le #18164311
Bonjour.
Si la colonne O est triée et que la colonne D est numérique :
=RECHERCHEV(D18;O26:P28;2;1)
Sinon, matricielle :
=INDEX(P26:P28;EQUIV(VRAI();(GAUCHE(D18;3)*1=O26:O28);0))
Cordialement.
Daniel

Re,
décidemment ...
j'ai trouvé ça en formule matricielle, quelqu'un peut me dire si c'est le
mieux ???

{=SI(D17="";"";INDEX($O$26:$P$35;EQUIV(GAUCHE($D17;3)*1;INDEX($O$26:$P$35;;1);0);2))}

Merci. YANN


ChristianM
Le #18164411
Bonjour,
Chez moi çà marche avec :
=INDEX($O$26:$P$35;EQUIV(GAUCHE(B11;3)*1;$O$26:$O$35;0);2)
voir classeur sur
http://cjoint.com/?mrrlFOxc2g

est ce bon pour toi ?
--
ChristianM


"Sunburn" news:
Bonjour,
j'ai du mal avec index et equiv... voici mon tableau :

A !! B
11 !! formule !! 701
12 !! formule !! 718
13 !! formule !! 702

!! O !! P
26 !! 701 !! texte
27 !! 702 !! texte
28 !! 703 !! texte

en fait, mon tableau de données de bases est en 026 à P35
ma colonne B comporte des nombres, à au moins 3 chiffres.

Donc, je veux qu'en colonne A, il me donne le texte de la colonne P, en
fonction des 3 premiers caratères de la colonne B sont égaux à la colonne
O.
Actuellement, j'ai ça, mais ça plante:
=INDEX(O26:P35;EQUIV(GAUCHE(D13;3);O26:P35;0);2)

Merci de votre aide.
YANN


Publicité
Poster une réponse
Anonyme