Index Equiv

Le
Bruno
Bonsoir,
J'ai un tableau construit de la façon suivante ;
Si K >=5 alors 0.15
si k <5 et > alors 0.25
si k <10 et > alors 0.45
si k <15 et >% alors 0.90
si k <25 et >5 alors 1
si k <35 et >P alors 1
si k <50 et >p alors 1
si k <70 et >0 alors 1

En fonction de K, je voudrais renvoyer dans une cellule x le chiffre
adéquat. K est un ratio entre deux valeurs avec deux ou plus de decimales.
J'essaie d'utiliser la formule Index combinée avec equiv, mais j'obtiens un
résultat décalé : En clair je n'ai pas su gérér le "inférieur ou egal à" ou
"le supérieur à et inférieur ou egal à"
De plus selon le critère a, b, c ou d, la valeur à retourner K sera puisé
dans une table a, b,c ou d ?
Merci à vous,
(Si, si, je fais des efforts, mais je n'ai pas l'esprit logique)
Bruno
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Papyjac
Le #16490721
Bonjour, Bruno

1. D'abord je pense que l'énoncé de ton tableau n'est pas correct : Si je ne
me trompe pas
Si K <=5 alors 0.15
si k >5 et < alors 0.25
si k >10 et < alors 0.45
si k >15 et <% alors 0.90
si k >25 et <0 alors 1



Il fallait juste inverser les > < et supprimer les dernières lignes

2. Il ne faut pas utiliser EQUIV et INDEX mais seulement
RECHERCHEV(K;tableau;2;vrai)

Tout çà, si j'ai bien compris ta question


--
P a p y j a c

"Bruno" news:
Bonsoir,
J'ai un tableau construit de la façon suivante ;
Si K >=5 alors 0.15
si k <5 et > alors 0.25
si k <10 et > alors 0.45
si k <15 et >% alors 0.90
si k <25 et >5 alors 1
si k <35 et >P alors 1
si k <50 et >p alors 1
si k <70 et >0 alors 1

En fonction de K, je voudrais renvoyer dans une cellule x le chiffre
adéquat. K est un ratio entre deux valeurs avec deux ou plus de decimales.
J'essaie d'utiliser la formule Index combinée avec equiv, mais j'obtiens
un
résultat décalé : En clair je n'ai pas su gérér le "inférieur ou egal à"
ou
"le supérieur à et inférieur ou egal à"
De plus selon le critère a, b, c ou d, la valeur à retourner K sera puisé
dans une table a, b,c ou d ?
Merci à vous,
(Si, si, je fais des efforts, mais je n'ai pas l'esprit logique...)
Bruno


Bruno
Le #16490851
Oui, il y avait une erreur dans les signes :
La valeur de k (ratio) renvoie à un tableau constitué comme suit :
Si le critère complémentaire est c, on prend les valeurs de la colonne c,
s'il est p, les valeurs de p, and so on.

c p CM CM
-----------------------------------------------------------------------------------
Si K <=5 alors 0.15 0,10 0.05 0.00
> si k >5 et < alors 0.25 0.15 0.10 0.05
> si k >10 et < alors 0.45 0.25 0.15 0.05
> si k >15 et <% alors 0.90 0.50 0.20 0.05
> si k >25 et <5 alors 1 0.60 0.25 0.10


si k >25 et <P alors 1 0.70 0.40 0.10
si k >35 et <p alors 1 0.80 0.60 0.15
si k >70 et <0 alors 1 0.90 0.80 0.20

Comment puis-je mettre tout cela dans une formule ?

Mille mercis de l'aide apportée
Bruno

"Papyjac" a écrit :

Bonjour, Bruno

1. D'abord je pense que l'énoncé de ton tableau n'est pas correct : Si je ne
me trompe pas
> Si K <=5 alors 0.15
> si k >5 et < alors 0.25
> si k >10 et < alors 0.45
> si k >15 et <% alors 0.90
> si k >25 et <0 alors 1

Il fallait juste inverser les > < et supprimer les dernières lignes

2. Il ne faut pas utiliser EQUIV et INDEX mais seulement
RECHERCHEV(K;tableau;2;vrai)

Tout çà, si j'ai bien compris ta question


--
P a p y j a c

"Bruno" news:
> Bonsoir,
> J'ai un tableau construit de la façon suivante ;
> Si K >=5 alors 0.15
> si k <5 et > alors 0.25
> si k <10 et > alors 0.45
> si k <15 et >% alors 0.90
> si k <25 et >5 alors 1
> si k <35 et >P alors 1
> si k <50 et >p alors 1
> si k <70 et >0 alors 1
>
> En fonction de K, je voudrais renvoyer dans une cellule x le chiffre
> adéquat. K est un ratio entre deux valeurs avec deux ou plus de decimales.
> J'essaie d'utiliser la formule Index combinée avec equiv, mais j'obtiens
> un
> résultat décalé : En clair je n'ai pas su gérér le "inférieur ou egal à"
> ou
> "le supérieur à et inférieur ou egal à"
> De plus selon le critère a, b, c ou d, la valeur à retourner K sera puisé
> dans une table a, b,c ou d ?
> Merci à vous,
> (Si, si, je fais des efforts, mais je n'ai pas l'esprit logique...)
> Bruno



Sam
Le #16491231
Bonjour,
avec une formule avec des sommeprod ça a l'air de fonctionner
=SOMMEPROD((A7:A14<B1)*(B7:B14>±)*(C6²)*C7:C14)+SOMMEPROD((A7:A14<B1)*(B7:B14>±)*(D6²)*D7:D14)+SOMMEPROD((A7:A14<B1)*(B7:B14>±)*(E6²)*E7:E14)+SOMMEPROD((A7:A14<B1)*(B7:B14>±)*(F6²)*F7:F14)

voir le fichier sur
http://cjoint.com/?igvXg4Ej5a
Cordialement
Michel dit "Sam"


"Bruno"
Bonsoir,
J'ai un tableau construit de la façon suivante ;
Si K >=5 alors 0.15
si k <5 et > alors 0.25
si k <10 et > alors 0.45
si k <15 et >% alors 0.90
si k <25 et >5 alors 1
si k <35 et >P alors 1
si k <50 et >p alors 1
si k <70 et >0 alors 1

En fonction de K, je voudrais renvoyer dans une cellule x le chiffre
adéquat. K est un ratio entre deux valeurs avec deux ou plus de decimales.
J'essaie d'utiliser la formule Index combinée avec equiv, mais j'obtiens
un
résultat décalé : En clair je n'ai pas su gérér le "inférieur ou egal à"
ou
"le supérieur à et inférieur ou egal à"
De plus selon le critère a, b, c ou d, la valeur à retourner K sera puisé
dans une table a, b,c ou d ?
Merci à vous,
(Si, si, je fais des efforts, mais je n'ai pas l'esprit logique...)
Bruno


Sam
Le #16491211
re-bonjour,
j'ai simplifié un peu plus la formule et ça donne
=SOMMEPROD((A7:A14<B1)*(B7:B14>±)*((B2Æ)*C7:C14+(B2Ö)*D7:D14+(B2æ)*E7:E14+(B2ö)*F7:F14))
Cordialement
Michel dit "Sam"

"Sam" 489a00bf$0$877$



Bonjour,
avec une formule avec des sommeprod ça a l'air de fonctionner
=SOMMEPROD((A7:A14<B1)*(B7:B14>±)*(C6²)*C7:C14)+SOMMEPROD((A7:A14<B1)*(B7:B14>±)*(D6²)*D7:D14)+SOMMEPROD((A7:A14<B1)*(B7:B14>±)*(E6²)*E7:E14)+SOMMEPROD((A7:A14<B1)*(B7:B14>±)*(F6²)*F7:F14)

voir le fichier sur
http://cjoint.com/?igvXg4Ej5a
Cordialement
Michel dit "Sam"


"Bruno"
Bonsoir,
J'ai un tableau construit de la façon suivante ;
Si K >=5 alors 0.15
si k <5 et > alors 0.25
si k <10 et > alors 0.45
si k <15 et >% alors 0.90
si k <25 et >5 alors 1
si k <35 et >P alors 1
si k <50 et >p alors 1
si k <70 et >0 alors 1

En fonction de K, je voudrais renvoyer dans une cellule x le chiffre
adéquat. K est un ratio entre deux valeurs avec deux ou plus de
decimales.
J'essaie d'utiliser la formule Index combinée avec equiv, mais j'obtiens
un
résultat décalé : En clair je n'ai pas su gérér le "inférieur ou egal à"
ou
"le supérieur à et inférieur ou egal à"
De plus selon le critère a, b, c ou d, la valeur à retourner K sera puisé
dans une table a, b,c ou d ?
Merci à vous,
(Si, si, je fais des efforts, mais je n'ai pas l'esprit logique...)
Bruno






michdenis
Le #16491461
Pour le plaisir,

Si tu entres une valeur en A1 entre 0 et 100, cela devrait
te retourner une valeur entre 0.15 et 1 correspondant.

Évidemment, tu remplaces A1 par la cellule de ton choix

Ce qui suit n'est qu'UNE formule, attention aux coupures
du service de messagerie.

Les bornes du tableau comme 5,0001, le ,0001 c'est pour
inclure 5 dans le bon spectre.

=INDEX({0,15.0,25.0,045.0,9.1.1};EQUIV(RECHERCHEH(A1;{0.5,0001.10,0001.15,0001.25,0001.35,0001.100,0001};1;VRAI);{0.5,0001.10,0001.15,0001.25,0001.35,0001.100,0001};0))




"Bruno"
Bonsoir,
J'ai un tableau construit de la façon suivante ;
Si K >=5 alors 0.15
si k <5 et > alors 0.25
si k <10 et > alors 0.45
si k <15 et >% alors 0.90
si k <25 et >5 alors 1
si k <35 et >P alors 1
si k <50 et >p alors 1
si k <70 et >0 alors 1

En fonction de K, je voudrais renvoyer dans une cellule x le chiffre
adéquat. K est un ratio entre deux valeurs avec deux ou plus de decimales.
J'essaie d'utiliser la formule Index combinée avec equiv, mais j'obtiens un
résultat décalé : En clair je n'ai pas su gérér le "inférieur ou egal à" ou
"le supérieur à et inférieur ou egal à"
De plus selon le critère a, b, c ou d, la valeur à retourner K sera puisé
dans une table a, b,c ou d ?
Merci à vous,
(Si, si, je fais des efforts, mais je n'ai pas l'esprit logique...)
Bruno
Bruno
Le #16500321
Merci a tous,

J'ai essayé la formule qui fonctionne sans erreurs : pouvez-vous m'expliquer
comment fonctionne SOMMEPROD ? Je ne suis pas capable d'adapter seul cette
formule à un autre problème, car je ne comprends pas la logique de cette
fonction ?

Mille merci

Bruno

"Sam" a écrit :


re-bonjour,
j'ai simplifié un peu plus la formule et ça donne
=SOMMEPROD((A7:A14<B1)*(B7:B14>±)*((B2Æ)*C7:C14+(B2Ö)*D7:D14+(B2æ)*E7:E14+(B2ö)*F7:F14))
Cordialement
Michel dit "Sam"

"Sam" 489a00bf$0$877$
>
>
>
> Bonjour,
> avec une formule avec des sommeprod ça a l'air de fonctionner
> =SOMMEPROD((A7:A14<B1)*(B7:B14>±)*(C6²)*C7:C14)+SOMMEPROD((A7:A14<B1)*(B7:B14>±)*(D6²)*D7:D14)+SOMMEPROD((A7:A14<B1)*(B7:B14>±)*(E6²)*E7:E14)+SOMMEPROD((A7:A14<B1)*(B7:B14>±)*(F6²)*F7:F14)
>
> voir le fichier sur
> http://cjoint.com/?igvXg4Ej5a
> Cordialement
> Michel dit "Sam"
>
>
> "Bruno" >
>> Bonsoir,
>> J'ai un tableau construit de la façon suivante ;
>> Si K >=5 alors 0.15
>> si k <5 et > alors 0.25
>> si k <10 et > alors 0.45
>> si k <15 et >% alors 0.90
>> si k <25 et >5 alors 1
>> si k <35 et >P alors 1
>> si k <50 et >p alors 1
>> si k <70 et >0 alors 1
>>
>> En fonction de K, je voudrais renvoyer dans une cellule x le chiffre
>> adéquat. K est un ratio entre deux valeurs avec deux ou plus de
>> decimales.
>> J'essaie d'utiliser la formule Index combinée avec equiv, mais j'obtiens
>> un
>> résultat décalé : En clair je n'ai pas su gérér le "inférieur ou egal à"
>> ou
>> "le supérieur à et inférieur ou egal à"
>> De plus selon le critère a, b, c ou d, la valeur à retourner K sera puisé
>> dans une table a, b,c ou d ?
>> Merci à vous,
>> (Si, si, je fais des efforts, mais je n'ai pas l'esprit logique...)
>> Bruno
>
>





Misange
Le #16501631
Bonjour,

tu trouveras des explications assez complètes sur cette fonction magique ici
http://xlwiki.free.fr/wiki/wakka.php?wiki=SommeProd (et les deux pages
suivantes)
Seule la fonction initiale de somme prod (faire le produit de sommes)
est documentée dans l'aide d'excel alors qu'on peut faire des merveilles
avec cette fonction.

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

Bruno a écrit :
Merci a tous,

J'ai essayé la formule qui fonctionne sans erreurs : pouvez-vous m'expliquer
comment fonctionne SOMMEPROD ? Je ne suis pas capable d'adapter seul cette
formule à un autre problème, car je ne comprends pas la logique de cette
fonction ?

Mille merci

Bruno

"Sam" a écrit :

re-bonjour,
j'ai simplifié un peu plus la formule et ça donne
=SOMMEPROD((A7:A14<B1)*(B7:B14>±)*((B2Æ)*C7:C14+(B2Ö)*D7:D14+(B2æ)*E7:E14+(B2ö)*F7:F14))
Cordialement
Michel dit "Sam"

"Sam" 489a00bf$0$877$


Bonjour,
avec une formule avec des sommeprod ça a l'air de fonctionner
=SOMMEPROD((A7:A14<B1)*(B7:B14>±)*(C6²)*C7:C14)+SOMMEPROD((A7:A14<B1)*(B7:B14>±)*(D6²)*D7:D14)+SOMMEPROD((A7:A14<B1)*(B7:B14>±)*(E6²)*E7:E14)+SOMMEPROD((A7:A14<B1)*(B7:B14>±)*(F6²)*F7:F14)

voir le fichier sur
http://cjoint.com/?igvXg4Ej5a
Cordialement
Michel dit "Sam"


"Bruno"
Bonsoir,
J'ai un tableau construit de la façon suivante ;
Si K >=5 alors 0.15
si k <5 et > alors 0.25
si k <10 et > alors 0.45
si k <15 et >% alors 0.90
si k <25 et >5 alors 1
si k <35 et >P alors 1
si k <50 et >p alors 1
si k <70 et >0 alors 1

En fonction de K, je voudrais renvoyer dans une cellule x le chiffre
adéquat. K est un ratio entre deux valeurs avec deux ou plus de
decimales.
J'essaie d'utiliser la formule Index combinée avec equiv, mais j'obtiens
un
résultat décalé : En clair je n'ai pas su gérér le "inférieur ou egal à"
ou
"le supérieur à et inférieur ou egal à"
De plus selon le critère a, b, c ou d, la valeur à retourner K sera puisé
dans une table a, b,c ou d ?
Merci à vous,
(Si, si, je fais des efforts, mais je n'ai pas l'esprit logique...)
Bruno











Sam
Le #16504011
Bonjour,
ça me rajeunit de 6 mois !
j'avais posé la même question ici le 11 février !

Pour la réponse complète voir le mail de Misange,

pour une réponse simplifiée :
on utilise une condition qui si elle est respectée donne la valeur 1, et 0
si non respectée
cette valeur 1 ou 0 est ensuite multipliée par les valeurs adéquates et tout
cela pour chaque ligne
Ex
=SOMMEPROD((A7:A14<B1)*(B7:B14>±)*((B2Æ)*C7:C14+(B2Ö)*D7:D14+(B2æ)*E7:E14+(B2ö)*F7:F14))

si k et critère = CMO

pour les lignes 7 à 8 de mon fichier j'aurai
=SOMMEPROD((1)*(0)*((0)*C7:C14+(0)*D7:D14+(0)*E7:E14+(1)*F7:F14))
soit 0

pour la ligne 9
=SOMMEPROD((1)*(1)*((0)*C7:C14+(0)*D7:D14+(0)*E7:E14+(1)*F7:F14))
soit la valeur de F9

pour les lignes 10 à 14
=SOMMEPROD((0)*(1)*((0)*C7:C14+(0)*D7:D14+(0)*E7:E14+(1)*F7:F14))
soit 0

Cordialement
Michel dit "Sam"

"Bruno"
Merci a tous,

J'ai essayé la formule qui fonctionne sans erreurs : pouvez-vous
m'expliquer
comment fonctionne SOMMEPROD ? Je ne suis pas capable d'adapter seul cette
formule à un autre problème, car je ne comprends pas la logique de cette
fonction ?

Mille merci

Bruno

"Sam" a écrit :


re-bonjour,
j'ai simplifié un peu plus la formule et ça donne
=SOMMEPROD((A7:A14<B1)*(B7:B14>±)*((B2Æ)*C7:C14+(B2Ö)*D7:D14+(B2æ)*E7:E14+(B2ö)*F7:F14))
Cordialement
Michel dit "Sam"

"Sam" 489a00bf$0$877$
>
>
>
> Bonjour,
> avec une formule avec des sommeprod ça a l'air de fonctionner
> =SOMMEPROD((A7:A14<B1)*(B7:B14>±)*(C6²)*C7:C14)+SOMMEPROD((A7:A14<B1)*(B7:B14>±)*(D6²)*D7:D14)+SOMMEPROD((A7:A14<B1)*(B7:B14>±)*(E6²)*E7:E14)+SOMMEPROD((A7:A14<B1)*(B7:B14>±)*(F6²)*F7:F14)
>
> voir le fichier sur
> http://cjoint.com/?igvXg4Ej5a
> Cordialement
> Michel dit "Sam"
>
>
> "Bruno" > news:
>
>> Bonsoir,
>> J'ai un tableau construit de la façon suivante ;
>> Si K >=5 alors 0.15
>> si k <5 et > alors 0.25
>> si k <10 et > alors 0.45
>> si k <15 et >% alors 0.90
>> si k <25 et >5 alors 1
>> si k <35 et >P alors 1
>> si k <50 et >p alors 1
>> si k <70 et >0 alors 1
>>
>> En fonction de K, je voudrais renvoyer dans une cellule x le chiffre
>> adéquat. K est un ratio entre deux valeurs avec deux ou plus de
>> decimales.
>> J'essaie d'utiliser la formule Index combinée avec equiv, mais
>> j'obtiens
>> un
>> résultat décalé : En clair je n'ai pas su gérér le "inférieur ou egal
>> à"
>> ou
>> "le supérieur à et inférieur ou egal à"
>> De plus selon le critère a, b, c ou d, la valeur à retourner K sera
>> puisé
>> dans une table a, b,c ou d ?
>> Merci à vous,
>> (Si, si, je fais des efforts, mais je n'ai pas l'esprit logique...)
>> Bruno
>
>







Publicité
Poster une réponse
Anonyme