Indirect comportant un Somme.Si

Le
HD
Bonjour,

J'aurais voulu utiliser la fonction INDIRECT pour une fonction SOMME.SI
mais lorsque je l'utilise j'ai systématiquement le message de retour #REF!

Voilà ma formule
=SI($C7=0;;INDIRECT("SOMME.SI(Param!$E$16:$E$115;$B7;Param!" & G$110 &
"$16:" & G$110 & "$115)")/$C7*$AH7)
En cellule G110 j'ai la valeur I
Si je met directement la formule:
=SOMME.SI(Param!$E$16:$E$115;$B7;Param!I$16:I$115))/$C7*$AH7
J'ai bien le bon résultat.

Merci d'avance pour votre aide,

Cordialement,

HD
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacky
Le #24353151
Bonjour,

J'aurais voulu utiliser la fonction INDIRECT ....


Essaye comme ceci
=SI($C7=0;"";SOMME.SI(param!$E$16:$E$115;$B7;INDIRECT("param!"&G$110&"$16:"&G$110&"$115"))/$C7*$AH7)
--
Salutations
JJ


"HD"
Bonjour,

J'aurais voulu utiliser la fonction INDIRECT pour une fonction SOMME.SI... mais lorsque je l'utilise j'ai
systématiquement le message de retour #REF!

Voilà ma formule...
=SI($C7=0;;INDIRECT("SOMME.SI(Param!$E$16:$E$115;$B7;Param!" & G$110 & "$16:" & G$110 & "$115)")/$C7*$AH7)
En cellule G110 j'ai la valeur I
Si je met directement la formule:
=SOMME.SI(Param!$E$16:$E$115;$B7;Param!I$16:I$115))/$C7*$AH7
J'ai bien le bon résultat.

Merci d'avance pour votre aide,

Cordialement,

HD

HD
Le #24353231
Essaye comme ceci
=SI($C7=0;"";SOMME.SI(param!$E$16:$E$115;$B7;INDIRECT("param!"&G$110&"$16:"&G$110&"$115"))/$C7*$AH7)


Effectivement, cela fonctionne maintenant. La fonction INDIRECT est limité
par la taille de la formule ? Ou a-t-elle du mal a interprété la formule
avec des fonctions imbriquées dedans ?

En tout cas Merci.

Cordialement,

HD
Jacky
Le #24353211
Re...
Dans ce cas, ce n'est pas la fonction qui est indirect, mais uniquement le 3ème paramètre de la fonction, soit
'"Somme_plage"

--
Salutations
JJ


"HD"
Essaye comme ceci
=SI($C7=0;"";SOMME.SI(param!$E$16:$E$115;$B7;INDIRECT("param!"&G$110&"$16:"&G$110&"$115"))/$C7*$AH7)


Effectivement, cela fonctionne maintenant. La fonction INDIRECT est limité par la taille de la formule ? Ou
a-t-elle du mal a interprété la formule avec des fonctions imbriquées dedans ?

En tout cas Merci.

Cordialement,

HD

Publicité
Poster une réponse
Anonyme