Indirect, Sommeprod, Adresse...

Le
Manu
Bonsoir,

J'ai un gros soucis sur une formule complexe de recherche sur XL 2003, pour
simplifier mon explication, je vous joint le fichier ce sera ainsi plus
simple au niveau clarté.
http://www.cijoint.fr/cjlink.php?file=cj200911/cijYvfGKey.xls
Merci de votre aide car je n'arrive pas à m'en sortir.

Manu
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #20651741
Bonsoir,

Exemple:

http://boisgontierjacques.free.fr/pages_site/sommeprod3D.htm#Compte3D
http://boisgontierjacques.free.fr/fichiers/Matriciel/MatPlanning3D.xls

JB
http://boisgontierjacques.free.fr


On 28 nov, 18:18, "Manu"
Bonsoir,

J'ai un gros soucis sur une formule complexe de recherche sur XL 2003, po ur
simplifier mon explication, je vous joint le fichier ce sera ainsi plus
simple au niveau clarté.http://www.cijoint.fr/cjlink.php?file=cj20091 1/cijYvfGKey.xls
Merci de votre aide car je n'arrive pas à m'en sortir.

Manu


JB
Le #20652001
http://cjoint.com/?lCuJc5YV56

JB

On 28 nov, 20:00, JB
Bonsoir,

Exemple:

http://boisgontierjacques.free.fr/pages_site/sommeprod3D.htm#Compte3Dhttp ://boisgontierjacques.free.fr/fichiers/Matriciel/MatPlanning3D.xls

JBhttp://boisgontierjacques.free.fr

On 28 nov, 18:18, "Manu"


> Bonsoir,

> J'ai un gros soucis sur une formule complexe de recherche sur XL 2003, pour
> simplifier mon explication, je vous joint le fichier ce sera ainsi plus
> simple au niveau clarté.http://www.cijoint.fr/cjlink.php?file=cj200 911/cijYvfGKey.xls
> Merci de votre aide car je n'arrive pas à m'en sortir.

> Manu- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -


Sam
Le #20652901
Bonjour,
Plusieurs remarques si j'avais à le faire:
- je simplifierais C5 du mois en mettant
=CHOISIR(JOURSEM(C6;2);"L";"M";"M";"J";"V";"S";"D") et tirer à droite

- l'unité de période étant le mois, je ferais un total dans chaque feuille
mois, en fin de chaque ligne pour les différentes causes
avec une formule du type =NB.SI($C7:$AG7;AI$6) et tirer vers la droite et
vers le bas
les causes étant en ligne 6 de AI à AT
nota : le "M" n'apparait pas dans la liste de cause
Dans cette feuille je ferais également le bilan par service et global du
mois

- je ferais une feuille supplémentaire "Année" qui ferait les totaux par
individus, par service et global de l'année

- dans les choix de SYNTHESE il y a un pb car quand on choisit un individu,
le choix service est inutile ou dangereux
Je ferais 2 résultats synthèse - par individu; - par service
Je rajouterai un choix "Année"

- en B8 de Synthèse je mettrais (pour les
employés)=INDEX(INDIRECT($H$2&"!AI7:AI23");EQUIV($D$2;EMPLOYE;0))

Cordialement
Michel dit "Sam"

"Manu"
Bonsoir,

J'ai un gros soucis sur une formule complexe de recherche sur XL 2003,
pour simplifier mon explication, je vous joint le fichier ce sera ainsi
plus simple au niveau clarté.
http://www.cijoint.fr/cjlink.php?file=cj200911/cijYvfGKey.xls
Merci de votre aide car je n'arrive pas à m'en sortir.

Manu



Humanum
Le #20653331
Bonjour,
Tout d'abord bravo à Manu pour le fichier de départ et chapeau JB pour
la formule!

Voulant continuer sur le sujet j'essaye de créer la synthèse par service
J'ai repris la formule pour les noms et bien sur le resultat correspond
au premier service trouvé et non à la somme du service...

Cdt,
Humanum

JB a écrit :
http://cjoint.com/?lCuJc5YV56

JB

On 28 nov, 20:00, JB
Bonsoir,

Exemple:

http://boisgontierjacques.free.fr/pages_site/sommeprod3D.htm#Compte3Dhttp://boisgontierjacques.free.fr/fichiers/Matriciel/MatPlanning3D.xls

JBhttp://boisgontierjacques.free.fr

On 28 nov, 18:18, "Manu"



Bonsoir,



J'ai un gros soucis sur une formule complexe de recherche sur XL 2003, pour
simplifier mon explication, je vous joint le fichier ce sera ainsi plus
simple au niveau clarté.http://www.cijoint.fr/cjlink.php?file=cj200911/cijYvfGKey.xls
Merci de votre aide car je n'arrive pas à m'en sortir.



Manu- Masquer le texte des messages précédents -



- Afficher le texte des messages précédents -






Manu
Le #20656251
Ouah, super cette formule JB, pourtant je m'etais inspiré de tes fichiers,
mais pas moyen.
En tous cas, merci à vous tous, je continu et vous tiens au courant car j'ai
encore pas mal de soucis à resoudre, si je n'y arrive pas, je me permettrais
à nouveau de vous appeler au secours.

Manu

"Sam" 4b1197a1$0$1010$

Bonjour,
Plusieurs remarques si j'avais à le faire:
- je simplifierais C5 du mois en mettant
=CHOISIR(JOURSEM(C6;2);"L";"M";"M";"J";"V";"S";"D") et tirer à droite

- l'unité de période étant le mois, je ferais un total dans chaque feuille
mois, en fin de chaque ligne pour les différentes causes
avec une formule du type =NB.SI($C7:$AG7;AI$6) et tirer vers la droite et
vers le bas
les causes étant en ligne 6 de AI à AT
nota : le "M" n'apparait pas dans la liste de cause
Dans cette feuille je ferais également le bilan par service et global du
mois

- je ferais une feuille supplémentaire "Année" qui ferait les totaux par
individus, par service et global de l'année

- dans les choix de SYNTHESE il y a un pb car quand on choisit un
individu, le choix service est inutile ou dangereux
Je ferais 2 résultats synthèse - par individu; - par service
Je rajouterai un choix "Année"

- en B8 de Synthèse je mettrais (pour les
employés)=INDEX(INDIRECT($H$2&"!AI7:AI23");EQUIV($D$2;EMPLOYE;0))

Cordialement
Michel dit "Sam"

"Manu"
Bonsoir,

J'ai un gros soucis sur une formule complexe de recherche sur XL 2003,
pour simplifier mon explication, je vous joint le fichier ce sera ainsi
plus simple au niveau clarté.
http://www.cijoint.fr/cjlink.php?file=cj200911/cijYvfGKey.xls
Merci de votre aide car je n'arrive pas à m'en sortir.

Manu







Publicité
Poster une réponse
Anonyme