Infos mise en place ADAM

Le
borazy
Bonjour,

Je suis en train de tester la solution ADAM de Microsoft sur un serveur 2003
SP2 tout frais, tout reinstaller tout propre (aucun service AD, DNS ne
sont configurés dessus).

L'idée était de monter le service ADAM afin de pouvoir faire bénéficier les
quelques utilisateurs (20 PC) d'un annuaire LDAP centralisé dans
Outlook/carnet d'adresse Windows sans avoir à monter un AD (actuellement
postes en workgroup).

Je suis donc la procédure de Microsft "ADAM_Step-by-Step_Guide.doc",
installation, configuration de l'instance, création users tout OK.

Je teste la connexion à l'annuaire LDAP sur ce même serveur et tente une
recherche d'un user via le carnet d'adresse le user sort correctement.

CEPENDANT, je test depuis mon poste et la aucun utilisateur ne sort et me
sort le message d'erreur suivant : "Aucune entrée du service ne correspond à
votre recherche"

Comment tester la bonne liaison entre mon poste de test et mon serveur
hebergant le service ADAM ? et surtout pouquoi la connexion à l'instance
fonctionne en local sur le serveur et non sur un poste distant ?

Merci

PS : le serveur + poste de test sont sur le même LAN, ping OK
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Emmanuel Dreux
Le #16772131
Bonjour,

ça doit être l'authentification auprès du service ADAM qui ne passe pas
puisque vous êtes en Workgroup et que le compte utilisarteur de la machine
distante n'a pas les permissions d'accès à ADAM.

Vérifiez la clé Foreceguest sur la machine ou est installé ADAM et forcez la
à zéro.
HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlLsaforceguest

--
Cordialement,
Emmanuel Dreux
http://www.ilinfo.fr


"borazy" a écrit :

Bonjour,

Je suis en train de tester la solution ADAM de Microsoft sur un serveur 2003
SP2 tout frais, tout reinstaller tout propre (aucun service AD, DNS ...ne
sont configurés dessus).

L'idée était de monter le service ADAM afin de pouvoir faire bénéficier les
quelques utilisateurs (20 PC) d'un annuaire LDAP centralisé dans
Outlook/carnet d'adresse Windows sans avoir à monter un AD (actuellement
postes en workgroup).

Je suis donc la procédure de Microsft "ADAM_Step-by-Step_Guide.doc",
installation, configuration de l'instance, création users... tout OK.

Je teste la connexion à l'annuaire LDAP sur ce même serveur et tente une
recherche d'un user via le carnet d'adresse... le user sort correctement.

CEPENDANT, je test depuis mon poste et la aucun utilisateur ne sort et me
sort le message d'erreur suivant : "Aucune entrée du service ne correspond à
votre recherche..."

Comment tester la bonne liaison entre mon poste de test et mon serveur
hebergant le service ADAM ? et surtout pouquoi la connexion à l'instance
fonctionne en local sur le serveur et non sur un poste distant ?

Merci

PS : le serveur + poste de test sont sur le même LAN, ping OK...


borazy
Le #16772831
Bonjour,

Merci mais apparement la clé est par défaut à 0.

"Emmanuel Dreux" wrote:

Bonjour,

ça doit être l'authentification auprès du service ADAM qui ne passe pas
puisque vous êtes en Workgroup et que le compte utilisarteur de la machine
distante n'a pas les permissions d'accès à ADAM.

Vérifiez la clé Foreceguest sur la machine ou est installé ADAM et forcez la
à zéro.
HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlLsaforceguest

--
Cordialement,
Emmanuel Dreux
http://www.ilinfo.fr


"borazy" a écrit :

> Bonjour,
>
> Je suis en train de tester la solution ADAM de Microsoft sur un serveur 2003
> SP2 tout frais, tout reinstaller tout propre (aucun service AD, DNS ...ne
> sont configurés dessus).
>
> L'idée était de monter le service ADAM afin de pouvoir faire bénéficier les
> quelques utilisateurs (20 PC) d'un annuaire LDAP centralisé dans
> Outlook/carnet d'adresse Windows sans avoir à monter un AD (actuellement
> postes en workgroup).
>
> Je suis donc la procédure de Microsft "ADAM_Step-by-Step_Guide.doc",
> installation, configuration de l'instance, création users... tout OK.
>
> Je teste la connexion à l'annuaire LDAP sur ce même serveur et tente une
> recherche d'un user via le carnet d'adresse... le user sort correctement.
>
> CEPENDANT, je test depuis mon poste et la aucun utilisateur ne sort et me
> sort le message d'erreur suivant : "Aucune entrée du service ne correspond à
> votre recherche..."
>
> Comment tester la bonne liaison entre mon poste de test et mon serveur
> hebergant le service ADAM ? et surtout pouquoi la connexion à l'instance
> fonctionne en local sur le serveur et non sur un poste distant ?
>
> Merci
>
> PS : le serveur + poste de test sont sur le même LAN, ping OK...


Emmanuel Dreux
Le #16773441
Essayez ceci, puis si ça ne marche toujours pas,essayez de vous connecter
avec un requêteur LDAP (récupérer l'outil ldp.exe de microsoft) et voyez ce
que ça répond.

http://technet2.microsoft.com/windowsserver/fr/library/6e1ea3d1-f78b-4a95-afff-0a475327ddb61036.mspx?mfr=true

Comment puis-je configurer ADAM pour qu'il prenne en charge des liens LDAP
anonymes ?

Par défaut, ADAM n'accepte pas les demandes de lien anonyme. Pour activer
les opérations LDAP anonymes dans ADAM, vous devez définir le septième
caractère de la valeur dsHeuristics à 2.

Vous trouverez l'attribut dsHeuristics sur l'objet Service d'annuaire dans
la partition d'annuaire de configuration (CN=Directory Service,CN=Windows
NT,CN=Services,CN=Configuration,CN={GUID}).

Modifiez l'attribut avec la valeur suivante :

0000002001000

En outre, attribuez des autorisations pour que les utilisateurs anonymes
puissent accéder aux objets appropriés dans l'annuaire. Pour accorder aux
utilisateurs anonymes l'autorisation Lecture sur tous les objets d'une
partition d'annuaire donnée, il vous suffit d'ajouter l'entité de sécurité
Anonyme (à partir de l'ordinateur) au groupe Lecteurs de la partition
d'annuaire.

--
Cordialement,
Emmanuel Dreux
http://www.ilinfo.fr


"borazy" a écrit :

Bonjour,

Merci mais apparement la clé est par défaut à 0.

"Emmanuel Dreux" wrote:

> Bonjour,
>
> ça doit être l'authentification auprès du service ADAM qui ne passe pas
> puisque vous êtes en Workgroup et que le compte utilisarteur de la machine
> distante n'a pas les permissions d'accès à ADAM.
>
> Vérifiez la clé Foreceguest sur la machine ou est installé ADAM et forcez la
> à zéro.
> HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlLsaforceguest
>
> --
> Cordialement,
> Emmanuel Dreux
> http://www.ilinfo.fr
>
>
> "borazy" a écrit :
>
> > Bonjour,
> >
> > Je suis en train de tester la solution ADAM de Microsoft sur un serveur 2003
> > SP2 tout frais, tout reinstaller tout propre (aucun service AD, DNS ...ne
> > sont configurés dessus).
> >
> > L'idée était de monter le service ADAM afin de pouvoir faire bénéficier les
> > quelques utilisateurs (20 PC) d'un annuaire LDAP centralisé dans
> > Outlook/carnet d'adresse Windows sans avoir à monter un AD (actuellement
> > postes en workgroup).
> >
> > Je suis donc la procédure de Microsft "ADAM_Step-by-Step_Guide.doc",
> > installation, configuration de l'instance, création users... tout OK.
> >
> > Je teste la connexion à l'annuaire LDAP sur ce même serveur et tente une
> > recherche d'un user via le carnet d'adresse... le user sort correctement.
> >
> > CEPENDANT, je test depuis mon poste et la aucun utilisateur ne sort et me
> > sort le message d'erreur suivant : "Aucune entrée du service ne correspond à
> > votre recherche..."
> >
> > Comment tester la bonne liaison entre mon poste de test et mon serveur
> > hebergant le service ADAM ? et surtout pouquoi la connexion à l'instance
> > fonctionne en local sur le serveur et non sur un poste distant ?
> >
> > Merci
> >
> > PS : le serveur + poste de test sont sur le même LAN, ping OK...


borazy
Le #16776851
Merci pour les infos mais cela ne amrche malheuresement pas.

Je viens donc de tester avec un vrai AD et cela fonctionne parfaitement.

Les utilisateurs apparaissent bien dans mon carnet d'adresse MAIS comment
faire pour créér des listes de diffusion ?

j'ai essayé en créeant un "groupe de distribution" mais il ne remonte pas
dans mon carnet d'adresse.

Merci

"Emmanuel Dreux" wrote:

Essayez ceci, puis si ça ne marche toujours pas,essayez de vous connecter
avec un requêteur LDAP (récupérer l'outil ldp.exe de microsoft) et voyez ce
que ça répond.

http://technet2.microsoft.com/windowsserver/fr/library/6e1ea3d1-f78b-4a95-afff-0a475327ddb61036.mspx?mfr=true

Comment puis-je configurer ADAM pour qu'il prenne en charge des liens LDAP
anonymes ?

Par défaut, ADAM n'accepte pas les demandes de lien anonyme. Pour activer
les opérations LDAP anonymes dans ADAM, vous devez définir le septième
caractère de la valeur dsHeuristics à 2.

Vous trouverez l'attribut dsHeuristics sur l'objet Service d'annuaire dans
la partition d'annuaire de configuration (CN=Directory Service,CN=Windows
NT,CN=Services,CN=Configuration,CN={GUID}).

Modifiez l'attribut avec la valeur suivante :

0000002001000

En outre, attribuez des autorisations pour que les utilisateurs anonymes
puissent accéder aux objets appropriés dans l'annuaire. Pour accorder aux
utilisateurs anonymes l'autorisation Lecture sur tous les objets d'une
partition d'annuaire donnée, il vous suffit d'ajouter l'entité de sécurité
Anonyme (à partir de l'ordinateur) au groupe Lecteurs de la partition
d'annuaire.

--
Cordialement,
Emmanuel Dreux
http://www.ilinfo.fr


"borazy" a écrit :

> Bonjour,
>
> Merci mais apparement la clé est par défaut à 0.
>
> "Emmanuel Dreux" wrote:
>
> > Bonjour,
> >
> > ça doit être l'authentification auprès du service ADAM qui ne passe pas
> > puisque vous êtes en Workgroup et que le compte utilisarteur de la machine
> > distante n'a pas les permissions d'accès à ADAM.
> >
> > Vérifiez la clé Foreceguest sur la machine ou est installé ADAM et forcez la
> > à zéro.
> > HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlLsaforceguest
> >
> > --
> > Cordialement,
> > Emmanuel Dreux
> > http://www.ilinfo.fr
> >
> >
> > "borazy" a écrit :
> >
> > > Bonjour,
> > >
> > > Je suis en train de tester la solution ADAM de Microsoft sur un serveur 2003
> > > SP2 tout frais, tout reinstaller tout propre (aucun service AD, DNS ...ne
> > > sont configurés dessus).
> > >
> > > L'idée était de monter le service ADAM afin de pouvoir faire bénéficier les
> > > quelques utilisateurs (20 PC) d'un annuaire LDAP centralisé dans
> > > Outlook/carnet d'adresse Windows sans avoir à monter un AD (actuellement
> > > postes en workgroup).
> > >
> > > Je suis donc la procédure de Microsft "ADAM_Step-by-Step_Guide.doc",
> > > installation, configuration de l'instance, création users... tout OK.
> > >
> > > Je teste la connexion à l'annuaire LDAP sur ce même serveur et tente une
> > > recherche d'un user via le carnet d'adresse... le user sort correctement.
> > >
> > > CEPENDANT, je test depuis mon poste et la aucun utilisateur ne sort et me
> > > sort le message d'erreur suivant : "Aucune entrée du service ne correspond à
> > > votre recherche..."
> > >
> > > Comment tester la bonne liaison entre mon poste de test et mon serveur
> > > hebergant le service ADAM ? et surtout pouquoi la connexion à l'instance
> > > fonctionne en local sur le serveur et non sur un poste distant ?
> > >
> > > Merci
> > >
> > > PS : le serveur + poste de test sont sur le même LAN, ping OK...


Publicité
Poster une réponse
Anonyme