initramfs-tools

Le
Courrier Debian
Bonjour,
Tout d'abord je suis en Sid AMD64, depuis la dernière mise à jour=
de
initramfs-tools j'ai une anomalie de mise à jour.
Traitement des actions différées (« triggers ») pour =
« initramfs-tools »
update-initramfs: Generating /boot/initrd.img-2.6.32-trunk-amd64
update-initramfs: failed for /boot/initrd.img-2.6.32-trunk-amd64
dpkg : erreur de traitement de initramfs-tools (--configure) :
le sous-processus script post-installation installé a retourné u=
ne erreur de
sortie d'état 1
..
Des erreurs ont été rencontrées pendant l'exécution :
initramfs-tools
E: Sub-process /usr/bin/dpkg returned an error code (1)
J'ai regardé dans les Bugs référencés et je ne la vois =
pas répertorié, avez
vous ce problème? dois je faire un rapport de Bug ?
Philippe

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/201006241101.09162.phil-deb1.merlin@laposte.net
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sylvain Sauvage
Le #22292241
Courrier Debian, jeudi 24 juin 2010, 11:01:09 CEST

Bonjour,



’jour,

Tout d'abord je suis en Sid AMD64, depuis la dernière mise à jo ur de
initramfs-tools j'ai une anomalie de mise à jour.
Traitement des actions différées (« triggers ») pour « initramfs-tools »...
update-initramfs: Generating /boot/initrd.img-2.6.32-trunk-amd64
update-initramfs: failed for /boot/initrd.img-2.6.32-trunk-amd64
dpkg : erreur de traitement de initramfs-tools (--configure) :
le sous-processus script post-installation installé a retourné une erreur de
sortie d'état 1
.....
Des erreurs ont été rencontrées pendant l'exécution :
initramfs-tools
E: Sub-process /usr/bin/dpkg returned an error code (1)
J'ai regardé dans les Bugs référencés et je ne la voi s pas répertorié, avez
vous ce problème? dois je faire un rapport de Bug ?
Philippe



Le 2.6.32-trunk n’existe plus. Le noyau courant d’une Sid
Amd64 est le 2.6.32-5.

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Courrier Debian
Le #22292281
Bonjour,
Le jeudi 24 juin 2010 11:11:19, Sylvain Sauvage a écrit :
Courrier Debian, jeudi 24 juin 2010, 11:01:09 CEST

> Bonjour,

’jour,

> Tout d'abord je suis en Sid AMD64, depuis la dernière mise à jour de
> initramfs-tools j'ai une anomalie de mise à jour.
> Traitement des actions différées (« triggers ») pou r « initramfs-tools
> »... update-initramfs: Generating /boot/initrd.img-2.6.32-trunk-am d64
> update-initramfs: failed for /boot/initrd.img-2.6.32-trunk-amd64
>
> dpkg : erreur de traitement de initramfs-tools (--configure) :
> le sous-processus script post-installation installé a retournà © une
> erreur de
>
> sortie d'état 1
> .....
>
> Des erreurs ont été rencontrées pendant l'exécution :
> initramfs-tools
>
> E: Sub-process /usr/bin/dpkg returned an error code (1)
> J'ai regardé dans les Bugs référencés et je ne la v ois pas répertorié,
> avez vous ce problème? dois je faire un rapport de Bug ?
> Philippe

Le 2.6.32-trunk n’existe plus. Le noyau courant d’une S id
Amd64 est le 2.6.32-5.


Je suis certainement d'accord avec toi, mais si je fait un :
dpkg -l|grep 2.6.32
ii firmware-linux-free 2.6.32-15 Binary firmware for va rious
drivers in the Linux kernel
ii linux-headers-2.6.32-trunk-amd64 2.6.32-5 Header files for Linu x
2.6.32-trunk-amd64
ii linux-headers-2.6.32-trunk-common 2.6.32-5 Common header f iles
for Linux 2.6.32-trunk
ii linux-image-2.6.32-trunk-amd64 2.6.32-5 Linux 2.6. 32
for 64-bit PCs
ii linux-kbuild-2.6.32 2.6.32-1 Kbuild infrastruct ure
for Linux 2.6.32
ii linux-libc-dev 2.6.32-15 Linux suppor t
headers for userspace development
et il me semble que le 2.6.32-trunk-amd64 existe toujours.
Amicalement.
Philippe

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Pascal Hambourg
Le #22292291
Salut,

Sylvain Sauvage a écrit :
Courrier Debian, jeudi 24 juin 2010, 11:01:09 CEST

Tout d'abord je suis en Sid AMD64, depuis la dernière mise à jour de
initramfs-tools j'ai une anomalie de mise à jour.
Traitement des actions différées (« triggers ») pour « initramfs-tools »...
update-initramfs: Generating /boot/initrd.img-2.6.32-trunk-amd64
update-initramfs: failed for /boot/initrd.img-2.6.32-trunk-amd64




[...]
Le 2.6.32-trunk n'existe plus. Le noyau courant d'une Sid
Amd64 est le 2.6.32-5.



Soit, mais je suis curieux : en quoi cela peut-il provoquer l'erreur
ci-dessus ? Un générateur d'initramfs qui ne marche que pour la version
courante du noyau, ça ne me paraît pas très fiable.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Christophe
Le #22292271
Le jeudi 24 juin 2010 à 11:25 +0200, Courrier Debian a écrit :
Bonjour,
Le jeudi 24 juin 2010 11:11:19, Sylvain Sauvage a écrit :
> Courrier Debian, jeudi 24 juin 2010, 11:01:09 CEST
>
> > Bonjour,
>
> ’jour,
>
> > Tout d'abord je suis en Sid AMD64, depuis la dernière mise à jour de
> > initramfs-tools j'ai une anomalie de mise à jour.
> > Traitement des actions différées (« triggers ») pour « initramfs-tools
> > »... update-initramfs: Generating /boot/initrd.img-2.6.32-trunk-amd64
> > update-initramfs: failed for /boot/initrd.img-2.6.32-trunk-amd64
> >
> > dpkg : erreur de traitement de initramfs-tools (--configure) :
> > le sous-processus script post-installation installé a retourné une
> > erreur de
> >
> > sortie d'état 1
> > .....
> >
> > Des erreurs ont été rencontrées pendant l'exécution :
> > initramfs-tools
> >
> > E: Sub-process /usr/bin/dpkg returned an error code (1)
> > J'ai regardé dans les Bugs référencés et je ne la vois pas répertorié,
> > avez vous ce problème? dois je faire un rapport de Bug ?
> > Philippe
>
> Le 2.6.32-trunk n’existe plus. Le noyau courant d’une Sid
> Amd64 est le 2.6.32-5.
Je suis certainement d'accord avec toi, mais si je fait un :
dpkg -l|grep 2.6.32
ii firmware-linux-free 2.6.32-15 Binary firmware for various
drivers in the Linux kernel
ii linux-headers-2.6.32-trunk-amd64 2.6.32-5 Header files for Linux
2.6.32-trunk-amd64
ii linux-headers-2.6.32-trunk-common 2.6.32-5 Common header files
for Linux 2.6.32-trunk
ii linux-image-2.6.32-trunk-amd64 2.6.32-5 Linux 2.6.32
for 64-bit PCs
ii linux-kbuild-2.6.32 2.6.32-1 Kbuild infrastructure
for Linux 2.6.32
ii linux-libc-dev 2.6.32-15 Linux support
headers for userspace development
et il me semble que le 2.6.32-trunk-amd64 existe toujours.
Amicalement.
Philippe



Salut,
Il existe chez toi (dpkg -l liste les paquets de ta base dpkg).

# apt-cache policy linux-image-2.6.32-trunk-amd64
W: Impossible de trouver le paquet linux-image-2.6.32-trunk-amd64

Cordialement,
Christophe

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Sylvain Sauvage
Le #22292371
Courrier Debian, jeudi 24 juin 2010, 11:25:10 CEST
[…]
Je suis certainement d'accord avec toi, mais si je fait un :
dpkg -l|grep 2.6.32
[…]
et il me semble que le 2.6.32-trunk-amd64 existe toujours.



dpkg -l ne t’indique que les paquets installés. Donc,
évidemment, puisque tu n’as que le -trunk d’installà ©, tu ne
risques pas d’y voir le -5.

aptitude/apt-cache search/policy sont tes amis.

Pascal Hambourg, jeudi 24 juin 2010, 11:27:40 CEST
[…]
Soit, mais je suis curieux : en quoi cela peut-il provoquer l'erreur
ci-dessus ? Un générateur d'initramfs qui ne marche que pour la version
courante du noyau, ça ne me paraît pas très fiable.



Mon hypothèse était plutôt que c’est un gén érateur d’initramfs
qui ne marche pas pour la version -trunk du paquet ; paquet
obsolète certainement pour de bonnes raisons.

L’idée est donc : installer un paquet encore disponible donc
encore maintenu et vérifier si ça coince ou non. Personne n†™a
signalé de bogue donc il semble que l’installation de Philippe
est en cause. Un bogue avec un paquet qui n’existe plus étant
difficile à reproduire chez les autres, si le problème persiste
avec le paquet courant, on avisera…

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Courrier Debian
Le #22292411
Le jeudi 24 juin 2010 11:45:39, Sylvain Sauvage a écrit :
Courrier Debian, jeudi 24 juin 2010, 11:25:10 CEST

>[…]
>
> Je suis certainement d'accord avec toi, mais si je fait un :
> dpkg -l|grep 2.6.32
>
>[…]
>
> et il me semble que le 2.6.32-trunk-amd64 existe toujours.

dpkg -l ne t’indique que les paquets installés. Donc,
évidemment, puisque tu n’as que le -trunk d’install é, tu ne
risques pas d’y voir le -5.

aptitude/apt-cache search/policy sont tes amis.

Pascal Hambourg, jeudi 24 juin 2010, 11:27:40 CEST

>[…]
>
> Soit, mais je suis curieux : en quoi cela peut-il provoquer l'erreur
> ci-dessus ? Un générateur d'initramfs qui ne marche que pour la version
> courante du noyau, ça ne me paraît pas très fiable.

Mon hypothèse était plutôt que c’est un gén érateur d’initramfs
qui ne marche pas pour la version -trunk du paquet ; paquet
obsolète certainement pour de bonnes raisons.

L’idée est donc : installer un paquet encore disponible do nc
encore maintenu et vérifier si ça coince ou non. Personne n⠀™a
signalé de bogue donc il semble que l’installation de Philip pe
est en cause. Un bogue avec un paquet qui n’existe plus étant
difficile à reproduire chez les autres, si le problème persiste
avec le paquet courant, on avisera…


Pas tout à fait d'accord avec toi, si tu regardes bien le mon dpkg -l tu vois
linux-image-2.6.32-trunk-amd64 2.6.32-5 Linux 2.6.32
for 64-bit PCs
qu'il est au niveau 2.6.32-5
D'autre part je ne me rappelle plus quand j'ai du installé ce linux-
image.....trunk-amd64 es ce au cours de l'installation de linux en testing ou
au cours de la migration en sid?!?
quel que soit la raison il y a il me semble un bug quelque part .
Amitiés.
Philippe

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Courrier Debian
Le #22292461
Le jeudi 24 juin 2010 11:45:39, Sylvain Sauvage a écrit :
Courrier Debian, jeudi 24 juin 2010, 11:25:10 CEST

>[…]
>
> Je suis certainement d'accord avec toi, mais si je fait un :
> dpkg -l|grep 2.6.32
>
>[…]
>
> et il me semble que le 2.6.32-trunk-amd64 existe toujours.

dpkg -l ne t’indique que les paquets installés. Donc,
évidemment, puisque tu n’as que le -trunk d’install é, tu ne
risques pas d’y voir le -5.

aptitude/apt-cache search/policy sont tes amis.

Pascal Hambourg, jeudi 24 juin 2010, 11:27:40 CEST

>[…]
>
> Soit, mais je suis curieux : en quoi cela peut-il provoquer l'erreur
> ci-dessus ? Un générateur d'initramfs qui ne marche que pour la version
> courante du noyau, ça ne me paraît pas très fiable.

Mon hypothèse était plutôt que c’est un gén érateur d’initramfs
qui ne marche pas pour la version -trunk du paquet ; paquet
obsolète certainement pour de bonnes raisons.

L’idée est donc : installer un paquet encore disponible do nc
encore maintenu et vérifier si ça coince ou non. Personne n⠀™a
signalé de bogue donc il semble que l’installation de Philip pe
est en cause. Un bogue avec un paquet qui n’existe plus étant
difficile à reproduire chez les autres, si le problème persiste
avec le paquet courant, on avisera…


Je complète un :
apt-cache policy linux-image-2.6.32-trunk-amd64
linux-image-2.6.32-trunk-amd64:
Installé : 2.6.32-5
Candidat : 2.6.32-5
Table de version :
*** 2.6.32-5 0
100 /var/lib/dpkg/status
Cela me semble correct.
Amitiés.
Philippe

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Christophe
Le #22292451
Le jeudi 24 juin 2010 à 12:30 +0200, Courrier Debian a écrit :
Le jeudi 24 juin 2010 11:45:39, Sylvain Sauvage a écrit :
> Courrier Debian, jeudi 24 juin 2010, 11:25:10 CEST
>
> >[…]
> >
> > Je suis certainement d'accord avec toi, mais si je fait un :
> > dpkg -l|grep 2.6.32
> >
> >[…]
> >
> > et il me semble que le 2.6.32-trunk-amd64 existe toujours.
>
> dpkg -l ne t’indique que les paquets installés. Donc,
> évidemment, puisque tu n’as que le -trunk d’installé, tu ne
> risques pas d’y voir le -5.
>
> aptitude/apt-cache search/policy sont tes amis.
>
> Pascal Hambourg, jeudi 24 juin 2010, 11:27:40 CEST
>
> >[…]
> >
> > Soit, mais je suis curieux : en quoi cela peut-il provoquer l'erreur
> > ci-dessus ? Un générateur d'initramfs qui ne marche que pour la version
> > courante du noyau, ça ne me paraît pas très fiable.
>
> Mon hypothèse était plutôt que c’est un générateur d’initramfs
> qui ne marche pas pour la version -trunk du paquet ; paquet
> obsolète certainement pour de bonnes raisons.
>
> L’idée est donc : installer un paquet encore disponible donc
> encore maintenu et vérifier si ça coince ou non. Personne n’a
> signalé de bogue donc il semble que l’installation de Philippe
> est en cause. Un bogue avec un paquet qui n’existe plus étant
> difficile à reproduire chez les autres, si le problème persiste
> avec le paquet courant, on avisera…
Je complète un :
apt-cache policy linux-image-2.6.32-trunk-amd64
linux-image-2.6.32-trunk-amd64:
Installé : 2.6.32-5
Candidat : 2.6.32-5
Table de version :
*** 2.6.32-5 0
100 /var/lib/dpkg/status


La table de version ne contient que ta base dpkg, et aucun dépôt Debian.
Par exemple :

# apt-cache policy linux-image-2.6-amd64
linux-image-2.6-amd64:
Installé : 2.6.32+27
Candidat : 2.6.32+27
Table de version :
*** 2.6.32+27 0
990 http://routeur squeeze/main Packages
1 http://routeur unstable/main Packages
100 /var/lib/dpkg/status

Cela me semble correct.
Amitiés.
Philippe




Cordialement,
Christophe

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
daniel huhardeaux
Le #22292501
Le 24/06/2010 12:30, Courrier Debian a écrit :
Le jeudi 24 juin 2010 11:45:39, Sylvain Sauvage a écrit :

Courrier Debian, jeudi 24 juin 2010, 11:25:10 CEST


[…]

Je suis certainement d'accord avec toi, mais si je fait un :
dpkg -l|grep 2.6.32

[…]

et il me semble que le 2.6.32-trunk-amd64 existe toujours.



dpkg -l ne t’indique que les paquets installés. Donc,
évidemment, puisque tu n’as que le -trunk d’installé, tu ne
risques pas d’y voir le -5.

aptitude/apt-cache search/policy sont tes amis.

Pascal Hambourg, jeudi 24 juin 2010, 11:27:40 CEST


[…]

Soit, mais je suis curieux : en quoi cela peut-il provoquer l'erreur
ci-dessus ? Un générateur d'initramfs qui ne marche que pour la version
courante du noyau, ça ne me paraît pas très fiable.



Mon hypothèse était plutôt que c’est un générateur d’initramfs
qui ne marche pas pour la version -trunk du paquet ; paquet
obsolète certainement pour de bonnes raisons.

L’idée est donc : installer un paquet encore disponible donc
encore maintenu et vérifier si ça coince ou non. Personne n’a
signalé de bogue donc il semble que l’installation de Philippe
est en cause. Un bogue avec un paquet qui n’existe plus étant
difficile à reproduire chez les autres, si le problème persiste
avec le paquet courant, on avisera…



Je complète un :
apt-cache policy linux-image-2.6.32-trunk-amd64
linux-image-2.6.32-trunk-amd64:
Installé : 2.6.32-5
Candidat :2.6.32-5


Chez moi:

#sudo apt-cache policy linux-image-2.6.32-trunk-amd64
W: Impossible de trouver le paquet linux-image-2.6.32-trunk-amd64

#sudo aptitude search linux-image
v linux-image -
v linux-image-2.6 -
p
linux-image-2.6-amd64 -
Linux 2.6 for 64-bit PCs (meta-package)
p
linux-image-2.6-openvz-amd64 -
Linux 2.6 for 64-bit PCs (meta-package), OpenVZ support
p
linux-image-2.6-vserver-amd64 -
Linux 2.6 for 64-bit PCs (meta-package), Linux-VServer support
p
linux-image-2.6-xen-amd64 -
Linux 2.6 for 64-bit PCs (meta-package), Xen dom0 support, Xen dom0 support
c
linux-image-2.6.17-2-amd64 -
Linux 2.6.17 image on AMD64
i
linux-image-2.6.32-4-amd64 -
Linux 2.6.32 for 64-bit PCs
i
linux-image-2.6.32-5-amd64 -
Linux 2.6.32 for 64-bit PCs
p
linux-image-2.6.32-5-amd64-dbg -
Debugging infos for Linux 2.6.32-5-amd64
p
linux-image-2.6.32-5-openvz-amd64 -
Linux 2.6.32 for 64-bit PCs, OpenVZ support
p
linux-image-2.6.32-5-openvz-amd64-dbg -
Debugging infos for Linux 2.6.32-5-openvz-amd64
p
linux-image-2.6.32-5-vserver-amd64 -
Linux 2.6.32 for 64-bit PCs, Linux-VServer support
p
linux-image-2.6.32-5-vserver-amd64-dbg -
Debugging infos for Linux 2.6.32-5-vserver-amd64
p
linux-image-2.6.32-5-xen-amd64 -
Linux 2.6.32 for 64-bit PCs, Xen dom0 support
p
linux-image-2.6.32-5-xen-amd64-dbg -
Debugging infos for Linux 2.6.32-5-xen-amd64
p
linux-image-amd64 -
Linux for 64-bit PCs (meta-package)
p
linux-image-openvz-amd64 -
Linux for 64-bit PCs (meta-package), OpenVZ support
p
linux-image-vserver-amd64 -
Linux for 64-bit PCs (meta-package), Linux-VServer support
p linux-image-xen-amd64

#sudo aptitude search trunk
ne retourne rien

--
Daniel

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Pascal Hambourg
Le #22292541
Sylvain Sauvage a écrit :

Pascal Hambourg, jeudi 24 juin 2010, 11:27:40 CEST

Soit, mais je suis curieux : en quoi cela peut-il provoquer l'erreur
ci-dessus ? Un générateur d'initramfs qui ne marche que pour la version
courante du noyau, ça ne me paraît pas très fiable.



Mon hypothèse était plutôt que c'est un générateur d'initramfs
qui ne marche pas pour la version -trunk du paquet



Une idée de ce que cette version -trunk aurait de particulier, et de ce
que la nouvelle version d'initramfs-tools aurait de particulier aussi
puisqu'apparemment les versions précédentes fonctionnaient avec le noyau
-trunk ?

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme