Insertion champ "telephone"

Le
Philippe
Bonjour

J'utilise Office 2003.
Lorsque je veux insérer dans Wored un champ correspondant à un n° de
telephone pris dans Excel (format cellule spécial numero de telephone) le
champ insere dans Word ne conserve pas la mise en forme.
Il devient 1234567 au lieu de 01 23 45 67. Pouvez-vous m'aider
Cordialement
Philippe D
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Tisane
Le #1678421
Bonjour Philippe,

Lorsque je veux insérer dans Wored un champ correspondant à un n° de
telephone pris dans Excel (format cellule spécial numero de telephone) le
champ insere dans Word ne conserve pas la mise en forme.
Il devient 1234567 au lieu de 01 23 45 67. Pouvez-vous m'aider


Si tes numéros sont issus d'une fusion, tu peux :
- soit ajouter le commutateur # "00 00 00 00 00"
<Alt><F9> pour afficher/masquer les codes de champs
{ MERGEFIELD "Ton_Champ" # "00 00 00 00 00" }

- soit imposer le protocole DDE si tu n'as qu'une feuille dans le classeur
ou si elle est en première position :
- menu Outils | Options, onglet [Général],
- coche "Confirmation des conversions lors de l'ouverture"
- resélectionne ta source de données
- choisis DDE (Échange dynamique de données)

--
Tisane

Philippe
Le #1678420
Bonjour
Merci cela est parfait avec la 1er solution
Philippe

"Tisane"
Bonjour Philippe,

Lorsque je veux insérer dans Wored un champ correspondant à un n° de
telephone pris dans Excel (format cellule spécial numero de telephone) le
champ insere dans Word ne conserve pas la mise en forme.
Il devient 1234567 au lieu de 01 23 45 67. Pouvez-vous m'aider


Si tes numéros sont issus d'une fusion, tu peux :
- soit ajouter le commutateur # "00 00 00 00 00"
<Alt><F9> pour afficher/masquer les codes de champs
{ MERGEFIELD "Ton_Champ" # "00 00 00 00 00" }

- soit imposer le protocole DDE si tu n'as qu'une feuille dans le classeur
ou si elle est en première position :
- menu Outils | Options, onglet [Général],
- coche "Confirmation des conversions lors de l'ouverture"
- resélectionne ta source de données
- choisis DDE (Échange dynamique de données)

--
Tisane



Anacoluthe
Le #1678419
Bonjour !

'Philippe' nous a écrit ...
Lorsque je veux insérer dans Wored un champ correspondant à un n° de
telephone pris dans Excel (format cellule spécial numero de telephone) le
champ insere dans Word ne conserve pas la mise en forme.
Il devient 1234567 au lieu de 01 23 45 67. Pouvez-vous m'aider


On peut évidemment formater dans Word un champ numérique avec un commutateur*

Mais vous devriez plutôt revoir ça dans Excel : un numéro de téléphone
n'est PAS une donnée /numérique/ à laquelle on appliquerait un format.
C'est une donnée /textuelle/ : songez aux numéros étrangers, aux indicatifs
avec parenthèses ou tirets, aux zéros significatifs etc
Vous pouvez rétablir dans Excel ce type correct (et conseillé) de données
avec la fonction TEXTE(valeur;format)

Anacoluthe
« J'ai toujours rêvé d'un ordinateur qui soit aussi facile
à utiliser qu'un téléphone. Mon rêve s'est réalisé :
je ne sais plus comment utiliser mon téléphone. »
- Bjarne STROUSTRUP

Philippe
Le #1678418
Bonjour
Effectivement en saississant dans Excel le format special Telephone j'ai des
soucis pour les utiliser dans d'autres applis et notamment avec le 0.
Comment puis-je faire avec la fonction texte pour que le 1234567 soit 01 23
45 67 dans Excel
Excuser de mettre cette demande dans forum Word mais c'est pour la réponse
de Anacoluthe
Merci
Philippe

"Anacoluthe" %
Bonjour !

'Philippe' nous a écrit ...
Lorsque je veux insérer dans Wored un champ correspondant à un n° de
telephone pris dans Excel (format cellule spécial numero de telephone) le
champ insere dans Word ne conserve pas la mise en forme.
Il devient 1234567 au lieu de 01 23 45 67. Pouvez-vous m'aider


On peut évidemment formater dans Word un champ numérique avec un
commutateur*

Mais vous devriez plutôt revoir ça dans Excel : un numéro de téléphone
n'est PAS une donnée /numérique/ à laquelle on appliquerait un format.
C'est une donnée /textuelle/ : songez aux numéros étrangers, aux
indicatifs
avec parenthèses ou tirets, aux zéros significatifs etc
Vous pouvez rétablir dans Excel ce type correct (et conseillé) de données
avec la fonction TEXTE(valeur;format)

Anacoluthe
« J'ai toujours rêvé d'un ordinateur qui soit aussi facile
à utiliser qu'un téléphone. Mon rêve s'est réalisé :
je ne sais plus comment utiliser mon téléphone. »
- Bjarne STROUSTRUP



Anacoluthe
Le #1678414
Bonjour !

'Philippe' nous a écrit ...
Comment puis-je faire avec la fonction texte pour que le 1234567 soit 01 23
45 67 dans Excel


Créez une colonne où vous placerez la formule:
=TEXTE(A:A;Telephone) [On suppose les numéros en colonne A]
avec Insertion / Nom / Définir / Telephone 0#" "##" "##" "##" "##
où les 4 espaces séparateurs sont mis entre guillemets simples
Si vous utilisez le format directement, il faut en plus doubler les guillemets
=TEXTE(A1;"0#"" ""##"" ""##"" ""##"" ""##")
Ce n'est effectivement pas très simple comme format avec tous ces guillemets

Ensuite coupez-collez-spécial-comme-valeurs cette colonne et supprimez
la colonne des numéros de téléphone 'numériques'

Anacoluthe
« J'ai toujours rêvé d'un ordinateur qui soit aussi facile
à utiliser qu'un téléphone. Mon rêve s'est réalisé :
je ne sais plus comment utiliser mon téléphone. »
- Bjarne STROUSTRUP

Publicité
Poster une réponse
Anonyme