Install sur PPC (suite)

Le
tyranorl
Salut à tous,

Donc, me revoilà, avec mon install sur PPC. Donc, pour l'install, en dehors de
l'utilitaire de partitionnement de Mac OS X, dont il est dit qu'il est erratique
(j'irais plus loin, en ce qui me concerne), l'install s'est bien passée.

J'en suis à compiler un noyau maison patché temps réel, etc.
Mais, le problème, c'est que lorsque je veux actualiser yaboot pour qu'il puisse
booter sur le nouveau noyau, je me retrouve avec cette erreur :

bartok-184:/home/bela# ybin -v
ybin: Finding OpenFirmware device path to `/dev/sda2'
ofpath: /proc/scsi/scsi does not exist
ofpath: Make sure you compiled your kernel with CONFIG_SCSI_PROC_FS=y
ybin: Unable to find OpenFirmware path for boot=/dev/sda2
ybin: Please add ofboot=<path> where <path> is the OpenFirmware path to
/dev/sda2 to /etc/yaboot.conf
ybin: Finding OpenFirmware device path to `/dev/sda3'
ofpath: /proc/scsi/scsi does not exist
ofpath: Make sure you compiled your kernel with CONFIG_SCSI_PROC_FS=y
ybin: Unable to determine OpenFirmware path for macosx=/dev/sda3
ybin: Try specifying the real OpenFirmware path for macosx=/dev/sda3 in
/etc/yaboot.conf


En pratique, en effet, pas de /proc/scsi, puisque sysfs est utilisé (il me
semble que ça fait un moment que c'est comme ça, non ?), et il s'agit là de la
config du système après upgrade en squeeze (mais pour le reste, rien touché
personellement, encore).

Du coup, je ne sais pas bien quoi faire. Il y a bien l'option de rentrer le path
OpenFirmware mais je ne sais pas bien ce que c'est ni ou le trouver, donc dans
l'immédiat, ça me tente moyen d'essayer ça.

Qu'en pensez-vous ?

Merci

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Samy Mezani
Le #20968601
le 13/01/2010 19:18, a écrit:

Mais, le problème, c'est que lorsque je veux actualiser yaboot pour qu'il puisse
booter sur le nouveau noyau, je me retrouve avec cette erreur :

bartok-184:/home/bela# ybin -v
ybin: Finding OpenFirmware device path to `/dev/sda2'...
ofpath: /proc/scsi/scsi does not exist
ofpath: Make sure you compiled your kernel with CONFIG_SCSI_PROC_FS=y
ybin: Unable to find OpenFirmware path for boot=/dev/sda2
ybin: Please add ofboot=<path> where <path> is the OpenFirmware path to
/dev/sda2 to /etc/yaboot.conf


[...]

Salut,

Comme ça, sans creuser, t'es sûr que ton "path" ne devrait pas être du
type /dev/hdaX plutôt ?

Samy


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Aurelien
Le #20974491
On Wed, Jan 13, 2010 at 08:32:31PM +0100, Samy Mezani wrote :
le 13/01/2010 19:18, a écrit:

>Mais, le problème, c'est que lorsque je veux actualiser yaboot pour qu'il puisse
>booter sur le nouveau noyau, je me retrouve avec cette erreur :
>
>bartok-184:/home/bela# ybin -v
>ybin: Finding OpenFirmware device path to `/dev/sda2'...
>ofpath: /proc/scsi/scsi does not exist
>ofpath: Make sure you compiled your kernel with CONFIG_SCSI_PROC_FS=y
>ybin: Unable to find OpenFirmware path for boot=/dev/sda2
>ybin: Please add ofboot=<path> where <path> is the OpenFirmware path to
>/dev/sda2 to /etc/yaboot.conf
[...]

Salut,

Comme ça, sans creuser, t'es sûr que ton "path" ne devrait pas être
du type /dev/hdaX plutôt ?



Non, il s'agit bien de disque SATA. En fait, j'ai réussi à m'en sortir
en utilisant l'ofpath (en cherchant dans /proc/device-tree et en
composant à partir de ce qu'on peut trouver d'écrit dans
/etc/yaboot.conf - la ligne device, notamment).

Par contre, mon noyau RT se vautre pour l'instant, mais j'ai pas encore
eu le temps de voir ça en détail (il était tard, et j'ai pas pu m'y
replonger pour l'instant.

Je vous redis ça !


Samy


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS




--
Aurélien

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Aurelien
Le #21004431
Bon me revoici.

Donc, j'en étais là où j'en étais, à savoir un noyau temps-réel qui
merdait, mais celui d'origine sur lequel je pouvais toujours booter pour
remplacer.
Sauf que, sauf que. Ce matin, je veux reprendre les choses à plat, et
là, kernel panic sur tous les noyaux !!! :

Begin: Mounting root file system ... /init: line 196: divide by zero
Kernel panic - not syncing. Attempted to kill init

(évidemment la ligne 196 change en fonction des noyaux)

Donc, si je comprends bien un problème avec les initramfs, mais bon, je
n'y ai pas touché (ou en tout cas pas de manière directe, ni réellement
indirecte, en fait).
Je n'arrive pas à identifier l'action que j'ai pu faire entre temps qui
mène à ça....

Bref, vu que j'ai des délais assez courts, je réinstalle du début, mais
je suis preneur d'explications s'il y a.

Tcho !


On Thu, Jan 14, 2010 at 09:42:49PM +0100, Aurelien wrote :
On Wed, Jan 13, 2010 at 08:32:31PM +0100, Samy Mezani wrote :
> le 13/01/2010 19:18, a écrit:
>
> >Mais, le problème, c'est que lorsque je veux actualiser yaboot pour qu'il puisse
> >booter sur le nouveau noyau, je me retrouve avec cette erreur :
> >
> >bartok-184:/home/bela# ybin -v
> >ybin: Finding OpenFirmware device path to `/dev/sda2'...
> >ofpath: /proc/scsi/scsi does not exist
> >ofpath: Make sure you compiled your kernel with CONFIG_SCSI_PROC_FS=y
> >ybin: Unable to find OpenFirmware path for boot=/dev/sda2
> >ybin: Please add ofboot=<path> where <path> is the OpenFirmware path to
> >/dev/sda2 to /etc/yaboot.conf
> [...]
>
> Salut,
>
> Comme ça, sans creuser, t'es sûr que ton "path" ne devrait pas être
> du type /dev/hdaX plutôt ?

Non, il s'agit bien de disque SATA. En fait, j'ai réussi à m'en sortir
en utilisant l'ofpath (en cherchant dans /proc/device-tree et en
composant à partir de ce qu'on peut trouver d'écrit dans
/etc/yaboot.conf - la ligne device, notamment).

Par contre, mon noyau RT se vautre pour l'instant, mais j'ai pas encore
eu le temps de voir ça en détail (il était tard, et j'ai pas pu m'y
replonger pour l'instant.

Je vous redis ça !

>
> Samy
>
>
> --
> Lisez la FAQ de la liste avant de poser une question :
> http://wiki.debian.org/fr/FrenchLists
>
> Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
> vers
> En cas de soucis, contactez EN ANGLAIS
>

--
Aurélien

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS




--
Aurélien

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Publicité
Poster une réponse
Anonyme