Installation de LFTP

Le
romer
Hi,

J'installe la dernière version 4.6.4 de LFTP mais quand je rgarde d'un
peu plus près, je vois que c'est la précédente qui fonctionne.
En faisant dans le terminal 'brew install lftp', j'obtiens l'alerte
suivante :
lftp-4.6.4 already installed, it's just not linked

Question : que faire pour "linker" ;) cette version et la rendre
opérationnelle ?

Thx
--
A+
--
Romer
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Matt
Le #26375487
On Jeu 29 octobre 2015 (16:29),
Bernd
Hi,



Hello,

J'installe la dernière version 4.6.4 de LFTP mais quand je rgarde d'un
peu plus près, je vois que c'est la précédente qui fonctionne.
En faisant dans le terminal 'brew install lftp', j'obtiens l'alerte
suivante :
lftp-4.6.4 already installed, it's just not linked

Question : que faire pour "linker" ;) cette version et la rendre
opérationnelle ?

Thx



Regarde combien de lftp ton shell connaît avec `type -a lftp` (le
premier de la liste est celui qui sera lancé).

--
<Stragus> qui a internet ici?
* http://bashfr.org/?80
romer
Le #26375490
Matt
> J'installe la dernière version 4.6.4 de LFTP mais quand je rgarde d'un
> peu plus près, je vois que c'est la précédente qui fonctionne.
> En faisant dans le terminal 'brew install lftp', j'obtiens l'alerte
> suivante :
> lftp-4.6.4 already installed, it's just not linked

> Question : que faire pour "linker" ;) cette version et la rendre
> opérationnelle ?

Regarde combien de lftp ton shell connaît avec `type -a lftp` (le
premier de la liste est celui qui sera lancé).



Apparemment un seul. Voici le résultat e la commande que tu indiques :
"usr/local/bin/lftp"

--
A+
--
Romer
Matt
Le #26375489
On Dim 01 novembre 2015 (22:50),
Bernd
Apparemment un seul. Voici le résultat e la commande que tu indiques :
"usr/local/bin/lftp"



Regarde si c'est un lien symbolique avec `ls -al`.
Si c'est le cas, supprime-le et crée un nouveau lien avec ln(1) pointant
sur le nouveau lftp.

--
<Louloute> JosS, t'es revenu?
<JosS> Louloute, nan, je fais semblant là
* http://bashfr.org/?117
romer
Le #26375530
Matt
On Dim 01 novembre 2015 (22:50),
Bernd
> Apparemment un seul. Voici le résultat e la commande que tu indiques :
> "usr/local/bin/lftp"

Regarde si c'est un lien symbolique avec `ls -al`.
Si c'est le cas, supprime-le et crée un nouveau lien avec ln(1) pointant
sur le nouveau lftp.



Ce n'est pas un lien symbolique - c'est l'exécutable Unix. Si je le
lance, il m'ouvre lftp et qd je regarde sa version, c'est la 4.6.0 alors
que j'ai installé la dernière (4.6.4) qui apparemment n'est pas trouvée
pour une qestion de lien qui ne se fait pas.
Où donc se niche la nouvelle version ?

--
A+
--
Romer
romer
Le #26375532
Bernd
Matt
> On Dim 01 novembre 2015 (22:50),
> Bernd >
> > Apparemment un seul. Voici le résultat e la commande que tu indiques :
> > "usr/local/bin/lftp"
>
> Regarde si c'est un lien symbolique avec `ls -al`.
> Si c'est le cas, supprime-le et crée un nouveau lien avec ln(1) pointant
> sur le nouveau lftp.

Ce n'est pas un lien symbolique - c'est l'exécutable Unix. Si je le
lance, il m'ouvre lftp et qd je regarde sa version, c'est la 4.6.0 alors
que j'ai installé la dernière (4.6.4) qui apparemment n'est pas trouvée
pour une qestion de lien qui ne se fait pas.
Où donc se niche la nouvelle version ?



Je viens de réinstaller lftp dernière version.
Il ne se trouve pas dans /usr/local/bin/lftp
mais ici :

/usr/local/Cellar/lftp

Donc, que faire pour l'atteindre ?

Thx

--
A+
--
Romer
Matt
Le #26375644
On Lun 02 novembre 2015 (12:17),
Bernd
Je viens de réinstaller lftp dernière version.
Il ne se trouve pas dans /usr/local/bin/lftp
mais ici :

/usr/local/Cellar/lftp

Donc, que faire pour l'atteindre ?




Si j'ai bien compris il te faut faire `brew link lftp`.

--
<Krosan> Combien de fois vais-je devoir te le dire?! La sodomie n'est pas un
pays!
* http://bashfr.org/?4683
romer
Le #26375700
Matt
> Je viens de réinstaller lftp dernière version.
> Il ne se trouve pas dans /usr/local/bin/lftp
> mais ici :

> /usr/local/Cellar/lftp

> Donc, que faire pour l'atteindre ?


Si j'ai bien compris il te faut faire `brew link lftp`.



J'ai fait tout cela mais la conséquence fut funeste pour lftp. Il ne
répond plus et n'est plus reconnu.
J'avais un clone très récent du systéme et en qq minutes tout est
revenu normal (avec la version 4.6.0 évidemment).
Donc pour l'instant, j'en reste là. Après tout cette 4.6.0 marche bien.
Merci de tous ces tuyaux.
La seule question qui reste pourtant est cette alerte après install de
la dernière version : "4.6.4 is already installed but just not linked".
Faudrait un forum sur lftp mais il n'a pas l'air d'exister.
--
A+
--
Romer
Matt
Le #26375845
On Mar 03 novembre 2015 (13:25),
Bernd
J'ai fait tout cela mais la conséquence fut funeste pour lftp. Il ne
répond plus et n'est plus reconnu.
J'avais un clone très récent du systéme et en qq minutes tout est
revenu normal (avec la version 4.6.0 évidemment).
Donc pour l'instant, j'en reste là. Après tout cette 4.6.0 marche bien.
Merci de tous ces tuyaux.
La seule question qui reste pourtant est cette alerte après install de
la dernière version : "4.6.4 is already installed but just not linked".



Alors crée un lien symbolique directement.

Faudrait un forum sur lftp mais il n'a pas l'air d'exister.



lftp marche très bien, le problème vient de brew. Essaye de trouver un
forum ou une liste de discussion sur ce logiciel.

--
[eagle1792] : Tu sais que l'amour rend con?
[sephiroth] : Tu doit être vachement amoureux eagle.
* http://bashfr.org/?4298
romer
Le #26375887
Matt
On Mar 03 novembre 2015 (13:25),
Bernd
> J'ai fait tout cela mais la conséquence fut funeste pour lftp. Il ne
> répond plus et n'est plus reconnu.
> J'avais un clone très récent du systéme et en qq minutes tout est
> revenu normal (avec la version 4.6.0 évidemment).
> Donc pour l'instant, j'en reste là. Après tout cette 4.6.0 marche bien.
> Merci de tous ces tuyaux.
> La seule question qui reste pourtant est cette alerte après install de
> la dernière version : "4.6.4 is already installed but just not linked".

Alors crée un lien symbolique directement.



Ok - ça vient de marcher comme cela - je me suis branché sur le DD
interne NAS de la Box en version 4.6.4 et en obtiens toute
l'arborescence.
Mais je n'ai pas les nombreux alias créés pour les actions directes de
sauvegarde et DL/UL
Je pense qu'il faut regarder de plus près lftp.conf et le remplacer par
l'ancien - ça devrait rouler, je le sens :-)
Merci de ton aide.

--
A+
--
Romer
Publicité
Poster une réponse
Anonyme