Installation Lubuntu sur carte SD

Le
pehache
Bonjour,

sur un eeepc 701 j'ai installé Lubuntu sur une carte SD, en utilisant le
disque interne (dont les 4Go devenaient vraiment trop justes) pour la
partition de swap.

Au premier reboot après installation je me prends un grub-error ("unknow
filesystem" ou un truc du genre) Logique je me dis, il faut que
j'aille dans le BIOS pour déclarer le lecteur de carte comme disque de
démarrage. Ce que je fais, et du coup ça marche (et au passage Lubuntu
me parait impeccable)

Néanmoins il y a un truc qui m'échappe : vu que l'OS a été installé sur
la carte SD et que l'eeepc a tenté de booter sur le disque interne,
qu'est-ce que grub vient faire dans cette histoire ?? C'est le grub
résiduel de Xubuntu qui était auparavant installé sur le disque interne ?

Merci de l'éclaircissement (autant Lilo je comprenais, autant Grub c'est
du chinois total pour moi)
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
jp willm
Le #24718602
Le 24/08/2012 20:15, pehache a écrit :

Néanmoins il y a un truc qui m'échappe : vu que l'OS a été installé sur
la carte SD et que l'eeepc a tenté de booter sur le disque interne,
qu'est-ce que grub vient faire dans cette histoire ?? C'est le grub
résiduel de Xubuntu qui était auparavant installé sur le disque interne ?



Si tu n'as rien spécifié durant l'installation, le grub s'est sans doute
installé sur le MBR du "disque" interne de ton pc (sda).


Merci de l'éclaircissement (autant Lilo je comprenais, autant Grub c'est
du chinois total pour moi)




On fini par s'y faire et même apprécier les possibilités.

--
http://perso.orange.fr/willms/index.html
pehache
Le #24718922
Le 24/08/12 21:23, jp willm a écrit :
Le 24/08/2012 20:15, pehache a écrit :

Néanmoins il y a un truc qui m'échappe : vu que l'OS a été installé sur
la carte SD et que l'eeepc a tenté de booter sur le disque interne,
qu'est-ce que grub vient faire dans cette histoire ?? C'est le grub
résiduel de Xubuntu qui était auparavant installé sur le disque interne ?



Si tu n'as rien spécifié durant l'installation, le grub s'est sans doute
installé sur le MBR du "disque" interne de ton pc (sda).




Pendant l'installation j'ai simplement spécifié de mettre / sur sdc1 et
d'utiliser sda1 pour le swap.

Si grub s'est installé sur sda, pourquoi fait-il une erreur quand le pc
tente de booter sur sda ?
jp willm
Le #24719332
Le 24/08/2012 23:31, pehache a écrit :

Pendant l'installation j'ai simplement spécifié de mettre / sur sdc1 et
d'utiliser sda1 pour le swap.



Et tu as dû louper une option (un bouton à cliquer) qui te permet de
spécifier où tu veux installer grub.

Ici on parle de la première partie de grub, les quelques octet que l'on
peut mettre dans une amorce d'une partition ou sur le MBR du premier
disque ; c'est l'option par défaut.

La deuxième partie est sur /boot/grub et les fichiers de configuration,
eux, sont sur /etc/default/grub)


Si grub s'est installé sur sda, pourquoi fait-il une erreur quand le pc
tente de booter sur sda ?


Avec ou sans la carte sd ?

Ensuite, booter sur un carte SD, peut poser des problèmes auxquels je ne
suis par rôdé :o|

--
http://perso.orange.fr/willms/index.html
pehache
Le #24719592
Le 25/08/12 10:08, jp willm a écrit :
Le 24/08/2012 23:31, pehache a écrit :

Pendant l'installation j'ai simplement spécifié de mettre / sur sdc1 et
d'utiliser sda1 pour le swap.



Et tu as dû louper une option (un bouton à cliquer) qui te permet de
spécifier où tu veux installer grub.



C'est possible, mais je n'ai vraiment pas le souvenir d'avoir eu cette
option sous les yeux. Je réessayerai de débuter l'installation pour voir
si il y a quelque chose.


Ici on parle de la première partie de grub, les quelques octet que l'on
peut mettre dans une amorce d'une partition ou sur le MBR du premier
disque ; c'est l'option par défaut.

La deuxième partie est sur /boot/grub et les fichiers de configuration,
eux, sont sur /etc/default/grub)


Si grub s'est installé sur sda, pourquoi fait-il une erreur quand le pc
tente de booter sur sda ?


Avec ou sans la carte sd ?



Avec :-)

Je la laisse à demeure, maintenant qu'il y a l'OS dessus...


Ensuite, booter sur un carte SD, peut poser des problèmes auxquels je ne
suis par rôdé :o|




Bah, c'est un disque comme un autre, non ?

Bon, jusqu'à preuve du contraire je vais supposer que grub s'est
installé sur sdc, et que sda contient le résidu de grub de l'OS
précédent qui était sur sda (et que j'ai écrasé en reformattant sda1
pehache
Le #24719972
Le 25/08/12 12:25, pehache a écrit :
Le 25/08/12 10:08, jp willm a écrit :
Le 24/08/2012 23:31, pehache a écrit :

Pendant l'installation j'ai simplement spécifié de mettre / sur sdc1 et
d'utiliser sda1 pour le swap.



Et tu as dû louper une option (un bouton à cliquer) qui te permet de
spécifier où tu veux installer grub.



C'est possible, mais je n'ai vraiment pas le souvenir d'avoir eu cette
option sous les yeux. Je réessayerai de débuter l'installation pour voir
si il y a quelque chose.



Arf, si elle y était ;-), je l'avais ratée en effet

Et par défaut c'est sur sdc que grub a été installé (donc logique que ça
ne boote pas du tout sur sda, où il devait y avoir le grub antérieur à
lubuntu).
jp willm
Le #24720172
Le 25/08/2012 16:02, pehache a écrit :

Arf, si elle y était ;-), je l'avais ratée en effet



;o)


Et par défaut c'est sur sdc que grub a été installé (donc logique que ça
ne boote pas du tout sur sda, où il devait y avoir le grub antérieur à
lubuntu).



CQFD
Merci pour le retour d'info !

@+

--
jp willm
http://perso.orange.fr/willms/index.html
Publicité
Poster une réponse
Anonyme