installation msttcorefonts impossible sous debian Etch ?

Le
Bernard
Bonjour à tous,

J'ai installé sans problème, il y a 18 mois, ces polices sur mon desktop
sous Debian Sarge. Hier et aujourd'hui, j'ai essayé de refaire cette
install sur mon portable sous Debian Etch mais là, çà n'a pas
marché !

#apt-get install msttcorefonts

a bien commencé le processus, jusqu'à ce que l'on arrive au
téléchargement de chacune des polices et là, toujours la même chose
à chaque tentative : connexion terminée par expiration du délai
d'attente ! Aucune police true type n'est donc installée.

Merci pour vos suggestions pour contourner ce problème. Je n'ai pas de
souci de connexion, car n'importe quelle autre installation avec apt-get,
fonctionne normalement.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jonathan ROTH
Le #17826491
Le 12.11.2008 20:59, Bernard s'exprima:
Bonjour à tous,



a bien commencé le processus, jusqu'à ce que l'on arrive au
téléchargement de chacune des polices... et là, toujours la même chose
à chaque tentative : connexion terminée par expiration du délai
d'attente ! Aucune police true type n'est donc installée.



Je viens tout juste d'installer msttcorefonts sur une lenny, aucun
soucis. Ca doit être un problème chez sourceforge, ça arrive de temps en
temps.

Tu as retenté d'installer ?
Bernard
Le #17826851
Le Wed, 12 Nov 2008 23:25:56 +0100, Jonathan ROTH a écrit :

Le 12.11.2008 20:59, Bernard s'exprima:
Bonjour à tous,



a bien commencé le processus, jusqu'à ce que l'on arrive au
téléchargement de chacune des polices... et là, toujours la même
chose à chaque tentative : connexion terminée par expiration du délai
d'attente ! Aucune police true type n'est donc installée.



Je viens tout juste d'installer msttcorefonts sur une lenny, aucun soucis.
Ca doit être un problème chez sourceforge, ça arrive de temps en temps.

Tu as retenté d'installer ?



Oui, j'ai essayé au moins trois fois depuis 48 heures, et la dernière
fois il y a moins d'une heure. Par ailleurs, chaque fois que j'installe
quelque chose d'autre par apt-get, à la fin de l'installation le système
va à nouveau me rechercher les fontes sur les serveurs inaccessibles : je
pense qu'il est écrit quelque part dans ma config que l'installation des
fontes n'était pas terminée, et que çà repart. Il se pourrait qu'il y
ait un bug dans le fichier de config qui se trouve dans le répertoire
pour Etch, et que pour Lenny ce bug ait été corrigé: en effet, cette
police nommée 'andale32.exe', çà a plutôt l'air d'être une police
pour MSWindows, non ? Sur mon desktop, j'ai des fontes du genre
'andale.ttf', mais rien en exe...

Je vais tenter de voir dans le répertoire pour Lenny, voire dans celui
pour Sarge...
Jonathan ROTH
Le #17826841
Le 12.11.2008 23:54, Bernard s'exprima:
Tu as retenté d'installer ?



Oui, j'ai essayé au moins trois fois depuis 48 heures, et la dernière
fois il y a moins d'une heure. Par ailleurs, chaque fois que j'installe
quelque chose d'autre par apt-get, à la fin de l'installation le système
va à nouveau me rechercher les fontes sur les serveurs inaccessibles : je
pense qu'il est écrit quelque part dans ma config que l'installation des
fontes n'était pas terminée, et que çà repart.



Tout à fait normal, le téléchargement est dans le script postinst.

Il se pourrait qu'il y
ait un bug dans le fichier de config qui se trouve dans le répertoire
pour Etch, et que pour Lenny ce bug ait été corrigé:



Euh, possible mais peu probable.

en effet, cette
police nommée 'andale32.exe', çà a plutôt l'air d'être une police
pour MSWindows, non ? Sur mon desktop, j'ai des fontes du genre
'andale.ttf', mais rien en exe...



Non, c'est tout à fait normal: Microsoft avait fourni, à l'époque, ces
polices dans le but de permettre l'interopérabilité. Elle les a fournies
compressées dans des CAB auto-extractibles, et avec l'obligation de
redistribuer uniquement ces polices dans le forme d'origine.

Je vais tenter de voir dans le répertoire pour Lenny, voire dans celui
pour Sarge...


Bernard
Le #17827221
Le Thu, 13 Nov 2008 00:01:28 +0100, Jonathan ROTH a écrit :

Le 12.11.2008 23:54, Bernard s'exprima:
Tu as retenté d'installer ?



Oui, j'ai essayé au moins trois fois depuis 48 heures, et la dernière
fois il y a moins d'une heure. Par ailleurs, chaque fois que j'installe
quelque chose d'autre par apt-get, à la fin de l'installation le
système va à nouveau me rechercher les fontes sur les serveurs
inaccessibles : je pense qu'il est écrit quelque part dans ma config
que l'installation des fontes n'était pas terminée, et que çà
repart.



Tout à fait normal, le téléchargement est dans le script postinst.

Il se pourrait qu'il y
ait un bug dans le fichier de config qui se trouve dans le répertoire
pour Etch, et que pour Lenny ce bug ait été corrigé:



Euh, possible mais peu probable.

en effet, cette
police nommée 'andale32.exe', çà a plutôt l'air d'être une police
pour MSWindows, non ? Sur mon desktop, j'ai des fontes du genre
'andale.ttf', mais rien en exe...



Non, c'est tout à fait normal: Microsoft avait fourni, à l'époque, ces
polices dans le but de permettre l'interopérabilité. Elle les a fournies
compressées dans des CAB auto-extractibles, et avec l'obligation de
redistribuer uniquement ces polices dans le forme d'origine.

Je vais tenter de voir dans le répertoire pour Lenny, voire dans celui
pour Sarge...





Je viens de faire cette expérience: dans /etc/apt/sources.list, j'ai
coché avec des # toutes les précédentes lignes opérationnelles avec
des adresses en France, et les ai remplacées par deux lignes:

deb http://http.us.debian.org/debian/ lenny main contrib non-free
deb-src http://http.us.debian.org/debian/ lenny main contrib non-free

et, après un apt-get update, on recommence l'install des msttcorefonts
après avoir désinstallé la précédente. Eh bien, à ma surprise, les
choses se sont passées exactement comme précédemment, les mêmes liens
ont été appelés et les mêmes erreurs de timeout. Alors je n'y
comprends rien. Ces adresses de sourceforge, inopérantes, apparemment ce
sont les mêmes auxquelles le serveur américain fait appel, et ce, même
dans le répertoire pour Lenny (alors que mes précédents problèmes
étaient avec les fichiers du répertoire pour Etch)?
Se pourrait il que ces adresses http inopérantes soient inscrites dans
un fichier de
config sur mon système ? Bien étrange tout de même que çà fonctionne
chez vous, et non pas chez moi ? Je ne veux pas réessayer sur mon
desktop (d'où vous parviennent ces lignes, sous Sarge), car, d'abord,
apparemment les fichiers pour Sarge ne sont plus disponibles, et enfin,
comme sur ce desktop çà fonctionne, j'ai peur de faire des bétises qui
vont demander des heures à réparer ensuite :)

Je ne sais donc toujours pas comment m'en sortir...
Fabien LE LEZ
Le #17827881
On Thu, 13 Nov 2008 00:33:22 +0100, Bernard
Eh bien, à ma surprise, les
choses se sont passées exactement comme précédemment, les mêmes liens
ont été appelés et les mêmes erreurs de timeout. [...]
Se pourrait il que ces adresses http inopérantes soient inscrites dans
un fichier de config sur mon système ?



Non, le .deb, au lieu de contenir les fichiers à installer, est en
fait un programme qui télécharge les polices en question.

Plus précisément, le .deb contient, entre autres, le fichier
/usr/sbin/update-ms-fonts, qui télécharge plusieurs fichiers, en
essayant plusieurs adresses.

Essaie la commande suivante :

wget http://surfnet.dl.sourceforge.net/sourceforge/corefonts/andale32.exe



Elle fonctionne parfaitement chez moi ; si ce n'est pas le cas chez
toi (ce que je soupçonne), essaie de comprendre pourquoi.


[Note : pour obtenir cette info, j'ai cherché msttcorefonts dans
http://www.debian.org/distrib/packages#search_packages, puis j'ai
téléchargé le .deb, et l'ai transformé en .tar.gz avec alien. Il y a
probablement une méthode plus rapide...]


Ou bien, tu peux télécharger les fichiers

http://surfnet.dl.sourceforge.net/sourceforge/corefonts/andale32.exe
http://surfnet.dl.sourceforge.net/sourceforge/corefonts/arial32.exe
http://surfnet.dl.sourceforge.net/sourceforge/corefonts/arialb32.exe
http://surfnet.dl.sourceforge.net/sourceforge/corefonts/comic32.exe
http://surfnet.dl.sourceforge.net/sourceforge/corefonts/courie32.exe
http://surfnet.dl.sourceforge.net/sourceforge/corefonts/georgi32.exe
http://surfnet.dl.sourceforge.net/sourceforge/corefonts/impact32.exe
http://surfnet.dl.sourceforge.net/sourceforge/corefonts/times32.exe
http://surfnet.dl.sourceforge.net/sourceforge/corefonts/trebuc32.exe
http://surfnet.dl.sourceforge.net/sourceforge/corefonts/verdan32.exe
http://surfnet.dl.sourceforge.net/sourceforge/corefonts/webdin32.exe

et te démerder pour que le script les accepte directement.
Michael DENIS
Le #17828601
Fabien LE LEZ a écrit :
Elle fonctionne parfaitement chez moi ; si ce n'est pas le cas chez
toi (ce que je soupçonne), essaie de comprendre pourquoi.



La seule fois où j'ai eu un problème d'installation de msttcorefonts,
c'est sur une machine qui n'avait pas l'accès à internet. Maintenant, si
la machine a accès à internet, n'y aurait-il pas du filtrage (sur les
exécutables par exemple) ?

--
Michaël DENIS
Charlie Root
Le #17828751
Michael DENIS
Fabien LE LEZ a écrit :
Elle fonctionne parfaitement chez moi ; si ce n'est pas le cas chez
toi (ce que je soupçonne), essaie de comprendre pourquoi.



La seule fois où j'ai eu un problème d'installation de msttcorefonts,
c'est sur une machine qui n'avait pas l'accès à internet. Maintenant, si
la machine a accès à internet, n'y aurait-il pas du filtrage (sur les
exécutables par exemple) ?



Ou un passage obligatoire par un proxy que ne connais pas le script ?
Vérifier dans ce cas la variable http_proxy

--
Le travail n'est pas une bonne chose. Si ça l'était,
les riches l'auraient accaparé
Bernard
Le #17833771
Le Thu, 13 Nov 2008 02:45:14 +0100, Fabien LE LEZ a écrit :

On Thu, 13 Nov 2008 00:33:22 +0100, Bernard
Eh bien, à ma surprise, les
choses se sont passées exactement comme précédemment, les mêmes liens
ont été appelés et les mêmes erreurs de timeout. [...]
Se pourrait il que ces adresses http inopérantes soient inscrites dans
un fichier de config sur mon système ?



Non, le .deb, au lieu de contenir les fichiers à installer, est en fait
un programme qui télécharge les polices en question.

Plus précisément, le .deb contient, entre autres, le fichier
/usr/sbin/update-ms-fonts, qui télécharge plusieurs fichiers, en
essayant plusieurs adresses.

Essaie la commande suivante :

wget
http://surfnet.dl.sourceforge.net/sourceforge/corefonts/andale32.exe



Elle fonctionne parfaitement chez moi ; si ce n'est pas le cas chez toi
(ce que je soupçonne), essaie de comprendre pourquoi.




Si, çà fonctionne aussi chez moi: je viens d'essayer, et même sans
wget, aucun problème pour télécharger andale32.exe. Alors, voyant cela,
j'ai cru un moment que mes déboires d'hier étaient dus à un
dysfonctionnement du serveur sourceforge... Eh bien non, ce n'était pas
cela ! En effet, un nouvel essai s'installation via apt-get install
msttcorefonts, donne exactement le même résultat qu'hier, à savoir:

Résolution de switch.dl.sourceforge.net... échec: Connexion terminée
par expiration du délai d'attente !

C'est à n'y rien comprendre ! Se
pourrait il que dans le fichier debian qui s'exécute et programme le
retrait des polices sur des serveurs distants, soit précisée un
résolveur de nom (dns) qui vienne se superposer à celui que j'ai dans
mon '/etc/resolv.conf' et qui ne permette pas la résolution des noms ?
Quoi imaginer d'autre ?


[Note : pour obtenir cette info, j'ai cherché msttcorefonts dans
http://www.debian.org/distrib/packages#search_packages, puis j'ai
téléchargé le .deb, et l'ai transformé en .tar.gz avec alien. Il y a
probablement une méthode plus rapide...]


Ou bien, tu peux télécharger les fichiers

http://surfnet.dl.sourceforge.net/sourceforge/corefonts/andale32.exe
http://surfnet.dl.sourceforge.net/sourceforge/corefonts/arial32.exe
http://surfnet.dl.sourceforge.net/sourceforge/corefonts/arialb32.exe
http://surfnet.dl.sourceforge.net/sourceforge/corefonts/comic32.exe
http://surfnet.dl.sourceforge.net/sourceforge/corefonts/courie32.exe
http://surfnet.dl.sourceforge.net/sourceforge/corefonts/georgi32.exe
http://surfnet.dl.sourceforge.net/sourceforge/corefonts/impact32.exe
http://surfnet.dl.sourceforge.net/sourceforge/corefonts/times32.exe
http://surfnet.dl.sourceforge.net/sourceforge/corefonts/trebuc32.exe
http://surfnet.dl.sourceforge.net/sourceforge/corefonts/verdan32.exe
http://surfnet.dl.sourceforge.net/sourceforge/corefonts/webdin32.exe

et te démerder pour que le script les accepte directement.



Comment faire ? Je peux en effet sans doute télécharger tous ces
fichiers... ensuite je puis les mettre dans des répertoires exactement
comme ils sont sur mon desktop... mais j'ai mes doutes pour la suite,
d'autant que sur le Desktop c'est Sarge et sur le portable Etch !
François
Le #17835111
Bernard a exprimé avec précision :

J'ai installé sans problème, il y a 18 mois, ces polices sur mon
desktop
sous Debian Sarge. Hier et aujourd'hui, j'ai essayé de refaire cette
install sur mon portable sous Debian Etch... mais là, çà n'a pas
marché !



#apt-get install msttcorefonts



a bien commencé le processus, jusqu'à ce que l'on arrive au
téléchargement de chacune des polices... et là, toujours la même
chose
à chaque tentative : connexion terminée par expiration du délai
d'attente ! Aucune police true type n'est donc installée.



Et avec une installation manuelle ?
http://packages.debian.org/etch/msttcorefonts

--
François
Si le bol de riz qu'on te propose ne te convient pas, laisse le riz
et mange le bol.
Bernard
Le #17835691
Le Thu, 13 Nov 2008 09:26:02 +0100, Charlie Root a écrit :

Michael DENIS
Fabien LE LEZ a écrit :
Elle fonctionne parfaitement chez moi ; si ce n'est pas le cas chez toi
(ce que je soupçonne), essaie de comprendre pourquoi.



La seule fois où j'ai eu un problème d'installation de msttcorefonts,
c'est sur une machine qui n'avait pas l'accès à internet. Maintenant,
si la machine a accès à internet, n'y aurait-il pas du filtrage (sur
les exécutables par exemple) ?



Ou un passage obligatoire par un proxy que ne connais pas le script ?
Vérifier dans ce cas la variable http_proxy



Je viens de vérifier. Sur le portable objet des problèmes cités, un

#find / | grep http_proxy

ne me liste qu'un seul fichier :

/usr/share/gconf/schemas/system_http_proxy.schemas

ce fichier de 4914 lignes multilingues (y compris le russe, l'arabe et
l'hébreu avec leurs caractères graphiques particuliers, ainsi que le
mandarin avec des symboles étranges) comporte en anglais les lignes
suivantes :

<?xml version="1.0"?
<gconfschemafile>
<schema>
<key>/schemas/system/http_proxy/use_http_proxy</key>
<applyto>/system/http_proxy/use_http_proxy</applyto>
<owner>gnome-vfs<owner>
<type>bool</type>
<default>false</default>
<locale name="C">
<short>Use HTTP proxy</short>
<long>Enables the proxy settings when accessing HTTP over the
Internet.</long>
</locale>

Si je comprends bien, par défaut c'est paramètré "false", c'est à dire
sans faire appel à proxy ?

Je rappelle que, lors de multiples autres installations via apt-get, les
téléchargements depuis les bases Debian se sont toujours très bien
déroulés sans erreurs... Alors pourquoi çà déconne ici ?

Donc, ce fichier 'system_http_proxy.schemas', c'est sur mon portable sous
Etch que je l'ai trouvé, celui pour lequel j'ai le problème avec
msttcorefonts. Sur mon desktop équipé de Sarge (celui sur lequel ne n'ai
pas eu de problème pour installer msttcorefonts il y a 18 mois), j'ai
d'autres fichiers :

debreil:/home/bd# find / | grep http_proxy
/etc/gconf/gconf.xml.defaults/schemas/system/http_proxy
/etc/gconf/gconf.xml.defaults/schemas/system/http_proxy/%gconf.xml
/etc/gconf/gconf.xml.defaults/system/http_proxy
/etc/gconf/gconf.xml.defaults/system/http_proxy/%gconf.xml
/usr/share/gconf/schemas/system_http_proxy.schemas

Quant à lister ces fichiers avec 'vi', c'est une autre histoire... L'un
d'entre eux dit qu'il ne s'agit pas d'une 'regular file'
Publicité
Poster une réponse
Anonyme