Installation d'un noyeau avec lilo

Le
Benoit B
Bonjour à tous,

Je me suis fait un noyau avec la commande :

make-kpkg --append_to_version -venus --initrd --revision 1 kernel-image

Mais lors de l'installation avec la commande dpkg -i

Le script postinst plante sur update-grub, forcément, j'utilise lilo.
Comment lui dire de ne pas lancer update-grub et me laisser rédiger
mon lilo.conf à la main ?

Voici l'erreur :

User postinst hook script [update-grub] failed to execute: Aucun
fichier ou répertoire de ce type
dpkg : erreur de traitement de linux-image-2.6.26.3-venus (--install) :
le sous-processus post-installation script a retourné une erreur de
sortie d'état 255
Des erreurs ont été rencontrées pendant l'exécution :
linux-image-2.6.26.3-venus


Merci d'avance.

--
Benoît

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
steve
Le #16699451
Le 2008-09-02, à 15:15:23 +0200, Benoit B () a écrit :

Bonjour à tous,



Salut,

Je me suis fait un noyau avec la commande :



question innocente : pourquoi ne pas utiliser un noyau tout fait ?

make-kpkg --append_to_version -venus --initrd --revision 1 kernel-image

Mais lors de l'installation avec la commande dpkg -i

Le script postinst plante sur update-grub, forcément, j'utilise lilo.



question innocente 2 : pourquoi ne pas utiliser grub ?

Comment lui dire de ne pas lancer update-grub et me laisser rédiger
mon lilo.conf à la main ?



Aucune idée.

Voici l'erreur :

User postinst hook script [update-grub] failed to execute: Aucun
fichier ou répertoire de ce type
dpkg : erreur de traitement de linux-image-2.6.26.3-venus (--install) :
le sous-processus post-installation script a retourné une erreur de
sortie d'état 255
Des erreurs ont été rencontrées pendant l'exécution :
linux-image-2.6.26.3-venus



Et si après cette erreur et avoir entré ce qu'il faut dans lilo.conf, tu
fais un

lilo

sur la ligne de commande, ça passe ?


Merci d'avance.

--
Benoît



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Benoit B
Le #16699591
Le 2 septembre 2008 15:36, steve
Le 2008-09-02, à 15:15:23 +0200, Benoit B () a écr it :

Bonjour à tous,



Salut,

Je me suis fait un noyau avec la commande :



question innocente : pourquoi ne pas utiliser un noyau tout fait ?



Pour avoir le driver CAN BUS



make-kpkg --append_to_version -venus --initrd --revision 1 kernel-image

Mais lors de l'installation avec la commande dpkg -i

Le script postinst plante sur update-grub, forcément, j'utilise lilo.



question innocente 2 : pourquoi ne pas utiliser grub ?



Parce que je ne connais pas grub et suis bien rodé à la syntaxe du lilo .conf.
Donc par incompétance. ;-)
Mais si tu m'expliques tout en détail pour en savoir autant avec gub
que j'en sais avec lilo je veux bien changer ! ;-)


Comment lui dire de ne pas lancer update-grub et me laisser rédiger
mon lilo.conf à la main ?



Aucune idée.

Voici l'erreur :

User postinst hook script [update-grub] failed to execute: Aucun
fichier ou répertoire de ce type
dpkg : erreur de traitement de linux-image-2.6.26.3-venus (--install) :
le sous-processus post-installation script a retourné une erreur de
sortie d'état 255
Des erreurs ont été rencontrées pendant l'exécution :
linux-image-2.6.26.3-venus



Et si après cette erreur et avoir entré ce qu'il faut dans lilo.conf, tu
fais un

lilo

sur la ligne de commande, ça passe ?



Ca passe très bien je vais d'ailleurs essayer de redémarrer.
Je te tiens au courant. :-)



Merci d'avance.

--
Benoît



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact .org





--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
steve
Le #16699571
Le 2008-09-02, à 15:48:24 +0200, Benoit B () a écrit :

Lignes : 85

Le 2 septembre 2008 15:36, steve > Le 2008-09-02, à 15:15:23 +0200, Benoit B () a écrit :
>
>> Bonjour à tous,
>
> Salut,
>
>> Je me suis fait un noyau avec la commande :
>
> question innocente : pourquoi ne pas utiliser un noyau tout fait ?

Pour avoir le driver CAN BUS



c'est quoi ça ?


>
>> make-kpkg --append_to_version -venus --initrd --revision 1 kernel-image
>>
>> Mais lors de l'installation avec la commande dpkg -i
>>
>> Le script postinst plante sur update-grub, forcément, j'utilise lilo.
>
> question innocente 2 : pourquoi ne pas utiliser grub ?

Parce que je ne connais pas grub et suis bien rodé à la syntaxe du lilo.conf.
Donc par incompétance. ;-)



Et paresse ;-) ?

Mais si tu m'expliques tout en détail pour en savoir autant avec gub
que j'en sais avec lilo je veux bien changer ! ;-)



aptitude install grub
aptitude purge lilo

et tous les prochaines installations d'un noyau seront automatiquement
prises en compte, plus de lilo à taper (et à oublier.. de taper).

>
>> Comment lui dire de ne pas lancer update-grub et me laisser rédiger
>> mon lilo.conf à la main ?
>
> Aucune idée.
>
>> Voici l'erreur :
>>
>> User postinst hook script [update-grub] failed to execute: Aucun
>> fichier ou répertoire de ce type
>> dpkg : erreur de traitement de linux-image-2.6.26.3-venus (--install) :
>> le sous-processus post-installation script a retourné une erreur de
>> sortie d'état 255
>> Des erreurs ont été rencontrées pendant l'exécution :
>> linux-image-2.6.26.3-venus
>
> Et si après cette erreur et avoir entré ce qu'il faut dans lilo.conf, tu
> fais un
>
> lilo
>
> sur la ligne de commande, ça passe ?

Ca passe très bien je vais d'ailleurs essayer de redémarrer.
Je te tiens au courant. :-)



volontiers

>
>>
>> Merci d'avance.
>>
>> --
>> Benoît
>
> --
> Lisez la FAQ de la liste avant de poser une question :
> http://wiki.debian.org/DebFrFrenchLists
> Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
> "Reply-To:"
>
> To UNSUBSCRIBE, email to
> with a subject of "unsubscribe". Trouble? Contact
>
>

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Benoit B
Le #16699771
Le 2 septembre 2008 15:57, steve
Le 2008-09-02, à 15:48:24 +0200, Benoit B () a écr it :

Lignes : 85

Le 2 septembre 2008 15:36, steve > Le 2008-09-02, à 15:15:23 +0200, Benoit B () a écrit :
>
>> Bonjour à tous,
>
> Salut,
>
>> Je me suis fait un noyau avec la commande :
>
> question innocente : pourquoi ne pas utiliser un noyau tout fait ?

Pour avoir le driver CAN BUS



c'est quoi ça ?



http://fr.wikipedia.org/wiki/CAN_bus

Google est ton ami ! Qui parle de paresse ? ;-)



>
>> make-kpkg --append_to_version -venus --initrd --revision 1 kernel-ima ge
>>
>> Mais lors de l'installation avec la commande dpkg -i
>>
>> Le script postinst plante sur update-grub, forcément, j'utilise lil o.
>
> question innocente 2 : pourquoi ne pas utiliser grub ?

Parce que je ne connais pas grub et suis bien rodé à la syntaxe du l ilo.conf.
Donc par incompétance. ;-)



Et paresse ;-) ?



Oui sans aucun doute... :-)


Mais si tu m'expliques tout en détail pour en savoir autant avec gub
que j'en sais avec lilo je veux bien changer ! ;-)



aptitude install grub
aptitude purge lilo

et tous les prochaines installations d'un noyau seront automatiquement
prises en compte, plus de lilo à taper (et à oublier.. de taper).

>
>> Comment lui dire de ne pas lancer update-grub et me laisser rédiger
>> mon lilo.conf à la main ?
>
> Aucune idée.
>
>> Voici l'erreur :
>>
>> User postinst hook script [update-grub] failed to execute: Aucun
>> fichier ou répertoire de ce type
>> dpkg : erreur de traitement de linux-image-2.6.26.3-venus (--install) :
>> le sous-processus post-installation script a retourné une erreur d e
>> sortie d'état 255
>> Des erreurs ont été rencontrées pendant l'exécution :
>> linux-image-2.6.26.3-venus
>
> Et si après cette erreur et avoir entré ce qu'il faut dans lilo.co nf, tu
> fais un
>
> lilo
>
> sur la ligne de commande, ça passe ?

Ca passe très bien je vais d'ailleurs essayer de redémarrer.
Je te tiens au courant. :-)



volontiers



Ca se configure dans le ficher
/etc/kernel-img.conf

J'ai simplement commenté les deux lignes

#postinst_hook = update-grub
#postrm_hook = update-grub

Bon je ne le dis plus je reboot ce truc. :-)
Croisons les doigts

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
steve
Le #16699761
Le 2008-09-02, à 16:10:37 +0200, François Cerbelle () a écrit :

Lignes : 21


Le Mar 2 septembre 2008 15:57, steve a écrit :
[...]
>> Mais si tu m'expliques tout en détail pour en savoir autant avec gub
>> que j'en sais avec lilo je veux bien changer ! ;-)
> aptitude install grub
> aptitude purge lilo

Il a redémarré, on n'est pas prêt de le revoir ici !!! ;-)



François voyons ... :)

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
François Cerbelle
Le #16699751
Le Mar 2 septembre 2008 15:57, steve a écrit :
[...]
Mais si tu m'expliques tout en détail pour en savoir autant avec gub
que j'en sais avec lilo je veux bien changer ! ;-)


aptitude install grub
aptitude purge lilo



Il a redémarré, on n'est pas prêt de le revoir ici !!! ;-)

François Cerbelle

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
François Boisson
Le #16699901
Il me semble que dans /etc/kernel-img.conf, il y a les instructions à exécuter
après l'installation d'un noyau. Il suffit de commenter celle relative à grub.
(genre postinst_hook update_grub ou un truc de ce style)

Par ailleurs, j'utilise lilo et je n'aime pas grub, j'ai eu des soucis avec ce
truc (parce que je ne le connais pas bien) et lilo a toujours fonctionné
parfaitement. Donc je comprends qu'on puisse continuer à utiliser lilo (qui
est bien) et prendre grub dans les cas délicats. (En plus grub est moche :)).

François Boisson

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
steve
Le #16704411
Le 2008-09-02, à 16:09:34 +0200, François Boisson () a écrit :

Lignes : 20

Il me semble que dans /etc/kernel-img.conf, il y a les instructions à exécuter
après l'installation d'un noyau. Il suffit de commenter celle relative à grub.
(genre postinst_hook update_grub ou un truc de ce style)



C'est juste, cela m'avait échapper

Par ailleurs, j'utilise lilo et je n'aime pas grub, j'ai eu des soucis avec ce
truc (parce que je ne le connais pas bien)



Quels genres de soucis ?

et lilo a toujours fonctionné
parfaitement. Donc je comprends qu'on puisse continuer à utiliser lilo (qui
est bien) et prendre grub dans les cas délicats.




(En plus grub est moche :)).



Pour ce que tu rallumes ta machine ... ;-)

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
steve
Le #16704401
Le 2008-09-03, à 09:15:18 +0200, steve () a écrit :

Lignes : 33

Le 2008-09-02, à 16:09:34 +0200, François Boisson () a écrit :

> Lignes : 20
>
> Il me semble que dans /etc/kernel-img.conf, il y a les instructions à exécuter
> après l'installation d'un noyau. Il suffit de commenter celle relative à grub.
> (genre postinst_hook update_grub ou un truc de ce style)

C'est juste, cela m'avait échapper



échappé, bien sûr

> Par ailleurs, j'utilise lilo et je n'aime pas grub, j'ai eu des soucis avec ce
> truc (parce que je ne le connais pas bien)

Quels genres de soucis ?

> et lilo a toujours fonctionné
> parfaitement. Donc je comprends qu'on puisse continuer à utiliser lilo (qui
> est bien) et prendre grub dans les cas délicats.


> (En plus grub est moche :)).

Pour ce que tu rallumes ta machine ... ;-)

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
François Boisson
Le #16707101
Le Wed, 3 Sep 2008 09:15:18 +0200
steve
> Par ailleurs, j'utilise lilo et je n'aime pas grub, j'ai eu des soucis
> avec ce truc (parce que je ne le connais pas bien)

Quels genres de soucis ?



À l'époque de sarge, grub n'a jamais pu s'installer avec un noyau 2.6.17, puis
avec etch, j'ai eu des pbms de paramétrage essentiellement du à ma
méconnaissance de la syntaxe. Je n'ai jamais dit que mon aversionb pour grub
était rationnelle :).


François Boisson

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme