Installation de paquets rpm 32bits sur une debian lenny 64 bits

Le
Guy Roussin
Bonjour,

J'ai besoin d'installer des paquets proprio rpm 32bits sur une debian
lenny 64bits

Pour l'install sur une debian lenny 32bits, il n'y a pas de problèmes :

alien *i586.rpm
dpkg -i *deb

Mais sur une architecture amd64, l'aliénisation ne passe pas car alien =
détecte une
incompatibilité d'architecture.
Qu'à cela ne tienne je peux toujours aliéniser sur une autre machine =
en 32 bits
et j'obtiens un paquet *i386.deb que je transfere sur la debian 64 bits.
et lors de l'install j'ai un :
l'architecture du paquet (i386) ne correspond pas à celle du système =
(amd64)

Existe t-il une solution ?

Merci.

--
Guy

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/4C627AD0.4030905@teledetection.fr
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Guy Roussin
Le #22461181
J'ai trouvé quelques éléments de réponse. Je vais essayé de ré gler ça avec un
dpkg -i --force-architecture *deb
Et si ça pose trop de problèmes, j'essaierai de faire un chroot 32bit s ...
Merci.
Guy

Le 11/08/2010 12:26, Guy Roussin a écrit :
Bonjour,

J'ai besoin d'installer des paquets proprio rpm 32bits sur une debian
lenny 64bits ...

Pour l'install sur une debian lenny 32bits, il n'y a pas de problèmes :

alien *i586.rpm
dpkg -i *deb

Mais sur une architecture amd64, l'aliénisation ne passe pas car alie n
détecte une incompatibilité d'architecture.
Qu'à cela ne tienne je peux toujours aliéniser sur une autre machin e en
32 bits
et j'obtiens un paquet *i386.deb que je transfere sur la debian 64 bits .
et lors de l'install j'ai un :
l'architecture du paquet (i386) ne correspond pas à celle du systèm e
(amd64)

Existe t-il une solution ?

Merci.




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme