Installation tinyerp-server postgresql

Le
Hugues LARRIVE
This is an OpenPGP/MIME signed message (RFC 2440 and 3156)
--enigFC94EB7D73A096D0CC51330D
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Bonsoir,

Je viens d'installer tinyerp-server et posgresql sur debian etch, j'ai
suivie les instruction dans /usr/share/doc/tinyerp-server/README.Debian
pour la création de la base de donnée mais le tinyerp-server refuse d=
e
démarrer (pas de message d'erreur) :

www:~# /etc/init.d/tinyerp-server start
Starting tinyerp-server: tinyerp-server.
www:~# nmap -p 8069 localhost

Starting Nmap 4.11 ( http://www.insecure.org/nmap/ ) at 2008-01-24 23:03 =
CET
Interesting ports on localhost.localdomain (127.0.0.1):
PORT STATE SERVICE
8069/tcp closed unknown

Nmap finished: 1 IP address (1 host up) scanned in 0.107 seconds
www:~# /etc/init.d/tinyerp-server restart
Restarting tinyerp-server: start-stop-daemon: warning: failed to kill
13380: No such process
tinyerp-server.

www:~# tail /var/log/postgresql/postgresql-7.4-main.log
2008-01-24 18:27:49 TRACE: Le système de bases de données est prêt=

2008-01-24 18:27:49 TRACE: Paquet de démarrage incomplet
2008-01-24 18:28:04 ERREUR: La base de données « terp » existe dé=

2008-01-24 18:28:31 ERREUR: La relation « audittrail_rule » n'existe=
pas
2008-01-24 20:02:01 TRACE: Paquet de démarrage incomplet
2008-01-24 22:58:01 ERREUR: La relation « audittrail_rule » n'existe=
pas
2008-01-24 23:03:11 ERREUR: La relation « audittrail_rule » n'existe=
pas
2008-01-24 23:03:16 ERREUR: La relation « audittrail_rule » n'existe=
pas
2008-01-24 23:03:22 ERREUR: La relation « audittrail_rule » n'existe=
pas
2008-01-24 23:04:17 ERREUR: La relation « audittrail_rule » n'existe=
pas



J'ai cherché "La relation « audittrail_rule » n'existe pas" dans go=
ogle
mais ça ne donne aucun résultat !




--enigFC94EB7D73A096D0CC51330D
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

--BEGIN PGP SIGNATURE--
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFHmQ5jNdTZuHWpgVIRAlPLAJ9cVBkce0FcS5KY85ctO6kT37niLgCggIPz
XgUNBfFEzkJrc3SMMFCdcrQ=
=nU5l
--END PGP SIGNATURE--

--enigFC94EB7D73A096D0CC51330D--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
pascatgm
Le #9643161
Hugues LARRIVE a écrit :
Bonsoir,

Je viens d'installer tinyerp-server et posgresql sur debian etch, j'ai
suivie les instruction dans /usr/share/doc/tinyerp-server/README.Debian
pour la création de la base de donnée mais le tinyerp-server refuse de
démarrer (pas de message d'erreur) :

www:~# /etc/init.d/tinyerp-server start
Starting tinyerp-server: tinyerp-server.
www:~# nmap -p 8069 localhost

Starting Nmap 4.11 ( http://www.insecure.org/nmap/ ) at 2008-01-24 23:03 CET
Interesting ports on localhost.localdomain (127.0.0.1):
PORT STATE SERVICE
8069/tcp closed unknown

Nmap finished: 1 IP address (1 host up) scanned in 0.107 seconds
www:~# /etc/init.d/tinyerp-server restart
Restarting tinyerp-server: start-stop-daemon: warning: failed to kill
13380: No such process
tinyerp-server.

www:~# tail /var/log/postgresql/postgresql-7.4-main.log
2008-01-24 18:27:49 TRACE: Le système de bases de données est prêt
2008-01-24 18:27:49 TRACE: Paquet de démarrage incomplet
2008-01-24 18:28:04 ERREUR: La base de données « terp » existe déjà
2008-01-24 18:28:31 ERREUR: La relation « audittrail_rule » n'existe pas
2008-01-24 20:02:01 TRACE: Paquet de démarrage incomplet
2008-01-24 22:58:01 ERREUR: La relation « audittrail_rule » n'existe pas
2008-01-24 23:03:11 ERREUR: La relation « audittrail_rule » n'existe pas
2008-01-24 23:03:16 ERREUR: La relation « audittrail_rule » n'existe pas
2008-01-24 23:03:22 ERREUR: La relation « audittrail_rule » n'existe pas
2008-01-24 23:04:17 ERREUR: La relation « audittrail_rule » n'existe pas



J'ai cherché "La relation « audittrail_rule » n'existe pas" dans google
mais ça ne donne aucun résultat !






Salut
D'où vient ton tinyerp-server ? Le paquet n'existe pas sous etch à ma
connaissance.
Quelle est ta version ? Ton /etc/default/tinyerp-server ?
A première vue je dirais qu'il te manque un package python...
Il est rare que l'installation du serveur pose des problèmes...C'est
généralement lors de la connexion du client au serveur que l'on commence
à s'amuser...
Pascal


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Jean-Yves F. Barbier
Le #9643081
pascatgm a écrit :
Hugues LARRIVE a écrit :


.......
www:~# tail /var/log/postgresql/postgresql-7.4-main.log
2008-01-24 18:27:49 TRACE: Le système de bases de données est prêt
2008-01-24 18:27:49 TRACE: Paquet de démarrage incomplet
2008-01-24 18:28:04 ERREUR: La base de données « terp » existe déjà





REinstallation puisque la BDD existe...
avant de REinstaller, 1ère chose, faire un:
$: dropdb terp

est-ce que le user postgres s'est bien vu attribuer un password
(conformément à la doc ubuntu/tinyerp)?

D'où vient ton tinyerp-server ? Le paquet n'existe pas sous etch à ma
connaissance.



nan, il est en std dans mon mirroir etch de ftp.fr.debian.org,
en version 3.4.2-1

/etc/default/tinyerp-server ?



wai, il a raison, le contenu de ce fichier est Timportant

--
But they went to MARS around 1953!!


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
pascatgm
Le #9643071
Jean-Yves F. Barbier a écrit :
pascatgm a écrit :
Hugues LARRIVE a écrit :


.......
www:~# tail /var/log/postgresql/postgresql-7.4-main.log
2008-01-24 18:27:49 TRACE: Le système de bases de données est prêt
2008-01-24 18:27:49 TRACE: Paquet de démarrage incomplet
2008-01-24 18:28:04 ERREUR: La base de données « terp » existe déjà





REinstallation puisque la BDD existe...
avant de REinstaller, 1ère chose, faire un:
$: dropdb terp

est-ce que le user postgres s'est bien vu attribuer un password
(conformément à la doc ubuntu/tinyerp)?


Ca n'est certainement pas ça qui bloque le démarrage du serveur. Chez
moi cette étape a été franchie sans pb avec ou sans mot de passe pour
postgres.

D'où vient ton tinyerp-server ? Le paquet n'existe pas sous etch à ma
connaissance.



nan, il est en std dans mon mirroir etch de ftp.fr.debian.org,
en version 3.4.2-1


Vi vi au temps pour moi...Il a dû passer tel quel avec etch en stable...
Mais cette version commence à dater.
Je suis ss testing et j'ai dû en fait installer la 4.2.1.1 pour que tout
fonctionne...

/etc/default/tinyerp-server ?



wai, il a raison, le contenu de ce fichier est Timportant



Bha bien sûr :)


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Jean-Yves F. Barbier
Le #9643061
pascatgm a écrit :
Jean-Yves F. Barbier a écrit :
pascatgm a écrit :
Hugues LARRIVE a écrit :


.......
www:~# tail /var/log/postgresql/postgresql-7.4-main.log
2008-01-24 18:27:49 TRACE: Le système de bases de données est prêt
2008-01-24 18:27:49 TRACE: Paquet de démarrage incomplet
2008-01-24 18:28:04 ERREUR: La base de données « terp » existe déjà




REinstallation puisque la BDD existe...
avant de REinstaller, 1ère chose, faire un:
$: dropdb terp

est-ce que le user postgres s'est bien vu attribuer un password
(conformément à la doc ubuntu/tinyerp)?


Ca n'est certainement pas ça qui bloque le démarrage du serveur. Chez
moi cette étape a été franchie sans pb avec ou sans mot de passe pour
postgres.



?? vu que ubuntu est une Cc de Debian, et que leur doc spécifie d'attribuer
une P/W au usr postgres, je doute (maintenant, j'ai fais des tas de tests
récemment et il est possible que je me trompe (Adempierre nécessite cette
manip))
MAIS j'en doute: que ce soit la doc ubuntu ou le morceau de doc Debian sur
le site de TinyERP, les 2 parlent d'un P/W pour le user postgres...

D'où vient ton tinyerp-server ? Le paquet n'existe pas sous etch à ma
connaissance.


nan, il est en std dans mon mirroir etch de ftp.fr.debian.org,
en version 3.4.2-1


Vi vi au temps pour moi...Il a dû passer tel quel avec etch en stable...
Mais cette version commence à dater.
Je suis ss testing et j'ai dû en fait installer la 4.2.1.1 pour que tout
fonctionne...



pas nécessairement (la version stable 4.2.1 date du 24/12/07), et nous
sommes sous Linux, pas sous m$; donc la course à la dernière version ne
se justifie QUE si le changelog indique que des gros bugs ont été
erradiqués, ou si cette version apporte un changement voulu au comportement
du pgm.

--
I guess you guys got BIG MUSCLES from doing too much STUDYING!


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
pascatgm
Le #9643041
Jean-Yves F. Barbier a écrit :
pascatgm a écrit :
Jean-Yves F. Barbier a écrit :
pascatgm a écrit :
Hugues LARRIVE a écrit :


.......
www:~# tail /var/log/postgresql/postgresql-7.4-main.log
2008-01-24 18:27:49 TRACE: Le système de bases de données est prêt
2008-01-24 18:27:49 TRACE: Paquet de démarrage incomplet
2008-01-24 18:28:04 ERREUR: La base de données « terp » existe déjà




REinstallation puisque la BDD existe...
avant de REinstaller, 1ère chose, faire un:
$: dropdb terp

est-ce que le user postgres s'est bien vu attribuer un password
(conformément à la doc ubuntu/tinyerp)?


Ca n'est certainement pas ça qui bloque le démarrage du serveur. Chez
moi cette étape a été franchie sans pb avec ou sans mot de passe pour
postgres.



?? vu que ubuntu est une Cc de Debian, et que leur doc spécifie
d'attribuer
une P/W au usr postgres, je doute (maintenant, j'ai fais des tas de tests
récemment et il est possible que je me trompe (Adempierre nécessite cette
manip))
MAIS j'en doute: que ce soit la doc ubuntu ou le morceau de doc Debian
sur
le site de TinyERP, les 2 parlent d'un P/W pour le user postgres...


Je ne vais pas recopier la phrase plus haut...Ha et puis oui tiens :
"Chez moi cette étape a été franchie sans pb avec ou sans mot de passe pour
postgres. "

D'où vient ton tinyerp-server ? Le paquet n'existe pas sous etch à ma
connaissance.


nan, il est en std dans mon mirroir etch de ftp.fr.debian.org,
en version 3.4.2-1


Vi vi au temps pour moi...Il a dû passer tel quel avec etch en stable...
Mais cette version commence à dater.
Je suis ss testing et j'ai dû en fait installer la 4.2.1.1 pour que tout
fonctionne...



pas nécessairement (la version stable 4.2.1 date du 24/12/07), et nous
sommes sous Linux, pas sous m$; donc la course à la dernière version ne
se justifie QUE si le changelog indique que des gros bugs ont été
erradiqués, ou si cette version apporte un changement voulu au
comportement
du pgm.



On ne doit pas parler de la même chose...
Extrait du tracking :
[2007-11-12] tinyerp-server 4.2.0-1 MIGRATED to testing
[2008-01-12] Accepted 4.2.1-1 in unstable (low)
[2008-01-23] tinyerp-server 4.2.1-1 MIGRATED to testing

Pour ma part je ne parlais pas de m$ ou de courses aux versions ni de
quelconques généralités mais de mon expérience personnelle.
"Je" me suis battu avec les versions précédentes de tiny :
l'ante-pénultième avait un problème de correspondance de port entre le
serveur tiny et le serveur pgsql, l'avant dernière version du client
(packagé debian) n'a jamais fonctionné chez moi (et pas que chez moi :
un bugg la concernant n'a été clos qu'avec la sortie de la version 4.2.1.1).
Je ne faisais qu'essayer d'aider en faisant profiter une autre personne
de la liste de la façon dont j'avais solutionné *mes* problèmes.
Voilà.
Bon vendredi :)
P.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Jean-Yves F. Barbier
Le #9643021
pascatgm a écrit :
Jean-Yves F. Barbier a écrit :
pascatgm a écrit :
Jean-Yves F. Barbier a écrit :
pascatgm a écrit :
Hugues LARRIVE a écrit :


.......
www:~# tail /var/log/postgresql/postgresql-7.4-main.log
2008-01-24 18:27:49 TRACE: Le système de bases de données est prêt
2008-01-24 18:27:49 TRACE: Paquet de démarrage incomplet
2008-01-24 18:28:04 ERREUR: La base de données « terp » existe déjà




REinstallation puisque la BDD existe...
avant de REinstaller, 1ère chose, faire un:
$: dropdb terp

est-ce que le user postgres s'est bien vu attribuer un password
(conformément à la doc ubuntu/tinyerp)?


Ca n'est certainement pas ça qui bloque le démarrage du serveur. Chez
moi cette étape a été franchie sans pb avec ou sans mot de passe pour
postgres.


?? vu que ubuntu est une Cc de Debian, et que leur doc spécifie
d'attribuer
une P/W au usr postgres, je doute (maintenant, j'ai fais des tas de tests
récemment et il est possible que je me trompe (Adempierre nécessite cette
manip))
MAIS j'en doute: que ce soit la doc ubuntu ou le morceau de doc Debian
sur
le site de TinyERP, les 2 parlent d'un P/W pour le user postgres...


Je ne vais pas recopier la phrase plus haut...Ha et puis oui tiens :
"Chez moi cette étape a été franchie sans pb avec ou sans mot de passe pour
postgres. "



<mode troll>
Je ne vais pas recopier la phrase plus haut...Ha et puis oui tiens :
"il est possible que je me trompe (Adempierre nécessite cette manip)"
</mode troll> (vive le vendredi!!!)

D'où vient ton tinyerp-server ? Le paquet n'existe pas sous etch à ma
connaissance.


nan, il est en std dans mon mirroir etch de ftp.fr.debian.org,
en version 3.4.2-1


Vi vi au temps pour moi...Il a dû passer tel quel avec etch en stable...
Mais cette version commence à dater.
Je suis ss testing et j'ai dû en fait installer la 4.2.1.1 pour que tout
fonctionne...


pas nécessairement (la version stable 4.2.1 date du 24/12/07), et nous
sommes sous Linux, pas sous m$; donc la course à la dernière version ne
se justifie QUE si le changelog indique que des gros bugs ont été
erradiqués, ou si cette version apporte un changement voulu au
comportement
du pgm.



On ne doit pas parler de la même chose...
Extrait du tracking :
[2007-11-12] tinyerp-server 4.2.0-1 MIGRATED to testing
[2008-01-12] Accepted 4.2.1-1 in unstable (low)
[2008-01-23] tinyerp-server 4.2.1-1 MIGRATED to testing

Pour ma part je ne parlais pas de m$ ou de courses aux versions ni de
quelconques généralités mais de mon expérience personnelle.
"Je" me suis battu avec les versions précédentes de tiny :
l'ante-pénultième avait un problème de correspondance de port entre le
serveur tiny et le serveur pgsql, l'avant dernière version du client
(packagé debian) n'a jamais fonctionné chez moi (et pas que chez moi :
un bugg la concernant n'a été clos qu'avec la sortie de la version 4.2.1.1).
Je ne faisais qu'essayer d'aider en faisant profiter une autre personne
de la liste de la façon dont j'avais solutionné *mes* problèmes.
Voilà.



<mode trollounet>
Je ne vais pas recopier la phrase plus haut...Ha et puis oui tiens :
"donc la course à la dernière version ne se justifie QUE si le changelog
indique que des gros bugs ont été erradiqués, ou si cette version apporte un
changement voulu au comportement du pgm."
C'est pô bien d'être susceptible à ce point là.
</mode trollounet>

<mode franchement troll>
Il-y-a quand même qq chose de bizarre: tinyERP est localisé en wallonie, et
on a même pas droit à un package de langue intégralement françisé en std (à
moins que les programmeurs ne soient flamands, ce qui expliquerait la
chose...)
</mode franchement troll>
--
Our similarities are different. -Dale Berra, son of Yogi


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
pascatgm
Le #9643011
Jean-Yves F. Barbier a écrit :

<mode troll>
Je ne vais pas recopier la phrase plus haut...Ha et puis oui tiens :
"il est possible que je me trompe (Adempierre nécessite cette manip)"
</mode troll> (vive le vendredi!!!)


Error : Not valid XML
You must enclose the CData portion " (vive le vendredi!!!) " between
proper tags

<mode trollounet>
Je ne vais pas recopier la phrase plus haut...Ha et puis oui tiens :
"donc la course à la dernière version ne se justifie QUE si le changelog
indique que des gros bugs ont été erradiqués, ou si cette version
apporte un
changement voulu au comportement du pgm."
C'est pô bien d'être susceptible à ce point là.
</mode trollounet>


<mode pas trollounet>
C'était pas de la susceptibilté
Juste des précisions !
mais on est vendredi, non ?
</mode pas trollounet>

<mode franchement troll>
Il-y-a quand même qq chose de bizarre: tinyERP est localisé en
wallonie, et
on a même pas droit à un package de langue intégralement françisé en
std (à
moins que les programmeurs ne soient flamands, ce qui expliquerait la
chose...)
</mode franchement troll>


A ce propos leur traduction laisse à désirer et je suis en train
d'essayer de m'immerger dans leur XML.
Ca n'est pas de la tarte...
Ils ont commencé directement en anglais je crois. Il n'en reste pas
moins que c'est un sacré soft...
P.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Jean-Yves F. Barbier
Le #9643001
pascatgm a écrit :
........
<mode franchement troll>
Il-y-a quand même qq chose de bizarre: tinyERP est localisé en
wallonie, et
on a même pas droit à un package de langue intégralement françisé en
std (à
moins que les programmeurs ne soient flamands, ce qui expliquerait la
chose...)
</mode franchement troll>


A ce propos leur traduction laisse à désirer et je suis en train
d'essayer de m'immerger dans leur XML.
Ca n'est pas de la tarte...
Ils ont commencé directement en anglais je crois. Il n'en reste pas
moins que c'est un sacré soft...



vi, mais c'est justement là que le bas blesse: difficile de faire une
implantation en clientèle si tu dois te repalucher la traduction à
chaque nouvelle version (et même en local: les gens ne maîtrisent pas
forcément l'Anglais comptable, voire l'Anglais tout court)

Remarque y'a pire: OpenBravo, les strings ne sont pas normalisées
(certaines comportent des majuscules à chaque mot, d'autres (les même!) non;
les ":" sont collés ou non à la string, etc..., c'est un réel cauchemar à
traduire)

Et si, par le plus grand des hasards, qqun de TinyERP lisait cela, ça serait
*vraiment* super d'avoir un commentaire long et très descriptif pour chaque
string, afin de savoir si le terme à traduire parle de compta ou non...

--
Free yourself from negative influence. Negative thoughts are the old
habits that gnaw at the roots of the soul.
Moses Shongo, (Seneca)


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Hugues LARRIVE
Le #9642451
This is an OpenPGP/MIME signed message (RFC 2440 and 3156)
--------------enigD297854963B65004EEAB27DF
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Jean-Yves F. Barbier a écrit :
pascatgm a écrit :
Jean-Yves F. Barbier a écrit :
pascatgm a écrit :
Hugues LARRIVE a écrit :


.......
www:~# tail /var/log/postgresql/postgresql-7.4-main.log
2008-01-24 18:27:49 TRACE: Le système de bases de données est prêt
2008-01-24 18:27:49 TRACE: Paquet de démarrage incomplet
2008-01-24 18:28:04 ERREUR: La base de données « terp » exis te déjà




REinstallation puisque la BDD existe...
avant de REinstaller, 1ère chose, faire un:
$: dropdb terp

est-ce que le user postgres s'est bien vu attribuer un password
(conformément à la doc ubuntu/tinyerp)?


Ca n'est certainement pas ça qui bloque le démarrage du serveur. C hez
moi cette étape a été franchie sans pb avec ou sans mot de passe pour
postgres.



?? vu que ubuntu est une Cc de Debian, et que leur doc spécifie
d'attribuer
une P/W au usr postgres, je doute (maintenant, j'ai fais des tas de tes ts
récemment et il est possible que je me trompe (Adempierre nécessite cette
manip))
MAIS j'en doute: que ce soit la doc ubuntu ou le morceau de doc Debian
sur
le site de TinyERP, les 2 parlent d'un P/W pour le user postgres...

D'où vient ton tinyerp-server ? Le paquet n'existe pas sous etch à ma
connaissance.


nan, il est en std dans mon mirroir etch de ftp.fr.debian.org,
en version 3.4.2-1


Vi vi au temps pour moi...Il a dû passer tel quel avec etch en stabl e...
Mais cette version commence à dater.
Je suis ss testing et j'ai dû en fait installer la 4.2.1.1 pour que tout
fonctionne...



pas nécessairement (la version stable 4.2.1 date du 24/12/07), et nou s
sommes sous Linux, pas sous m$; donc la course à la dernière versio n ne
se justifie QUE si le changelog indique que des gros bugs ont été
erradiqués, ou si cette version apporte un changement voulu au
comportement
du pgm.



Ok, j'ai tout purgé (postgresql* et tinyerp*).
J'ai installé postgresql 8.1 (au lieu de 7.4) et tinyerp 4.2.1 de testi ng.
J'ai créé la base de donnée comme indiqué dans le README.Debian d e
tinyerp (pas de mot de pass pour l'utilisateur postgres, j'ai simplement
commencé par un su postgres.
J'ai modifié DATABASE_PORT dans /etc/default/tinyerp-server : 5432 au
lieu de 5433
J'ai supprimé mon ~/.terprc suite à je ne sais plus quel message
d'erreur lors de la connexion du client...
J'ai du créer une base de donnée depuis le client avant de pouvoir me
connecter au serveur (ce que je pensait avoir déjà fais mais bon...)

Après je me suis battu pendant une heure avec la gestion des modules
pour installer le module esale et j'ai abandonné... le but de la manip
étant justement de tester ce module.

Si quelqu'un utilise ce module ou une autre interface eCommerce pour
tinyerp je suis intéressé par un retour d'expérience, notamment la
possibilité de gérer plusieurs boutiques depuis le même erp...

J'ai peu d'espoir de trouver une solution parfaitement adaptée à mes
besoins et php / mysql / perl me sont bien plus familiers que python /
postgresql. Du coup j'oriente mes recherche du coté de dolibarr dont
l'interface avec oscommerce est à un stade "embryonnaire".

@+




--------------enigD297854963B65004EEAB27DF
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFHnpACNdTZuHWpgVIRAr5pAJ9mS3HsWRj8D+HmoRsmMUNgwYKFBwCdG8Vv
Ex3o+ZxuvPDUcx1YXyUtQ4I =HT3q
-----END PGP SIGNATURE-----

--------------enigD297854963B65004EEAB27DF--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Jean-Michel OLTRA
Le #9642411
Bonjour,


Le mardi 29 janvier 2008, Hugues LARRIVE a écrit...


J'ai peu d'espoir de trouver une solution parfaitement adaptée à mes
besoins et php / mysql / perl me sont bien plus familiers que python /
postgresql. Du coup j'oriente mes recherche du coté de dolibarr dont
l'interface avec oscommerce est à un stade "embryonnaire".



J'utilise OpenSI, comme solution de gestion. On peut dire cependant que
tinyERP est plus « complet » que OpenSI, puisque c'est un ERP (en fait
nous utilisons la CRM de Tiny).

Il y a une interface OpenSI à OsCommerce, mais SpeedInfo la vend fort
cher. En fait, j'en ai développé une, le problème avec OpenSI étant que
l'API Web Manager change tout le temps, et que c'est bugué. Donc il me
faut suivre les versions. Je suis en train de remettre en état le web
manager pour le faire fonctionner avec la version 4.0

A suivre donc, si tu désires utiliser OpenSI. Je pense que nous allons
prochaînement donner les sources de ce que j'ai fait (mais contrairement
à toi je suis plus à l'aise en python qu'en php, et le serveur soap
OpenSI -> OsCommerce est en php) quand ça fonctionnera pour la 4.0. A
vos risques et périls.

--
jm

A.E.L. Sarl (R.C.S CASTRES 490843240)
http://www.spidboutic.fr



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme