installation xen sous debian lenny

Le
Thierry B
Bonjour,

J'ai voulu essayer d'installer xen sur ma debian lenny, qui a un noyau
2.6.21, mais j'ai des erreurs quand j'essaie de le lancer

Déja, au niveau de l'install des paquets, j'ai remarqué, qu'il n'y avait
pas de linux-image 2.6.21 por xe, mais j'avais lu qu'apparemment, ce
n'est plus la peine à partir du 2.6.21.

Voila les paquets installés:

# aptitude install xen-utils-3.1-1 xen-docs-3.1 xen-hypervisor
..

Les NOUVEAUX paquets suivants vont être automatiquement installés :
iproute libatm1 libc6-xen xen-hypervisor-3.1-1-i386 xen-utils-common
.
Les NOUVEAUX paquets suivants vont être installés :
iproute libatm1 libc6-xen xen-docs-3.1 xen-hypervisor-3.1-1-i386
xen-utils-3.1-1 xen-utils-common

J'ai crée un fichier image /home/thierry/xen_debian_etch.iso sur
laquelle j'ai mis une debian etch par debootstrap.

J'ai lancé le script pour la configuration du réseau en bridge:
/etc/xen/scripts/network-bridge start

Ce qui me donne ceci, en nouvelle interface:

xenbr0 Lien encap:Ethernet HWaddr 00:0E:7B:AC:A6:97
inet adr:192.168.0.12 Bcast:192.168.0.255 Masque:255.255.255.0
adr inet6: fe80::200:ff:fe00:0/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:25224 errors:0 dropped:0 overruns:0 frame:0
TX packets:22029 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
RX bytes:6671645 (6.3 MiB) TX bytes:1878313 (1.7 MiB)


la configuration de la machine virtuelle /etc/xen/debian_etch donne cela:

kernel = "/boot/vmlinuz-2.6.21.0710041819"
memory = 128
name = "debian_etch"
root = "/dev/hda1 ro"
ramdisk = '/boot/initrd.img-2.6.21.0710041819'
disk = [
'file:/home/thierry/xen_debian_etch.iso,hda1,w','phy:/dev/hda6,hda2,w']
vif = [ '' ]
dhcp="dhcp"


Mais quand je tape: xm create -c /etc/xen/debian_etch

Cela me donne:

WARING! Can't find hypervisor information in sysfs!
ERROR Internal error: Could not obtain handle on privileged command
interface (2 = No such file or directory)
Using config file "/etc/xen/debian_etch".
ERROR Internal error: Could not obtain handle on privileged command
interface (2 = No such file or directory)
ERROR Internal error: Could not obtain handle on privileged command
interface (2 = No such file or directory)
ERROR Internal error: Could not obtain handle on privileged command
interface (2 = No such file or directory)
ERROR Internal error: Could not obtain handle on privileged command
interface (2 = No such file or directory)
ERROR Internal error: Could not obtain handle on privileged command
interface (2 = No such file or directory)
ERROR Internal error: Could not obtain handle on privileged command
interface (2 = No such file or directory)
ERROR Internal error: Could not obtain handle on privileged command
interface (2 = No such file or directory)
ERROR Internal error: Could not obtain handle on privileged command
interface (2 = No such file or directory)
Error: Unable to connect to xend: No such file or directory. Is xend
running?

Et quand j'essaie de lancer xend, ca me donne ca:

# xend &
[3] 16978
# WARING! Can't find hypervisor information in sysfs!
ERROR Internal error: Could not obtain handle on privileged command
interface (2 = No such file or directory)
ERROR Internal error: Could not obtain handle on privileged command
interface (2 = No such file or directory)
Traceback (most recent call last):
File "/usr/lib/xen-default/bin/xend", line 36, in ?
from xen.xend.server import SrvDaemon
File "/usr/lib/xen-3.1-1/lib/python/xen/xend/server/SrvDaemon.py",
line 26, in ?
import relocate
File "/usr/lib/xen-3.1-1/lib/python/xen/xend/server/relocate.py", line
26, in ?
from xen.xend import XendDomain
File "/usr/lib/xen-3.1-1/lib/python/xen/xend/XendDomain.py", line 35, in ?
from xen.xend import XendOptions, XendCheckpoint, XendDomainInfo
File "/usr/lib/xen-3.1-1/lib/python/xen/xend/XendCheckpoint.py", line
22, in ?
from xen.xend.XendConfig import XendConfig
File "/usr/lib/xen-3.1-1/lib/python/xen/xend/XendConfig.py", line 27, in ?
from xen.xend.XendDevices import XendDevices
File "/usr/lib/xen-3.1-1/lib/python/xen/xend/XendDevices.py", line 22,
in ?
from xen.xend.server import blkif, netif, tpmif, pciif, iopif,
irqif, usbif, vfbif
File "/usr/lib/xen-3.1-1/lib/python/xen/xend/server/pciif.py", line
38, in ?
xc = xen.lowlevel.xc.xc()
xen.lowlevel.xc.Error: (1, 'Internal error', 'Could not obtain handle on
privileged command interface (2 = No such file or directory)')

[3]+ Exit 1 xend

Ext-ce que ca vient du noyau 2.6.21?

Je l'ai recompilé recemment à partir des sources mais en pfrenant la
config du linux-image 2.6.21.

Si quelqu'un a une idée? :-)

Merci :-)


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Gilles Mocellin
Le #9757891
--nextPart14563241.zSI7osVAVN
Content-Type: text/plain;
charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Le Sunday 07 October 2007 04:23:12 Thierry B, vous avez écrit :
Bonjour,

J'ai voulu essayer d'installer xen sur ma debian lenny, qui a un noyau
2.6.21, mais j'ai des erreurs quand j'essaie de le lancer...

Déja, au niveau de l'install des paquets, j'ai remarqué, qu'il n'y av ait
pas de linux-image 2.6.21 por xe, mais j'avais lu qu'apparemment, ce
n'est plus la peine à partir du 2.6.21.


[...]

Et non, ce qui ne sera plus la peine, c'est un noyau pour le guest, domU.
Pour le dom0, il faut toujours un noyau special.
Et il n'y en a pas eu de généré depuis le 2.6.20.
Ca n'a pas l'air simple et stable.

A moins de tout recompiler (Xen et noyau avec Xen pour dom0), il faut mieux
rester en stable/Etch pour monter une plateforme Xen actuellement.

--nextPart14563241.zSI7osVAVN
Content-Type: application/pgp-signature; name=signature.asc
Content-Description: This is a digitally signed message part.

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQBHCVcmDltnDmLJYdARAuG/AJ4ng8t8C118VcBR1mTkSTWkTOcX1ACeJ4U8
CBvDv6hipXqSjIWupCrM2AQ =SqV/
-----END PGP SIGNATURE-----

--nextPart14563241.zSI7osVAVN--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Thierry B
Le #9757871
Gilles Mocellin a écrit :
Le Sunday 07 October 2007 04:23:12 Thierry B, vous avez écrit :
Bonjour,

J'ai voulu essayer d'installer xen sur ma debian lenny, qui a un noyau
2.6.21, mais j'ai des erreurs quand j'essaie de le lancer...

Déja, au niveau de l'install des paquets, j'ai remarqué, qu'il n'y avait
pas de linux-image 2.6.21 por xe, mais j'avais lu qu'apparemment, ce
n'est plus la peine à partir du 2.6.21.


[...]

Et non, ce qui ne sera plus la peine, c'est un noyau pour le guest, domU.
Pour le dom0, il faut toujours un noyau special.
Et il n'y en a pas eu de généré depuis le 2.6.20.
Ca n'a pas l'air simple et stable.

A moins de tout recompiler (Xen et noyau avec Xen pour dom0), il faut mieux
rester en stable/Etch pour monter une plateforme Xen actuellement.




ha ok, merci :-)


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme