Installer un canner usb plustek U24 aie, aie...

Le
jmarco
Bonsoir a tous,
je suis sous debian etch 2.6.18,
je viens de recuperer un
scanner usb Plustek U2448,

#lusb me donne:
07b3:0011 Plustek, Inc. OpticPro U24 Scanner

je suis alle voir ici:
http://www.gjaeger.de/scanner/plustek/
et j'ai vu qu'il est bien supporte par sane,

ensuite je telecharge le backend correspondant ici:
http://www.gjaeger.de/scanner/downloads/plustek-usb-0.52-3.tar.gz

je decompresse sur le bureau,et je ne vois pas comment utiliser ce
backend
je me retrouve comme un crapaud sur une boite d'allumette:
je ne sais plus quoi faire pour que ce scanner fonctionne
xsane me renvoi: pas de periferique, etc, etc,


Merci de me repondre, si vous avez quelques conseils pour que ce scanner
puisse fonctionner.

cordialement,
Jmarc Dufour


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
thveillon.debian
Le #17940981
jmarco a écrit :
Bonsoir a tous,
je suis sous debian etch 2.6.18,
je viens de recuperer un
scanner usb Plustek U2448,

#lusb me donne:
07b3:0011 Plustek, Inc. OpticPro U24 Scanner

je suis alle voir ici:
http://www.gjaeger.de/scanner/plustek/
et j'ai vu qu'il est bien supporte par sane,

ensuite je telecharge le backend correspondant ici:
http://www.gjaeger.de/scanner/downloads/plustek-usb-0.52-3.tar.gz

je decompresse sur le bureau,et je ne vois pas comment utiliser ce
backend...
je me retrouve comme un crapaud sur une boite d'allumette:
je ne sais plus quoi faire pour que ce scanner fonctionne...
xsane me renvoi: pas de periferique, etc, etc,


Merci de me repondre, si vous avez quelques conseils pour que ce scanner
puisse fonctionner.

cordialement,
Jmarc Dufour




Salut,

ce scanner est supporté nativement par Sane semble-t-il, mais il
necessite peut-être un peu de configuration dans les fichiers de
/etc/sane.d/plustek.conf. (et peut-être également une version plus
récente de libsane que celle de Etch, à voir.)

Il y a toutes les explications nécessaires ici :

http://www.sane-project.org/man/sane-plustek.5.html

mais c'est malheureusement en Anglais. Il n'y a sans doute pas grand
chose à modifier, par contre c'est parfois nécessaire de vérifier les
permissions dans /dev/usb/[numéro du port] qui doivent être à
root:scanner et ug=rw, ton utilisateur doit également faire partie du
groupe scanner.

Pour identifier le scanner les commandes "scanimage -L" et
"sane-find-scanner" sont efficaces.

Si malgré tout des problèmes persistent il faut regarder du côté de la
règle udev, et éventuellement assouplir les permissions. La règle par
défaut est dans /etc/udev/rules.d/z60_libsane.rules :

# Plustek OpticPro U24
SYSFS{idVendor}=="07b3", SYSFS{idProduct}=="0011", MODE="0664",
GROUP="scanner", ENV{libsane_matched}="yes"

passer à MODE="0777" peut être nécessaire.


J'espère que ça t'aidera à avancer un peu...

Tom

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
jmarco
Le #17943261
Bonjour,
merci de ta reponse,
je vais essayer tout cela.

Jmarc

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
jmarco
Le #17947211
thveillon.debian a écrit :

Salut,

ce scanner est supporté nativement par Sane semble-t-il, mais il
necessite peut-être un peu de configuration dans les fichiers de
/etc/sane.d/plustek.conf.


j'y ai rajoute les lignes:

[usb] 0x07B3 0x0011

et

device /dev/usbscanner



(et peut-être également une version plus
récente de libsane que celle de Etch, à voir.)

Il y a toutes les explications nécessaires ici :

http://www.sane-project.org/man/sane-plustek.5.html

mais c'est malheureusement en Anglais. Il n'y a sans doute pas grand
chose à modifier, par contre c'est parfois nécessaire de vérifier les
permissions dans /dev/usb/[numéro du port] qui doivent être à
root:scanner et ug=rw, ton utilisateur doit également faire partie du
groupe scanner.



...? comment dois-je faire cela ?

Pour identifier le scanner les commandes "scanimage -L" et
"sane-find-scanner" sont efficaces.



# scanimage -L

device `plustek:libusb:001:002' is a Plustek Unknown device USB flatbed
scanner

# sane-find-scanner
found USB scanner (vendor=0x07b3 [PLUSTEK INC], product=0x0011 [USB
SCANNER], ch ip=LM9831) at libusb:001:002


Si malgré tout des problèmes persistent il faut regarder du côté de la
règle udev, et éventuellement assouplir les permissions. La règle par
défaut est dans /etc/udev/rules.d/z60_libsane.rules :



chez moi c'est: /etc/udev/rules.d/025_libsane.rules
avec # Plustek OpticPro U24
SYSFS{idVendor}=="07b3", SYSFS{idProduct}=="0011", MODE="777",
GROUP="scanner", ENV{libsane_matched}="yes"

# Plustek OpticPro U24
SYSFS{idVendor}=="07b3", SYSFS{idProduct}=="0011", MODE="0664",
GROUP="scanner", ENV{libsane_matched}="yes"

passer à MODE="0777" peut être nécessaire.



Du coup xsane s'ouvre bien mais lorsque je tente de voir l'apercu ou de
scanner, la lampe a scanner s'allume mais il ne se passe rien de plus,
je dois faire: annuler pour stopper la fonction.

Donc pour l'instant rien de bon, que puis-je faire pour qu'il fonctionne?

merci,
Jmarc

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
jpb
Le #17948021
Est-ce que ce scanner fonctionne en étant root ?

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
jmarco
Le #17949471
jpb a écrit :
Est-ce que ce scanner fonctionne en étant root ?



Bonsoir,
il fait la meme chose que je viens de decrire precedemment (17h30)
Jmarc

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
thveillon.debian
Le #17950471
jmarco a écrit :
[...]
/etc/sane.d/plustek.conf.


j'y ai rajoute les lignes:

[usb] 0x07B3 0x0011

et

device /dev/usbscanner



Pour que ça fonctionne il faut que /dev/usbscanner corresponde
réellement à un node dans /dev, est-ce le cas? Cette ligne est mise en
exemple, mais tu devrais la remplacer par la véritable adresse du
scanner, soit d'après ton "scanimage -L" /dev/bus/usb/001/002, ou
/dev/scanner si ça existe sur ton système.

[...]
>> permissions dans /dev/usb/[numéro du port] qui doivent être à
root:scanner et ug=rw, ton utilisateur doit également faire partie du
groupe scanner.



...? comment dois-je faire cela ?



ls -l /dev/bus/usb/001/ te donnera les permissions et propriétaires
actuels du node, si tu dois les changer c'est :
"chown root:scanner" et "chmod 664 fichier" (ou 777 si c'est nécessaire).
Normalement tout ça sera définie au démarrage en fonction de la règle
udev que tu as dans /etc/udev/rules.d/.
Pour vérifier que ton utilisateur est dans le groupe "scanner" c'est la
commande "groups".

chez moi c'est: /etc/udev/rules.d/025_libsane.rules
avec # Plustek OpticPro U24
SYSFS{idVendor}=="07b3", SYSFS{idProduct}=="0011", MODE="777",
GROUP="scanner", ENV{libsane_matched}="yes"



Ça paraît bien.


Du coup xsane s'ouvre bien mais lorsque je tente de voir l'apercu ou de
scanner, la lampe a scanner s'allume mais il ne se passe rien de plus,
je dois faire: annuler pour stopper la fonction.



La lampe peut avoir besoin de chauffer, sinon tu peux modifier ces
paramètres dans le fichier de configuration (plustek.conf):

option warmup t

où "t" est la durée en secondes du préchauffage de la lampe. Si la
valeur est à "-1" c'est le mode automatique qui est utilisé.

Tom


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
jmarco
Le #17950831
modif dans plustek.conf:

/dev/bus/usb/001/002,

>> permissions dans /dev/usb/[numéro du port] qui doivent être à
root:scanner et ug=rw, ton utilisateur doit également faire partie du
groupe scanner.



...? comment dois-je faire cela ?



ls -l /dev/bus/usb/001/ te donnera les permissions et propriétaires
actuels du node, si tu dois les changer c'est :
"chown root:scanner" et "chmod 664 fichier" (ou 777 si c'est nécessaire).
Normalement tout ça sera définie au démarrage en fonction de la règle
udev que tu as dans /etc/udev/rules.d/.
Pour vérifier que ton utilisateur est dans le groupe "scanner" c'est la
commande "groups".



# ls -l /dev/bus/usb/001/
total 0
crw-rw-r-- 1 root root 189, 0 2008-11-24 23:30 001
crwxrwxrwx 1 root scanner 189, 1 2008-11-24 22:34 002

$ groups
jmarc dialout cdrom floppy audio video plugdev netdev lpadmin powerdev

chez moi c'est: /etc/udev/rules.d/025_libsane.rules
avec # Plustek OpticPro U24
SYSFS{idVendor}=="07b3", SYSFS{idProduct}=="0011", MODE="777",
GROUP="scanner", ENV{libsane_matched}="yes"



Ça paraît bien.





La lampe peut avoir besoin de chauffer, sinon tu peux modifier ces
paramètres dans le fichier de configuration (plustek.conf):

option warmup t

où "t" est la durée en secondes du préchauffage de la lampe. Si la
valeur est à "-1" c'est le mode automatique qui est utilisé.


c'est le cas.

>> Du coup xsane s'ouvre bien mais lorsque je tente de voir l'apercu ou
>> de scanner, la lampe a scanner s'allume mais il ne se passe rien de
>> plus, je dois faire: annuler pour stopper la fonction.
rien de nouveau...

Jmarc

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Serge Cavailles
Le #17951241
Bonsoir,

Le lundi 24 novembre 2008 22:42, jmarco a écrit :
> Pour vérifier que ton utilisateur est dans le groupe "scanner" c'est la
> commande "groups".

$ groups
jmarc dialout cdrom floppy audio video plugdev netdev lpadmin powerdev



Tu ne fais pas partie du groupe "scanner". Il faut ajouter ton user (jmarc)
à la ligne du groupe scanner (celle qui commence par scanner) dans le
fichier /etc/group.

Cordialement,
--
Serge

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
jmarco
Le #17952411
Bonjour,
merci pour ta reponse,

Le lundi 24 novembre 2008 22:42, jmarco a écrit :
Pour vérifier que ton utilisateur est dans le groupe "scanner" c'est la
commande "groups".


$ groups
jmarc dialout cdrom floppy audio video plugdev netdev lpadmin powerdev



Tu ne fais pas partie du groupe "scanner". Il faut ajouter ton user (jmarc)
à la ligne du groupe scanner (celle qui commence par scanner) dans le
fichier /etc/group.



-Donc j'ajoute jmarc au groupe scanner:

# usermod -G
jmarc,scanner,dialout,cdrom,floppy,audio,video,plugdev,netdev,lpadmin,powerdev
jmarc

-Je redemarre, et toujours la meme chose, le scanner s'allume lorsque je
demande l'apercu avec xsane, et puis rien ne bouge, j'annule et je
ferme xsane.

~$ groups
jmarc dialout cdrom floppy audio video plugdev netdev lpadmin powerdev
scanner

une idee?

cordialement,
Jmarc

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
jmarco
Le #17952961
Bonjour,
donc apres un redemarrage, ouverture de xsane et
choix d'un dossier de destination (peut-etre la le blocage...)
tout fonctionne bien pour le moment,
merci pour votre aide,
cordialement,
Jmarc

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme