Installer etch sur clé usb

Le
Steve
Bonjour,

Pour apprendre et m'amuser, je suis en train d'essayer d'installer une
etch sur une clé usb, tout ça depuis une etch. Pour cela, je suis le
tuto à l'adresse :
http://blog.shadoware.org/index.php?2007/08/04/23-debian-etch-cle-usb

Voici ce que j'ai fait.

1) partitionnement de la clé (2G)

sdc1 : 50M /boot en ext2
sdc2 : 1400M / en ext2
sdc3 : 450M /home en ext2

2) on donne un LABEL à ces partitions :

mke2fs /dev/sdc1 -L live-boot
mke2fs /dev/sdc2 -L live-root
mke2fs /dev/sdc2 -L live-home

on peut aussi le faire avec e2label

Remarque : il est peut-être nécessaire de redémarrer la machine.
Certains disent qu'un « partprobe » (du paquet parted) devrait suffire,
mais pas dans mon cas)

3) Montage des partitions

mount /dev/sdc2 /mnt
mkdir /mnt/boot
mkdir /mnt/home
mount /dev/sdc1 /mnt/boot
mount /dev/sdc3 /mnt/home

4) Installation avec debootstrap

debootstrap --arch i386 etch /mnt ftp://ftp2.fr.debian.org/debian

5) Chroot

chroot /mnt

6) fstab

LABEL=live-root / ext2 defaults,errors=remount-ro,noatime 0 1
LABEL=live-boot /boot ext2 defaults,noatime,ro 0 2
LABEL=live-home /home ext2 defaults,noatime 0 2
proc /proc proc defaults 0 0
#tmpfs /etc/network/run tmpfs defaults,noatime 0 0
tmpfs /tmp tmpfs defaults,noatime 0 0
tmpfs /var/lock tmpfs defaults,noatime 0 0
tmpfs /var/log tmpfs defaults,noatime 0 0
tmpfs /var/run tmpfs defaults,noatime 0 0
tmpfs /var/tmp tmpfs defaults,noatime 0 0

7) Montage des partitions

mount -a

Et là un problème surgit :

mount: /dev/sdc1 already mounted or /boot busy
mount: /dev/sdc3 already mounted or /home busy

Dans le tuto, on conseille si on rencontre ce genre de problème de
monter en --bind le /dev (hors chroot) :

mount --bind /dev /mnt/dev

Mais ça ne change rien, et je suis bloqué et je demande donc votre aide.

Dès ce stade réglé j'écrirai la suite ici.

Merci d'avance
--
Steve

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
François Boisson
Le #9682071
> 7) Montage des partitions

mount -a

Et là un problème surgit :

mount: /dev/sdc1 already mounted or /boot busy
mount: /dev/sdc3 already mounted or /home busy




Ça n'est pas un problème, ces partitions sont déjà montées. Tout va bien donc.

Dans le tuto, on conseille si on rencontre ce genre de problème de
monter en --bind le /dev (hors chroot) :




Ça c'est lorsque tu as ton /dev initial vide du fait de l'utilisation de udev.
Monter celui de l'ordianteur hote en «bind» te permet de récupérer tous les
fichiers spéciaux de périphériques construit par udev dans le /dev de l'hote.
Tu n'as pas à les recréer toi même...

mount --bind /dev /mnt/dev

Mais ça ne change rien, et je suis bloqué et je demande donc votre aide.



Normal donc


Dès ce stade réglé j'écrirai la suite ici.




Il suffit d'ignorer l'erreur et de continuer...

François Boisson

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
François Boisson
Le #9651351
Le Mon, 28 Apr 2008 11:01:18 +0200
Steve
Le 26-04-2008, à 10:17:47 +0200, François Boisson
() a écrit :

> Lignes : 45
>
>
> > 7) Montage des partitions
> >
> > mount -a
> >
> > Et là un problème surgit :
> >
> > mount: /dev/sdc1 already mounted or /boot busy
> > mount: /dev/sdc3 already mounted or /home busy
> >
>
> Ça n'est pas un problème, ces partitions sont déjà montées. Tout va bien
> donc.

Mais on ne les voit pas dans le chroot avec un mount.



As tu monté /proc?
Sinon c'est simpolement que le contenu de /etc/mtab est foireux:
Exemple:

bling:/mnt# chroot /srv
bling:/# mount
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
bling:/# cat /proc/mounts
rootfs / rootfs rw 0 0
none /sys sysfs rw 0 0
none /proc proc rw 0 0
udev /dev tmpfs rw,size240k,modeu5 0 0
/dev/root / ext3 rw,errors=remount-ro,data=ordered 0 0
/dev/root /dev/.static/dev ext3 rw,errors=remount-ro,data=ordered 0 0
tmpfs /lib/init/rw tmpfs rw,nosuid,modeu5 0 0
usbfs /proc/bus/usb usbfs rw,nosuid,nodev,noexec,devgid0,devmodef4 0 0
tmpfs /dev/shm tmpfs rw,nosuid,nodev 0 0
devpts /dev/pts devpts rw,nosuid,noexec,gid=5,modeb0 0 0
/dev/sda7 /home ext3 rw,errors=continue,data=ordered 0 0
/dev/sda7 /home ext3 rw,errors=continue,data=ordered 0 0
/dev/root /tmp ext3 rw,errors=remount-ro,data=ordered 0 0
proc /proc proc rw 0 0
/dev/root /var/run/lprng ext3 rw,errors=remount-ro,data=ordered 0 0
udev /dev tmpfs rw,size240k,modeu5 0 0
/dev/sdb /mnt vfat rw,fmask22,dmask22,codepage=cp437,iocharset=iso8859-1 0 0

Si ça t'ennuie, tu peux faire un car /proc/mounts sur /etc/mtab en enlevant les lignes superflues.
Je te suggère de traiter ça par le mépris. Par contre, si tu as udev, il est important de mettre
/dev sur ta racine chroot en bind avant de manipuler. Les périphériques détectés
seront cohérents.

François Boisson

>
> > Dans le tuto, on conseille si on rencontre ce genre de problème de
> > monter en --bind le /dev (hors chroot) :
> >
>
> Ça c'est lorsque tu as ton /dev initial vide du fait de l'utilisation de
> udev. Monter celui de l'ordianteur hote en «bind» te permet de récupérer
> tous les fichiers spéciaux de périphériques construit par udev dans
> le /dev de l'hote. Tu n'as pas à les recréer toi même...

Ok.

> > mount --bind /dev /mnt/dev
> >
> > Mais ça ne change rien, et je suis bloqué et je demande donc votre aide.
>
> Normal donc
>
> >
> > Dès ce stade réglé j'écrirai la suite ici.
> >
>
> Il suffit d'ignorer l'erreur et de continuer...

C'est ce que j'ai fait. Donc, voici la suite pour ceux que ça intéresse
:

8) une fois que les partoches sont montées, il faut modifier quelques
ficheirs : /etc/hosts, /etc/hostname et /etc/kernel-img.conf

9) Installer le noyau (plus initrd-tools), grub et localpurge

Créer le /etc/apt/sources.list

10) Installer grub sur le mbr de la clé

grub-install --root-directory=/mnt /dev/sdc

Ensuite configurer le menu.lst

Là j'ai eu un petit problème au reboot car grub ne trouvait pas la clé.
J'ai 2 dd (sda et sdb) et je pensais donc mettre (hd2,1). Bizarrement,
il ne trouvat qu'un seul des deux dd et j'ai dû mettre (hd1,1) pour
pouvoir démarrer. (Utiliser le <tab> de grub pour trouver les partitions
et les essayer une à une m'a permis de m'en rendre compte).

11) ajouter un utilisateur et un mdp pour root

# chroot /mnt
# passdw
# adduser toto

12) Ajustement de minimiser les écritures sur la clé

Vu qu'une clé usb est assez limitée dans le nombre d'écriture avant de
merder, le tuto conseille de :

rm -f /etc/blkid.tab*
ln -s /dev/null /etc/blkid.tab
rm -f /etc/mtab
ln -s /proc/mounts /etc/mtab

Pour moi, ça ne m'a rapporté que des problèmes (pas de mtab ...).

13) Fin

# umount -a
# exit

et

# shutdown -r now


et le tour est joué. Ne reste plus ensuite qu'à configurer deux-trois
trucs et c'est fonctionnel.

> François Boisson

Merci François et excellente semaine

--
Steve

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Steve
Le #9651331
Le 26-04-2008, à 10:17:47 +0200, François Boisson () a écrit :

Lignes : 45


> 7) Montage des partitions
>
> mount -a
>
> Et là un problème surgit :
>
> mount: /dev/sdc1 already mounted or /boot busy
> mount: /dev/sdc3 already mounted or /home busy
>

Ça n'est pas un problème, ces partitions sont déjà montées. Tout va bien donc.



Mais on ne les voit pas dans le chroot avec un mount.


> Dans le tuto, on conseille si on rencontre ce genre de problème de
> monter en --bind le /dev (hors chroot) :
>

Ça c'est lorsque tu as ton /dev initial vide du fait de l'utilisation de udev.
Monter celui de l'ordianteur hote en «bind» te permet de récupérer tous les
fichiers spéciaux de périphériques construit par udev dans le /dev de l'hote.
Tu n'as pas à les recréer toi même...



Ok.

> mount --bind /dev /mnt/dev
>
> Mais ça ne change rien, et je suis bloqué et je demande donc votre aide.

Normal donc

>
> Dès ce stade réglé j'écrirai la suite ici.
>

Il suffit d'ignorer l'erreur et de continuer...



C'est ce que j'ai fait. Donc, voici la suite pour ceux que ça intéresse
:

8) une fois que les partoches sont montées, il faut modifier quelques
ficheirs : /etc/hosts, /etc/hostname et /etc/kernel-img.conf

9) Installer le noyau (plus initrd-tools), grub et localpurge

Créer le /etc/apt/sources.list

10) Installer grub sur le mbr de la clé

grub-install --root-directory=/mnt /dev/sdc

Ensuite configurer le menu.lst

Là j'ai eu un petit problème au reboot car grub ne trouvait pas la clé.
J'ai 2 dd (sda et sdb) et je pensais donc mettre (hd2,1). Bizarrement,
il ne trouvat qu'un seul des deux dd et j'ai dû mettre (hd1,1) pour
pouvoir démarrer. (Utiliser le <tab> de grub pour trouver les partitions
et les essayer une à une m'a permis de m'en rendre compte).

11) ajouter un utilisateur et un mdp pour root

# chroot /mnt
# passdw
# adduser toto

12) Ajustement de minimiser les écritures sur la clé

Vu qu'une clé usb est assez limitée dans le nombre d'écriture avant de
merder, le tuto conseille de :

rm -f /etc/blkid.tab*
ln -s /dev/null /etc/blkid.tab
rm -f /etc/mtab
ln -s /proc/mounts /etc/mtab

Pour moi, ça ne m'a rapporté que des problèmes (pas de mtab ...).

13) Fin

# umount -a
# exit

et

# shutdown -r now


et le tour est joué. Ne reste plus ensuite qu'à configurer deux-trois
trucs et c'est fonctionnel.

François Boisson



Merci François et excellente semaine

--
Steve

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Steve
Le #9651311
Le 28-04-2008, à 11:07:33 +0200, François Boisson () a écrit :

Lignes : 161

Le Mon, 28 Apr 2008 11:01:18 +0200
Steve
> Le 26-04-2008, à 10:17:47 +0200, François Boisson
> () a écrit :
>
> > Lignes : 45
> >
> >
> > > 7) Montage des partitions
> > >
> > > mount -a
> > >
> > > Et là un problème surgit :
> > >
> > > mount: /dev/sdc1 already mounted or /boot busy
> > > mount: /dev/sdc3 already mounted or /home busy
> > >
> >
> > Ça n'est pas un problème, ces partitions sont déjà montées. Tout va bien
> > donc.
>
> Mais on ne les voit pas dans le chroot avec un mount.

As tu monté /proc?



Il me semble que /proc était monté avant même de faire un "mount -a",
mais sans guarantie

Sinon c'est simpolement que le contenu de /etc/mtab est foireux:
Exemple:

bling:/mnt# chroot /srv
bling:/# mount
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
bling:/# cat /proc/mounts
rootfs / rootfs rw 0 0
none /sys sysfs rw 0 0
none /proc proc rw 0 0
udev /dev tmpfs rw,size240k,modeu5 0 0
/dev/root / ext3 rw,errors=remount-ro,data=ordered 0 0
/dev/root /dev/.static/dev ext3 rw,errors=remount-ro,data=ordered 0 0
tmpfs /lib/init/rw tmpfs rw,nosuid,modeu5 0 0
usbfs /proc/bus/usb usbfs rw,nosuid,nodev,noexec,devgid0,devmodef4 0 0
tmpfs /dev/shm tmpfs rw,nosuid,nodev 0 0
devpts /dev/pts devpts rw,nosuid,noexec,gid=5,modeb0 0 0
/dev/sda7 /home ext3 rw,errors=continue,data=ordered 0 0
/dev/sda7 /home ext3 rw,errors=continue,data=ordered 0 0
/dev/root /tmp ext3 rw,errors=remount-ro,data=ordered 0 0
proc /proc proc rw 0 0
/dev/root /var/run/lprng ext3 rw,errors=remount-ro,data=ordered 0 0
udev /dev tmpfs rw,size240k,modeu5 0 0
/dev/sdb /mnt vfat rw,fmask22,dmask22,codepage=cp437,iocharset=iso8859-1 0 0

Si ça t'ennuie, tu peux faire un car /proc/mounts sur /etc/mtab en enlevant les lignes superflues.
Je te suggère de traiter ça par le mépris.



C'est à dire ...

Par contre, si tu as udev, il est important de mettre
/dev sur ta racine chroot en bind avant de manipuler. Les périphériques détectés
seront cohérents.



Absolument, sans ça, ça ne marhce tout simplement pas.


François Boisson
>
> >
> > > Dans le tuto, on conseille si on rencontre ce genre de problème de
> > > monter en --bind le /dev (hors chroot) :
> > >
> >
> > Ça c'est lorsque tu as ton /dev initial vide du fait de l'utilisation de
> > udev. Monter celui de l'ordianteur hote en «bind» te permet de récupérer
> > tous les fichiers spéciaux de périphériques construit par udev dans
> > le /dev de l'hote. Tu n'as pas à les recréer toi même...
>
> Ok.
>
> > > mount --bind /dev /mnt/dev
> > >
> > > Mais ça ne change rien, et je suis bloqué et je demande donc votre aide.
> >
> > Normal donc
> >
> > >
> > > Dès ce stade réglé j'écrirai la suite ici.
> > >
> >
> > Il suffit d'ignorer l'erreur et de continuer...
>
> C'est ce que j'ai fait. Donc, voici la suite pour ceux que ça intéresse
> :
>
> 8) une fois que les partoches sont montées, il faut modifier quelques
> ficheirs : /etc/hosts, /etc/hostname et /etc/kernel-img.conf
>
> 9) Installer le noyau (plus initrd-tools), grub et localpurge
>
> Créer le /etc/apt/sources.list
>
> 10) Installer grub sur le mbr de la clé
>
> grub-install --root-directory=/mnt /dev/sdc
>
> Ensuite configurer le menu.lst
>
> Là j'ai eu un petit problème au reboot car grub ne trouvait pas la clé.
> J'ai 2 dd (sda et sdb) et je pensais donc mettre (hd2,1). Bizarrement,
> il ne trouvat qu'un seul des deux dd et j'ai dû mettre (hd1,1) pour
> pouvoir démarrer. (Utiliser le <tab> de grub pour trouver les partitions
> et les essayer une à une m'a permis de m'en rendre compte).
>
> 11) ajouter un utilisateur et un mdp pour root
>
> # chroot /mnt
> # passdw
> # adduser toto
>
> 12) Ajustement de minimiser les écritures sur la clé
>
> Vu qu'une clé usb est assez limitée dans le nombre d'écriture avant de
> merder, le tuto conseille de :
>
> rm -f /etc/blkid.tab*
> ln -s /dev/null /etc/blkid.tab
> rm -f /etc/mtab
> ln -s /proc/mounts /etc/mtab
>
> Pour moi, ça ne m'a rapporté que des problèmes (pas de mtab ...).
>
> 13) Fin
>
> # umount -a
> # exit
>
> et
>
> # shutdown -r now
>
>
> et le tour est joué. Ne reste plus ensuite qu'à configurer deux-trois
> trucs et c'est fonctionnel.
>
> > François Boisson
>
> Merci François et excellente semaine
>
> --
> Steve



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
François Boisson
Le #9651281
Le Mon, 28 Apr 2008 11:35:04 +0200
Steve
> Si ça t'ennuie, tu peux faire un car /proc/mounts sur /etc/mtab en
> enlevant les lignes superflues. Je te suggère de traiter ça par le mépris.

C'est à dire ...



En clair, tu t'en moques, si tu veux ce qui est monté, tu fais un
cat /proc/mounts et pour le reste tu ignores la sortie de mount.
Sinon, il te faut faire un fichier /etc/matab conforme à la réalité.

Frnaçois Boisson

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Steve
Le #9651271
Le 28-04-2008, à 11:59:45 +0200, François Boisson () a écrit :

Lignes : 23

Le Mon, 28 Apr 2008 11:35:04 +0200
Steve
> > Si ça t'ennuie, tu peux faire un car /proc/mounts sur /etc/mtab en
> > enlevant les lignes superflues. Je te suggère de traiter ça par le mépris.
>
> C'est à dire ...

En clair, tu t'en moques, si tu veux ce qui est monté, tu fais un
cat /proc/mounts et pour le reste tu ignores la sortie de mount.



ok.

Sinon, il te faut faire un fichier /etc/matab conforme à la réalité.



Parce que celui obtenu dans le chroot n'est pas correct vu que les
partitions montées en-dehors du chroot ne sont pas visible dans le chroot
?

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
François Boisson
Le #9651261
Le Mon, 28 Apr 2008 14:06:37 +0200
Steve
Parce que celui obtenu dans le chroot n'est pas correct vu que les
partitions montées en-dehors du chroot ne sont pas visible dans le chroot
?


Oui, le mtab est en fait hérité de l'installation de ton chroot, et n'a rien à
voir avec la réalité...

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Steve
Le #9651231
Le 28-04-2008, à 14:14:23 +0200, François Boisson () a écrit :

Lignes : 18

Le Mon, 28 Apr 2008 14:06:37 +0200
Steve
> Parce que celui obtenu dans le chroot n'est pas correct vu que les
> partitions montées en-dehors du chroot ne sont pas visible dans le chroot
> ?
Oui, le mtab est en fait hérité de l'installation de ton chroot, et n'a rien à
voir avec la réalité...



C'est donc bien ça qui me faisait souci. Bon bin merci, j'ai (encore)
appris quelque chose de nouveau.


PS : petite question qui n'a rien à voir. sous quel nom apparaît mon
message dans le champ expéditeur ? Je pose la question car j'ai quelques
soucis pour configurer correctement mon mutt. Chez moi j'ai : To
debian-user-french .... alors que je devrais avoir steve.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Jacques L'helgoualc'h
Le #9651221
Steve a écrit, lundi 28 avril 2008, à 14:31 :
[...]
PS : petite question qui n'a rien à voir. sous quel nom apparaît mon
message dans le champ expéditeur ?



Le tien, From: Steve...

Je pose la question car j'ai quelques
soucis pour configurer correctement mon mutt. Chez moi j'ai : To
debian-user-french .... alors que je devrais avoir steve.



Ben non, tu l'as bien envoyé à la liste (To:).

Chez moi, les messages de DUF sont dans Mail/LIST.debian-user-french, et
dans mon ~/.muttrc, j'ai (entre autres) ces lignes

mailboxes +LIST.debian-user-french +LIST.debian-security-announce
subscribe debian-

# Valeurs par défaut
folder-hook . "[...]
ignore * ; unignore From: Subject: Date: ;
[...]"

# hooks pour les listes en général
folder-hook LIST "push <collapse-all> ;
[et autres trucs particuliers pour les listes]"
# Si besoin je pourrais spécifier
folder-hook debian- "..."


J'ai aussi une ligne

alternates (la mère des regexpes de mes @dresses)

qui peut intervenir (mais je ne me rappelle plus très bien comment).
--
Jacques L'helgoualc'h

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Steve
Le #9651191
Le 28-04-2008, à 15:18:46 +0200, Jacques L'helgoualc'h (lhh+) a écrit :

Lignes : 48

Steve a écrit, lundi 28 avril 2008, à 14:31 :
[...]
> PS : petite question qui n'a rien à voir. sous quel nom apparaît mon
> message dans le champ expéditeur ?

Le tien, From: Steve...



Oui, un membre de cette liste (dont je tairais le nom) me l'a déjà dit en privé ;-)

> Je pose la question car j'ai quelques
> soucis pour configurer correctement mon mutt. Chez moi j'ai : To
> debian-user-french .... alors que je devrais avoir steve.

Ben non, tu l'as bien envoyé à la liste (To:).



Comment ça non ? Je devrais avoir mon nom qui s'affiche (comme c'était
le cas avant que je bi/merdouille le ~/.muttrc.), ça me paraît naturel.
Ou alors je fatigue

Chez moi, les messages de DUF sont dans Mail/LIST.debian-user-french, et
dans mon ~/.muttrc, j'ai (entre autres) ces lignes

mailboxes +LIST.debian-user-french +LIST.debian-security-announce



moi :

mailboxes `find ~/mail/ -type d -name cur -printf '%h '`

subscribe debian-



Cette ligne suffit pour *toutes* les listes ?


# Valeurs par défaut
folder-hook . "[...]
ignore * ; unignore From: Subject: Date: ;



Quelque autres

[...]"

# hooks pour les listes en général
folder-hook LIST "push <collapse-all> ;



Faudrait que j'essaie

[et autres trucs particuliers pour les listes]"
# Si besoin je pourrais spécifier
folder-hook debian- "..."


J'ai aussi une ligne

alternates (la mère des regexpes de mes @dresses)



Moi aussi, je l'ai rajouté dernièrement, et c'est probablement de là que les ennuis proviennent. Je voulais intégrer une nouvelle adresse dans mutt et configurer le truc de telle manière que les personnes m'envoyant un message à cette nouvelle adresse reçoivent la réponse avec cette même nouvelle adresse. Il y avait aussi un « set reverse_name » dans l'affaire. J'ai pas eu le temps de me pencher vraiment sur ce problème et donc depuis tous mes messages aux listes me sont affichés comme à « to Debian-* »..

qui peut intervenir (mais je ne me rappelle plus très bien comment).



c'est un peu le problème avec Mutt...

Salutations

--
Jacques L'helgoualc'h



--
steve

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme