interdire le changt de format

Le
plex
Bonjour,
Comment interdire le changement de format quand je fais ctrl C / ctrl V,
d'une colonne a une autre.
le format de la colonne B ne doit pas changer quand je fais un copier coller
de la colonne A vers B, car j'ai fait dans B des formats conditionnels qui
sont effacés a chaque fois.
Formats utilisés condition 1 et condition 2 de la colonne B
=SOMMEPROD(($A$4:$A$20Ä)*1)>0 (police gras)
=SOMMEPROD(($A$4:$A$20Ä)*1)=0 (police barré)

Merci pour la réponse.
--
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
michdenis
Le #18551271
Copie - collage spécial valeur seulement ne fonctionne pas ?



"plex"
Bonjour,
Comment interdire le changement de format quand je fais ctrl C / ctrl V,
d'une colonne a une autre.
le format de la colonne B ne doit pas changer quand je fais un copier coller
de la colonne A vers B, car j'ai fait dans B des formats conditionnels qui
sont effacés a chaque fois.
Formats utilisés condition 1 et condition 2 de la colonne B
=SOMMEPROD(($A$4:$A$20Ä)*1)>0 (police gras)
=SOMMEPROD(($A$4:$A$20Ä)*1)=0 (police barré)

Merci pour la réponse.
--
plex
Le #18551431
le probléme c'est que je suis pas le seul a utiliser ce fichier et mes
collègues sans le faire exprès, vont foutre en l'air les formats
conditionnels lors de copier coller nécessaire à l'utilisation entre A et B.


"michdenis"
Copie - collage spécial valeur seulement ne fonctionne pas ?



"plex" discussion :

Bonjour,
Comment interdire le changement de format quand je fais ctrl C / ctrl V,
d'une colonne a une autre.
le format de la colonne B ne doit pas changer quand je fais un copier
coller
de la colonne A vers B, car j'ai fait dans B des formats conditionnels qui
sont effacés a chaque fois.
Formats utilisés condition 1 et condition 2 de la colonne B
=SOMMEPROD(($A$4:$A$20Ä)*1)>0 (police gras)
=SOMMEPROD(($A$4:$A$20Ä)*1)=0 (police barré)

Merci pour la réponse.
--



michdenis
Le #18551631
Pour les versions d'avant 2007, il y a quelque chose comme ceci :
http://cjoint.com/?cdruU5opaM

Tu as toujours l'alternative de désactiver le copier-coller
sur une plage précise de cellules : à titre d'exemple :

Tu copies la déclaration des API dans le haut de ta
feuille où l'action se produit
Cet exemple rend impossible de copier quoi que ce soit
dans la plage A1:C25. à chaque fois que l'usager
sélectionne la plage, le presse-papier est vidé.

'--------------------------------
Private Declare Function OpenClipboard Lib "user32" _
(ByVal hwnd As Long) As Long
Private Declare Function EmptyClipboard Lib "user32" () As Long
Private Declare Function CloseClipboard Lib "user32" () As Long
'--------------------------------
Private Sub Worksheet_SelectionChange(ByVal Target As Range)
If Not Intersect(Target, Range("A1:C25")) Is Nothing Then
OpenClipboard 0
EmptyClipboard
CloseClipboard
End If

End Sub
'--------------------------------



"plex"
le probléme c'est que je suis pas le seul a utiliser ce fichier et mes
collègues sans le faire exprès, vont foutre en l'air les formats
conditionnels lors de copier coller nécessaire à l'utilisation entre A et B.


"michdenis"
Copie - collage spécial valeur seulement ne fonctionne pas ?



"plex" discussion :

Bonjour,
Comment interdire le changement de format quand je fais ctrl C / ctrl V,
d'une colonne a une autre.
le format de la colonne B ne doit pas changer quand je fais un copier
coller
de la colonne A vers B, car j'ai fait dans B des formats conditionnels qui
sont effacés a chaque fois.
Formats utilisés condition 1 et condition 2 de la colonne B
=SOMMEPROD(($A$4:$A$20Ä)*1)>0 (police gras)
=SOMMEPROD(($A$4:$A$20Ä)*1)=0 (police barré)

Merci pour la réponse.
--



plex
Le #18551731
ça me semble pas mal du tout, reste a l'adapter, pourquoi ça ne
fonctionnearit pas sur les versions ultérieures ?

Merci pour le fichier et pour la recherche.

"michdenis"
Pour les versions d'avant 2007, il y a quelque chose comme ceci :
http://cjoint.com/?cdruU5opaM

Tu as toujours l'alternative de désactiver le copier-coller
sur une plage précise de cellules : à titre d'exemple :

Tu copies la déclaration des API dans le haut de ta
feuille où l'action se produit
Cet exemple rend impossible de copier quoi que ce soit
dans la plage A1:C25. à chaque fois que l'usager
sélectionne la plage, le presse-papier est vidé.

'--------------------------------
Private Declare Function OpenClipboard Lib "user32" _
(ByVal hwnd As Long) As Long
Private Declare Function EmptyClipboard Lib "user32" () As Long
Private Declare Function CloseClipboard Lib "user32" () As Long
'--------------------------------
Private Sub Worksheet_SelectionChange(ByVal Target As Range)
If Not Intersect(Target, Range("A1:C25")) Is Nothing Then
OpenClipboard 0
EmptyClipboard
CloseClipboard
End If

End Sub
'--------------------------------



"plex" discussion :

le probléme c'est que je suis pas le seul a utiliser ce fichier et mes
collègues sans le faire exprès, vont foutre en l'air les formats
conditionnels lors de copier coller nécessaire à l'utilisation entre A et
B.


"michdenis"
Copie - collage spécial valeur seulement ne fonctionne pas ?



"plex" discussion :

Bonjour,
Comment interdire le changement de format quand je fais ctrl C / ctrl V,
d'une colonne a une autre.
le format de la colonne B ne doit pas changer quand je fais un copier
coller
de la colonne A vers B, car j'ai fait dans B des formats conditionnels
qui
sont effacés a chaque fois.
Formats utilisés condition 1 et condition 2 de la colonne B
=SOMMEPROD(($A$4:$A$20Ä)*1)>0 (police gras)
=SOMMEPROD(($A$4:$A$20Ä)*1)=0 (police barré)

Merci pour la réponse.
--






michdenis
Le #18552021
Comme je ne suis pas familier avec le ruban de la version 2007...
je ne prends pas de chance !!!
En fait, il fonctionne sous Excel 2007...
mais ne le dit pas trop fort ! ;-))


"plex"
ça me semble pas mal du tout, reste a l'adapter, pourquoi ça ne
fonctionnearit pas sur les versions ultérieures ?

Merci pour le fichier et pour la recherche.

"michdenis"
Pour les versions d'avant 2007, il y a quelque chose comme ceci :
http://cjoint.com/?cdruU5opaM

Tu as toujours l'alternative de désactiver le copier-coller
sur une plage précise de cellules : à titre d'exemple :

Tu copies la déclaration des API dans le haut de ta
feuille où l'action se produit
Cet exemple rend impossible de copier quoi que ce soit
dans la plage A1:C25. à chaque fois que l'usager
sélectionne la plage, le presse-papier est vidé.

'--------------------------------
Private Declare Function OpenClipboard Lib "user32" _
(ByVal hwnd As Long) As Long
Private Declare Function EmptyClipboard Lib "user32" () As Long
Private Declare Function CloseClipboard Lib "user32" () As Long
'--------------------------------
Private Sub Worksheet_SelectionChange(ByVal Target As Range)
If Not Intersect(Target, Range("A1:C25")) Is Nothing Then
OpenClipboard 0
EmptyClipboard
CloseClipboard
End If

End Sub
'--------------------------------



"plex" discussion :

le probléme c'est que je suis pas le seul a utiliser ce fichier et mes
collègues sans le faire exprès, vont foutre en l'air les formats
conditionnels lors de copier coller nécessaire à l'utilisation entre A et
B.


"michdenis"
Copie - collage spécial valeur seulement ne fonctionne pas ?



"plex" discussion :

Bonjour,
Comment interdire le changement de format quand je fais ctrl C / ctrl V,
d'une colonne a une autre.
le format de la colonne B ne doit pas changer quand je fais un copier
coller
de la colonne A vers B, car j'ai fait dans B des formats conditionnels
qui
sont effacés a chaque fois.
Formats utilisés condition 1 et condition 2 de la colonne B
=SOMMEPROD(($A$4:$A$20Ä)*1)>0 (police gras)
=SOMMEPROD(($A$4:$A$20Ä)*1)=0 (police barré)

Merci pour la réponse.
--






plex
Le #18552081
OK merci pour la réponse et bonne soirée

"michdenis"
Comme je ne suis pas familier avec le ruban de la version 2007...
je ne prends pas de chance !!!
En fait, il fonctionne sous Excel 2007...
mais ne le dit pas trop fort ! ;-))


"plex" discussion :

ça me semble pas mal du tout, reste a l'adapter, pourquoi ça ne
fonctionnearit pas sur les versions ultérieures ?

Merci pour le fichier et pour la recherche.

"michdenis"
Pour les versions d'avant 2007, il y a quelque chose comme ceci :
http://cjoint.com/?cdruU5opaM

Tu as toujours l'alternative de désactiver le copier-coller
sur une plage précise de cellules : à titre d'exemple :

Tu copies la déclaration des API dans le haut de ta
feuille où l'action se produit
Cet exemple rend impossible de copier quoi que ce soit
dans la plage A1:C25. à chaque fois que l'usager
sélectionne la plage, le presse-papier est vidé.

'--------------------------------
Private Declare Function OpenClipboard Lib "user32" _
(ByVal hwnd As Long) As Long
Private Declare Function EmptyClipboard Lib "user32" () As Long
Private Declare Function CloseClipboard Lib "user32" () As Long
'--------------------------------
Private Sub Worksheet_SelectionChange(ByVal Target As Range)
If Not Intersect(Target, Range("A1:C25")) Is Nothing Then
OpenClipboard 0
EmptyClipboard
CloseClipboard
End If

End Sub
'--------------------------------



"plex" discussion :

le probléme c'est que je suis pas le seul a utiliser ce fichier et mes
collègues sans le faire exprès, vont foutre en l'air les formats
conditionnels lors de copier coller nécessaire à l'utilisation entre A et
B.


"michdenis"
Copie - collage spécial valeur seulement ne fonctionne pas ?



"plex" discussion :

Bonjour,
Comment interdire le changement de format quand je fais ctrl C / ctrl V,
d'une colonne a une autre.
le format de la colonne B ne doit pas changer quand je fais un copier
coller
de la colonne A vers B, car j'ai fait dans B des formats conditionnels
qui
sont effacés a chaque fois.
Formats utilisés condition 1 et condition 2 de la colonne B
=SOMMEPROD(($A$4:$A$20Ä)*1)>0 (police gras)
=SOMMEPROD(($A$4:$A$20Ä)*1)=0 (police barré)

Merci pour la réponse.
--









Publicité
Poster une réponse
Anonyme