Internal error: found 2 (choice -> promotion) mappings for a single choice.

Le
C. Mourad Jaber
Bonjour,

Depuis quelques jours, j'ai le message suivant :
"Internal error: found 2 (choice -> promotion) mappings for a single choice."
quand je veux faire un "aptitude upgrade"

Au bout de quelques temps, cela semble fonctionnement, mais cela ne me semble pas très sain

Avec la commande apt-get tout roule !

Est-ce qu'il y a un moyen de corriger aptitude ?

++

Mourad
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Bernard Schoenacker
Le #26396330
Le Mon, 25 Apr 2016 18:31:52 +0200,
"C. Mourad Jaber"
Bonjour,

Depuis quelques jours, j'ai le message suivant :
"Internal error: found 2 (choice -> promotion) mappings for a single
choice." quand je veux faire un "aptitude upgrade"...

Au bout de quelques temps, cela semble fonctionnement, mais cela ne
me semble pas très sain...

Avec la commande apt-get tout roule !

Est-ce qu'il y a un moyen de corriger aptitude ?

++

Mourad




bonjour,

serait il possible de changer de version pour apt et aptitude ?

rmadison -a amd64,i386 aptitude
aptitude | 0.6.8.2-1 | oldstable | amd64, i386
aptitude | 0.6.11-1+b1 | stable | amd64, i386
aptitude | 0.7.5-3 | testing | amd64, i386
aptitude | 0.8-1 | unstable | amd64, i386

apt policy aptitude
aptitude:
Installé : 0.8-1
Candidat : 0.8-1
Table de version :
*** 0.8-1 500
500 http://httpredir.debian.org/debian sid/main amd64 Packages


slt
bernard
steve
Le #26396346
Salut,

Le 25-04-2016, à 18:31:52 +0200, C. Mourad Jaber a écrit :

Bonjour,

Depuis quelques jours, j'ai le message suivant :
"Internal error: found 2 (choice -> promotion) mappings for a single choice."
quand je veux faire un "aptitude upgrade"...

Au bout de quelques temps, cela semble fonctionnement, mais cela ne me semble pas très sain...

Avec la commande apt-get tout roule !

Est-ce qu'il y a un moyen de corriger aptitude ?



Juste une idée : n'y aurait-il pas deux lignes sensiblement pareilles
dans ton sources.list ? Genre une avec le nom stable et l'autre avec
jessie (ou pareil avec testing et stretch etc…).

Sinon, peux-tu montrer ce qu'il y a avant et après ce message ?
steve
Le #26396345
En fait il semble que le problème provienne du fait que tu as dû
installer un paquet qui a des dépendances insolubles. Probablement un
paquet deb ne faisant pas partie des dépôts officiels. Ne reste plus
qu'à trouver lequel, le désinstaller et trouver une manière plus saine
de le réinstaller.
Publicité
Poster une réponse
Anonyme