Internet via une carte PCMCIA Orange 3G

Le
LESOUEF Emmanuel
Bonjour à tous,

Voilà, je tente de me connecter à internet avec une carte 3G Orange =
Fusion+.

Celle-ci est bien reconnue à l'aide du module nozomi et j'ai donc un =
péripherique /dev/noz0 fonctionnel.

J'ai utilisé les pages suivantes :

http://www.klabs.be/~fpiat/linux/debian/Option_Qualcomm_MSM6275_UMTS/

et

http://contrib.xarli.net/optionfusionsousdebian/

J'ai donc utilisé ppp (donc pon) pour lancer la connexion. Ca semble =
fonctionner mais l'interface ppp0 n'est pas adressée (pas d'IP).

En mode debug, j'ai les lignes suivantes :

[~] $ sudo pon orange
Serial connection established.
using channel 14
Using interface ppp0
Connect: ppp0 <--> /dev/noz0
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xb43155c2> <pcomp> =
<accomp>]
rcvd [LCP ConfReq id=0x1e <asyncmap 0x0> <auth chap MD5> <magic =
0x84f01acf> <pcomp> <accomp>]
sent [LCP ConfAck id=0x1e <asyncmap 0x0> <auth chap MD5> <magic =
0x84f01acf> <pcomp> <accomp>]
rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0xb43155c2> <pcomp> =
<accomp>]
sent [LCP EchoReq id=0x0 magic=0xb43155c2]
rcvd [LCP DiscReq id=0x1f magic=0x84f01acf]
rcvd [CHAP Challenge id=0x1 <dc24a6af9a41bec45e4ac5a6dab695e2>, name =
= "UMTS_CHAP_SRVR"]
sent [CHAP Response id=0x1 <ac08c1745ac9d7a4d394008e78c01098>, name =
= "orange"]
rcvd [LCP EchoRep id=0x0 magic=0x84f01acf b4 31 55 c2]
rcvd [CHAP Success id=0x1 ""]
CHAP authentication succeeded
CHAP authentication succeeded
sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns3 =
0.0.0.0>]
rcvd [IPCP ConfNak id=0x1 <ms-dns1 10.11.12.13> <ms-dns3 10.11.12.14> =
<ms-wins 10.11.12.13> <ms-wins 10.11.12.14>]
sent [IPCP ConfReq id=0x2 <addr 0.0.0.0> <ms-dns1 10.11.12.13> =
<ms-dns3 10.11.12.14>]
sent [IPCP ConfReq id=0x2 <addr 0.0.0.0> <ms-dns1 10.11.12.13> =
<ms-dns3 10.11.12.14>]

Les deux dernière lignes se répetent et le log s'achève avec :

sent [LCP EchoReq id=0x1 magic=0x5f0ac1f8]
IPCP: timeout sending Config-Requests
sent [LCP TermReq id=0x2 "No network protocols running"]
sent [LCP TermReq id=0x3 "No network protocols running"]
Connection terminated.
Modem hangup

Est-ce que quelqu'un a une idée ?

Pour info, ma configuration : Debian Unstable sur un portable HP nc2400.

Merci pour toute l'aide que vous pourrez m'apporter.

--
Emmanuel Lesouef
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
fabrice régnier
Le #9634321
salut,

Il y a quelques semaines, j'ai aussi fait ce test. Si ça peut aider...

Résumé 0000740: test carte 3G orange sur debian
Description http://contrib.xarli.net/optionfusionsousdebian/ [^]

insérer la carte:

FR-PORT:~# lspci | grep UMTS
07:00.2 Network controller: Option N.V. Qualcomm MSM6275 UMTS chip
installation du driver kivabien:

FR-PORT:/boot# aptitude install nozomi-source

FR-PORT:/boot# m-a

FR-PORT:/boot# dpkg -al|grep nozomi
ii nozomi-modules-2.6.22-2-686 2.1-3+2.6.22-4 GlobeTrotter HSDPA driver
for Linux (kernel
ii nozomi-source 2.1-3 source for GlobeTrotter HSDPA kernel driver

FR-PORT:/boot# modprobe nozomi
FR-PORT:/boot# lsmod | grep nozomi
nozomi 18672 0

installation de l'utilitaire de gestion de la carte:
FR-PORT:~# aptitude install gcom

FR-PORT:~# gcom -d /dev/noz0
FR-PORT:~# gcom -d /dev/noz0 reg

FR-PORT:/usr/bin# aptitude install wvdial ppp


FR-PORT:/usr/bin# cat /etc/wvdial.conf
[Dialer Defaults]
Modem = /dev/noz0
Baud = 460800
SetVolume = 0
Dial Command = ATDT
FlowControl = NOFLOW
Init1 = ATZ
Init2 = ATM0

[Dialer orange-public]
Username = any
Password = any
Phone = *99***1#
Stupid Mode = 1
Init3 = AT+CGDCONT=1,"IP","orange.fr"
Dial Attempts = 3

[Dialer orange-entreprise]
Username = any
Password = any
Phone = *99***1#
Stupid Mode = 1
Init3 = AT+CGDCONT=1,"IP","internet-entreprise"
Dial Attempts = 3

[Dialer orange-vpn]
Username = any
Password = any
Phone = *99***1#
Stupid Mode = 1
Init3 = AT+CGDCONT=1,"IP","orange.vpn"
Dial Attempts = 3

FR-PORT:/usr/bin# cat /etc/ppp/peers/wvdial
plugin passwordfd.so
noauth
name wvdial
replacedefaultroute
noipdefault
nomagic
usepeerdns
ipcp-accept-local
ipcp-accept-remote
nomp
noccp
nopredictor1
novj
novjccomp
nobsdcomp

FR-PORT:/usr/bin# wvdial orange-public

et voili ;)

a+

f.



LESOUEF Emmanuel wrote:
Bonjour à tous,

Voilà, je tente de me connecter à internet avec une carte 3G Orange Fusion+.

Celle-ci est bien reconnue à l'aide du module nozomi et j'ai donc un péripherique /dev/noz0 fonctionnel.

J'ai utilisé les pages suivantes :

http://www.klabs.be/~fpiat/linux/debian/Option_Qualcomm_MSM6275_UMTS/

et

http://contrib.xarli.net/optionfusionsousdebian/

J'ai donc utilisé ppp (donc pon) pour lancer la connexion. Ca semble fonctionner mais l'interface ppp0 n'est pas adressée (pas d'IP).

En mode debug, j'ai les lignes suivantes :

[~] $ sudo pon orange
Serial connection established.
using channel 14
Using interface ppp0
Connect: ppp0 <--> /dev/noz0
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xb43155c2> <pcomp> <accomp>]
rcvd [LCP ConfReq id=0x1e <asyncmap 0x0> <auth chap MD5> <magic 0x84f01acf> <pcomp> <accomp>]
sent [LCP ConfAck id=0x1e <asyncmap 0x0> <auth chap MD5> <magic 0x84f01acf> <pcomp> <accomp>]
rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0xb43155c2> <pcomp> <accomp>]
sent [LCP EchoReq id=0x0 magic=0xb43155c2]
rcvd [LCP DiscReq id=0x1f magic=0x84f01acf]
rcvd [CHAP Challenge id=0x1 <dc24a6af9a41bec45e4ac5a6dab695e2>, name = "UMTS_CHAP_SRVR"]
sent [CHAP Response id=0x1 <ac08c1745ac9d7a4d394008e78c01098>, name = "orange"]
rcvd [LCP EchoRep id=0x0 magic=0x84f01acf b4 31 55 c2]
rcvd [CHAP Success id=0x1 ""]
CHAP authentication succeeded
CHAP authentication succeeded
sent [IPCP ConfReq id=0x1 rcvd [IPCP ConfNak id=0x1 sent [IPCP ConfReq id=0x2 sent [IPCP ConfReq id=0x2
Les deux dernière lignes se répetent et le log s'achève avec :

sent [LCP EchoReq id=0x1 magic=0x5f0ac1f8]
IPCP: timeout sending Config-Requests
sent [LCP TermReq id=0x2 "No network protocols running"]
sent [LCP TermReq id=0x3 "No network protocols running"]
Connection terminated.
Modem hangup

Est-ce que quelqu'un a une idée ?

Pour info, ma configuration : Debian Unstable sur un portable HP nc2400.

Merci pour toute l'aide que vous pourrez m'apporter.

--
Emmanuel Lesouef




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Emmanuel Lesouef
Le #9634281
Salut,

Le vendredi 28 décembre 2007 à 09:38 +0100, fabrice régnier a écrit :
salut,

Il y a quelques semaines, j'ai aussi fait ce test. Si ça peut aider. ..

Résumé 0000740: test carte 3G orange sur debian
Description http://contrib.xarli.net/optionfusionsousdebian/ [^]

insérer la carte:

FR-PORT:~# lspci | grep UMTS
07:00.2 Network controller: Option N.V. Qualcomm MSM6275 UMTS chip
installation du driver kivabien:

FR-PORT:/boot# aptitude install nozomi-source

FR-PORT:/boot# m-a

FR-PORT:/boot# dpkg -al|grep nozomi
ii nozomi-modules-2.6.22-2-686 2.1-3+2.6.22-4 GlobeTrotter HSDPA driver
for Linux (kernel
ii nozomi-source 2.1-3 source for GlobeTrotter HSDPA kernel driver

FR-PORT:/boot# modprobe nozomi
FR-PORT:/boot# lsmod | grep nozomi
nozomi 18672 0

installation de l'utilitaire de gestion de la carte:
FR-PORT:~# aptitude install gcom

FR-PORT:~# gcom -d /dev/noz0
FR-PORT:~# gcom -d /dev/noz0 reg



Jusqu'ici, tout va bien :)


FR-PORT:/usr/bin# aptitude install wvdial ppp



Perso j'avais juste testé avec ppp (donc pon) et les scripts fournis
dans les howto.

Le problème (temporaire je l'espere...) est le suivant :

[~] $ sudo apt-get install wvdial
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.

Puisque vous n'avez demandé qu'une seule opération, le paquet n'e st
probablement pas installable et vous devriez envoyer un rapport de
bogue.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
wvdial: Dépend: libuniconf4.4 mais il n'est pas installable
Dépend: libwvstreams4.4-base mais il n'est pas installable
Dépend: libwvstreams4.4-extras mais il n'est pas installable
E: Paquets défectueux

Donc pour tester avec wvdial, il va falloir attendre un peu. Quoique je
vais essayer d'adapter un peu les fichiers suivants.



FR-PORT:/usr/bin# cat /etc/wvdial.conf
[Dialer Defaults]
Modem = /dev/noz0
Baud = 460800
SetVolume = 0
Dial Command = ATDT
FlowControl = NOFLOW
Init1 = ATZ
Init2 = ATM0

[Dialer orange-public]
Username = any
Password = any
Phone = *99***1#
Stupid Mode = 1
Init3 = AT+CGDCONT=1,"IP","orange.fr"
Dial Attempts = 3

[Dialer orange-entreprise]
Username = any
Password = any
Phone = *99***1#
Stupid Mode = 1
Init3 = AT+CGDCONT=1,"IP","internet-entreprise"
Dial Attempts = 3

[Dialer orange-vpn]
Username = any
Password = any
Phone = *99***1#
Stupid Mode = 1
Init3 = AT+CGDCONT=1,"IP","orange.vpn"
Dial Attempts = 3

FR-PORT:/usr/bin# cat /etc/ppp/peers/wvdial
plugin passwordfd.so
noauth
name wvdial
replacedefaultroute
noipdefault
nomagic
usepeerdns
ipcp-accept-local
ipcp-accept-remote
nomp
noccp
nopredictor1
novj
novjccomp
nobsdcomp

FR-PORT:/usr/bin# wvdial orange-public

et voili ;)

a+

f.




Merci de ton aide.

--
Emmanuel Lesouef
Alex Perso
Le #9634261
Bonjour,
je viens de récuperer une carte FUSION Globe trotter HSDPA, je te
remercie pour ton tuto.

Mais j'ai un petit souci, j'utilise la connexion orange-vpn.
J'arrive bien a me connecter, mais ensuite j'utilise l'openvpn pour me
connecter a mon bureau.
Et la c'est le hic.

Voici la sortie de la commande route -n:
Destination Passerelle Genmask Indic Metric Ref Use
Iface
10.64.64.64 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
0.0.0.0 0.0.0.0 0.0.0.0 U 0 0 0 ppp0


Puis lorsque je me connecte sur openvpn, j'ai la route par defaut qui ne
peut se mettre:
Fri Dec 28 11:16:17 2007 NOTE: unable to redirect default gateway --
Cannot read current default gateway from system

Je n'ai pas ce problème quand je me connecte en wifi ou en filaire.

Quelqu'un a-til deja rencontré ce problème?

Merci

Alexandre

fabrice régnier a écrit :
salut,

Il y a quelques semaines, j'ai aussi fait ce test. Si ça peut aider...

Résumé 0000740: test carte 3G orange sur debian
Description http://contrib.xarli.net/optionfusionsousdebian/ [^]

insérer la carte:

FR-PORT:~# lspci | grep UMTS
07:00.2 Network controller: Option N.V. Qualcomm MSM6275 UMTS chip
installation du driver kivabien:

FR-PORT:/boot# aptitude install nozomi-source

FR-PORT:/boot# m-a

FR-PORT:/boot# dpkg -al|grep nozomi
ii nozomi-modules-2.6.22-2-686 2.1-3+2.6.22-4 GlobeTrotter HSDPA driver
for Linux (kernel
ii nozomi-source 2.1-3 source for GlobeTrotter HSDPA kernel driver

FR-PORT:/boot# modprobe nozomi
FR-PORT:/boot# lsmod | grep nozomi
nozomi 18672 0

installation de l'utilitaire de gestion de la carte:
FR-PORT:~# aptitude install gcom

FR-PORT:~# gcom -d /dev/noz0
FR-PORT:~# gcom -d /dev/noz0 reg

FR-PORT:/usr/bin# aptitude install wvdial ppp


FR-PORT:/usr/bin# cat /etc/wvdial.conf
[Dialer Defaults]
Modem = /dev/noz0
Baud = 460800
SetVolume = 0
Dial Command = ATDT
FlowControl = NOFLOW
Init1 = ATZ
Init2 = ATM0

[Dialer orange-public]
Username = any
Password = any
Phone = *99***1#
Stupid Mode = 1
Init3 = AT+CGDCONT=1,"IP","orange.fr"
Dial Attempts = 3

[Dialer orange-entreprise]
Username = any
Password = any
Phone = *99***1#
Stupid Mode = 1
Init3 = AT+CGDCONT=1,"IP","internet-entreprise"
Dial Attempts = 3

[Dialer orange-vpn]
Username = any
Password = any
Phone = *99***1#
Stupid Mode = 1
Init3 = AT+CGDCONT=1,"IP","orange.vpn"
Dial Attempts = 3

FR-PORT:/usr/bin# cat /etc/ppp/peers/wvdial
plugin passwordfd.so
noauth
name wvdial
replacedefaultroute
noipdefault
nomagic
usepeerdns
ipcp-accept-local
ipcp-accept-remote
nomp
noccp
nopredictor1
novj
novjccomp
nobsdcomp

FR-PORT:/usr/bin# wvdial orange-public

et voili ;)

a+

f.



LESOUEF Emmanuel wrote:
Bonjour à tous,

Voilà, je tente de me connecter à internet avec une carte 3G Orange
Fusion+.

Celle-ci est bien reconnue à l'aide du module nozomi et j'ai donc un
péripherique /dev/noz0 fonctionnel.

J'ai utilisé les pages suivantes :

http://www.klabs.be/~fpiat/linux/debian/Option_Qualcomm_MSM6275_UMTS/

et

http://contrib.xarli.net/optionfusionsousdebian/

J'ai donc utilisé ppp (donc pon) pour lancer la connexion. Ca semble
fonctionner mais l'interface ppp0 n'est pas adressée (pas d'IP).

En mode debug, j'ai les lignes suivantes :

[~] $ sudo pon orange
Serial connection established.
using channel 14
Using interface ppp0
Connect: ppp0 <--> /dev/noz0
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xb43155c2> <pcomp>
<accomp>]
rcvd [LCP ConfReq id=0x1e <asyncmap 0x0> <auth chap MD5> <magic
0x84f01acf> <pcomp> <accomp>]
sent [LCP ConfAck id=0x1e <asyncmap 0x0> <auth chap MD5> <magic
0x84f01acf> <pcomp> <accomp>]
rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0xb43155c2> <pcomp>
<accomp>]
sent [LCP EchoReq id=0x0 magic=0xb43155c2]
rcvd [LCP DiscReq id=0x1f magic=0x84f01acf]
rcvd [CHAP Challenge id=0x1 <dc24a6af9a41bec45e4ac5a6dab695e2>, name >> "UMTS_CHAP_SRVR"]
sent [CHAP Response id=0x1 <ac08c1745ac9d7a4d394008e78c01098>, name >> "orange"]
rcvd [LCP EchoRep id=0x0 magic=0x84f01acf b4 31 55 c2]
rcvd [CHAP Success id=0x1 ""]
CHAP authentication succeeded
CHAP authentication succeeded
sent [IPCP ConfReq id=0x1 0.0.0.0>]
rcvd [IPCP ConfNak id=0x1 sent [IPCP ConfReq id=0x2 sent [IPCP ConfReq id=0x2
Les deux dernière lignes se répetent et le log s'achève avec :

sent [LCP EchoReq id=0x1 magic=0x5f0ac1f8]
IPCP: timeout sending Config-Requests
sent [LCP TermReq id=0x2 "No network protocols running"]
sent [LCP TermReq id=0x3 "No network protocols running"]
Connection terminated.
Modem hangup

Est-ce que quelqu'un a une idée ?

Pour info, ma configuration : Debian Unstable sur un portable HP nc2400.

Merci pour toute l'aide que vous pourrez m'apporter.

--
Emmanuel Lesouef








--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Emmanuel Lesouef
Le #9634251
Bonjour,

Le vendredi 28 décembre 2007 à 11:19 +0100, Alex Perso a écr it :
Bonjour,
je viens de récuperer une carte FUSION Globe trotter HSDPA, je te
remercie pour ton tuto.

Mais j'ai un petit souci, j'utilise la connexion orange-vpn.
J'arrive bien a me connecter, mais ensuite j'utilise l'openvpn pour me
connecter a mon bureau.
Et la c'est le hic.



Il me semble que Orange exige l'utilisation d'IPSEC pour les connexions
VPN.

A moins que je ne me trompe, openvpn est différent.

--
Emmanuel Lesouef
Alex Perso
Le #9634241
Ok, pour ipsec/orange.
Mais le problème est que openvpn n'arrive pas a ajouter la route par defaut.
Je me connecte bien au vpn, j'arrive sur le lan du boulot.

J'ai un collegue sous windows, qui se connecte egalement avec cette
carte, il utilise egalement openvpn. Et lui n'a pas ce problème. bref.

Pour moi, openvpn n'arrive pas a forcer la route.
Si quelqu'un a une idée.

alex

Emmanuel Lesouef a écrit :
Bonjour,

Le vendredi 28 décembre 2007 à 11:19 +0100, Alex Perso a écrit :
Bonjour,
je viens de récuperer une carte FUSION Globe trotter HSDPA, je te
remercie pour ton tuto.

Mais j'ai un petit souci, j'utilise la connexion orange-vpn.
J'arrive bien a me connecter, mais ensuite j'utilise l'openvpn pour me
connecter a mon bureau.
Et la c'est le hic.



Il me semble que Orange exige l'utilisation d'IPSEC pour les connexions
VPN.

A moins que je ne me trompe, openvpn est différent.





--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
fabrice régnier
Le #9634201
salut,

[~] $ sudo apt-get install wvdial


[zap]
E: Paquets défectueux
Donc pour tester avec wvdial, il va falloir attendre un peu. Quoique je
vais essayer d'adapter un peu les fichiers suivants.


Juste pour le test, pourquoi ne pas installer la version 1.56-1.2 de
lenny/etch ?

a+

f.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Emmanuel Lesouef
Le #9634151
Le vendredi 28 décembre 2007 à 12:53 +0100, fabrice régnier a écrit :
salut,
Juste pour le test, pourquoi ne pas installer la version 1.56-1.2 de
lenny/etch ?




Oui aprés tout... Excellente idée.

Bon, une fois installé et tes scripts mis en place, wvdial lance pppd et
boucle comme ca :

ATDT*99***1#
CONNECT 1800000
--> Carrier detected. Starting PPP immediately.
--> Starting pppd at Fri Dec 28 13:43:09 2007
--> Pid of pppd: 5526
--> Using interface ppp0
--> pppd: Hh���[0e][06][08]�[01][06][08]
--> pppd: Hh���[0e][06][08]�[01][06][08]

[snip]

--> pppd: Hh���[0e][06][08]�[01][06][08]
--> Disconnecting at Fri Dec 28 13:45:34 2007
--> The PPP daemon has died: A modem hung up the phone (exit code = 16)

Trés étrange... Si quelqu'un a une idée...

a+




A plus et merci encore du coup de main.

f.




--
Emmanuel Lesouef
Publicité
Poster une réponse
Anonyme