IP d'interface débranchée répond au ping

Le
Alain Rpnpif
Bonjour,

Sous Squeeze modifié par testing, j'ai deux cartes réseaux eth0 et
eth1. Seule eth1 est branchée.

/etc/network/interfaces
allow-hotplug eth1
auto eth1
iface eth1 inet static
address 192.168.1.23
[]
auto eth0
iface eth0 inet static
address 192.168.1.24


Auriez-vous une idée de la raison qui fait qu'un ping vers
192.168.1.24 (eth0) réponde à partir d'un autre poste du rés=
eau
192.168.1.0 malgré le fait que le câble soit débranché =
? Évidemment les
adresses MAC sont différentes.

Cela fait comme si l'interface eth1 avait deux IP différentes, c'est
que dit l'arp sur le poste appelant. Pourtant ifconfig donne la bonne
info.

--
Alain Rpnpif

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/20120226134421.44095D821F@chro.home
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Bzzz
Le #24281291
On Sun, 26 Feb 2012 14:44:21 +0100
Alain Rpnpif

Auriez-vous une idée de la raison qui fait qu'un ping vers
192.168.1.24 (eth0) réponde à partir d'un autre poste du rà ©seau
192.168.1.0 malgré le fait que le câble soit débranchà © ? Évidemment les
adresses MAC sont différentes.

Cela fait comme si l'interface eth1 avait deux IP différentes, c'est
que dit l'arp sur le poste appelant. Pourtant ifconfig donne la bonne
info.



Que raconte route?
--
ignoranus, n.:
A person who's both stupid and an asshole.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Bernard Schoenacker
Le #24281381
Le Sun, 26 Feb 2012 14:44:21 +0100,
Alain Rpnpif
Bonjour,

Sous Squeeze modifié par testing, j'ai deux cartes réseaux eth0 et
eth1. Seule eth1 est branchée.

/etc/network/interfaces
allow-hotplug eth1
auto eth1
iface eth1 inet static
address 192.168.1.23
[...]
auto eth0
iface eth0 inet static
address 192.168.1.24


Auriez-vous une idée de la raison qui fait qu'un ping vers
192.168.1.24 (eth0) réponde à partir d'un autre poste du réseau
192.168.1.0 malgré le fait que le câble soit débranché ? Évidemment
les adresses MAC sont différentes.

Cela fait comme si l'interface eth1 avait deux IP différentes, c'est
que dit l'arp sur le poste appelant. Pourtant ifconfig donne la bonne
info.




bonjour,



que donne :

ifconfig |grep HWaddr


ensuite reprendre le script dispo dans :

/usr/share/doc/ifupdown/examples/check-mac-address.sh

et l'exemple suivant :

zgrep mac /usr/share/doc/ifupdown/examples/network-interfaces.gz



slt
bernard


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Alain Rpnpif
Le #24281391
Le 26 février 2012, Bzzz a écrit :

On Sun, 26 Feb 2012 14:44:21 +0100
Alain Rpnpif
>
> Auriez-vous une idée de la raison qui fait qu'un ping vers
> 192.168.1.24 (eth0) réponde à partir d'un autre poste du rà ©seau
> 192.168.1.0 malgré le fait que le câble soit débranchà © ? Évidemment les
> adresses MAC sont différentes.
>
> Cela fait comme si l'interface eth1 avait deux IP différentes, c'e st
> que dit l'arp sur le poste appelant. Pourtant ifconfig donne la bonne
> info.

Que raconte route?



/sbin/route -n
Table de routage IP du noyau
Destination Passerelle Genmask Indic Metric Ref Use Iface
0.0.0.0 192.168.1.30 0.0.0.0 UG 0 0 0 eth1
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0

--
Alain Rpnpif

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Daniel Huhardeaux
Le #24281431
Le 26/02/2012 15:19, Alain Rpnpif a écrit :
Le 26 février 2012, Bzzz a écrit :

On Sun, 26 Feb 2012 14:44:21 +0100
Alain Rpnpif
Auriez-vous une idée de la raison qui fait qu'un ping vers
192.168.1.24 (eth0) réponde à partir d'un autre poste du réseau
192.168.1.0 malgré le fait que le câble soit débranché ? Évidemment les
adresses MAC sont différentes.

Cela fait comme si l'interface eth1 avait deux IP différentes, c'est
que dit l'arp sur le poste appelant. Pourtant ifconfig donne la bonne
info.


Que raconte route?


/sbin/route -n
Table de routage IP du noyau
Destination Passerelle Genmask Indic Metric Ref Use Iface
0.0.0.0 192.168.1.30 0.0.0.0 UG 0 0 0 eth1
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0



Alors c'est normal puisque le fait d'avoir débrancher le câble n'a pas
baissé l'interface eth0 qui a gardée son adresse IP. Pour que eth0 ne
réponde pas il faut faire un ifdown eth0, le câble peut alors rester
connecté.

--
Daniel

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Alain Rpnpif
Le #24281521
Le 26 février 2012, Daniel Huhardeaux a écrit :

> /sbin/route -n
> Table de routage IP du noyau
> Destination Passerelle Genmask Indic Metric Ref Use Iface
> 0.0.0.0 192.168.1.30 0.0.0.0 UG 0 0 0 eth1
> 192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
> 192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0

Alors c'est normal puisque le fait d'avoir débrancher le câble n'a pas
baissé l'interface eth0 qui a gardée son adresse IP. Pour que e th0 ne
réponde pas il faut faire un ifdown eth0, le câble peut alors r ester
connecté.



Oui, d'accord mais ici, le câble n'a jamais été connectà ©. La
déclaration dans /etc/network/interfaces n'est là que pour permet tre
une connexion automatique quand j'y raccorde un câble, ce que permet en
théorie NetworkManager. Mais Daniel, effectivement j'avais un problà ¨me
similaire de non-désactivation correcte quand je débranchais le c âble à
chaud. Mais ici, jamais de câble. Et je voudrais pour gagner du temps
que la désactivation soit complète et correcte comme cela se fait sur
les autres OS, Linux ou pas. Je garde cette carte réseau en dépan nage.

Quelques essais intéressants :
Câble eth0 toujours débranchée.
Au démarrage de Debian Squeeze, eth0 et eth1 sont activées avec l es deux
adresses IP transmises au réseau (par eth1 !).
Je désactive le réseau par l'icône de NetworkManager sur la barre de
Gnome (qui doit faire un ifdown en arrière-plan).
Je réactive ensuite le réseau par le même moyen. Et là le câble est bien
détecté comme débranché et seule eth1 est activée (les logs le
confirment). La deuxième adresse IP n'est plus reconnue sur le ré seau
comme il se doit.

Donc le problème se situe au démarrage de Debian qui ne déte cte pas les
câbles débranchés. Savez-vous quel est le programme qui devr ait faire ce
travail au démarrage ? Bien sûr je peux faire un script rc avec u n ifup
ou ifdown mais je voudrais corriger ce bogue de façon normale.

PS : Daniel, tu devrais mettre un répondre à vers la liste (ou ne pas
en mettre).

--
Alain Rpnpif

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
yata.jb
Le #24281531
--=_7f8a6752b0b881845aa91d8d6eff9c0c
Content-Transfer-Encoding: 8bit
Content-Type: text/plain; charset=UTF-8



On Sun, 26 Feb 2012 15:30:41 +0100, Daniel Huhardeaux wrote:

Le


26/02/2012 15:19, Alain Rpnpif a écrit :

Le 26 février 2012, Bzzz




a écrit :

On Sun, 26 Feb 2012 14:44:21 +0100 Alain Rpnpif






wrote:

Auriez-vous une idée de la raison qui fait qu'un ping








vers 192.168.1.24 (eth0) réponde à partir d'un autre poste du réseau
192.168.1.0 malgré le fait que le câble soit débranché ? Évidemment les
adresses MAC sont différentes. Cela fait comme si l'interface eth1 avait
deux IP différentes, c'est que dit l'arp sur le poste appelant. Pourtant
ifconfig donne la bonne info.
Que raconte route?


/sbin/route -n




Table de routage IP du noyau Destination Passerelle Genmask Indic Metric
Ref Use Iface 0.0.0.0 192.168.1.30 0.0.0.0 UG 0 0 0 eth1 192.168.1.0
0.0.0.0 255.255.255.0 U 0 0 0 eth1 192.168.1.0 0.0.0.0 255.255.255.0 U 0
0 0 eth0

Alors c'est normal puisque le fait d'avoir débrancher le


câble n'a pas
baissé l'interface eth0 qui a gardée son adresse IP.


Pour que eth0 ne
réponde pas il faut faire un ifdown eth0, le câble


peut alors rester
connecté.

-- Daniel



Une possibilié autre, la
machine a l 'IPMI actif , quid d un scan pour voir ce qui est
éventuellement ouvert et d une connexion sur les services ouverts ?




Links:
------
[1] mailto:

--=_7f8a6752b0b881845aa91d8d6eff9c0c
Content-Transfer-Encoding: quoted-printable
Content-Type: text/html; charset=UTF-8

<html><body>
<p>On Sun, 26 Feb 2012 15:30:41 +0100, Daniel Huhardeaux wrote:</p>
<blockquote type="cite" style="padding-left:5px; border-left:#1010ff 2p x solid; margin-left:5px; width:100%"><!-- html ignored --><!-- head ignore d --><!-- meta ignored -->
<pre>Le 26/02/2012 15:19, Alain Rpnpif a &eacute;crit :</pre>
<blockquote type="cite" style="padding-left:5px; border-left:#1010ff 2p x solid; margin-left:5px; width:100%">Le 26 f&eacute;vrier 2012, Bzzz a &ea cute;crit :
Que raconte route?</blockquote>
/sbin/route -n Table de routage IP du noyau Destination Passerelle Genmask Indic Metric Ref Use Iface 0.0.0.0 192.168.1.30 0.0.0.0 UG 0 0 0 eth1 192 .168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1 192.168.1.0 0.0.0.0 255.255 .255.0 U 0 0 0 eth0</blockquote>
<pre>Alors c'est normal puisque le fait d'avoir d&eacute;brancher le c&acir c;ble n'a pas
baiss&eacute; l'interface eth0 qui a gard&eacute;e son adresse IP. Pour que eth0 ne
r&eacute;ponde pas il faut faire un ifdown eth0, le c&acirc;ble peut alors rester
connect&eacute;.

<span class="sig">-- Daniel </span></pre>
</blockquote>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>Une possibili&eacute; autre, la machine a l 'IPMI actif , quid d un scan pour voir ce qui est &eacute;ventuellement ouvert et d une connexion sur l es services ouverts ?</p>
<div>&nbsp;</div>
<pre></pre>
</body></html>

--=_7f8a6752b0b881845aa91d8d6eff9c0c--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Alain Rpnpif
Le #24281541
Le 26 février 2012, Daniel Huhardeaux a écrit :

> /sbin/route -n
> Table de routage IP du noyau
> Destination Passerelle Genmask Indic Metric Ref Use Iface
> 0.0.0.0 192.168.1.30 0.0.0.0 UG 0 0 0 eth1
> 192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
> 192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0

Alors c'est normal puisque le fait d'avoir débrancher le câble n'a pas
baissé l'interface eth0 qui a gardée son adresse IP. Pour que e th0 ne
réponde pas il faut faire un ifdown eth0, le câble peut alors r ester
connecté.



Oui, d'accord mais ici, le câble n'a jamais été connectà ©. La
déclaration dans /etc/network/interfaces n'est là que pour permet tre
une connexion automatique quand j'y raccorde un câble, ce que permet en
théorie NetworkManager. Mais Daniel, effectivement j'avais un problà ¨me
similaire de non-désactivation correcte quand je débranchais le c âble à
chaud. Mais ici, jamais de câble. Et je voudrais pour gagner du temps
que la désactivation soit complète et correcte comme cela se fait sur
les autres OS, Linux ou pas. Je garde cette carte réseau en dépan nage.

Quelques essais intéressants :
Câble eth0 toujours débranchée.
Au démarrage de Debian Squeeze, eth0 et eth1 sont activées avec l es deux
adresses IP transmises au réseau (par eth1 !).
Je désactive le réseau par l'icône de NetworkManager sur la barre de
Gnome (qui doit faire un ifdown en arrière-plan).
Je réactive ensuite le réseau par le même moyen. Et là le câble est bien
détecté comme débranché et seule eth1 est activée (les logs le
confirment). La deuxième adresse IP n'est plus reconnue sur le ré seau
comme il se doit.

Donc le problème se situe au démarrage de Debian qui ne déte cte pas les
câbles débranchés. Savez-vous quel est le programme qui devr ait faire ce
travail au démarrage ? Bien sûr je peux faire un script rc avec u n ifup
ou ifdown mais je voudrais corriger ce bogue de façon normale.

--
Alain Rpnpif

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Bzzz
Le #24281591
On Sun, 26 Feb 2012 15:59:53 +0100
Alain Rpnpif
Au démarrage de Debian Squeeze, eth0 et eth1 sont activées avec les deux
adresses IP transmises au réseau (par eth1 !).
Je désactive le réseau par l'icône de NetworkManager sur l a barre de
Gnome (qui doit faire un ifdown en arrière-plan).
Je réactive ensuite le réseau par le même moyen. Et là   le câble est bien
détecté comme débranché et seule eth1 est activé e (les logs le
confirment). La deuxième adresse IP n'est plus reconnue sur le rà ©seau
comme il se doit.



Et en passant eth0 à allow-hotplug au lieu d'auto?

--
After they got rid of capital punishment, they had to hang twice
as many people as before.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
daniel huhardeaux
Le #24281601
Le 26/02/2012 15:59, Alain Rpnpif a écrit :

[...]
Donc le problème se situe au démarrage de Debian qui ne détecte pas
les câbles débranchés. Savez-vous quel est le programme qui devrait
faire ce travail au démarrage ? Bien sûr je peux faire un script rc
avec un ifup ou ifdown mais je voudrais corriger ce bogue de façon
normale.



Debian n'y est pour rien! J'utilise le fichier interfaces avec
ifup/ifdown et cela fonctionne (option hotplug)

--
Daniel

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Stephane Bortzmeyer
Le #24282361
On Sun, Feb 26, 2012 at 02:44:21PM +0100,
Alain Rpnpif a message of 38 lines which said:

Auriez-vous une idée de la raison qui fait qu'un ping vers
192.168.1.24 (eth0) réponde à partir d'un autre poste du réseau
192.168.1.0 malgré le fait que le câble soit débranché ?



Il faudrait connaître la topologie du réseau (où eth1 est-il branché ?
J'ai l'impression qu'il n'existe qu'un seul réseau physique) mais, a
priori, c'est tout à fait normal. Sur Linux, contrairement à IOS,
débrancher le câble réseau ne supprime pas l'adresse IP et la machine
continue donc normalement à y répondre.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme