IP sous XP pris en compte après redémarrage

Le
LLedo
Bonjour à tous,

Voilà, j'aurais aimer savoir s'il était possible depuis Win XP d'attendre le
redemarrage du PC pour prendre en compte la nouvelle adresse IP que l'on
renseigne comme sous NT4.

J'explique pourquoi je souhaites ceci:

*Via un Batch:
-Je connecte un lecteur réseau pointant sur le serveur. (net use S:
"\ServeurDossiers" password /user:username)
-Je lance un programme Windev sur le PC. (S:gest_prog.exe)

*A un moment dans mon programme Windev, je lance la commande "netsh" qui
configure une nouvelle adresse IP au PC.
Or le problème est que j'ai encore quelques actions à faire après la
configuration mais mon programme se ferme étant sur le lecteur "S:" (Il faut
savoir que le "S:" sera toujours accessible avec la nouvelle adresse IP
renseignée).
Suite à la configuration de l'adresse via le netsh, il ferme mon programme
(installé sur le "S:") et cherche le "S:" ,le trouve mais ne relance pas mon
appli.

Merci pour votre aide.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
~Jean-Marc~ [MVP]
Le #1255461
Salut LLedo,
tu nous disais :
Bonjour à tous,

Voilà, j'aurais aimer savoir s'il était possible depuis Win XP
d'attendre le redemarrage du PC pour prendre en compte la nouvelle
adresse IP que l'on renseigne comme sous NT4.

J'explique pourquoi je souhaites ceci:

*Via un Batch:
-Je connecte un lecteur réseau pointant sur le serveur. (net use S:
"\ServeurDossiers" password /user:username)
-Je lance un programme Windev sur le PC. (S:gest_prog.exe)

*A un moment dans mon programme Windev, je lance la commande "netsh"
qui configure une nouvelle adresse IP au PC.
Or le problème est que j'ai encore quelques actions à faire après la
configuration mais mon programme se ferme étant sur le lecteur "S:"
(Il faut savoir que le "S:" sera toujours accessible avec la nouvelle
adresse IP renseignée).
Suite à la configuration de l'adresse via le netsh, il ferme mon
programme (installé sur le "S:") et cherche le "S:" ,le trouve mais
ne relance pas mon appli.



Copie le le nécessaire en "local" et efface à la fin...

@+

--
~Jean-Marc~ MVP Shell/User Fr
( Vista x86 Ultimate )
- http://msmvps.com/blogs/docxp/ -
- http://docxp.mvps.org -

Publicité
Poster une réponse
Anonyme